Wwise Unity Integration Documentation: Wwise Unity 集成

Wwise Unity Integration Documentation
Wwise Unity 集成

Wwise Unity Integration 提供有一系列相关资源，方便在 Unity 游戏中使用 Wwise 声音引擎。在文档后面的部分中，我们将称它为 "集成"（Integration）。它包含 Unity 插件库、使用 C# 编写的 Wwise SDK API 绑定以及多个实用 组件 和 Editor 窗口。如果要了解 Wwise SDK 的基本功能，请参阅其文档，文档可以 在线阅读，也可以在您的 Wwise 安装找到它的 CHM。

这个集成文档提供了关于 Unity-Wwise 集成和 Wwise API 的信息。如果您需要关于 Wwise 设计工具的信息（对于声音设计师），请参考正确的帮助文件，可以在 在线文档 中找到，也可以在您的本地安装中找到（一般在 C:\Program Files(x86)\Audiokinetic\Wwise [version] \Authoring\Help 中）。

  • 版本说明 - Wwise Unity Integration 2022.1.2.8150.2694
  • 先前版本说明
  • 在 Unity 工程中安装或升级集成
  • 卸载 Wwise Integration Package
  • 调整 Unity Editor Settings
  • 调整 Wwise Initialization Settings
  • Managing SoundBanks
  • 使用 Wwise Unity 集成
  • Wwise Picker
    • WAAPI 实用工具
  • 为目标平台构建您的 Unity 游戏
  • 用 Wwise 和 Unity 制作 DLC
  • 从源代码构建原生集成插件
  • API 变化和限制
  • 有关平台的特定信息
  • Demo Game
  • 在 Unity 中使用 Spatial Audio
  • 在 Unity 中使用 Wwise Addressables Package
  • Installing the Wwise Unity Addressables Package
  • DLC 打包基础教程
  • Wwise Addressables 示例
  • 故障排除

联系我们

如果您对该集成有任何疑问，请将问题发布到我们的 社区问答论坛上去。如果您已经购买了技术支持，请联系我们的 客户支持团队。

参见
  • Audiokinetic Launcher: Integrating Wwise into a Unity Project
  • Wwise-301：Wwise Unity Integration


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2022.1.2.8150.2694

版本说明 - Wwise Unity Integration 2022.1.2.8150.2694

此次发布为 Wwise 2022.1.2 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2022.1.2
  • Unity：此 Integration 针对 Unity 2020.3、2021.3、2022.1 和 2022.2 编译。其针对 2022.2.2f1 进行了测试。暂不支持比上述更高的 Unity 版本，但后续补丁版本中会提供相应支持。

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复
  • 社区报告的漏洞修复

漏洞修复

  • WG-63482 已修复：在通过 Inspector 播放 Event 后打开不同的场景还会播放声音。

社区报告的漏洞修复

  • WG-63469 已修复：无法在 Prefab 中保存对 Environment Aware 属性所作的 AkGameObj 组件修改。
  • WG-64036 Improved migration times for projects using Wwise 2019.1 or later


Wwise Unity Integration Documentation: 先前版本说明

先前版本说明

以下页面包含先前版本中对 Integration 所做改进的相关信息。

  • 版本说明 - Wwise Unity Integration 2022.1.1.8100.2644
  • 版本说明 – Wwise Unity Integration 2021.1.11.7933.2488
  • 版本说明 - Wwise Unity Integration 2022.1.0.8070.2611
  • 版本说明 – Wwise Unity Integration 2021.1.10.7883.2429
  • 版本说明 – Wwise Unity Integration 2021.1.9.7847.2389
  • 版本说明 - Wwise Unity Integration 2021.1.8.7831.2373
  • 版本说明 – Wwise Unity Integration 2021.1.7.7796.2335
  • 版本说明 – Wwise Unity Integration 2021.1.6.7774.2308
  • 版本说明 - Wwise Unity Integration 2021.1.5.7749.2277
  • 版本说明 – Wwise Unity Integration 2021.1.4.7707.2232
  • 版本说明 - Wwise Unity Integration 2021.1.3.7665.2179
  • 版本说明 - Wwise Unity Integration 2021.1.2.7629.2141
  • 版本说明 - Wwise Unity Integration 2021.1.1.7601.2102
  • 版本说明 - Wwise Unity Integration 2021.1.0.7575.2069
  • 版本说明 – Wwise Unity Integration 2019.2.15.7667.2215
  • 版本说明 – Wwise Unity Integration 2019.2.14.7616.2152
  • 版本说明 - Wwise Unity Integration 2019.2.13.7577.2104
  • 版本说明 - Wwise Unity Integration 2019.2.12.7544.2058
  • 版本说明 - Wwise Unity Integration 2019.2.11.7512.2017
  • 版本说明 – Wwise Unity Integration 2019.2.10.7490.1989
  • 版本说明 - Wwise Unity Integration 2019.2.9.7459.1949
  • 版本说明 - Wwise Unity Integration 2019.2.8.7432.1919
  • 版本说明 - Wwise Unity Integration 2019.2.7.7402.1888
  • 版本说明 - Wwise Unity Integration 2019.2.6.7381.1867
  • 版本说明 - Wwise Unity Integration 2019.2.5.7349.1831
  • 版本说明 - Wwise Unity Integration 2019.2.4.7329.1806
  • 版本说明 - Wwise Unity Integration 2019.2.3.7304.1778
  • 版本说明 - Wwise Unity Integration 2019.2.2.7275.1749
  • 版本说明 – Wwise Unity Integration 2019.2.1.7250.1718
  • 版本说明 – Wwise Unity Integration 2019.2.0.7216.1681
  • 版本说明 - Wwise Unity Integration 2019.1.11.7296.1786
  • 版本说明 - Wwise Unity Integration 2019.1.10.7250.1738
  • 版本说明 - Wwise Unity Integration 2019.1.9.7221.1704
  • 版本说明 - Wwise Unity Integration 2019.1.8.7173.1654
  • 版本说明 – Wwise Unity Integration 2019.1.7.7135.1611
  • 版本说明 - Wwise Unity Integration 2019.1.6.7110.1585
  • 版本说明 - Wwise Unity Integration 2019.1.5.7093.1568
  • 版本说明 - Wwise Unity Integration 2019.1.4.7065.1538
  • 版本说明 - Wwise Unity Integration 2019.1.3.7048.1516
  • 版本说明 - Wwise Unity Integration 2019.1.2.7018.1481
  • 版本说明 - Wwise Unity Integration 2019.1.2.7018.1480
  • 版本说明 - Wwise Unity Integration 2019.1.1.6977.1430
  • 版本说明 - Wwise Unity Integration 2019.1.0.6947.1394
  • 版本说明 - Wwise Unity Integration 2018.1.6.6858.1313
  • 版本说明 - Wwise Unity Integration 2018.1.5.6835.1288
  • 版本说明 - Wwise Unity Integration 2018.1.4.6807.1258
  • 版本说明 - Wwise Unity Integration 2018.1.3.6784.1233
  • 版本说明 - Wwise Unity Integration 2018.1.2.6762.1211
  • 版本说明 - Wwise Unity Integration 2018.1.1.6727.1172
  • 版本说明 - Wwise Unity Integration 2018.1.0.6714.1154
    • 新功能 2018.1
  • 版本说明 - Wwise Unity Integration 2017.2.9.6726.1210
  • 版本说明 - Wwise Unity Integration 2017.2.8.6698.1171
  • 版本说明 - Wwise Unity Integration 2017.2.7.6661.1133
  • 版本说明 - Wwise Unity Integration 2017.2.6.6636.1107
  • 版本说明 - Wwise Unity Integration 2017.2.5.6619.1090
  • 版本说明 - Wwise Unity Integration 2017.2.4.6590.1064
  • 版本说明 - Wwise Unity Integration 2017.2.4.6590.1054
  • 版本说明 - Wwise Unity Integration 2017.2.3.6575.1037
  • 版本说明 - Wwise Unity Integration 2017.2.2.6553.1015
  • 版本说明 - Wwise Unity Integration 2017.2.1.6524.980
  • 版本说明 - Wwise Unity Integration 2017.2.0.6500.947
    • 新功能 2017.2
    • 重要迁移说明 2017.2
  • 版本说明 - Wwise Unity Integration 2017.1.9.6501.947
  • 版本说明 - Wwise Unity Integration 2017.1.8.6488.933
  • 版本说明 - Wwise Unity Integration 2017.1.7.6467.910
  • 版本说明 - Wwise Unity Integration 2017.1.6.6446.890
  • 版本说明 - Wwise Unity Integration 2017.1.5.6429.870
  • 版本说明 - Wwise Unity Integration 2017.1.4.6407.845
  • 版本说明 - Wwise Unity Integration 2017.1.3.6377.812
  • 版本说明 - Wwise Unity Integration 2017.1.2.6361.791
  • 版本说明 - Wwise Unity Integration 2017.1.1.6340.770
  • 版本说明 - Wwise Unity Integration 2017.1.0.6302.726
    • 新功能 2017.1
    • 重要迁移说明 2017.1
  • 版本说明 - Wwise Unity Integration 2016.2.6.6153.595
  • 版本说明 - Wwise Unity Integration 2016.2.5.6121.560
  • 版本说明 - Wwise Unity Integration 2016.2.4.6098.531
  • 版本说明 - Wwise Unity Integration 2016.2.3.6077.504
  • 版本说明 - Wwise Unity Integration 2016.2.2.6022.430
  • 版本说明 - Wwise Unity Integration 2016.2.1.5995.409
  • 版本说明 - Wwise Unity Integration 2016.2.1
  • 版本说明 - Wwise Unity Integration 2016.2.0
  • 版本说明 - Wwise Unity Integration 2016.1.6
  • 版本说明 - Wwise Unity Integration 2016.1.5
  • 版本说明 - Wwise Unity Integration 2016.1.4
  • 版本说明 - Wwise Unity Integration 2016.1.3
  • 版本说明 - Wwise Unity Integration 2016.1.2
  • 版本说明 - Wwise Unity Integration 2016.1.1
  • 版本说明 - Wwise Unity Integration 2016.1
  • 版本说明 - Wwise Unity Integration 2015.1.9
  • 版本说明 - Wwise Unity Integration 2015.1.8
  • 版本说明 - Wwise Unity Integration 2015.1.7
  • 版本说明 - Wwise Unity Integration 2015.1.6
  • 版本说明 - Wwise Unity Integration 2015.1.5
  • 版本说明 - Wwise Unity Integration 2015.1.4
  • 版本说明 - Wwise Unity Integration 2015.1.3
  • 版本说明 - Wwise Unity Integration 2015.1.2
  • 版本说明 - Wwise Unity Integration 2015.1.1
  • 版本说明 - Wwise Unity Integration 2015.1
  • 版本说明 - Wwise Unity Integration 2014.1.6
  • 版本说明 - Wwise Unity Integration 2014.1.5
  • 版本说明 - Wwise Unity Integration 2014.1.4
  • 版本说明 - Wwise Unity Integration 2014.1.3
  • 版本说明 - Wwise Unity Integration 2014.1.2
  • 版本说明 - Wwise Unity Integration 2014.1.1
  • 版本说明 - Wwise Unity Integration 2014.1
  • 版本说明 - Wwise Unity Integration 2013.2.10
  • 版本说明 - Wwise Unity Integration 2013.2.9
  • 版本说明 - Wwise Unity Integration 2013.2.8
  • 版本说明 - Wwise Unity Integration 2013.2.5
  • 版本说明 - Wwise Unity Integration 2013.2.4
  • 版本说明 - Wwise Unity Integration 2013.2.1
  • 版本说明 - Wwise Unity Integration 2013.1.1
  • 版本说明 - Wwise Unity Integration 2013.1


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2022.1.1.8100.2644

版本说明 - Wwise Unity Integration 2022.1.1.8100.2644

此次发布为 Wwise 2022.1.1 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2022.1.1
  • Unity：此 Integration 针对 Unity 2020.3、2021.3 和 2022.1 编译。其针对 2021.3.16f1 进行了测试。暂不支持比上述更高的 Unity 版本，但后续补丁版本中会提供相应支持。

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 其他改进
  • 漏洞修复
  • 社区报告的漏洞修复

其他改进

  • WG-62355 依据最佳实践对 Unity Spatial Audio 代码做了改进。

漏洞修复

  • WG-62061 已修复：(Spatial Audio) 在播放过程中移动 Room 时，Game Object 3D Viewer 中重复显示 Room。
  • WG-62388 已修复：(Spatial Audio) 无法正确更新之前与 AkGeometry 关联的 Room。
  • WG-62411 已修复：(Spatial Audio) 在对父级 GameObject 实施变换后无法正确缩放 AkRoom。
  • WG-62690 已修复：在迁移后，Unity Console 中显示以下错误：
    • WwiseUnity: The platform SoundBank subfolder within the Wwise project could not be found.
    • WwiseUnity: Could not find source folder for <\Assets> platform. Did you remember to generate your banks?
    • NullReferenceException: Object reference not set to an instance of an object
    • Asset import failed, "Assets/WwiseData/Banks/iOS/Subtitles.bnk" > NullReferenceException: Object reference not set to an instance of an object
  • WG-63116 已修复：(Spatial Audio) 在更新与 Portal 交叠的 Geometry Set 时发生死锁。
  • WG-63119 已修复：在停止 AkAmbient 时引发错误。

社区报告的漏洞修复

  • WG-62051 已修复：无法在 Prefab 中正确保存对 AkGameObj 位置偏置所作的修改。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2021.1.11.7933.2488

版本说明 – Wwise Unity Integration 2021.1.11.7933.2488

此次发布为 Wwise 2021.1.11 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2021.1.11
  • Unity：此 Integration 针对 Unity 2020.3、2021.3 和 2022.1 编译。其针对 2021.3.14f1 进行了测试。暂不支持比上述更高的 Unity 版本，但后续补丁版本中会提供相应支持。

有关早期版本的信息，请参阅 先前版本说明 章节。

  • Fixes for Community-Reported Bugs

Fixes for Community-Reported Bugs

  • WG-61295 已修复：在 Server build 上默认禁用了 Unity Integration。
  • WG-61373 已修复：(Wwise Unity Addressables) 在删除并重新生成 Init WwiseAddressableSoundBank 时，未打开的场景中的 Init SoundBank 失效。
  • WG-62390 已修复：可能会在 LoadCount > 0 的情况下将 WwiseAddressableSoundBank RefCount 序列化。 该值无需再序列化。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2022.1.0.8070.2611

版本说明 - Wwise Unity Integration 2022.1.0.8070.2611

此次发布为 Wwise 2022.1.0 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2022.1.0
  • Unity：此 Integration 针对 Unity 2020.3、2021.3 和 2022.1 编译。其针对 2021.3.0f1 和 2022.1.8f1 进行了测试。暂不支持比上述更高的 Unity 版本，但后续补丁版本中会提供相应支持。

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 新增功能
  • API 改进
  • 行为改进
  • 其他改进
  • 社区报告的漏洞修复

新增功能

  • WG-54310 添加了一个 Auto-defined SoundBank 选项。若启用，Wwise 会在可能的情况下针对每个 Event 和 Aux Bus 自动定义 SoundBank。有关更多详细信息，请参阅自动定义 SoundBank。

用户可通过 SoundBank Settings 启用 Auto-defined SoundBank。有关更多详细信息，请参阅 SoundBank Settings。

  • WG-54685 为了更加灵活地并行执行声音引擎处理任务，将 Task Scheduler API 替换为了新的 Job Manager。
  • WG-59193 为了调节 XML 和 WAAPI 的超时时间，针对新的错误消息转换器添加了两项新的 Wwise Editor Project Settings。这些设置可在新的 Wwise Error Message Translator 分区下找到。

API 改进

  • WG-55811 添加了对 WwiseExternalSourceManager 的最小实现 WwiseSimpleExternalSourceManager 并用在了 Wwise Demo Game 中。
  • WG-56860 为 SetPosition 和 SetMultiplePositions 添加了新的 in_eFlags 参数，其允许针对同一游戏对象单独设置发声体和听者位置。

行为改进

  • WG-60908 针对所有平台将 AkCommonUserSettings::m_SamplesPerFrame 的默认值改为了 512。这样会略微增加 Wwise 中的即时可用 CPU 用量，但可以大幅缩短声音引擎中的总计音频延迟。为了实现游戏的总计音频延迟和可用计算资源之间的平衡，仍建议对 "Samples Per Frame" 和 "Number of Refills In Voice" 进行适当调节。

其他改进

  • WG-57028 现在在所有平台上都由 stdint.h 提供数字类型。

社区报告的漏洞修复

  • WG-61295 已修复：在 Server build 上默认禁用了 Unity Integration。
  • WG-61373 已修复：(Wwise Unity Addressables) 在删除并重新生成 Init WwiseAddressableSoundBank 时，未打开的场景中的 Init SoundBank 失效。
  • WG-62390 已修复：可能会在 LoadCount > 0 的情况下将 WwiseAddressableSoundBank RefCount 序列化。 该值无需再序列化。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2021.1.10.7883.2429

版本说明 – Wwise Unity Integration 2021.1.10.7883.2429

此次发布为 Wwise 2021.1.10 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2021.1.10
  • Unity：此 Integration 针对 Unity 2019.4、2020.3、 和 2021.3 编译。其针对 2021.3.8f1 进行了测试。暂不支持比上述更高的 Unity 版本，但后续补丁版本中会提供相应支持。

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复
  • 社区报告的漏洞修复

漏洞修复

  • WG-60348 已修复：SetGameObjectRadius API 调用没有返回其 Game Object ID。

社区报告的漏洞修复

  • WG-57736 已修复：在使用命令行迁移需要 AkAmbient.cs 的素材时引发错误。
  • WG-61133 已修复：若未找到 Wwise 工程，Unity Integration 可能会引发内存泄漏。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2021.1.9.7847.2389

版本说明 – Wwise Unity Integration 2021.1.9.7847.2389

此次发布为 Wwise 2021.1.9 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2021.1.9
  • Unity：此 Integration 针对 Unity 2019.4、2020.3 和 2021.2 编译。其针对 2021.2.17f1 进行了测试。暂不支持比上述更高的 Unity 版本，但后续补丁版本中会提供相应支持。

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复

漏洞修复

  • WG-59609 已修复：在针对特定平台调用 GenerateApiBinding.py 时显示询问其他平台的错误消息。
  • WG-60097 已修复：在 Unity Editor 中播放时每帧都调用 SetGameObjectRadius。
  • WG-60099 已修复：Unity 和 Unity Demo Game 中默认的 Spatial Audio Initialization Setting Movement Threshold 过高。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2021.1.8.7831.2373

版本说明 - Wwise Unity Integration 2021.1.8.7831.2373

此次发布为 Wwise 2021.1.8 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2021.1.8
  • Unity：此 Integration 针对 Unity 2019.4、2020.3 和 2021.2 编译。其针对 2021.2.17f1 进行了测试。暂不支持比上述更高的 Unity 版本，但后续补丁版本中会提供相应支持。

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 其他改进
  • 漏洞修复
  • 社区报告的漏洞修复

其他改进

  • WG-53953 在本地输出中提前报告 Wwise 初始化错误。

漏洞修复

  • WG-59456 已修复：在 Unity 2020 中，默认 "Outdoors" Room 中设置的游戏对象使用了错误的 ID。
  • WG-59563 已修复：即便在 Unity Editor 中找不到 SoundBank，在声音引擎初始化时也不显示警告消息。
  • WG-59812 已修复：在 OnDisable 内播放 AkRoom 底噪时，Unity Editor 发生崩溃。

社区报告的漏洞修复

  • WG-58413 已修复：在 Unity 中播放声音时禁用 Room 会显示 'Unknown game object ID' 错误消息。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2021.1.7.7796.2335

版本说明 – Wwise Unity Integration 2021.1.7.7796.2335

此次发布为 Wwise 2021.1.7 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2021.1.7
  • Unity：Unity 2019.4.22f1 和 2020.3.1f1 (Personal 或 Pro)。
    备注： 此 Integration 版本不支持 Unity 4。此列表仅包含已执行严格兼容性测试的 Unity 版本。虽然也有可能与其他 Unity 版本兼容，但不保证一定兼容。
平台： | 已在以下平台上测试 Wwise Unity Integration：
Mac（Editor 和 Runtime） Windows（Editor 和 Runtime） Linux（仅 Runtime） PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 新增功能
  • 社区报告的漏洞修复

新增功能

  • WG-58565 向 Addressables Package 添加了示例脚本，以便针对 Wwise 素材执行 Addressables 元数据的序列化和恢复。

社区报告的漏洞修复

  • WG-54625 已修复：在 Windows 以外的平台上，AkAddressableBankManager 无法加载 AK.Wwise.Unity.API.WwiseTypes 程序集。
  • WG-54627 已修复：Addressables 对应的 Wwise Build Script 仅构建 Editor 平台素材包，且 WwiseAddressableSoundBank 总是序列化 Editor 平台而非目标构建平台的 AssetReference。
  • WG-58396 已修复：在个别 Wwise Work Unit 解析操作中日志记录性能欠佳。为此添加了 Auto-delete WwiseObjectReferences 设置，以便用户禁止 Work Unit 解析程序执行素材删除操作。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2021.1.6.7774.2308

版本说明 – Wwise Unity Integration 2021.1.6.7774.2308

此次发布为 Wwise 2021.1.6 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2021.1.6
  • Unity：Unity 2019.4.22f1 和 2020.3.1f1 (Personal 或 Pro)。
    备注： 此 Integration 版本不支持 Unity 4。此列表仅包含已执行严格兼容性测试的 Unity 版本。虽然也有可能与其他 Unity 版本兼容，但不保证一定兼容。
平台： | 已在以下平台上测试 Wwise Unity Integration：
Mac（Editor 和 Runtime） Windows（Editor 和 Runtime） Linux（仅 Runtime） PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 其他改进

其他改进

  • WG-57492 暴露了两项新的初始化设置：MemoryAllocationSizeLimit（限制内存用量）和 MemoryDebugLevel（调试内存问题）。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2021.1.5.7749.2277

版本说明 - Wwise Unity Integration 2021.1.5.7749.2277

此次发布为 Wwise 2021.1.5 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2021.1.5
  • Unity：Unity 2019.4.22f1 和 2020.3.1f1 (Personal 或 Pro)。
    备注： 此 Integration 版本不支持 Unity 4。此列表仅包含已执行严格兼容性测试的 Unity 版本。虽然也有可能与其他 Unity 版本兼容，但不保证一定兼容。
平台： | 已在以下平台上测试 Wwise Unity Integration：
Mac（Editor 和 Runtime） Windows（Editor 和 Runtime） Linux（仅 Runtime） PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复

漏洞修复

  • WG-56969 已修复：无法在游戏时间的第二帧之前启动离线渲染。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2021.1.4.7707.2232

版本说明 – Wwise Unity Integration 2021.1.4.7707.2232

此次发布为 Wwise 2021.1.4 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2021.1.4
  • Unity：Unity 2019.4.22f1 和 2020.3.1f1 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。此列表仅包含已执行严格兼容性测试的 Unity 版本。虽然也有可能与其他 Unity 版本兼容，但不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows Linux PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 新增功能
  • 性能改进
  • 其他改进
  • 漏洞修复
  • 社区报告的漏洞修复

新增功能

  • WG-29814 添加了对离线渲染的支持。

性能改进

  • WG-55340 提升了解析或获取大型项目层级结构时两种 Wwise Picker 模式的性能。

其他改进

  • WG-55912 Unity C# 绑定现在通过 SWIG 4.0.2 生成。
  • WG-56370 社区报告：需要提供 JsonSerialize Unity 数据包才能从旧的版本迁移到 Wwise 2021.1.1 及更高版本。

漏洞修复

  • WG-55639 已修复：(Spatial Audio) Room 在禁用并重新启用后丢失。

社区报告的漏洞修复

  • WG-55076 已修复：WwiseTypes 的程序集加载仅适用于构建的游戏中的 Windows 平台。
  • WG-55077 已修复：在 SoundBank 加载失败时尝试访问 SoundBank 中的 Event 列表导致出现 NullReferenceExceptions 问题。
  • WG-55078 已修复：无法妥善处理“SoundBank 在完成异步加载前被卸载”这样的个别情况。
  • WG-55704 已修复：无法将 Wwise 集成到所含插件的文件路径包含 Runtime/Plugins 的 Unity 工程中。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2021.1.3.7665.2179

版本说明 - Wwise Unity Integration 2021.1.3.7665.2179

此次发布为 Wwise 2021.1.3 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2021.1.3
  • Unity：Unity 2019.4.22f1 和 2020.3.1f1 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。此列表仅包含已执行严格兼容性测试的 Unity 版本。虽然也有可能与其他 Unity 版本兼容，但不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows Linux PS4 PS5 Switch Xbox One (Game Core) Xbox Series X iOS Android | Unity 2021.1.10f1
Xbox One tvOS UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 其他改进
  • 漏洞修复
  • 社区报告的漏洞修复

其他改进

  • WG-47576 将 Integration 脚本由 Python 2 升级到了 Python 3。

漏洞修复

  • WG-55388 已修复：Unity WwiseDemoScene 报告 AkSpatialAudioListener 错误。

社区报告的漏洞修复

  • WG-54782 已修复：在 AkWwiseProjectInfo 中做了不当的定义，导致在使用 AssetDatabase V2 打开编辑器并创建 AkWwiseProjectData 素材时出现问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2021.1.2.7629.2141

版本说明 - Wwise Unity Integration 2021.1.2.7629.2141

此次发布为 Wwise 2021.1.2 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2021.1.2
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 或 Pro).
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia Xbox Series X Xbox One (Game Core) | Unity 2020.1.16f1
PS5 | Unity 2020.1.15f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复
  • 社区报告的漏洞修复

漏洞修复

  • WG-52653 已修复：在游戏对象带有禁用的 AkSurfaceReflector 时没有显示 AkRoom 组件 Wet Transmission 警告消息。
  • WG-53624 已修复：在操控 Playable 的 Time 属性时音频没有寻址。

社区报告的漏洞修复

  • WG-54127 已修复：Wwise 脚本化对象一直被标记为未同步状态。
  • WG-54619 已修复：在本地电脑的区域设置不使用句点作为十进制分隔符时无法解析 SoundbankInfo.xml。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2021.1.1.7601.2102

版本说明 - Wwise Unity Integration 2021.1.1.7601.2102

此次发布为 Wwise 2021.1.1 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2021.1.1
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 或 Pro).
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia Xbox Series X Xbox One (Game Core) | Unity 2020.1.16f1
PS5 | Unity 2020.1.15f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复
  • 社区报告的漏洞修复

漏洞修复

  • WG-53257 已修复：Integration 中的 CPU Limit 值不在有效范围内。

社区报告的漏洞修复

  • WG-50723 已修复：AkTriggerEnable 只在 Awake() 时触发一次，后续重新启用时没有触发。
  • WG-53320 已修复：将 Unity Integration 已经包含的动态库复制到了 DSP 文件夹。
  • WG-53410 已修复：在批处理模式下，AkAmbient 试图与未初始化的 AkSoundEngine 交互。
  • WG-53722 已修复：在 'Wwise Authoring' 模式下，Wwise Picker 中没有显示 Game Parameter。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2021.1.0.7575.2069

版本说明 - Wwise Unity Integration 2021.1.0.7575.2069

此次发布为 Wwise 2021.1.0 提供了 Wwise SDK 更新。

  • 重要迁移说明 2021.1

兼容性：

  • Wwise SDK：2021.1.0
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 或 Pro).
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia Xbox Series X Xbox One (Game Core) | Unity 2020.1.16f1
PS5 | Unity 2020.1.15f1

此处提供了有关平台的特定信息：

Windows 和 Windows Store Apps 2021.1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 新增功能
  • API 改进
  • 行为改进
  • 其他改进
  • 漏洞修复
  • 社区报告的漏洞修复

新增功能

  • WG-34342 Wwise Picker 窗口现在可在适用情况下使用 WAAPI。
  • WG-43009 添加了 Wwise Addressables Package，来为通过 Unity Addressables 系统加载 Wwise 素材提供支持。
  • WG-48935 现在可更改 Editor 视图中显示的衰减球体的颜色。
  • WG-49016 对 Wwise Picker 进行了更新，现在使用 Unity TreeView 后端。

API 改进

  • WG-48127 总线电平测量回调函数 AkBusMeteringCallbackFunc 采用新的签名接收结构 AkBusMeteringCallbackInfo。现在游戏可通过 AK::SoundEngine::RegisterBusMeteringCallback 传递其所携带的可选 Cookie。同样地，AK::SoundEngine::RegisterBusVolumeCallback() 现在接收由 AkSpeakerVolumeMatrixCallbackInfo 结构传给 AkBusCallbackFunc 的 Cookie。
  • WG-50742 重新命名了 Spatial Audio 中的参数，由原来的“声笼”改为使用“透射损失”。

行为改进

  • WG-47929 改进了源的布局，以便将整合内容拆分到未来的 Unity 数据包中。
  • WG-48326 现在可在设计工具中监控回调数据结构内存。
  • WG-52040 现在使用自定义平台名称需要注册委托。请参阅 在 Unity 中使用 Wwise 自定义平台 以了解更多信息。

其他改进

  • WG-52025 添加了相应按钮以便将 AkRoomAwareObject 组件添加到带有 AkGameObj 组件的游戏对象上。
  • WG-52182 增大了默认的 Monitor Queue Pool Size。

漏洞修复

  • WG-48587 已修复：Wwise Picker 中无法正确显示空 Work Unit 的层级结构。
  • WG-48929 已修复：编辑器视图中无法清晰显示衰减球体。

社区报告的漏洞修复

  • WG-52936 已修复：在 Timeline 中拖动播放时出现播放问题。


Wwise Unity Integration Documentation: 重要迁移说明 2021.1

重要迁移说明 2021.1

Spatial Audio

在 Spatial Audio 中，我们会说“衍射”和“透射”而非“声障”和“声笼”。

  • 在 AkRoom 组件中，将 Wall Occlusion 重命名为了 Transmission Loss。
  • 在 AkSurfaceReflector 组件中，将 Occlusion Values 重命名为了 Transmission Loss Values。

对 Spatial Audio Initialization Settings 实施了更新和改进。若将工程更新至 2021.1，请务必检查 Spatial Audio Initialization Settings，以确保所有设置仍然符合要求（参见 AkSpatialAudioInitSettings 结构参考）。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2019.2.15.7667.2215

版本说明 – Wwise Unity Integration 2019.2.15.7667.2215

此次发布为 Wwise 2019.2.15 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.2.15
  • Unity：此 Integration 针对 Unity 2019.4、2020.3 和 2021.2 编译。其针对 2021.2.17f1 进行了测试。暂不支持比上述更高的 Unity 版本，但后续补丁版本中会提供相应支持。

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复

漏洞修复

  • WG-50265 已修复：Unity SpatialAudioTutorial 的 Mobile Main Camera 对象没有 Spatial Audio Listener。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2019.2.14.7616.2152

版本说明 – Wwise Unity Integration 2019.2.14.7616.2152

此次发布为 Wwise 2019.2.14 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.2.14
  • Unity：Unity 2018.4.31f1，2019.4.21f1，2020.3.0f1（Personal 或 Pro）。
    备注： 重要说明：此列表仅包含已执行严格兼容性测试的 Unity 版本。虽然也有可能与其他 Unity 版本兼容，但不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows Android PS4 Switch | Unity 2021.1.10f1
Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 其他改进

其他改进

  • WG-55912 Unity C# 绑定现在通过 SWIG 4.0.2 生成。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.2.13.7577.2104

版本说明 - Wwise Unity Integration 2019.2.13.7577.2104

此次发布为 Wwise 2019.2.13 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.2.13
  • Unity：Unity 2018.4.31f1，2019.4.21f1，2020.3.0f1（Personal 或 Pro）。
    备注： 重要说明：此列表仅包含已执行严格兼容性测试的 Unity 版本。虽然也有可能与其他 Unity 版本兼容，但不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows Android PS4 Switch | Unity 2021.1.10f1
Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • API 改进
  • 漏洞修复

API 改进

  • WG-56084 更新了 AkUtilities.GetWwiseSoundBankDestinationFolder 函数签名。

漏洞修复

  • WG-52943 已修复：在 Unity Editor 中进入 Play 模式时清理了 Decode Compressed Data 路径。
  • WG-55388 已修复：Unity 的 WwiseDemoScene 报告 AkSpatialAudioListener 错误。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.2.12.7544.2058

版本说明 - Wwise Unity Integration 2019.2.12.7544.2058

此次发布为 Wwise 2019.2.12 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.2.12
  • Unity： 2018.4、2019.1、2019.2、2019.3、2019.4、2020.1、2020.3、2021.1（Personal 或 Pro）。
    备注： 重要提示：对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows Android PS4 Switch | Unity 2021.1.10f1
Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 其他改进
  • 漏洞修复
  • 社区报告的漏洞修复

其他改进

  • WG-47576 将 Integration 脚本由 Python 2 升级到了 Python 3。

漏洞修复

  • WG-53624 已修复：在操控 Playable 的 Time 属性时音频没有寻址。

社区报告的漏洞修复

  • WG-53980 已修复：Unity Integration 代码中的脚本与 .NET 3.5 不兼容。
  • WG-54619 已修复：在本地电脑的区域设置不使用句点作为十进制分隔符时无法解析 SoundbankInfo.xml。
  • WG-54782 已修复：在 AkWwiseProjectInfo 中做了不当的定义，导致在使用 AssetDatabase V2 打开编辑器并创建 AkWwiseProjectData 素材时出现问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.2.11.7512.2017

版本说明 - Wwise Unity Integration 2019.2.11.7512.2017

此次发布为 Wwise 2019.2.11 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.2.11
  • Unity： 2018.4、2019.1、2019.2、2019.3、2019.4、2020.1、2020.3（Personal 或 Pro）。
    备注： 重要提示：对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows | Unity 2020.3.0f1
Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 社区报告的漏洞修复

社区报告的漏洞修复

  • WG-53320 已修复：将 Unity Integration 已经包含的库复制到了 DSP 文件夹。
  • WG-54308 已修复：在直接通过代码更改 Playable 的时间时并不会寻找活跃的 Event。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2019.2.10.7490.1989

版本说明 – Wwise Unity Integration 2019.2.10.7490.1989

此次发布为 Wwise 2019.2.10 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.2.10
  • Unity： 2018.4、2019.1、2019.2、2019.3、2019.4、2020.1、2020.3（Personal 或 Pro）。
    备注： 重要提示：对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows | Unity 2020.3.0f1
Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复
  • 社区报告的漏洞修复

漏洞修复

  • WG-53615 已修复：AkPluginActivator 最初会在错误的路径中查找插件 xml 文件。

社区报告的漏洞修复

  • WG-50723 已修复：AkTriggerEnable 只在 Awake() 时触发一次，后续重新启用时没有触发。
  • WG-52936 已修复：在 Timeline 中拖动播放时出现播放问题。
  • WG-53410 已修复：在批处理模式下，AkAmbient 试图与未初始化的 AkSoundEngine 交互。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.2.9.7459.1949

版本说明 - Wwise Unity Integration 2019.2.9.7459.1949

此次发布为 Wwise 2019.2.9 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2019.2.9
  • Unity: Unity 2017.4, 2018.1, 2018.2, 2018.3, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 或 Pro).
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复

漏洞修复

  • WG-47326 已修复：在 Spatial Audio 教程中，为实现对白语音的距离衰减而应用的低通滤波器反应幅度过大。
  • WG-51287 已修复：在 Unity 中打开工程时需要很长时间来填充 Wwise Picker。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.2.8.7432.1919

版本说明 - Wwise Unity Integration 2019.2.8.7432.1919

此次发布为 Wwise 2019.2.8 提供了 Wwise SDK 更新。

  • 重要迁移说明 2019.2.8

兼容性：

  • Wwise SDK：2019.2.8
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 或 Pro).
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Xbox One | Unity 2019.4.0f1

有关早期版本的信息，请参阅 先前版本说明 章节。


Wwise Unity Integration Documentation: 重要迁移说明 2019.2.8

重要迁移说明 2019.2.8

结合 iOS 使用 Bitcode

自 2019.2.8 起，使用 XCode 12 构建 Wwise SDK for iOS。若仍使用 XCode 11，则需在生成的 XCode 工程中禁用 Bitcode。为此，可在完成 Unity 构建流程后打开生成的 XCode 工程。然后转到 Xcode 工程的 Build Settings，并将 Build Options 分区中的 Enable Bitcode 设为 No。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.2.7.7402.1888

版本说明 - Wwise Unity Integration 2019.2.7.7402.1888

此次发布为 Wwise 2019.2.7 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2019.2.7
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 或 Pro).
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Xbox One | Unity 2019.4.0f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复
  • 社区报告的漏洞修复

漏洞修复

  • WG-50610 已修复：使用有效范围以外的 Room ID 会导致不符合预期的行为。无论 Room 和 Portal Integration Demo 有何说明，AkRoomID::OutdoorsGameObjID 都不是一个有效的 Room ID。对此，应当使用 AK::SpatialAudio::kOutdoorRoomID (-1)。

社区报告的漏洞修复

  • WG-51147 已修复：在 Unity Editor 中进入 Play 模式时，XmlWatcher.EnableRaisingEvents 导致等待时间过长。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.2.6.7381.1867

版本说明 - Wwise Unity Integration 2019.2.6.7381.1867

此次发布为 Wwise 2019.2.6 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2019.2.6
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 或 Pro).
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Xbox One | Unity 2019.4.0f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复

漏洞修复

  • WG-47325 已修复：Spatial Audio 教程中使用的混响效果器启用了 Early Reflection。
  • WG-47374 已修复：在移除 Spatial Audio Room 时，房间底噪被视作落单处理。
  • WG-49936 已修复：在用作 Spatial Audio Geometry 时，教程中的 Spatial Audio Mesh 显示错误消息。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.2.5.7349.1831

版本说明 - Wwise Unity Integration 2019.2.5.7349.1831

此次发布为 Wwise 2019.2.5 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2019.2.5
  • Unity: Unity 2017.4, 2018.4, 2019.1, 2019.2, 2019.3, 2019.4, 2020.1 (Personal 或 Pro).
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows | Unity 2020.1.0f1
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Xbox One | Unity 2019.4.0f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 新增功能
  • 漏洞修复
  • 社区报告的漏洞修复

新增功能

  • WG-48674 在场景中播放声音时关闭 Portal，Portal 小控件会自动随之变化。

漏洞修复

  • WG-47470 已修复：无法正常迁移 AkSpatialAudioListener。
  • WG-48672 已修复：在按照深度 (Z) 进行缩放时，AkRoomPortal 指派了错误的 Front Room 和 Back Room。

社区报告的漏洞修复

  • WG-49902 已修复：Wwise Picker 中存在与嵌套 Work Unit 相关的问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.2.4.7329.1806

版本说明 - Wwise Unity Integration 2019.2.4.7329.1806

此次发布为 Wwise 2019.2.4 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2019.2.4
  • Unity：Unity 2017.4、2018.4、2019.1、2019.2（Personal 或 Pro）
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.4.0f1

漏洞修复

  • WG-45583 已修复：除非将 Wwise SDK 文件夹放在特定位置，否则无法正常构建 Unity Integration。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.2.3.7304.1778

版本说明 - Wwise Unity Integration 2019.2.3.7304.1778

此次发布为 Wwise 2019.2.3 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.2.3
  • Unity：Unity 2017.4、2018.4、2019.1、2019.2（Personal 或 Pro）
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.10f1

社区报告的漏洞修复

  • WG-49370 已修复：即便将 Load On 设成了 Awake，AkBank 还是会在 Awake 状态下卸载 SoundBank。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.2.2.7275.1749

版本说明 - Wwise Unity Integration 2019.2.2.7275.1749

此次发布为 Wwise 2019.2.2 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2019.2.2
  • Unity：Unity 2017.4、2018.4、2019.1、2019.2（Personal 或 Pro）
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.10f1

已解决的问题：

  • WG-46080 已修复：AkTriggerEnable 无法检测第一个触发器。
  • WG-47578 已修复：在通过命令行启动 Unity 时死机。
  • WG-48293 已修复：在 Wwise Project Explorer 层级结构中包含空白的虚文件夹时，无法在 Wwise Picker 中正确显示该层级结构。
  • WG-48525 已修复：Update 函数 AkWwiseXMLWatcher 存在性能问题。
  • WG-48709 已修复：在使用 Asset Pipeline v2 将 Wwise 集成到 Unity 工程时死机。
  • WG-48831 已修复：没有在构建的游戏中注册 Wwise 插件。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2019.2.1.7250.1718

版本说明 – Wwise Unity Integration 2019.2.1.7250.1718

此次发布为 Wwise 2019.2.1 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2019.2.1
  • Unity：Unity 2017.4、2018.4、2019.1、2019.2（Personal 或 Pro）
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.0f6

已解决的问题：

  • WG-47287 Unity Integration 中针对 Nintendo Switch 和 iOS 添加了对 Krotos Igniter 的支持。
  • WG-47349 已修复：Unity 2019.3 中 Wwise Picker 的颜色现在跟 Unity 2019.2 一样了。
  • WG-47491 已修复：(Stadia) 在 Stadia 上，无法在 Unity 中加载动态插件。
  • WG-47537 已修复 (Stadia)：Integration 库不再依赖 std::atomic。
  • WG-47621 修复了使用 .NET 3.5 脚本后端时发生的编译错误。
  • WG-48108 已修复：在生成大量回调时不会再发生死锁。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2019.2.0.7216.1681

版本说明 – Wwise Unity Integration 2019.2.0.7216.1681

此次发布为 Wwise 2019.2.0 提供了 Wwise SDK 更新。

  • 重要迁移说明 2019.2

兼容性：

  • Wwise SDK：2019.2.0
  • Unity：Unity 2017.4、2018.4、2019.1、2019.2（Personal 或 Pro）
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows | Unity 2019.3.0f6
Android iOS Linux Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Xbox One | Unity 2019.2.17f1
Stadia | Unity 2019.3.0f5

已解决的问题：

  • WG-39507 由 AkVector 和 AkVertex 改为使用 UnityEngine.Vector3 。
  • WG-42160 将 Wwise Editor Settings 和 Wwise Initialization Settings 注册为了 SettingsProviders。
  • WG-42486 已修复：在 Spatial Audio 中，Undo/Redo 对指派给 Back Room 和 Front Room 的 Portal 不起作用。
  • WG-42487 已修复：(Spatial Audio) 在禁用 AkRoom 组件时，没有将听者或发声体放在正确的 Room。
  • WG-43185 由 Mutex 锁改为使用 C# 锁，提升了锁定性能。
  • WG-43252 现在暴露了 Wwise 设备枚举。
  • WG-43255 将 "Wwise\Resources" 文件夹重命名为了 "Wwise\ScriptableObjects"。
  • WG-43329 向 Unity 暴露了 AK::SoundEngine::ResourceMonitor 功能。
  • WG-44044 对 LoadBank 进行了修改，将“内存重载”细分为了 LoadBankMemoryCopy 和 LoadBankMemoryView。
  • WG-44311 (Spatial Audio) AkEnvironmentPortal 现在支持撤消/重做操作。
  • WG-44366 已修复：在禁用 AkRoom 组件时，没有按预期方式工作。
  • WG-44450 AkArray、AkHashList、AkKeyArray 的所有变体现在均提供相应的 Grow Policy 规则选项，便于优化每个声明所应用的规则。
  • WG-44742 更新了 Unreal 和 Unity 中 Spatial Audio Settings 的值域限制。
  • WG-44768 现在允许在支持的平台上从 UnityEngine.Application.persistentDataPath 加载 SoundBank。
  • WG-45089 移除了在 Unity 的 Timeline 中处理 AkEventPlayables 时可能显示的警告。
  • WG-45586 为 Spatial Audio 添加了 bEnableDirectPathDiffraction 参数，以便统一启用或禁用衍射。
  • WG-45782 已修复：(Spatial Audio) 在禁用 AkRoom 后 AkSurfaceReflector 组件没有反应。
  • WG-46045 在 2019.2 中添加了迁移步骤：将 AkSpatialAudioEmitter 替换成了 AkRoomAwareObject。
  • WG-46158 添加了相应的菜单以便切换场景或退出应用程序并转到 WwiseDemoScene。
  • WG-46919 已修复：在删除 Library 文件夹后，WAAPI 客户端上可能会出现 DllNotFoundException 错误。
  • WG-46991 已修复：不会再出现后台卸载 SoundBank 的情况。
  • WG-47182 避免了手动修改 AkRoomPortal 的 Front Room 和 Back Room。现在会自动将 Room 与 AkRoomPortal 的前方和后方位置叠合，为其赋予最高优先级并将其设为活跃和启用状态。为此，移除了 SpatialAudioTutorial Unity 场景的 AkRoomPortal 组件 Baker 窗口。


Wwise Unity Integration Documentation: 重要迁移说明 2019.2

重要迁移说明 2019.2

Spatial Audio

AkSpatialAudioEmitter 组件已经弃用。自 2019.2 版本起，可在设计工具中针对每个声音应用 Spatial Audio 参数。不再需要将发声体标记为 Spatial Audio Emitter。

  • Early Reflections
    • Reflect Aux Bus：自 2019.2 版本起，可在设计工具内 Sound SFX Property Editor 的 General Settings 选项卡中选择早期反射辅助总线。虽然仍可通过调用 AK::SpatialAudio::SetEarlyReflectionsAuxSend() 来将 ER 辅助总线关联到游戏对象，但是最好还是在设计工具中指定早期反射辅助总线。有关更多详细信息，请参阅新增的 AkEarlyReflections 组件。目前，此组件会调用 AK::SpatialAudio::SetEarlyReflectionsAuxSend()，并通过此参数指定辅助总线。
    • Reflection Max Path Length：自 2019.2 版本起，需要通过设计工具中声音的 Attenuation Max Distance 值设置 Reflection Max Path Length。
    • Reflection Aux Bus Gain：自 2019.2 版本起，可在设计工具内 Sound SFX Property Editor 的 General Settings 选项卡中选择早期反射音量。不过，仍可通过调用 AK:SpatialAudio::SetEarlyReflectionsVolume() 来针对每个游戏对象设置早期反射音量。它将被额外应用到在设计工具中针对每个声音定义的音量。有关更多详细信息，请参阅新增的 AkEarlyReflections 组件。目前，此组件会调用 AK:SpatialAudio::SetEarlyReflectionsVolume()，并通过此参数指定音量。
    • Reflections Order：自 2019.2 版本起，需要在 Spatial Audio Initialization Settings 中设置 Reflection Order。
  • Rooms
    • Room Reverb Aux Bus Gain：自 2019.2 版本起，需要通过设计工具内 Sound Property Editor 中的 Game-Defined Auxiliary Sends Volume 设置 Room Reverb Aux Bus Gain。
  • Geometric Diffraction
    • Diffraction Max Edges：自 2019.2 版本起，需要在设计工具内的 Sound Property Editor 中启用衍射。
    • Diffraction Max Paths：自 2019.2 版本起，需要在设计工具内的 Sound Property Editor 中启用衍射。
    • Diffraction Max Path Length：自 2019.2 版本起，需要在设计工具内的 Sound Property Editor 中启用衍射。

  • Debug Draw：调试绘图转移到了新增的 AkSpatialAudioDebugDraw 组件。

    AkSurfaceReflector 组件添加了新的参数。

  • Mesh：AkSurfaceReflector 组件不再需要 MeshFilter 组件。现在通过此参数指定要发送到 Spatial Audio 的 Surface Reflector Mesh。若未选择任何内容，则该组件会检查 Unity Game Object 是否带有 Mesh Filter 组件，并将其 Mesh 用作 AkSurfaceReflector Mesh。
  • Acoustic Textures：在原来的 AkSurfaceReflector 组件中，只能为整个 Surface Reflector Mesh 选择一个 AkAcousticTexture。自 2019.2 版本起，您可以为前述参数中提供的 Mesh 的每个 Submesh 指定不同的 AkAcousticTexture。原来传给单个 Acoustic Texture 参数的值将被应用到所有 Submesh。

Spatial Audio 中添加了新的组件 AkRoomAwareObject。该组件会调用 AK::SpatialAudio::SetGameObjectInRoom()，以便 Spatial Audio 随时获知游戏对象在哪个 Room。注意，所有 Spatial Audio Emitter 和 Spatial Audio Listener 都要添加该组件。

  • 对于带有 AkSpatialAudioEmitter 的 GameObject，在迁移时会自动添加 AkRoomAwareObject 组件。不过，对于带有 AkSpatialAudioListener 的 GameObject，在迁移时并不会自动添加该组件；为此，用户需要手动执行该操作。
  • 有关 AkRoomAwareObject 的详细信息，请参阅 在 Inspector 中使用 AkRoomAwareObject 。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.11.7296.1786

版本说明 - Wwise Unity Integration 2019.1.11.7296.1786

此次发布为 Wwise 2019.1.11 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.1.11
  • Unity：Unity 2017.4、2018.4、2019.1、2019.2（Personal 或 Pro）
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Mac Windows Android PS4 Switch Xbox One iOS tvOS Linux UWP (Universal Windows Platform) Stadia | Unity 2020.1.16f1

有关早期版本的信息，请参阅 先前版本说明 章节。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.10.7250.1738

版本说明 - Wwise Unity Integration 2019.1.10.7250.1738

此次发布为 Wwise 2019.1.10 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2019.1.10
  • Unity：Unity 2017.4、2018.4、2019.1、2019.2（Personal 或 Pro）
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.10f1

有关早期版本的信息，请参阅 先前版本说明 章节。

  • 漏洞修复
  • 社区报告的漏洞修复

漏洞修复

  • WG-45583 已修复：除非将 Wwise SDK 文件夹放在特定位置，否则无法正常构建 Unity Integration。

社区报告的漏洞修复

  • WG-48525 已修复：Update 函数 AkWwiseXMLWatcher 存在性能问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.9.7221.1704

版本说明 - Wwise Unity Integration 2019.1.9.7221.1704

此次发布为 Wwise 2019.1.9 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2019.1.9
  • Unity：Unity 2017.4，2018.1，2018.2，2018.3，2018.4，2019.1，2019.2 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch Stadia tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.0f10

已解决的问题：

  • WG-47349 已修复：Unity 2019.3 中 Wwise Picker 的颜色与 Unity 2019.2 不一致。
  • WG-47578 已修复：在通过命令行启动 Unity 时死机。
  • WG-48108 已修复：在生成大量回调时可能会死机。
  • WG-48709 已修复：在使用 Asset Pipeline v2 将 Wwise 集成到 Unity 工程时死机。
  • WG-48831 已修复：没有在构建的游戏中注册 Wwise 插件。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.8.7173.1654

版本说明 - Wwise Unity Integration 2019.1.8.7173.1654

此次发布为 Wwise 2019.1.8 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2019.1.8
  • Unity：Unity 2017.4，2018.1，2018.2，2018.3，2018.4，2019.1，2019.2 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.3.0f6
Stadia | Unity 2019.3.0f5

已解决的问题：

  • WG-46771 已修复：(Android) 在显示通知或软件键盘时，声音引擎暂停工作。
  • WG-46919 已修复：在删除 Library 文件夹后，WAAPI 客户端上可能会出现 DllNotFoundException 错误。
  • WG-46984 为了做到与文档更加匹配，简化了 Unity 中的 Timeline Integration。
  • WG-47287 Unity Integration 中针对 Nintendo Switch 和 iOS 添加了对 Krotos 的支持。
  • WG-47418 已修复：在 Spatial Audio 中将静止的户外游戏对象放在了原点。
  • WG-47491 已修复：(Stadia) 在 Stadia 上，无法在 Unity 中加载动态插件。
  • WG-47687 已修复：将 AkSoundEngineLumin.make 添加到了 Wwise Unity Integration 源码包。


Wwise Unity Integration Documentation: 版本说明 – Wwise Unity Integration 2019.1.7.7135.1611

版本说明 – Wwise Unity Integration 2019.1.7.7135.1611

此次发布为 Wwise 2019.1.7 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.1.7
  • Unity：Unity 2017.4，2018.1，2018.2，2018.3，2018.4，2019.1，2019.2 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.2.17f1
Stadia | Unity 2019.3.0f5

已解决的问题：

  • WG-44250 从 EventCallbackPackage 中移除了原有的 Finalizer。
  • WG-46282 已修复：在路径名称中包含 Deployment 时，构建的游戏中显示 Plug-in not found 错误。
  • WG-46360 已修复：在游戏对象不移动的情况下，现在 AkGameObj 只设置一次位置。若此时将其设为多点定位且其目标 UnityEngine.GameObject 不是静态的，则 AkAmbientInspector 将显示警告。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.6.7110.1585

版本说明 - Wwise Unity Integration 2019.1.6.7110.1585

此次发布为 Wwise 2019.1.6 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2019.1.6
  • Unity：Unity 2017.4，2018.1，2018.2，2018.3，2018.4，2019.1，2019.2 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.2.10f1
Stadia | Unity 2019.3.0b8

已解决的问题：

  • WG-45582 将 AkEnvironmentPortal 发送的辅助发送值限制在了 [0, 1]。
  • WG-45671 在 Wwise Advanced Settings 中针对 Low-Level I/O 暴露了 Async Open。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.5.7093.1568

版本说明 - Wwise Unity Integration 2019.1.5.7093.1568

此次发布为 Wwise 2019.1.5 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.1.5
  • Unity：Unity 2017.4，2018.1，2018.2，2018.3，2018.4，2019.1，2019.2 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.2.6f1
Stadia | Unity 2019.3.0b8

已解决的问题：

  • WG-45084 修复了刷听 AkEventPlayable 后存在的播放问题。
  • WG-45708 (Switch) 修复了使用流播放声音时存在的卡顿问题。
  • WG-45806 优化了 Fixing clip durations of AkEventPlayables 弹窗之后的处理。
  • WG-45902 (Stadia) 修复了初始化时存在的崩溃问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.4.7065.1538

版本说明 - Wwise Unity Integration 2019.1.4.7065.1538

此次发布为 Wwise 2019.1.4 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.1.4
  • Unity：Unity 2017.4，2018.1，2018.2，2018.3，2018.4，2019.1 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.1.10f1
Stadia | Unity 2019.3.0a12

已解决的问题：

  • WG-44854 修复了针对 XboxOne 生成 SoundBank 基本路径时存在的拼写错误。
  • WG-44905 在修改 GroupObjectReferences 后会将 WwiseGroupValueObjectReferences 标记为未清理状态。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.3.7048.1516

版本说明 - Wwise Unity Integration 2019.1.3.7048.1516

此次发布为 Wwise 2019.1.3 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.1.3
  • Unity：Unity 2017.4，2018.1，2018.2，2018.3，2018.4，2019.1 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac Magic Leap (Lumin OS) PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.1.10f1
Stadia | Unity 2019.3.0a12

已解决的问题：

  • WG-43179 添加了对 Stadia 的初步支持。
  • WG-43705 修复了 Unity 中存在的声笼问题。
  • WG-43966 修复了采用默认 Mixer 插件绑定参数时 Google Resonance Mixer 插件存在的无输出问题。
  • WG-44142 现在会在日志、编辑器和构建的游戏中显示 Wwise 版本和版权信息。
  • WG-44205 现在只有更改了数据才会修改 {{WwiseObjectReference}} 素材文件。
  • WG-44393 移除了构建游戏时出现的编译警告。
  • WG-44581 (iOS, Switch) 在没有找到平台专用 PluginInfo.xml 文件时，构建版本不再引发 {{KeyNotFoundException}} 错误。
  • WG-44205 现在只有更改了数据才会修改 WwiseObjectReference 素材文件。
  • WG-44393 移除了构建游戏时出现的编译警告。
  • WG-44581 在没有找到针对平台的 PluginInfo.xml 文件时，Switch 和 iOS 构建版本不再引发 {{KeyNotFoundException}} 错误。
  • WG-44627 添加了 GetWindowsDeviceCount() 并修复了 GetWindowsDeviceName()，现在接收 AkAudioDeviceState 参数。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.2.7018.1481

版本说明 - Wwise Unity Integration 2019.1.2.7018.1481

此次发布为 Wwise 2019.1.2 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.1.2
  • Unity：Unity 2017.4，2018.1，2018.2，2018.3，2018.4，2019.1 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.1.1f1
Magic Leap (Lumin OS) | Unity 2019.1.8f1 和 ML SDK 0.21.0

已解决的问题：

  • WG-44216 现在使用 Bug Reporter 报告错误：修复了使用 .NET 3.5 脚本后端时发生的编译错误。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.2.7018.1480

版本说明 - Wwise Unity Integration 2019.1.2.7018.1480

此次发布为 Wwise 2019.1.2 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.1.2
  • Unity：Unity 2017.4，2018.1，2018.2，2018.3，2018.4，2019.1 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.1.1f1
Magic Leap (Lumin OS) | Unity 2019.1.8f1 和 ML SDK 0.21.0

已解决的问题：

  • WG-42831 添加了相应设置，现在可指定声音引擎是否在通过 Unity 回调挂起时实施渲染。
  • WG-43182 通过关闭所有打开的场景，修复了迁移包含大量场景的 Unity 工程时存在的问题。
  • WG-43292 修复了正确放置 Spatial Audio Portal 时出现的错误。
  • WG-43347 (Switch) 修复了使用 Community Plug-in 时存在的部署问题。
  • WG-43358 (iOS) 修复了使用 Community Plug-in 时存在的部署问题。
  • WG-43676 UWP：更新到了 VS 2017，并增添了对 ARM64 的支持。
  • WG-44134 修复了通过 Launcher 2019.5.905 集成 Wwise 后 AkSoundEngine.a 存在的 Unity 工程构建失败问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.1.6977.1430

版本说明 - Wwise Unity Integration 2019.1.1.6977.1430

此次发布为 Wwise 2019.1.1 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.1.1
  • Unity：Unity 5.6，2017.4，2018.1，2018.2，2018.3 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac PS4 Switch tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2019.1.0f2
Magic Leap (Lumin OS) | Unity 2019.1.0f2 with ML SDK 0.19.0

已解决的问题：

  • WG-40425 为了准确地进行更新，更改了 Timeline 内的 AkEvent 显示。现在可以反映名称和时机的变化，并在更新这些信息后重新生成 SoundBank 时予以指示。
  • WG-41071 在总计时长未知的情况下，现在会使用合适的最小时长来创建 Timeline 中的 AkEvent 片段。
  • WG-41383 现在允许指定 AkEventPlayable 对象是否随着关联片段播放结束而停止。
  • WG-41684 已修复：无法通过 Mac 编辑器构建 Windows 可执行文件。
  • WG-41721 修改了 AkRoomPortal 组件，现在允许选择初始状态。
  • WG-42001 已修复：在设置 AkExternalSourceInfo.szFile 时发生崩溃。
  • WG-42612 (Switch) 现在在构建源解决方案时无需指定文件夹位置。
  • WG-42625 为了接收结构数组，恰当地暴露了 API。
  • WG-42841 修复了选择绑定有 AkAmbient 的 GameObject 时出现的 NullReferenceException 问题。
  • WG-42870 将 Motion 插件 DLL 打包到了 Unity Integration 中。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2019.1.0.6947.1394

版本说明 - Wwise Unity Integration 2019.1.0.6947.1394

此次发布为 Wwise 2019.1.0 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2019.1.0
  • Unity：Unity 5.6，2017.4，2018.1，2018.2，2018.3 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Mac PS4 Switch Windows Xbox One | Unity 2018.3.7f1
Linux tvOS UWP (Universal Windows Platform) | Unity 2018.3.0f2
Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity-2018.1.0f2-MLTP6 with ML SDK 0.16.0)

已解决的问题：

  • WG-26971 确保了可在整个 Unity 工程内沿用 Wwise 对象重命名结果。
  • WG-36815 已修复：Advanced Profiler 的 Listeners 选项卡不会刷新 Game Object 或 Listener 名称。
  • WG-38842 现在可在 Unity 编辑器中正常地重新加载更新后的 SoundBank。
  • WG-39769 改进了 AkSurfaceReflector 组件，现在与 AkRoom 组件关联。
  • WG-40552 AkAmbient 不再针对 Large_Mode 定位类型使用难以操作的编辑器。现在改用包含 AkAmbientLargeModePositioner 组件的子对象作为多点定位的定位源。
  • WG-41010 将 Acoustic Texture 和 Game Parameter 的对应图标添加到了 Wwise Picker 中。
  • WG-41282 添加了 AkSurfaceReflector 作为 Acoustic Texture 的拖放目标。
  • WG-42073 现在所有 Python 构建脚本均与 Python 3 兼容。
  • WG-42081 (Linux) 取消了对 32 位插件的支持。
  • WG-42133 (Switch) 现在可在平台上使用所有可用插件。
  • WG-42208 已修复：(tvOS) DSP 插件的路径有误。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2018.1.6.6858.1313

版本说明 - Wwise Unity Integration 2018.1.6.6858.1313

此次发布为 Wwise 2018.1.6 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2018.1.6
  • Unity：Unity 5.6，2017.4，2018.1，2018.2，2018.3 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Mac Xbox One | Unity 2018.2.16f1
Linux PS4 tvOS UWP (Universal Windows Platform) Windows | Unity 2018.3.0f2
Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity-2018.1.0f2-MLTP6 with ML SDK 0.16.0)
Switch | Unity for Nintendo Switch 2018.2.16f1 with NintendoSDK 6.4.0

已解决的问题：

  • WG-36343 已修复：为无效门户设置了 Portal 声障，导致错误日志反复报错。
  • WG-37644 已修复：标准输出显示多条 "AkInitializer.cs Awake() was not executed yet" 误报。
  • WG-39629 已修复：在集成 Wwise Unity Integration 时，有些场景中未将 AkAudioListener 添加到镜头。
  • WG-39793 现在在 Editor 中暂停游戏时可连接 Wwise Profiler。
  • WG-40103 已修复：在迁移 WwiseTypes 时没有保存 Prefab。
  • WG-40988 已修复：在播放声音时无法正常刷新 AkAmbient Play 按钮。
  • WG-41012 已修复：在将条目从 Wwise Picker 拖放到 Game Object Inspector 视图时，有时无法生成相应的脚本。
  • WG-41018 已修复：在通过 Wwise Picker 创建 Component 时，无法正常撤消/恢复拖放操作。
  • WG-41107 (iOS, Switch, tvOS) 已修复：在构建的游戏引用的插件缺失时不显示错误。
  • WG-41185 已修复：在 Play 模式下，Wwise Picker 窗口显示 Root Item。
  • WG-41248 (PS4) 已修复：由于没有 ACP Batch 缓冲区，导致 ATRAC9 解码失败。
  • WG-41479 已修复：无法迁移 Timeline Demo Event 和 RTPC 音轨。
  • WG-41514 已修复：在从 Wwise Picker 拖放条目时，有时无法正确引用条目。
  • WG-41815 已修复：在从 Wwise 2018.1.3 升级到 2018.1.6 时无法正确迁移 Wwise 组件。
  • WG-41920 确保了 AkEvents 回调用于 Prefab 实例时，可以正常保存回调。
  • WG-42016 (Switch) 将 AkMotionSourceSource 添加到了数据包。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2018.1.5.6835.1288

版本说明 - Wwise Unity Integration 2018.1.5.6835.1288

此次发布为 Wwise 2018.1.5 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2018.1.5
  • Unity：Unity 5.6，2017.4，2018.1，2018.2，2018.3 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac PS4 tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2018.3.0f2
Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity-2018.1.0f2-MLTP6 with ML SDK 0.16.0)
Switch | Unity for Nintendo Switch 2018.2.16f1 with NintendoSDK 6.4.0

已解决的问题：

  • WG-36753 现在 Unity Integration 使用 SDK 提供的 premake5 生成 C++ 工程。
  • WG-39264 已修复：在撤消包含 Wwise 组件的对象时控制台会反复发送信息。
  • WG-39429 已修复：无法在 UI 中找到高级平台特定设置。
  • WG-39543 现在 Timeline 中的 Sound Event 会在生成 SoundBank 时显示新的名称。
  • WG-39990 添加了对 Android ARM64 的支持。
  • WG-40006 添加了用于确认更改插件配置的消息。
  • WG-40565 已修复：之前 Wwise Unity 初始化设置包含无效的默认 Spatial Audio 衍射值。现在更新了默认值，并会验证原有工程的默认值，以确保其在允许范围内。
  • WG-40674 已修复：2017.3 之前版本的 Unity 中的编译错误。
  • WG-40992 现在会适时保存 Unity 数据中的重复 Wwise 工程信息。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2018.1.4.6807.1258

版本说明 - Wwise Unity Integration 2018.1.4.6807.1258

此次发布为 Wwise 2018.1.4 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2018.1.4
  • Unity：Unity 5.6，2017.4，2018.1，2018.2 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac PS4 tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2018.2.5f1
Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity-2018.1.0f2-MLTP6 和 ML SDK 0.16.0)
Switch | Unity for Nintendo Switch 2018.2.16f1 和 NintendoSDK 6.4.0

已解决的问题：

  • WG-39412 修复了 HiDPI 监视器上不显示 AkAmbient 工具栏的问题。
  • WG-39444 修复了 AkExternalSourceInfo 文件名的字符串编码问题。
  • WG-39639 修复了 AkEventPlayable Timeline 片段不随 SoundBank 信息自动更新的问题。
  • WG-39849 修复了在使用字符串数组调用 AkSoundEngine.PrepareEvent() 或 AksoundEngine.PrepareGameSync() 时的堆损坏问题。
  • WG-40051 修复了 Switch 平台上的 Development Build 问题。
  • WG-40095 修复了边修改素材边打开工程时的挂起问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2018.1.3.6784.1233

版本说明 - Wwise Unity Integration 2018.1.3.6784.1233

此次发布为 Wwise 2018.1.3 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2018.1.3
  • Unity：Unity 5.6，2017.4，2018.1，2018.2 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac PS4 tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2018.2.5f1
Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity-2018.1.0f2-MLTP6 和 ML SDK 0.16.0)
Switch | Unity for Nintendo Switch 4.1.0 (Unity 2018.1.4f1 和 NintendoSDK 5.4.0)

已解决的问题：

  • WG-38413 已修复：在暂停 Editor 后进入 Play 模式会导致 Unity 卡顿。
  • WG-39235 对于已经初始化声音引擎的情况添加了相应的日志消息。
  • WG-39416 已修复：在将 Prepare Pool Size 设为 0 以外的值时 Unity 发生崩溃。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2018.1.2.6762.1211

版本说明 - Wwise Unity Integration 2018.1.2.6762.1211

此次发布为 Wwise 2018.1.2 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2018.1.2
  • Unity：Unity 5.6，2017.4，2018.1，2018.2 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac PS4 tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2018.2.5f1
Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity-2018.1.0f2-MLTP6 和 ML SDK 0.16.0)
Switch | Unity for Nintendo Switch 4.1.0 (Unity 2018.1.4f1 和 NintendoSDK 5.4.0)

已解决的问题：

  • WG-26971 现在会在整个 Unity 工程内沿用 Wwise 对象重命名结果。
  • WG-39195 已修复：在听者位置和朝向恒定时 Editor 反复发送信息。
  • WG-39235 对于已经初始化声音引擎的情况添加了相应的日志消息。
  • WG-39307 将衰减范围的可见性设成了 90% 透明。
  • WG-39331 确保了在执行更改后一并保存 AkWwiseInitializationSettings {{ScriptableObject}} 和平台设置。
  • WG-39362 向 Unity Integration 添加了 Opus 编解码器。
  • WG-39577 已修复：(Xbox One) 初始化问题。
  • WG-39608 向文件包添加了 WAAPI C# API 文件。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2018.1.1.6727.1172

版本说明 - Wwise Unity Integration 2018.1.1.6727.1172

此次发布为 Wwise 2018.1.1 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2018.1.1
  • Unity：Unity 5.6，2017.4，2018.1，2018.2 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux PS4 tvOS UWP (Universal Windows Platform) Xbox One | Unity 2018.1.5
Mac Windows | Unity 2018.2.2f1
Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity-2018.1.0f2-MLTP6 和 ML SDK 0.16.0)
Switch | Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 和 NintendoSDK 4.5.0)

已解决的问题：

  • WG-35762 已修复：在播放多个选定 AkEvents 时仅播放一个 Event ID。
  • WG-39012：移除了 AkWwisePostImportCallbackSetup.ClearConsole()。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2018.1.0.6714.1154

版本说明 - Wwise Unity Integration 2018.1.0.6714.1154

此次发布为 Wwise 2018.1.0 提供了 Wwise SDK 更新。

  • 新功能 2018.1

兼容性：

  • Wwise SDK: 2018.1.0
  • Unity：Unity 5.6，2017.4，2018.1，2018.2 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
平台： | Wwise Unity Integration 在以下平台测试过：
Android iOS Linux Mac PS4 tvOS UWP (Universal Windows Platform) Windows Xbox One | Unity 2018.1.0f2
Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity 2018.1.0b12-MLTP5 和 ML SDK 0.14.0)
Switch | Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 和 NintendoSDK 4.5.0)

已解决的问题：

  • WG-30965：向 C# 绑定暴露了 COMM 初始设置。
  • WG-32316：暴露了 Xbox One APU 内存堆大小。
  • WG-36375：在 Unity UI 中暴露了各种初始化设置。
  • WG-36993：修复了数组内的 WwiseTypes 设置。
  • WG-37127：针对房间底噪添加了对新的 Spatial Audio Room API 的支持。
  • WG-37514：添加了 Unity 对 WAAPI 的支持。


Wwise Unity Integration Documentation: 新功能 2018.1

新功能 2018.1

在 Wwise 2018.1 和它的 Unity 集成中有许多重要的新功能。新功能包含以下几点：

  • Unity Editor 中整合了性能分析器使用的通信设置。
  • 现在可在 Unity Integration 中设置 APU 堆大小。
  • 新增了 C# WAAPI Client 类，便于用户自行编写脚本，并通过 WAAPI 与 Wwise 设计工具进行通信。
  • 现在可在 Unity Editor 中针对各个平台定义 Wwise 初始化设置（定义各个内存池大小）。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.2.9.6726.1210

版本说明 - Wwise Unity Integration 2017.2.9.6726.1210

此次发布为 Wwise 2017.2.9 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2017.2.9
  • Unity：Unity 5.6，2017.4，2018.1，2018.2，2018.3 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
平台： | Wwise Unity Integration 在以下平台测试过：
iOS Mac tvOS Windows | Unity 2018.3.0f2
Android Linux PS4 UWP (Universal Windows Platform) Xbox One | Unity 2018.2.16f1
Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity-2018.1.9f1-MLTP9.6 with ML SDK 0.18.0)
Switch | Unity for Nintendo Switch 2018.2.16f1 with NintendoSDK 6.4.0

Resolved Issues:

  • WG-39412 修复了 Hi DPI 监视器上不显示 AkAmbient 工具栏的问题。
  • WG-39444 修复了 AkExternalSourceInfo 文件名的字符串编码问题。
  • WG-39849 修复了在使用字符串数组调用 AkSoundEngine.PrepareEvent() 或 AksoundEngine.PrepareGameSync() 时的堆损坏问题。
  • WG-39990 添加了对 Android ARM64 的支持。
  • WG-40006 添加了用于确认更改插件配置的消息。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.2.8.6698.1171

版本说明 - Wwise Unity Integration 2017.2.8.6698.1171

此次发布为 Wwise 2017.2.8 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2017.2.8
  • Unity: Unity 5.6, 2017.1, 2017.2, 2017.3, 2017.4, 2018.1, 和 2018.2 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Xbox One
    Mac
    Windows     		Unity 2018.2.5f1
    Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity 2018.1.0b12-MLTP5 with ML SDK 0.14.0)
    Switch | Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 with NintendoSDK 4.5.0)

已解决的问题：

  • WG-38413 已修复：在暂停 Editor 后进入 Play 模式会导致 Unity 卡顿。
  • WG-39195 已修复：在听者位置和朝向恒定时 Editor 反复发送信息。
  • WG-39201 移除了通过 Add Component 按钮添加 AkBank 组件时的错误消息。
  • WG-39235 对于已经初始化声音引擎的情况添加了相应的日志消息。
  • WG-39307 将衰减范围的可见性设成了 90% 透明。
  • WG-39388 已修复：在重新加载工程时没有保留 Ak Initializer 设置。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.2.7.6661.1133

版本说明 - Wwise Unity Integration 2017.2.7.6661.1133

此次发布为 Wwise 2017.2.7 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2017.2.7
  • Unity: Unity 5.6, 2017.1, 2017.2, 2017.3, 2017.4, 2018.1, 和 2018.2 (Personal 或 Pro)。
    备注： 重要说明：此 Integration 版本不支持 Unity 4。对于上述未列出的 Unity 版本，不保证一定兼容。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Xbox One     		Unity 2018.1.5
    Mac
    Windows     		Unity 2018.2.2f1
    Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity 2018.1.0b12-MLTP5 和 ML SDK 0.14.0)
    Switch | Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 和 NintendoSDK 4.5.0)

已解决的问题：

  • WG-35762 已修复：在播放多个选定 Ak Object 时仅播放一个 Event ID。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.2.6.6636.1107

版本说明 - Wwise Unity Integration 2017.2.6.6636.1107

此次发布为 Wwise 2017.2.6 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2017.2.6
  • Unity：Unity 5.6, 2017.1, 2017.2, 2017.3, 2017.4 和 2018.1 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity 2018.1.0b12-MLTP5 和 ML SDK 0.14.0)
    Switch | Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 和 NintendoSDK 4.5.0)

已解决的问题：

  • WG-36351 已修复：SpatialAudioTutorial Unity 场景的 AkRoomPortal 组件 Baker 窗口引发错误。
  • WG-38246 已修复：现在在 Inspector Window 中使用 WwiseTypes 列表时可以在列表中设置正确条目。
  • WG-38247 已修复：在非 Inspector 窗口中显示 WwiseType 不再会引发异常。
  • WG-38312 已修复：Save Decoded Bank 功能不再会覆盖原始 SoundBank。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.2.5.6619.1090

版本说明 - Wwise Unity Integration 2017.2.5.6619.1090

此次发布为 Wwise 2017.2.5 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2017.2.5
  • Unity：Unity 5.6, 2017.1, 2017.2, 2017.3, 2017.4 和 2018.1 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Magic Leap (Lumin OS) | Unity for Magic Leap Technical Preview (Unity 2018.1.0b12-MLTP5 和 ML SDK 0.14.0)
    Switch | Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 和 NintendoSDK 4.5.0)

已解决的问题：

  • WG-37187：修复了在 Editor 中删除 WwiseGlobal 对象时的声音引擎重新激活问题。
  • WG-37767：修复了构建的游戏中通过 OnApllicationPause() 和 OnApplicationFocus() 回调使声音引擎进入暂停/恢复状态的问题。
  • WG-37836：确保了 Xbox One PDB 文件名与 DLL 保持一致。
  • WG-38027：修复了 Unity 2018.1 中的 Wwise 类型和组件检视器。
  • WG-38191：添加了对 Magic Leap 平台的实验性支持。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.2.4.6590.1064

版本说明 - Wwise Unity Integration 2017.2.4.6590.1064

此次发布实现了与 Unity 2018.1 的兼容。

兼容性：

  • Wwise SDK：2017.2.4
  • Unity：Unity 5.6, 2017.1, 2017.2, 2017.3, 2017.4 和 2018.1 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Switch Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 和 NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.2.4.6590.1054

版本说明 - Wwise Unity Integration 2017.2.4.6590.1054

此次发布为 Wwise 2017.2.4 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2017.2.4
  • Unity：Unity 5.5, 5.6, 2017.1, 2017.2, 2017.3 和 2017.4 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2017.4.0f1
    Switch Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 和 NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.2.3.6575.1037

版本说明 - Wwise Unity Integration 2017.2.3.6575.1037

此次发布为 Wwise 2017.2.3 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2017.2.3
  • Unity：Unity 5.5, 5.6, 2017.1, 2017.2, 和 2017.3 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (Universal Windows Platform) | Unity 2017.3.0p3
    Switch | Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 和 NintendoSDK 3.5.2)

已解决的问题：

  • WG-36615：修复了连接到 Editor 时对象名称异常显示为 ID 的问题。
  • WG-36636：修复了 Editor 和游戏中的 AkInitializer 问题。
  • WG-36817：修复了在 Editor 中播放/停止场景时的默认听者游戏对象注册问题。
  • WG-36829：修复了 AkWwisePostImportCallbackSetup.cs 不会将场景标记为未清理状态的问题。
  • WG-36867：修复了 AkGameObj 和 AkAudioListener 初始化之间的循环依赖问题。
  • WG-36952：修复了 MSSpatial 插件激活问题。
  • WG-37021：修复了在 Editor 中从 StreamingAssets 文件夹加载 SoundBank 的问题。
  • WG-37061：修复了首次部署到 Switch、iOS 和 tvOS 时的失败问题。
  • WG-37065：修复了 Wwise 的 AK::SoundEngine::Term 可能发生崩溃的问题，在停止游戏时不再会导致 Unity Editor 崩溃。
  • WG-37122：修复了在单个 AkEnvironmentPortal 内移动时辅助发送的更新问题。
  • WG-37171：修复了 Unity 5.5 中的 AkAmbientInspector.cs 编译错误。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.2.2.6553.1015

版本说明 - Wwise Unity Integration 2017.2.2.6553.1015

此次发布为 Wwise 2017.2.2 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2017.2.2
  • Unity：Unity 5.5, 5.6, 2017.1, 2017.2, 和 2017.3 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (Universal Windows Platform) | Unity 2017.3.0p3
    Switch | Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 和 NintendoSDK 3.5.2)

已解决的问题：

  • WG-26533：在 Wwise Picker 中保存已展开的项时，仅会在必要时将工程设为未清理状态。
  • WG-33976：为了在 UWP 上实现 Wwise 通信，添加了相应的菜单项。有关详细信息，请参阅 有关 Windows 的特定信息 。
  • WG-36296：使用了 AkSoundEngine.AddListener 和 AkSoundEngine.AddDefaultListener 功能。
  • WG-36434：完全限定了 Integration 内使用的各种类型的名称。
  • WG-36499：修复了尚未加载 AkSoundEngine.dll 时的 Unity 安装问题。
  • WG-36584：添加了有关 AkSoundEngine 的文档，并修复了 API/Handwritten 和 Components 文件夹内各个类对应的文档。
  • WG-36827：修复了 AkInitializer 重新初始化和 SoundBank 卸载问题。
  • WG-36848：修复了 AkRoomPortals 检测不到带有触发器碰撞器的 AkRoom 组件的问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.2.1.6524.980

版本说明 - Wwise Unity Integration 2017.2.1.6524.980

此次发布为 Wwise 2017.2.1 提供了 Wwise SDK 更新。Wwise Unity 集成文档现在也有中文版本了。

兼容性：

  • Wwise SDK：2017.2.1
  • Unity：Unity 5.5, 5.6, 2017.1, 2017.2, 和 2017.3 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (Universal Windows Platform) | Unity 2017.3.0p3
    Switch | Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 和 NintendoSDK 3.5.2)

已解决的问题：

  • WG-34267：将 Wwise_IDs.cs 的成员放在了 AK 命名空间内，并为类名称加了 Ak 前缀。
  • WG-35301：将 AkEventSection 添加到 Timeline Track 时，Event 选择器将自动显示在检视器中。
  • WG-35609：现在 AkRoomPortal 检视器会实时更新前后房间。
  • WG-36086：为了实时更新前后房间，向 AkRoomPortal 添加了公共函数。
  • WG-36099：修复了从 2016.2.4 迁移时的 NullReferenceException 问题。
  • WG-36125：修复了与 Unity 5.5 的兼容问题。
  • WG-36144：为了避免潜在冲突，在 Wwise C# 脚本中指定了完整的 System.IO.Path。
  • WG-36219：修复了在 Unity 2017.3 下从 Wwise Picker 拖放对象时的异常问题。
  • WG-36356：在 AkInitializer 检视器中暴露了监控池大小和队列大小。
  • WG-36413：修复了两个房间之间存在不止一个门户时的崩溃问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.2.0.6500.947

版本说明 - Wwise Unity Integration 2017.2.0.6500.947

这次发布为 Wwise 2017.2.0 提供了 Wwise SDK 的更新，与 Unity 2017.3 兼容。

  • 新功能 2017.2
  • 重要迁移说明 2017.2

兼容性：

  • Wwise SDK: 2017.2.0
  • Unity：Unity 5.5, 5.6, 2017.1, 2017.2, 和 2017.3 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Mac
    Windows
            Unity 2017.3.0f3
    Android
    iOS
    Linux
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Xbox One     		Unity 2017.2.0f3
    Switch Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 和 NintendoSDK 3.5.2)

新功能：

  • 添加了一些新功能，详情请参见 新功能 2017.2 页面。

重要迁移说明：

  • 为了避免与其它软件包的命名冲突，做出了一些重大更改。具体细节参见 重要迁移说明 2017.2 页面。

已解决的问题：

  • WG-25994：现在可以通过 C# 脚本访问 Audio Input 源插件。详情参见 在 Unity 中使用 Audio Input 源插件 。
  • WG-27337：现在允许将 MIDI 事件发送到声音引擎。详情参见 将 MIDI 发送到 Wwise 。
  • WG-28541：为所有没有加 Ak 前缀的枚举添加了命名空间。为所有生成的类添加了 Ak 前缀。
  • WG-33501：添加了 SoundBank 自动管理功能。
  • WG-34446：减少了 AkCallbackManager 中指派的内存。


Wwise Unity Integration Documentation: 新功能 2017.2

新功能 2017.2

在 Wwise 2017.1 和它的 Unity 集成中有许多重要的新功能。新功能包含以下几点：

  • Edit 模式支持
    • 在 Edit 模式下加载和卸载音频包
  • 增添 WwiseGlobal 游戏对象组件
  • Wwise Audio Input 插件
  • MIDI 事件
  • SoundBank 自动管理

Edit 模式支持

现在支持在 Unity 处于 Edit 模式时初始化 Wwise 声音引擎。如此一来，无需进入 Play 模式便可从编辑器触发 Wwise 事件。为了展示这一改进，相应地更新了 AkEvent 和 AkAmbient 检视器 （Inspector）。检视器中现在设有相应按钮，方便直接从编辑器播放和停止 Event。您可以使用 Play/Stop 按钮来单独播放和停止各个 Event。在针对多个对象选中 AkEvent 时，则可使用 Play Multiple 和 Stop Multiple 按钮来播放或停止当前选中的所有 Event。此外，还可使用 Stop All 按钮来停止当前正在播放的所有 Event。

在 Edit 模式下加载和卸载音频包

注意，为了确保可正常使用 Edit 模式，必须将对应 AkBank 组件的 Load On: 属性设为 Awake，同时将 Unload On: 属性设为 Never。

增添 WwiseGlobal 游戏对象组件

WwiseGlobal 游戏对象包含了 AkEditorEventPlayer 组件。此组件仅适用于编辑器，方便在 Edit 模式下播放与 AkEvent 关联的 WwiseEvent。此外，WwiseGlobal 对象还包含了 Rigidbody、AkGameObj 和 AkAudioListener 组件。这些组件用于在 Edit 模式下实现 AkEnvironment、AkGameObj 和 AkRoom 组件之间的交互。请参阅 针对 Unity 工程所作的更改 。

Wwise Audio Input 插件

现在可以通过 C# 脚本来访问 Wwise Audio Input 源插件了。详情参见 在 Unity 中使用 Audio Input 源插件 。

MIDI 事件

现在可以通过 C# 脚本将 MIDI 事件发布至 Wwise 了。详情参见 将 MIDI 发送到 Wwise 。

SoundBank 自动管理

现在增加了 SoundBank 自动管理功能。详情参见 在单平台工程中部署 SoundBanks 和 在多平台工程中部署 SoundBank 。

空间音频集成

为 Unity 集成添加了空间音频 API。如需查看教程，请参阅 在 Unity 中使用 Spatial Audio 。


Wwise Unity Integration Documentation: 重要迁移说明 2017.2

重要迁移说明 2017.2

以下枚举已更改名称：

2017.2 之前的版本： | 2017.2 中新增：
ErrorCode | AK.Monitor.ErrorCode
ErrorLevel | AK.Monitor.ErrorLevel
DynamicSequenceType | AK.SoundEngine.DynamicSequence.DynamicSequenceType
MultiPositionType | AK.SoundEngine.MultiPositionType
PreparationType | AK.SoundEngine.PreparationType
RTPCValue_type | AK.SoundEngine.Query.RTPCValue_type

以下类已经更改了名称：

2017.2 之前的版本： | 2017.2 中新增：
Iterator | AkIterator
Playlist | AkPlaylist
PlaylistItem | AkPlaylistItem


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.1.9.6501.947

版本说明 - Wwise Unity Integration 2017.1.9.6501.947

此次发布为 Wwise 2017.1.9 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2017.1.9
  • Unity：Unity 5.5，5.6，2017.1，2017.2，2017.3，2017.4，2018.1 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Switch Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 和 NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.1.8.6488.933

版本说明 - Wwise Unity Integration 2017.1.8.6488.933

此次发布为 Wwise 2017.1.8 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2017.1.8
  • Unity：Unity 5.5，5.6，2017.1，2017.2，2017.3，2017.4，2018.1 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2018.1.0f2
    Switch Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 和 NintendoSDK 4.5.0)

已解决的问题：

  • WG-37836：确保了 Xbox One PDB 文件名与 DLL 保持一致。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.1.7.6467.910

版本说明 - Wwise Unity Integration 2017.1.7.6467.910

此次发布为 Wwise 2017.1.7 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2017.1.7
  • Unity：Unity 5.5, 5.6, 2017.1, 2017.2, 2017.3 和 2017.4 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2017.4.0f1
    Switch Unity for Nintendo Switch 4.1.0 (Unity 2017.4.0f1 和 NintendoSDK 4.5.0)


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.1.6.6446.890

版本说明 - Wwise Unity Integration 2017.1.6.6446.890

此次发布为 Wwise 2017.1.6 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK：2017.1.6
  • Unity：Unity 5.5, 5.6, 2017.1, 2017.2, 和 2017.3 (Personal 或 Pro)。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (Universal Windows Platform) | Unity 2017.3.0p3
    Switch | Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 和 NintendoSDK 3.5.2)


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.1.5.6429.870

版本说明 - Wwise Unity Integration 2017.1.5.6429.870

兼容性：

  • Wwise SDK：2017.1.5
  • Unity：Unity 5.5, 5.6, 2017.1 以及 2017.2 (Personal 或 Pro).
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    tvOS
    Windows
    Xbox One     		Unity 2017.3.0f3
    UWP (Universal Windows Platform) | Unity 2017.3.0p3
    Switch | Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 和 NintendoSDK 3.5.2)

已解决的问题：

  • WG-33289：将 SWIG 更新到了 3.0.12 版本。
  • WG-36079：恢复了 AddSecondaryOutput。
  • WG-36219：修复了在 Unity 2017.3 下从 Wwise Picker 拖放对象时的异常问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.1.4.6407.845

版本说明 - Wwise Unity Integration 2017.1.4.6407.845

兼容性：

  • Wwise SDK：2017.1.4
  • Unity：Unity 5.5, 5.6, 2017.1 以及 2017.2 (Personal 或 Pro).
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2017.2.0f3
    Switch Unity for Nintendo Switch 3.1.2 (Unity 5.6.4 和 NintendoSDK 3.5.2)

已解决的问题：

  • WG-35168：修复了在 Switch 上加载 SoundBank 时的崩溃问题。
  • WG-35383：修复了自定义检视器内 WwiseTypes 所关联 ID 属性的更新问题。
  • WG-35384：现在会在 OnEnable() 而非 Awake() 条件下激活 AkAudioListener 、 AkInitializer 和 AkTerminator ，所以在 Editor 中取消选中时会将其禁用。
  • WG-35513：为 AkGameObj 添加了全面的自定义定位。
  • WG-35958：添加了对 Unity 2017.3 的支持。注意，尚未在 Unity 2017.3 中全面测试集成效果，但应该不会出现兼容问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.1.3.6377.812

版本说明 - Wwise Unity Integration 2017.1.3.6377.812

本次发布为 Wwise 2017.1.3 提供了 Wwise SDK 更新，并与 Unity 2017.1 兼容。

兼容性：

  • Wwise SDK：2017.1.3
  • Unity：Unity 5.5, 5.6, 2017.1 以及 2017.2 (Personal 或 Pro).
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2017.2.0f3
    Switch Unity for Switch 1.0.1 (Unity 5.5.0p1 和 Nintendo SDK 1.4.0)

已解决的问题：

  • WG-34855：添加了 AkSoundEngine.GetCurrentLanguage()。
  • WG-35075 已修复：在 Audiokinetic Launcher 中添加了对 Unity 2017.2 集成的支持。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.1.2.6361.791

版本说明 - Wwise Unity Integration 2017.1.2.6361.791

此次发布为 Wwise 2017.2 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2017.1.2
  • Unity: Unity 2017.1（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    UWP (Universal Windows Platform)
    Windows
    Xbox One     		Unity 2017.1.1f1
    Switch Unity for Switch 1.0.1 (Unity 5.5.0p1 和 Nintendo SDK 1.4.0)


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.1.1.6340.770

版本说明 - Wwise Unity Integration 2017.1.1.6340.770

本次发布为 Wwise 2017.1.1 提供了 Wwise SDK 更新，并与 Unity 2017.1 兼容。

兼容性：

  • Wwise SDK: 2017.1.1
  • Unity: Unity 2017.1（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Mac
    Windows
            Unity 2017.1.0f3
    Android
    iOS
    Linux
    PS4
    PS Vita
    tvOS
    UWP (Universal Windows Platform)
    Xbox One     		Unity 5.6.1p1
    Switch Unity for Switch 1.0.1 (Unity 5.5.0p1 和 Nintendo SDK 1.4.0)

已解决的问题：

  • WG-33018 已修复：在使用 Decode Banks 功能时不会再生成本地化文件夹。
  • WG-33818：修复了 iOS 和 Android 上的音频包解码问题。
  • WG-34090：为 WSA Unity Plugin 修复了 TLS Allocator Error spamming。
  • WG-34205：System.EventHandler 的完全限定名，以避免命名冲突。
  • WG-34205：UnityEditor.Menu 和 UnityEditor.MenuItem 的完全限定名，以避免命名冲突。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2017.1.0.6302.726

版本说明 - Wwise Unity Integration 2017.1.0.6302.726

本次发布为 Wwise 2017.1.0 提供了 Wwise SDK 更新，并与 Unity 2017.1 兼容。

  • 新功能 2017.1
  • 重要迁移说明 2017.1

兼容性：

  • Wwise SDK: 2017.1.0
  • Unity: Unity 2017.1（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Mac
    Windows
            Unity 2017.1.0f3
    Android
    iOS
    Linux
    PS4
    PS Vita
    tvOS
    UWP (Universal Windows Platform)
    Xbox One     		Unity 5.6.1p1
    Switch Unity for Switch 1.0.1 (Unity 5.5.0p1 和 Nintendo SDK 1.4.0)

新功能：

  • 添加了一些新功能，详情请参见 新功能 2017.1 页面。

重要迁移说明：

  • 不再支持 Wii U 平台。
  • 包含自动注册 GameObject 的功能已经被转移到 Unity Integration Extensions。See more details about this change in the Wwise Installation and Migration Guide.
  • 针对 AkCallbackManager 有许多重大更改，详情请见 重要迁移说明 2017.1 页面。

已解决的问题：

  • WG-27479：可以通过 AkInitializer 配置回调缓冲区大小。
  • WG-30791：添加了 WwiseTypes。详情参见 Wwise Types 。
  • WG-31155：修复了 AkMemSettings 和 AkChannelConfig，因此它们的方法不检查 SoundEngine 初始化。
  • WG-31735：添加了钩子，使用户可以方便地扩展或删除 GameObjects 的自动注册。详情参见 Unity Integration Extensions（集成扩展） 。
  • WG-32348：修复了 SoundBanksInfo 文件的 XML 解析。
  • WG-32657：在使用回调类时减少内存分配，并删除 foreach 语句。
  • WG-33303：为 AK_MusicPlaylistSelect 添加支持。
  • WG-34003：安装过程不再会禁用工程中的其它原生插件。


Wwise Unity Integration Documentation: 新功能 2017.1

新功能 2017.1

在 Wwise 2017.1 和它的 Unity 集成中有许多重要的新功能。新功能包含以下几点：

  • 需要的组件
  • WwiseTypes
  • Unity Integration Extensions（集成扩展）
  • 3D 总线

需要的组件

[RequireComponent(typeof(AkGameObj))] 被添加到 AkEvent。

AkEnvironment 和 AkEnvironmentPortal 不再将 Rigidbody 指定为必需的组件，并且 Rigidbody 的成员不再被修改。如果一个 AkEnvironment 或 AkEnvironmentPortal 没有 Rigidbody 附加到它的游戏对象上，或者一个 AkGameObj 设置为 "Environment aware" 而且没有 Rigidbody 附加到它的游戏对象上，那么 Editor 中将显示以下警告：AkGameObj-AkEnvironment interactions require a Rigidbody component on the object or the environment.

以上警告都可以移除，方法是，在 Wwise Settings 窗口中，取消勾选 Show Warning for Missing RigidBody。

WwiseTypes

添加了新的 "WwiseTypes"，它能让用户更好地控制由 Wwise 对象表示的那些功能（例如 Event、game parameter、Switch 和 State）。这些新的类都有各自的属性抽屉，当单击它们时，会弹出一个 Wwise Picker，可以快速对游戏音频系统进行原型设计。

下面是一个简单的示范用例：

public class Footsteps : MonoBehaviour
{
[Header("Wwise Types")]
public AK.Wwise.Event FootStepEvent = null;
public AK.Wwise.RTPC SpeedRTPC = null;
public AK.Wwise.Switch UnderFootMaterialSwitch = null;
public AK.Wwise.Bank FootStepBank = null;
void InitializeSound() { FootStepBank.Load(); }
void FinalizeSound() { FootStepBank.Unload(); }
void PlayFootStepSound(float speed)
{
SpeedRTPC.SetValue(gameObject, speed);
UnderFootMaterialSwitch.SetValue(gameObject);
FootStepEvent.Post(gameObject);
}
}

Unity Integration Extensions（集成扩展）

AkSoundEngine 现在是一个不完全类。添加了用户钩子，这样可以使用户扩展游戏对象的自动注册或将此功能全部删除。The extensions are recommended, however, you can choose to exclude them when you integrate Wwise into your Unity project.

3D 总线

为了补充在 Wwise 中添加的 3D 总线功能，已经做了以下修改。不再限制听者的数量，并且添加了默认听者的概念；它的定义是，所有游戏对象最初设置为被哪个听者听到，则该听者就为默认听者。AkGameObj 已修改为持有一份 AkAudioListener 列表。默认情况下，AkGameObj 会向默认听者发送声音，AkAudioListener 是一个默认听者。

AK.Wwise.RTPC
This type can be used to set game parameter values to the sound engine.
Definition: AkWwiseRtpc.cs:25
AK
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Switch
This type can be used to set Switch values on gameobjects.
Definition: AkWwiseSwitch.cs:25
AK.Wwise.Bank
This type can be used to load/unload SoundBanks.
Definition: AkWwiseBank.cs:29


Wwise Unity Integration Documentation: 重要迁移说明 2017.1

重要迁移说明 2017.1

针对 AkCallbackManager 有以下重大更改：

  • AkCallbackManager.AudioInterruptionCallback() 的签名更新了：
    public delegate AKRESULT AudioInterruptionCallback(bool in_bEnterInterruption, object in_Cookie);
  • AkCallbackManager.BGMCallback() 的签名更新了:
    public delegate AKRESULT BGMCallback(bool in_bOtherAudioPlaying, object in_Cookie);
  • AkCallbackManager.EventCallback() 的签名更新了:
    public delegate void EventCallback(object in_cookie, AkCallbackType in_type, AkCallbackInfo in_info);
  • 回调类不再嵌套在 AkCallbackManager 中，并且有一个从 AkCallbackInfo 继承了许多内容的层级结构。只要有可能，这些类的关联和成员会模仿其 C++ 版本的语法。
  • 回调类的 gameObjID 成员现在是 ulong 类别，而不是 IntPtr。
  • AkCallbackManager.AkMidiEventCallbackInfo 这一类现在是 AkMIDIEventCallbackInfo。（请注意 "MIDI" 的大写）
  • AkCallbackManager.AkMusicSyncCallbackInfoBase 这个类被移除了。现在变为使用 AkMusicSyncCallbackInfo 这个类。
  • AkCallbackManager.AkMusicSyncCallbackInfo.segmentInfo 的所有成员已被开放成为 AkMusicSyncCallbackInfo.segmentInfo_* 的成员了。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.2.6.6153.595

版本说明 - Wwise Unity Integration 2016.2.6.6153.595

此次发布为 Wwise 2016.2.6 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2016.2.6
  • Unity: Unity 2017.2（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 2017.2.0f3
    Switch | Unity for Switch 3.1.2 (Unity 5.6.4p1 with NintendoSDK 3.5.2)
    Wii U | Unity 5.4.2f2
    已解决的问题：
  • WG-35075 已修复：在 Audiokinetic Launcher 中添加了对 Unity 2017.2 集成的支持。
  • WG-35168：修复了在 Switch 上加载 SoundBank 时的崩溃问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.2.5.6121.560

版本说明 - Wwise Unity Integration 2016.2.5.6121.560

此次发布为 Wwise 2016.2.5 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2016.2.5
  • Unity: Unity 2017.1（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 2017.1.0f3
    Switch | Unity for Switch 1.0.1 (Unity 5.5.0p1 和 NintendoSDK 1.4.0)
    Wii U | Unity 5.4.2f2
    Resolved Issues:
  • WG-33687：为 Nintendo Switch 上缺失的内部插件添加了头文件。
  • WG-34003：在安装过程中，不再会停用工程中的其他原生插件。
  • WG-34090：为 WSA Unity Plugin 修复了 TLS Allocator Error spamming。
  • WG-34216：修复了更新到 Unity 2017.1 时的编译问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.2.4.6098.531

版本说明 - Wwise Unity Integration 2016.2.4.6098.531

此次发布为 Wwise 2016.2.4 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2016.2.4
  • Unity: Unity 5.6（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.6.1p1
    Switch | Unity for Switch 1.0.1 (Unity 5.5.0p1 和 NintendoSDK 1.4.0)
    Wii U | Unity 5.4.2f2
    Resolved Issues:
  • WG-33395：在有潜在冲突的类名称中添加命名空间


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.2.3.6077.504

版本说明 - Wwise Unity Integration 2016.2.3.6077.504

此次发布为 Wwise 2016.2.3 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2016.2.3
  • Unity: Unity 5.6（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.6.0f3
    Switch | Unity for Switch 0.6.1
    Wii U | Unity 5.4.2f2

已解决的问题：

  • WG-32536：添加了 Nintendo Switch 支持。
  • WG-32623：修复了 Android 音乐自定义提示崩溃。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.2.2.6022.430

版本说明 - Wwise Unity Integration 2016.2.2.6022.430

此次发布为 Wwise 2016.2.2 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2016.2.2
  • Unity: Unity 5.5（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.5.0p4
    Wii U Unity 5.4.2f2

已解决的问题：

  • WG-31862：从事件回调列表中删除与事件回调无关的枚举值。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.2.1.5995.409

版本说明 - Wwise Unity Integration 2016.2.1.5995.409

此次发布为 2016.2.1 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2016.2.1
  • Unity: Unity 5.5（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.5.0f3
    Wii U Unity 5.4.2f2

已解决的问题：

  • WG-32006：修复了设置 GameObject 位置时的 "Unknown Game Object ID" 错误。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.2.1

版本说明 - Wwise Unity Integration 2016.2.1

此次发布为 2016.2.1 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2016.2.1
  • Unity: Unity 5.5（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.5.0f3
    Wii U Unity 5.4.2f2

已解决的问题：

  • WG-27085：减少了 AuxSends 造成的分配
  • WG-31127：为 AK_MusicSyncUserCue 修复了返回的用户提示名。
  • WG-31650：修复了当声音引擎未被初始化时 AkGameObj 中的 NullReferenceException。
  • WG-31651：避免在调用 SetObjectPosition 时自动创建 AkGameObj。
  • WG-31862：从事件回调列表中删除与事件回调无关的枚举值。

已知存在的问题

  • Unity case #861189：如果安装了 Unity Windows Store 播放引擎，使用 Launcher 来安装就会失败。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.2.0

版本说明 - Wwise Unity Integration 2016.2.0

此次发布为 Wwise 2016.2.0 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2016.2.0
  • Unity: Unity 5.4（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store (Universal Windows Platform)
    Xbox One     		Unity 5.4.1p2
    Wii U Unity 5.2.4f1

重要迁移说明

  • Windows Phone 8.1、Windows Store 8.0 和 8.1 平台已经被弃用。目前唯一支持的 Windows Store 平台是 Universal Windows Platform (UWP)。
  • 不再支持 Xbox 360 平台。
  • 不再支持 PS3 平台。

已解决的问题：

  • WG-30571：重新构建 Library 文件夹时将不再触发以下错误消息：Wwise Unity 集成没有安装到平台上。
  • WG-30960：对 AkGameObj 应用一个位置偏移量现在会反映在 Unity 的脏系统中。
  • WG-31507：添加 MediaID 和 bStreaming 到 duration 回调。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.1.6

版本说明 - Wwise Unity Integration 2016.1.6

此次发布为 Wwise 2016.1.6 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2016.1.6
  • Unity: Unity 5.5（Personal 或 Pro）。
    备注： 重要提示：我们不再正式支持对 Unity 4 的集成。 虽然它可能可以使用，但我们不会在 Unity 4 上测试当前或未来版本的 Wwise Integration。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.5.0p4
    PS3 | Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

已解决的问题：

  • WG-32006：修复了设置 GameObject 位置时的 "Unknown Game Object ID" 错误。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.1.5

版本说明 - Wwise Unity Integration 2016.1.5

此次发布为 Wwise 2016.1.5 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2016.1.5
  • Unity: Unity 5.5（Personal 或 Pro）。
    备注： 重要提示：我们不再正式支持对 Unity 4 的集成。 虽然它可能可以使用，但我们不会在 Unity 4 上测试当前或未来版本的 Wwise Integration。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.5.0f3
    PS3 | Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.1.4

版本说明 - Wwise Unity Integration 2016.1.4

此次发布为 Wwise 2016.1.4 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2016.1.4
  • Unity: Unity 5.4（Personal 或 Pro）。
    备注： 重要提示：我们不再正式支持对 Unity 4 的集成。 虽然它可能可以使用，但我们不会在 Unity 4 上测试当前或未来版本的 Wwise Integration。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

已解决的问题：

  • WG-31507：向时长回调添加了 MediaID 和 bStreaming 。
  • WG-31650：修复了未初始化声音引擎时 AkGameObj 中存在的 NullReferenceException 问题。
  • WG-31651：避免了在调用 SetObjectPosition() 时自动创建 AkGameObj 。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.1.3

版本说明 - Wwise Unity Integration 2016.1.3

此次发布为 Wwise 2016.1.3 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2016.1.3
  • Unity: Unity 5.4（Personal 或 Pro）。
    备注： 重要提示：我们不再正式支持对 Unity 4 的集成。 虽然它可能可以使用，但我们不会在 Unity 4 上测试当前或未来版本的 Wwise Integration。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.1.2

版本说明 - Wwise Unity Integration 2016.1.2

此次发布为 Wwise 2016.1.2 提供了 Wwise SDK 更新。Wwise Unity 集成文档现在也有日语版本了。

兼容性：

  • Wwise SDK: 2016.1.2
  • Unity: Unity 5.4（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.4.0p2
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

已解决的问题：

  • WG-30567 已修复：当使用 WAV 标记且它有一个空标签时，会崩溃。

重要迁移说明：

  • SWIG 源代码将不再与源码压缩包 文件一起分发了。所提供的 ZIP 源码包含所需的文件和预生成的 SWIG 接口，用于构建集成包，而无需使用 SWIG。
  • 仍然使用 Wwise 2014.1.4 及更低版本的工程不能直接升级到 2016.1。请先将您的工程更新到 2015.1.6，然后到 2016.1。
  • 如果想要将您的 Unity 工程更新到 Unity 5.4，请先执行 Wwise 迁移到 2016.1.2。Unity 5.4 中的一些更改破坏了较旧的集成。更新到 Wwise 2016.1.2 集成的话，会首先解决这些问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.1.1

版本说明 - Wwise Unity Integration 2016.1.1

此次发布为 Wwise 2016.1.1 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2016.1.1
  • Unity: Unity 5.3（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    tvOS
    Windows
    Windows Store
    Xbox One     		Unity 5.3.5p6
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

已解决的问题：

  • WG-30021：使用解码后 SoundBank 的最后修改日期，以确定它是否需要重新解码。
  • WG-30228：现在可以从源代码重新构建 Linux 集成了。
  • WG-30231：现在可以从源代码重新构建 tvOS 集成。
  • WG-30259：修复了调用 GC.Collect 时 AkGameObj 的注册行为。

已知存在的问题：

  • WG-30128：无法在 Vita 平台上将解码的 SoundBank 保存到磁盘。
  • WG-30139：将解码的声音库保存到Vita平台上是不可能的。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2016.1

版本说明 - Wwise Unity Integration 2016.1

此次发布为 Wwise 2016.1 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2016.1
  • Unity: Unity 5.3（Personal 或 Pro）。
    备注： 重要提示：该集成还没有在 Unity 4 上测试过。
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.4p3
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.0.1f1

已解决的问题：

  • WG-25675 已修复：在 Wwise Picker 中添加一个 “Generate SoundBanks” 按钮来为 Wwise 工程的所有平台生成 SoundBank。
  • WG-27583 已修复：现在自动管理 Unity assets 中的 SoundBank 文件夹，为当前 Unity 目标平台指向正确的 SoundBank。
  • WG-28175 已修复：在创建新场景时，WwiseGlobal 并不是每次都自动创建。
  • WG-26011 已修复：在创建一个新场景后，启用回 Ak Audio Listener 不能正确地破坏 Default Unity Audio Listener。

重要迁移说明：

  • SWIG 源代码将不再与源码压缩包 文件一起分发了。所提供的 ZIP 源码包含所需的文件和预生成的 SWIG 接口，用于构建集成包，而无需使用 SWIG。
  • 仍然使用 Wwise 2014.1.4 及更低版本的工程不能直接升级到 2016.1。请先将您的工程更新到 2015.1.6，然后到 2016.1。

已知存在的问题：

  • WG-30021：当在 Editor 中预览场景时，DecodeBanks 功能就会失效。
  • WG-30021：DecodeBanks 功能不会自动删除解码的 SoundBank。如果更新了声音库，则应该从目标设备中删除 DecodedBanks 文件夹。
  • WG-30128：无法在 Vita 平台上将解码的 SoundBank 保存到磁盘。
  • WG-30128：无法在 WiiU 平台上将解码的 SoundBank 保存到磁盘。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2015.1.9

版本说明 - Wwise Unity Integration 2015.1.9

此次发布为 Wwise 2015.1.9 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2015.1.9
  • Unity：Unity 4.6 Pro, 或 Unity 5.3 (Personal 或 Pro)
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.5p6
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2015.1.8

版本说明 - Wwise Unity Integration 2015.1.8

此次发布为 Wwise 2015.1.8 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2015.1.8
  • Unity：Unity 4.6 Pro, 或 Unity 5.3 (Personal 或 Pro)
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.5p6
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1

已解决的问题：

  • WG-30259 已修复：修复了调用 GC.Collect 时的 AkGameObj 注册行为。
  • WG-30422 已修复：在将 iOS 应用连接到 Apple TV 时，不再会中断音频。
  • WG-30567 已修复：修复了 WAV 标记含有空标签时的崩溃问题。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2015.1.7

版本说明 - Wwise Unity Integration 2015.1.7

此次发布为 Wwise 2015.1.7 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2015.1.7
  • Unity：Unity 4.6 Pro, 或 Unity 5.3 (Personal 或 Pro)
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.3.4p5
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1

已解决的问题：

  • WG-29521 已修复：(iOS) 在从未接 FaceTime 通话切换回来时发生死锁。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2015.1.6

版本说明 - Wwise Unity Integration 2015.1.6

此次发布为 Wwise 2015.1.6 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2015.1.6
  • Unity：Unity 4.6 Pro, 或 Unity 5.3 (Personal 或 Pro)
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store     		Unity 5.3.3p1
    Linux
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 5.2.4f1
    Xbox 360 | Unity 5.2.1f1

新功能

  • WG-23513 (Android) 添加了 Low-Level I/O，可读取 Unity 所用的 OBB 文件。

已解决的问题：

  • WG-29405 已修复：确保了不会在生成区域环境以外应用 AkEnvironment Effect。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2015.1.5

版本说明 - Wwise Unity Integration 2015.1.5

此次发布为 Wwise 2015.1.5 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2015.1.5
  • Unity：Unity 4.6 Pro, 或 Unity 5.3 (Personal 或 Pro)
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store     		Unity 5.3.1p3
    Linux
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 5.2.3p3 和 Wii U add-on 3.0.1
    Xbox 360 | Unity 5.2.1f1

新功能

  • 实现了 Wii U 集成与 Unity 5.2.3p3 的兼容。

已解决的问题：

  • WG-27300 已修复：整合了 Prepare Pool，允许使用 PrepareEvent() 和 PrepareBank()。
  • WG-28716 已修复：实现了源码包与 Python 3.4+ 的兼容。
  • WG-28917 已修复：对于 Main Camera 以外的 GameObject ，不再自动移除手动添加的 AkAudioListener 。
  • WG-28957 已修复：彻底解决了获取 Wwise 工程数据时的 NullReferenceExceptions 问题。
  • WG-28975 已修复：解决了 LoadBank() 和 UnLoadBank() 之间的竞争冲突。

已知问题：

  • 无法将 Profiler 连接到 Windows Store Apps 平台上的游戏。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2015.1.4

版本说明 - Wwise Unity Integration 2015.1.4

此次发布为 2015.1.4 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2015.1.4
  • Unity：Unity 4.6 Pro, 或 Unity 5.2 (Personal 或 Pro)
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 4.3.7f1 和 Wii U add-on 2.2.5
    Xbox 360 | Unity 5.0.1f1

新功能

  • 添加了对 Windows 10 Universal Apps 的支持。
  • 添加了对 Windows Store Apps SDK 8.1 的支持

重要迁移说明

  • 取消了对 Windows Phone 8.0 的支持
  • 取消了对 Windows Store Apps SDK 8.0 的支持

已解决的问题：

  • WG-28412 已修复： AkGameObj 位置偏移现在可以保存在预制件中。
  • WG-28723 已修复：现在可以将游戏构建为 PS4 包。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2015.1.3

版本说明 - Wwise Unity Integration 2015.1.3

本次发布为 Wwise 2015.1.3 和 Universal Windows Platform 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2015.1.3
  • Unity：Unity 4.6 Pro 或 Unity 5.2 (Personal 或 Pro)
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    PS3
    PS4
    PS Vita
    Windows
    Windows Store Apps
    Xbox One     		Unity 5.2.2p1
    Wii U | Unity 4.3.7f1 和 Wii U add-on 2.2.5
    Xbox 360 | Unity 5.0.1f1

新功能：

  • 在 Windows Store Apps 包下添加了对 Universal Windows Platform 的支持。
  • 添加了对 Windows Store Apps SDK 8.1 的支持。
  • 取消了对 Windows Phone 8.0 的支持。
  • 取消了对 Windows Store Apps SDK 8.0 的支持。

已解决的问题：

  • WG-25945 已修复：Wwise 错误总是被重定向到 Unity 控制台。在 WwiseGlobal 设置中添加一个菜单项，以便在 Unity 控制台中启用/禁用 Wwise 引擎输出。
  • WG-26011 已修复：在创建一个新场景后，启用回 Ak Audio Listener 不能正确地破坏 Default Unity Audio Listener。
  • WG-28108 已修复：当暂停编辑器时，声音仍然一直在播放。现在在编辑器中暂停后，声音会停止；取消暂停后，声音会重新播放。声音在切换窗口时（和以前一样）一直在播放。
  • WG-28175 已修复：在创建新场景时，WwiseGlobal 并不是每次都自动创建。
  • WG-28479 已修复：安装时尝试添加未勾选的选项。 现在在没有 Main Camera 的工程中安装集成时，安装会成功。
  • WG-28526 已修复：潜在的 Unity Editor 崩溃。确保了在注册和取消注册 GameObjects 之前，先对 SoundEngine 进行了初始化。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2015.1.2

版本说明 - Wwise Unity Integration 2015.1.2

此次发布为 Wwise 2015.1.2 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2015.1.2
  • Unity：Unity 4.6.5 Pro 或 Unity 5.1.2p2 (Personal 或 Pro)
    平台: Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PS Vita
    Windows
    Windows Phone
    Xbox One     		Unity 5.2.0f3
    Wii U | Unity 4.3.7f1 和 Wii U add-on 2.2.5
    Xbox 360 | Unity 5.0.1f1

已解决的问题：

  • WG-27029 已修复：修复了下述罕见的情况：一个失效的 Unity GameObject 可能导致关联的 AkGameObj 没有注册。
  • WG-28200 已修复：默认的激活状态的听者被设置为 Everything 受影响 离 (0, 0, 0)近的 GameObjects 的 3D 定位。是通过设置默认的听者 mask 到 L0 来解决此问题的。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2015.1.1

版本说明 - Wwise Unity Integration 2015.1.1

此次发布为 Wwise 2015.1.1 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2015.1.1
  • Unity：Unity 4.6.5 Pro 或 Unity 5.1.2p2 (Personal 或 Pro)
    平台: Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PS Vita
    Windows
    Windows Phone
    Xbox One     		Unity 5.1.2p2
    Wii U | Unity 4.3.7f1 和 Wii U add-on 2.2.5
    Xbox 360 | Unity 5.0.1f1

已解决的问题：

  • WG-27977 已修复：在终止时，如果脚本顺序错误，则 Unity 崩溃。
  • WG-28030 已修复：Wii U/Unity：根据 TRC 的要求，
  • WG-28042 已修复：Unity：如果 Wwise 工程不可访问，则无法运行游戏。
  • WG-28044 已修复：Unity：性能问题，Wwise 工程不断地被重新解析。
  • WG-28046 已修复：取消对 AkInitializer 实例的强制依赖。
  • WG-28048 已修复：在 Wwise 分析器中正确地显示 GameObject 名称。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2015.1

版本说明 - Wwise Unity Integration 2015.1

此次发布为 Wwise 2015.1 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2015.1

已知问题：

  • WG-25669：Wwise Picker 的 Auto Populate 在 Mac Editor 中无法使用。

已解决的问题：

  • WG-27079 已修复：为非英语环境正确地设置了 WwiseSettings.xml 文件的编码。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2014.1.6

版本说明 - Wwise Unity Integration 2014.1.6

此次发布为 2014.1.6 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2014.1.6
  • Unity：Unity 4.6.5 Pro, 或 Unity 5.0.2 (Personal 或 Pro)
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PSVita
    Windows
    Windows Phone
    Xbox One     		Unity 5.1.2p2
    WiiU | Unity 4.3.7f1 和 WiiU add-on 2.2.5
    Xbox 360 | Unity 5.0.1f1

已解决的问题：

  • WG-27585 已修复：在 Wwise Picker 窗口中正确地显示 Wwise 工程层级结构。
  • WG-27624 已修复：(PS3) SetListenerPostion 在 PS3 上不起作用
  • WG-27749 已修复：在销毁对象时调用 Wwise API 会显示大量错误。
  • WG-27977 已修复：在终止时，如果脚本顺序错误，则 Unity 崩溃。
  • WG-28030 已修复：Wii U/Unity：根据 TRC 的要求，Release 版本的 RPL 不再被标记为 NDEBUG 。

已知的 Unity 问题：

  • Xbox One：SoundEngine 初始化失败，即使 Unity 音频被禁用。请参见 故障排除 。
  • Windows Store Apps in Unity 4：构建的游戏会抛出一个 DllNotFoundException。请参见 故障排除 。

已解决的问题：

  • WG-27585 已修复：在 Wwise Picker 窗口中正确地显示 Wwise 工程层级结构。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2014.1.5

版本说明 - Wwise Unity Integration 2014.1.5

此次发布为 Wwise 2014.1.5 提供了 Wwise SDK 更新。 兼容性：

  • Wwise SDK: 2014.1.5
  • Unity：Unity 4.6.5 Pro, 或 Unity 5.0.2 (Personal 或 Pro)
    平台： Wwise Unity Integration 在以下平台测试过：
    Android
    iOS
    Linux
    Mac
    Metro
    PS3
    PS4
    PSVita
    Windows
    Windows Phone     		Unity 5.0.2p3
    Xbox 360 | Unity 5.0.1f1
    Xbox One | Unity 5.0.2p4

已知问题：

  • WG-25669 已修复：现在可在 Mac Editor 中正常使用 Wwise Picker 的 Auto Populate 功能。

已知的 Unity 问题：

  • Xbox One：SoundEngine 初始化失败，即使 Unity 音频被禁用。请参见 故障排除 。
  • Windows Store Apps in Unity 4：构建的游戏会抛出一个 DllNotFoundException。请参见 故障排除 。

新功能：

  • 添加了对 Android x86 的支持。
  • 对 Windows Store Apps 平台，消除了对 Scripting Define Symbols 的需求。

已解决的问题：

  • WG-25733 已修复：现在可以使用 Windows 编辑器来构建 iOS/Mac 游戏，反之亦然。
  • WG-26655 (iOS) 已修复：现在 AmbientSound 类别下的音频在被 iOS 8 来电打断后会自动恢复。
  • WG-26875 已修复：现在 AkMemBankLoader 组件分配了对齐的内存，防止在某些平台上出现故障。
  • WG-27108 已修复：现在在 Destroy 阶段发送事件时不再显示 Unity 错误消息。
  • WG-27461 已修复：现在与 AkEnvironment 位于同一对象上的 AkGameObj 可以正常响应环境效果。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2014.1.4

版本说明 - Wwise Unity Integration 2014.1.4

本次发布为 Wwise 2014.1.4 提供了 Wwise SDK 更新，并与 Unity 5 兼容。

兼容性：

  • Wwise SDK: 2014.1.4
  • Unity：Unity 4 Pro 或者 Unity 5（Personal 或 Pro）

已解决的问题：

  • WG-26780 已修复：如果机器上没有 Wwise 工程，这将不会导致在 Unity 控制台窗口出现报错。
  • WG-26837 已修复：在 AkBankManager 中修复了 SoundBank 引用计数，以防止过早卸载。

已知问题：

  • WG-25669：Wwise Picker 的 Auto Populate 在 Mac Editor 中无法使用。
  • WG-25733：无法使用 Windows 编辑器构建 iOS/Mac 游戏，反之亦然。

新功能：

  • 添加了对 Windows Phone 8.1 平台的支持（在构建设置中可以通过 Metro 平台访问）。
  • 现在完全与 Unity 5 兼容。Wwise Unity Integration 现在使用新的 Plugin Importer API 来激活插件。集成将不再使用 <UNITY_PROJECT_ROOT>/Assets/Plugins 文件夹。

重要迁移说明： 如果要将 Unity 4 项目升级为 Unity 5，建议您按照以下步骤操作：

  1. 确保您的项目有备份
  2. 在 Unity 5 中打开您的 Unity 4 项目。这将触发 Unity 升级助手。
  3. 一旦升级到 Unity 5 完成，就导入 2014.1.4 Unity 集成。
  4. 出现一个迁移窗口，点击“开始”
  5. 一旦迁移窗口关闭，就完成了迁移
  6. 现在可以开始使用 Unity 5 中的 Wwise Unity Integration 了！


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2014.1.3

版本说明 - Wwise Unity Integration 2014.1.3

此次发布为 Wwise 2014.1.3 提供了 Wwise SDK 更新。

兼容性：

  • Wwise SDK: 2014.1.3

已知问题：

  • WG-25669：Wwise Picker 的 Auto Populate 在 Mac Editor 中无法使用。
  • WG-25733：无法使用 Windows 编辑器构建 iOS/Mac 游戏，反之亦然。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2014.1.2

版本说明 - Wwise Unity Integration 2014.1.2

此次发布为 Wwise 2014.1.2 提供了 Wwise SDK 更新，并且修复了错误。

兼容性：

  • Wwise SDK: 2014.1.2
  • 由于 XDK 在 Unity Editor（10 月 XDK）和 Wwise SDK（11 月 XDK）之间不兼容，因此 Xbox One 平台无法使用此版本。

已解决的问题：

  • WG-26305 已修复：使用 null GameObject 在 64 位构建中报告一个未注册的 GameObject。
  • WG-26337 已修复：增加了对 Mac 64 位平台的兼容性。
  • WG-26385 已修复：Wwise 在 Android 系统的背景下在 Unity 中占用 CPU。
  • WG-26395 已修复：修复了下述情形下的构建失败：从命令行使用 MSBUILD 构建 Windows Phone 8 工程时。
  • WG-26430 已修复：修复了在 iOS 上调用 SetBasePath() 时的崩溃。

已知问题：

  • WG-25669：Wwise Picker 的 Auto Populate 在 Mac Editor 中无法使用。
  • WG-25733：无法使用 Windows 编辑器构建 iOS/Mac 游戏，反之亦然。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2014.1.1

版本说明 - Wwise Unity Integration 2014.1.1

此次发布为 Wwise 2014.1.1 提供了 Wwise SDK 更新，最终文档，和对错误的修复。

兼容性：

  • Wwise SDK: 2014.1.1
  • Unity: 4.x（目前还不支持 5.0）

新功能：

  • 添加了对 Wii U 平台的支持。
  • 添加了 Plug-in Registration 文档。
  • 在 Unity 的 "Wwise Settings" 对话框中显示 Wwise Sound Engine 版本。
  • 更新的文档，提供了更精确的关于 GeneratedSoundBanks 和 Populate 按钮的信息。

已解决的问题：

  • WG-26201：显式地调用 C# System 调用的范围


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2014.1

版本说明 - Wwise Unity Integration 2014.1

此次发布为 Wwise 2014.1 提供了 Wwise SDK 更新，针对错误进行了修复，提供了一个新的 Demonstration 场景，为那些使用 Wwise Unity Integration 2013.2 创建的工程提供了迁移过程。

显著功能：

  • 稳定性修复
  • 添加了一个演示场景
  • 为那些使用 Wwise Unity Integration 2013.2 创建的工程添加了迁移过程

兼容性：

  • Wwise SDK: 2014.1
  • Unity: 4.x

支持的平台：

  • Android
  • iOS
  • Linux
    • 32 位
    • 64 位
  • Mac OS X（10.6 和更高版本）
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32 位
    • 64 位
  • Windows 8（Metro）
    • Desktop？？？？
    • 在 Intel 设备上的 Windows Store App，和 ARM 平板电脑
  • Windows Phone 8.0
  • Xbox360
  • Xbox One

新功能：

  • 添加了一个演示场景，在一个单独的包中。详情请参见 Wwise 演示场景 。
  • 为那些使用 Wwise Unity Integration 2013.2 创建的工程添加了迁移过程。
  • Wwise Components 现在在 Wwise Unity Integration 中被 UUID 引用。这可以让您在 Wwise Project 中重命名它们，并且不会破坏与 Unity 项目的链接。
  • 添加了一些可自定义的触发器，用于发布事件和加载库。详情请见 为 Wwise Events 添加新的 Trigger。 。
  • 添加了一些可自定义的回调，用于 Wwise 事件。详情请见 在 Inspector 中使用 AkAmbient 。
  • 减少了 AkSoundEngine 插件的大小。
  • 添加了一个选项，用于创建（或销毁）WwiseGlobal 对象和 AkListener。

已解决的问题：

  • WG-25783：修复了 Callback Manager 中一个内存泄漏
  • WG-25677：修复了 Mac 上的路径问题

已知问题：

  • WG-25669：Wwise Picker 的 Auto Populate 在 Mac Editor 中无法使用。
  • WG-25733：无法使用 Windows 编辑器构建 iOS/Mac 游戏，反之亦然。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2013.2.10

版本说明 - Wwise Unity Integration 2013.2.10

此次发布为 Wwise 2013.2.10 提供了 Wwise SDK 更新，并且修复了错误。

显著功能：

  • WG-25783 已修复： 修复了取消回调时的内存泄漏问题

兼容性：

  • Wwise SDK: 2013.2.10
  • Unity: 4.x

支持的平台：

  • Android
  • iOS
  • Linux*
    • 32bit
    • 64bit
  • Mac OS X（10.6 和更高版本）
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32bit
    • 64bit
  • Windows 8（Metro）
    • Desktop？？？？
    • 在 Intel 设备上的 Windows Store App，和 ARM 平板电脑
  • Windows Phone 8.0
  • Xbox360
  • Xbox One


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2013.2.9

版本说明 - Wwise Unity Integration 2013.2.9

此次发布为 Wwise 2013.2.9 提供了 Wwise SDK 更新、最终文档和对错误的修复。

显著功能：

  • 文档的最终版本
  • 稳定性修复

兼容性：

  • Wwise SDK: 2013.2.9
  • Unity: 4.x

支持的平台：

  • Android
  • iOS
  • Linux
    • 32 位
    • 64=位
  • Mac OS X（10.6 和更高版本）
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32 位
    • 64 位
  • Windows 8（Metro）
    • Desktop？？？？
    • 在 Intel 设备上的 Windows Store App，和 ARM 平板电脑
  • Windows Phone 8.0
  • Xbox360
  • Xbox One

新功能：

  • 添加了对 Windows Phone 8.0 平台的支持。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2013.2.8

版本说明 - Wwise Unity Integration 2013.2.8

此次发布为 Wwise 2013.2.8 提供了 Wwise SDK 更新，新的 Wwise-Unity 集成工具，新增文档和错误修复。

显著功能：

  • 更加简单的新工程设置流程（参见 在 Unity 工程中安装或升级集成 ）
  • 使用 Wwise Picker 访问 Wwise 工程更加容易（见 Wwise Picker ）
  • 新的和改进的 Unity 组件，用于封装常见的音频任务（见 使用 Wwise Unity 集成 ）
  • Wwise-Unity Integration 文档合并，并和 Wwise SDK文档（就是本文档哦！）交叉引用

兼容性：

  • Wwise SDK: 2013.2.8
  • Unity: 4.x

支持的平台：

  • Android
  • iOS
  • Linux*
    • 32 位
    • 64 位
  • Mac OS X（10.6 和更高版本）
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32 位
    • 64 位
  • Windows 8（Metro）
    • Desktop？？？？
    • 在 Intel 设备上的 Windows Store App，和 ARM 平板电脑
  • Windows Phone 8.0
  • Xbox360
  • Xbox One

新功能：

  • 添加了对 Xbox One 平台的支持。
  • 添加了对 PS4 平台的支持。
  • 添加了对 Linux 平台的支持。* Wwise 2013.2.8 Linux BETA 版支持 Linux 的 Unity Integration。
  • 添加了对 Windows Phone 8.0 平台的支持。

迁移：

  • 现在，Multi-architecture Windows 和 Metro 插件安装到了它们指定的文件夹中，并且不再需要使用 Unity 的 Scripting Define Symbol 功能来切换。
  • 为了简单起见，Unity Editor 菜单中重新构建 Integration 的功能被移除。
  • 将现成的 Integration 与源代码分离。
  • 将 Windows IDE 解决方案从 Visual Studio 2008 升级到 2010。
  • 更新了 Windows 和 Metro 的指定平台文件夹。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2013.2.5

版本说明 - Wwise Unity Integration 2013.2.5

此次发布为 Wwise 2013.2.5 提供了 Wwise SDK 更新，对若干新平台的支持，和对错误的修复。

兼容性：

  • Wwise SDK: 2013.2, 2013.2.x
  • Unity: 4.x

支持的平台：

  • Android
  • iOS
  • Mac OS X（10.6 和更高版本）
  • PS3
  • PS4
  • PS Vita
  • Windows
    • 32 位
    • 64 位
  • Windows 8（Metro）
    • Desktop？？？？
    • 在 Intel 设备上的 Windows Store App，和 ARM 平板电脑
  • Xbox 360
  • Xbox One

新功能：

  • 添加了对新平台的支持：PS4。
  • 添加了对新平台的支持：PS Vita。
  • 添加了对新平台的支持：Xbox One。
  • Android：添加了一个新 API AddBasePath()，用于为 I/O 指定一个 POSIX 文件系统路径。

已解决的问题：

  • WG-24351：iOS：没有处理远程控制中断。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2013.2.4

版本说明 - Wwise Unity Integration 2013.2.4

此次发布为 Wwise 2013.2.4 提供了 Wwise SDK 更新，修复了错误，做了一些改进。

兼容性：

  • Wwise SDK: 2013.2, 2013.2.x
  • Unity: 4.x

支持的平台：

  • Windows 8（Metro）
    • Desktop？？？？
    • 在 Intel 设备上的 Windows Store App，和 ARM 平板电脑
  • Windows
    • 32 位
    • 64 位
  • Mac OS X（10.6 和更高版本）
  • iOS
  • Android
  • Xbox360
  • PS3

新功能：

  • 新菜单项目 Wwise > Help，用于在默认的网页浏览器中打开 Integration 文档。
  • 添加 Version.txt 元数据文件给所有发布，以指明基本的 Wwse SDK信息。

已解决的问题：

  • WG-24080：在 Windows 和 Mac API 切换到 Android 之后出现的编译器错误。

迁移：

  • 移除 Android armeabi 插件。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2013.2.1

版本说明 - Wwise Unity Integration 2013.2.1

此次发布为 2013.2.1 提供了 Wwise SDK 更新，新功能包括 overhauled distribution，安装和构建经验，和错误修复。

兼容性：

  • Wwise SDK: 2013.2, 2013.2.1
  • Unity：4.x（不再支持 3.x）

支持的平台：

  • Windows 8（Metro）
    • Desktop？？？？
    • 在 Intel 设备上的 Windows Store App，和 ARM 平板电脑
  • Windows
    • 32 位
    • 64 位
  • Mac OS X（10.6 和更高版本）
  • iOS
  • Android
  • Xbox360
  • PS3

新功能：

  • Unity Integration 现在作为一个 Unity 的资源包分发，其中包含目标平台版本和桌面版本。它可以直接导入到一个 Unity 工程中，在 Editor 中和目标设备上都能使用。
  • 在 Unity Editor UI 中添加了一个新的 Wwise 菜单，用于执行以下任务：
    • 安装插件。
    • 重新构建 Integration。
    • 将一个 SoundBank ID C++ header 转换为它的 C# 版本。
  • 运用 Unity 4 的 Scripting Define Symbols 功能，在多架构平台（例如 Windows）上构建和运行应用程序。
  • 一个构建脚本，用于在任何支持的平台上通过命令行重新构建 Integration。
  • 一个简化的定位演示，添加到了 IntegrationDemo。
  • Android：SoundBank 现在可以保存到 Android Expansion Files（OBB）中，也可从中载入。

已解决的问题：

  • WG-23781：库回调不起作用。
  • WG-23734：在 Windows 平台上，标记回调接收到混乱的字符串。
  • WG-23345：在 Unity Editor 中切换到不支持的平台时出现编译错误。
  • WG-23436：Unity：由于 而导致的听者定位错误。
  • WG-23423：Unity 中 GameObjects 的性能问题，与组件访问有关。
  • WG-22533：Unity：一些 API 绑定函数不应该有异常处理程序。

改进：

  • 简化了 iOS 插件的安装和部署。
  • 更新的文档，包含更精确的先决条件和其它说明。

迁移：

  • 安装好的文件和文件夹结构使用新发布的方法更新了。请参阅 在 Unity 工程中安装或升级集成 了解更多详情。
  • 重命名了多架构平台的插件。详情参见 BUILD THE APPLICATION FOR A MULTI-ARCHITECTURE PLATFORM 。
  • 在 iOS中，不再需要配置 Xcode 工程来查找插件库。但是需要一个新的原生 API 调用。请参阅 pg_iOSInfo 了解更多详情。
  • 之前多架构平台的构建 UI 脚本示例被移除。
  • Apple 平台的旧构建脚本被移除。
  • SWIG 升级到 2.0.11。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2013.1.1

版本说明 - Wwise Unity Integration 2013.1.1

此次发布为 Wwise 2013.1.1 提供了 Wwise SDK 更新。Integration 中没有其它更改。


Wwise Unity Integration Documentation: 版本说明 - Wwise Unity Integration 2013.1

版本说明 - Wwise Unity Integration 2013.1

此次发布为 Wwise 2013.1 提供了 Wwise SDK 更新，Android 相关的新功能，和一般的错误修复。

兼容性：

  • Wwise SDK: 2012.2.x, 2013.1
  • Unity: 3.4.x, 3.5.x, 4.x

支持的平台：

  • Windows 8
    • Desktop？？？？
    • 在 Intel 设备上的 Windows Store App，和 ARM 平板电脑
  • Windows（32 位）
  • Windows（64 位）
  • Mac OS X（10.6 和更高版本）
  • iOS
  • Android
  • Xbox360
  • PS3

新功能：

  • Android：SoundBank 现在可以在 Android 应用程序包（apk）中保存，并且可以使用 LoadBank() API 透明地访问。
  • 对 Windows 64 位的支持。
  • 对 Windows 8 的支持。

已解决的问题：

  • WG-22948：在 PS3 上，由听者索引指派错误导致的定位错误。
  • WG-22938：在 Mac OSX 上，Unity Integration 的定位数据无效。
  • WG-22334：Music userCue 名称被错误地以空字符串报告给 Unity。
  • WG-22329：Unity Integration 中，无法 PostEvent() 到全局范围。
  • WG-22255：Unity Android：在切换应用到后台后声音依然存在。
  • WG-22165：3D 定位在 iOS 和 Android 中无法正常工作。
  • WG-21933：AkCallbackManager.cs 无法正确处理浮点的去序列滑。UserCue 名称？？
  • WG-21365：Unity iOS：iOS 音频中断事件时不时发生之后，无法听到声音。
  • WG-22533：一些 API 绑定函数不应该有异常处理程序。

改进：

  • Windows 和 Mac 。。。可以在同一个 Unity 工程中共存。
  • 改进了文档的可读性和精确性，并添加了 有关平台的特定信息 部分，便于阅读有关平台的信息。
  • 出于可读性考虑，构建日志现在支持安静和详细模式。
  • 现在构建管线检查用户的 Python 版本，会在未更新版本时发出警告。
  • 现在可以直接使用部署脚本将 Integration 复制到 Unity 的工程中。

迁移：

  • 现在需要 Visual Studio 2010 来为 PS3 构建 Integration。
  • 构建脚本不再支持 Python 2.6 和更旧的版本。需要 Python 2.7.x 或者 3.x。
  • 您自己构建 Integration 时，不再需要环境变量 UNITY_PROJECT_ROOT。默认情况下，Integration 不再自动部署到 UNITY_PROJECT_ROOT 指定的文件夹中。详情参见 从源代码构建原生集成插件 。
  • Android 构建脚本不再部署 PostprocessBuildPlayer 脚本到 Unity 工程中。
  • IntegrationDemo 工程升级为 Unity 4 格式。


Wwise Unity Integration Documentation: 在 Unity 工程中安装或升级集成

在 Unity 工程中安装或升级集成

Wwise Unity Integration 包含将 Wwise 用在 Unity 工程中所需的各种 Unity 组件、Editor 工具和文档。

请参阅以下页面，以了解您可能需要的各种安装和升级过程的信息。

  • 前提条件
  • 第一次安装 Wwise 集成包
  • 针对 Unity 工程所作的更改
  • 将声音实现到您的游戏中
  • Setting the SoundBank Location
  • 添加插件
  • 升级集成包以使用新的 Wwise 版本


Wwise Unity Integration Documentation: 前提条件

前提条件

请在此检查 Wwise 对每个平台的要求： 有关平台的特定信息 。

备注： 此 Integration 版本不支持 Unity Cloud Build 服务。

Unity 集成需要以下软件：

平台 | 所需组件
iOS | Xcode 7.2 或更高版本及兼容的 iOS SDK
Windows | DirectX End-User Runtime x64 Visual Studio 2013 redistributable
Windows 32-位 Debug 版 | x86 Visual Studio 2013 redistributable


Wwise Unity Integration Documentation: 第一次安装 Wwise 集成包

第一次安装 Wwise 集成包

您可以使用 Audiokinetic Launcher 来安装 Wwise Integration 数据包。Refer to Integrating Wwise into a Unity Project for details.

警告： 在开始之前：
  • Back up your Unity project. You can either rely on your source control system or use the Audiokinetic Launcher. To back up your project through the Launcher, ensure that Install files into a copy of the Unity project directory, then apply changes if successful is selected on the project integration page.
  • 在安装 Wwise 集成之前，需要确保您的 Unity 工程可以成功编译。（出现警告是正常的。）
  • 如果 Unity 工程有版本控制，那么在开始集成之前一定要 check out 整个 Unity 工程文件夹。否则，将无法集成，因为无法修改文件。
  • If you plan to integrate an existing Wwise project into a Unity project, ensure the Enable Auto-Defined SoundBanks option is deselected in the Wwise Project Settings dialog.

Unity Integration Extensions（集成扩展）

以 partial 方法的形式添加了用户钩子，这样用户可以扩展游戏对象的自动注册功能或将此功能全部删除。The default extensions are recommended, however, you can choose to exclude them while Integrating Wwise into a Unity Project.


Wwise Unity Integration Documentation: 针对 Unity 工程所作的更改

针对 Unity 工程所作的更改

Wwise Integration 安装过程会对 Unity 工程做出以下形式的更改：

  • 在 Edit > Project Settings > Audio 中启用 Disable Audio 选项。内置的音频系统将因此被禁用。
  • 若启用了 "Create WwiseGlobal GameObject" Wwise Setting，则在当前场景中创建一个名为 Wwise Global 的游戏对象。另外，还为 WwiseGlobal 对象提供有 AkEditorEventPlayer、AkAudioListener 和 AkGameObj 脚本，方便在 Edit 模式下预览 AkEvent 对象。同时，还添加了 Rigidbody 组件，便于预览 AkEnvironment、AkRoom 和 AkGameObj 之间的交互。
备注： WwiseGlobal 对象是一个包含 Wwise 声音引擎 Initializing 和 Terminating 脚本的游戏对象。在 Editor 工作流中，会将其添加到每一场景，以便在 Editor 中正常预览。在构建版本中，只会在第一个场景中创建一个实例。该实例将在整个游戏当中保持有效。在初始化器脚本中，有一些可自定义的选项。参阅 Wwise SDK 文档中的初始化声音引擎模块。
  • 针对关键的 Wwise 脚本（AkInitializer、AkGameObj、AkAudioListener 和 AkBank）启用 Script Execution Order。
  • 若启用了 Add Ak Listener to Main Camera 复选框，则移除 Main Camera 对象上绑定的 Audio Listener 组件，并针对 Main Camera 对象设置默认的 AkAudioListener.cs 脚本。
  • 启用 Run in Background 选项 (Edit > Project Settings > Player > Resolution and Presentation)，以便连接 Wwise Profiler。


Wwise Unity Integration Documentation: 将声音实现到您的游戏中

将声音实现到您的游戏中

现阶段，您应该能够通过 Wwise 在您的游戏中播放声音了。若 Wwise 工程尚未设置声音、Event 和 SoundBank，则需启动 Wwise 并执行以下操作：

  1. 导入一个 WAV 文件。从 File Explorer 窗口拖放文件到 Project Explorer 的 Audio 选项卡。这将创建一个声音。
  2. 创建一个事件。在 Sound 上右击，并选择 New Event。给它起一个合适的名字。
  3. 创建一个 SoundBank。进入 SoundBanks 布局（F7）在 SoundBank Manager 中单击 New...。
  4. 把您的事件放到 SoundBank 中。为此，将 Event 从 Project Explorer 中拖放到 SoundBank 中。
  5. 单击 Generate Selected。现在您就有声音可以播放了。
警告： The Unity Integration does not support Auto-Defined SoundBanks. Make sure the feature is disabled in the Wwise Project Settings.

现在，为了将一个声音集成到您的 Unity 工程中：

  1. 打开 Wwise Picker 窗口（Window > Wwise Picker），它应该显示出您的 Events 和 SoundBanks。
  2. 将您的 SoundBank 拖放到场景中的对象上。
  3. 将您的 Event 拖放到场景中的一个对象上。
  4. 玩一下您的游戏吧！您应该能在启动时听到声音。

什么也听不到吗？想了解更多，参见 故障排除 页面。

集成更多的声音

当前 Unity 中 Wwise 的集成提供了一些 Unity 组件，这些组件足以应对一些常规的使用情况。

  • 使用 AkAmbient 来放置场景中的发声体。
  • 使用 AkBank 来加载 SoundBank。
  • 将 AkEnvironment 附加到碰撞体上，用来在指定区域内设置混响。
  • 了解其它组件。

然而，重要的是，如果想在游戏中实现更复杂的行为，需要程序员编写脚本来支持。您可以在这两节中找到更多关于 Wwise API 的信息：

  • Integrate Wwise Elements into Your Game
  • AK::SoundEngine Namespace Reference


Wwise Unity Integration Documentation: Setting the SoundBank Location

Setting the SoundBank Location

When you run a project in the Unity Editor, the SoundBanks are taken directly from the Wwise project's GeneratedSoundBanks folder to increase prototyping speed. The default folder location is …\<UnityProjectName>\Assets\StreamingAssets\Audio\GeneratedSoundBanks.

To change the SoundBanks location, go to Edit > Project Settings > Wwise Editor and update the SoundBanks Path as required.

When Unity packages your project, it does not selectively package assets based on the target platform. Instead, it packages all the SoundBanks located in the specified SoundBanks folder. To ensure that Unity only builds and packages SoundBanks for the required platforms, on the Wwise Editor page, leave Copy SoundBanks at pre-Build step selected.

Alternatively, advanced Unity developers can use a BuildPlayerPipeline script.

If you are using Unity Addressables, the SoundBank options are slightly different. Refer to Setting the Generated SoundBank Location for Addressables.

参见
  • 为目标平台构建您的 Unity 游戏

Setting the Generated SoundBank Location for Addressables

If you use Unity Addressables in your project, the folder that contains the generated SoundBanks must be located within the project so that the SoundBanks can be properly imported.

To set the generated SoundBanks path, go to Edit > Project Settings > Wwise Editor and change the Generated SoundBanks Path as required. The location must be under the Assets folder.

参见
  • Installing the Wwise Unity Addressables Package


Wwise Unity Integration Documentation: 添加插件

添加插件

Integration 中默认配套提供各种内置 Wwise 源/效果器插件。

效果器插件可作为动态库使用。这些库会基于在 Wwise 工程中的使用情况自动包含在 Unity 工程中。当生成 SoundBank 时，将编译您项目使用的效果器插件列表。

如果要将先前未使用的插件添加到您的工程中，请遵循以下步骤：

  1. 在 Wwise 工程中使用效果器插件。
  2. 为当前平台生成 SoundBank。
  3. 切换到您的 Unity 工程。
  4. 将新的 SoundBank 复制到预期的 StreamingAssets 文件夹中。（如果只是在编辑器中试玩，则无需复制。）
  5. 编译您的游戏（或在编辑器中试玩）。

在 Unity 工程中集成 Wwise 后，将自动添加之前通过 Launcher 在 Wwise 中安装的所有其他插件。However, if you install plug-ins in your Wwise project after integrating Wwise into your Unity project, you must follow the steps covered in Adding Plug-ins to Unity and Unreal Integrations to use the plug-ins in your Integration.

注意，需要授权的插件并非默认 Wwise 授权的一部分（McDSP、iZotope、Auro、SoundSeed、Crankcase REV、Convolution Reverb、Motion）。您可以在 Wwise 设计工具中试用它们，但不能在游戏中使用它们。如果您没有有效的授权，请 联系我们。评估授权是免费的。

若要为 Wwise 和 Unity 创建新的效果器插件，请参阅创建新的插件章节。对于 iOS、tvOS 和 Nintendo Switch，必须以静态库形式提供插件。请参阅 Plug-in Static Registration。对于 Integration 自带的插件，将在对应 CPP 文件中生成的 AkPluginActivator.StaticPluginRegistration 类中自动注册。假如要注册新插件，必须创建一个类似以下形式的 CPP 文件：

namespace AK { class PluginRegistration; };
#define AK_STATIC_LINK_PLUGIN(_pluginName_) extern AK::PluginRegistration _pluginName_##Registration; void *_pluginName_##_fp = (void*)&_pluginName_##Registration;
#include "MyNewPluginFactory.h"
AK
Definition: AkWwiseAcousticTexture.cs:21


Wwise Unity Integration Documentation: 升级集成包以使用新的 Wwise 版本

升级集成包以使用新的 Wwise 版本

随着新的 Wwise 大版本和小版本的发布，您可能想要更新 Integration 数据包以使用新的 Wwise 版本。

以下升级步骤假定：

  • 您已有一个 Unity 工程且其包含使用旧的 Wwise 版本构建的 Wwise Integration 数据包。
  • 您已经安装新的 Wwise 版本，包括现有集成包支持的 Wwise SDK 和所有部署平台。
警告：建议
  • 升级操作不可逆。确保事先对 Unity 工程进行备份。
  • 若 Unity 工程被添加到了版本控制系统中，请确保在开始升级前签出整个 Unity 工程文件夹。否则，升级会失败，因为无法成功修改文件。
  • 在升级 Wwise Integration 之前，请确保可成功无误地编译 Unity 工程。（出现警告是正常的。）
  • 若修改了 C++ AkSoundEngine 插件源码中的 C ++ Wwise SDK，请按照 当您修改了插件的 C++ 代码时，将 Wwise 集成包 更新/升级到一个较新的版本 中的说明执行相应操作。
  • If you are using 在 Unity 中使用 Wwise Addressables Package , refer to 更新 Wwise Unity Addressables Package.

与其他 Unity 插件不同，您必须保留之前安装的 Wwise Integration 数据包以便将其升级到新的版本。

警告： 不要在升级到新的版本之前删除现有 Wwise Integration。这会导致游戏中丢失所有 Wwise 音频。

升级分为两步。首先，要针对所要使用的新的 Wwise 版本更新 Wwise 工程，然后针对 Unity 工程执行同样的操作。

  1. 更新 Wwise 工程：
    1. 在 Launcher 中，选中 Wwise 页面。
    2. 启动新安装的 Wwise 版本。
    3. 打开现有 Wwise 工程。
    4. 在提示将 Wwise 工程更新到新的 Wwise 版本时，点击 Update。
    5. 在完成更新后，生成 Wwise SoundBank。
    6. 保存 Wwise 工程。
  2. 更新 Unity 工程：
    1. 可通过 Launcher 针对新的 Wwise 版本更新 Unity 工程。Refer to Upgrading or Modifying an Integration Package in the Launcher documentation for details.

从 2021.1.1 之前的 Wwise 版本升级

若要从 2021.1.1 之前的 Wwise 版本升级到 Wwise 2021.1.1，必须确保在 Unity 工程中激活 JsonSerialize 数据包。否则，升级会失败。对此，可选用以下两种方式来实现：

  1. 在 Unity Package Manager 中激活数据包。
    • 可在 Built-in packages 列表中找到数据包。
  2. 将 "com.unity.modules.jsonserialize": "1.0.0" 添加到 Packages/Manifest.json 中的依赖项列表。
    • 在执行此更改后打开并关闭 Unity 工程，来确保已将数据包正确添加到工程中。


Wwise Unity Integration Documentation: 卸载 Wwise Integration Package

卸载 Wwise Integration Package

若要卸载 Wwise Integration Package，则需手动从 Unity 工程中删除 Assets/Wwise 文件夹。这并不会从您的游戏对象中删除 Wwise 组件，也不会改变其它设置。

若同时使用了 Wwise Addressables Package，则需使用 Unity 的 Package Manager 移除该数据包，或在 [Unity Project]/Packages/manifest.json 删除对应条目。


Wwise Unity Integration Documentation: 调整 Unity Editor Settings

调整 Unity Editor Settings

Wwise Editor Settings 可在 Wwise Editor 分区下的 Project Settings Window (Edit > Project Settings...) 中找到。

有关 Wwise 声音引擎初始化中所用的工程设置，请参阅 调整 Wwise Initialization Settings 页面。

Wwise Project Settings

Wwise Project Path：此项表示与此游戏关联的 Wwise 工程的存储位置。建议存放在 Unity Project 根文件夹（Assets 文件夹之外）。

Wwise Application Path：此项表示 Wwise 应用程序的存储位置。需使用其来在 Unity 内生成 SoundBank。

Editor Behaviour Settings

The SoundBank options vary depending on whether you are using Unity Addressables or not. For more information on Addressables, refer to 在 Unity 中使用 Wwise Addressables Package.

SoundBanks Path: Location of the SoundBanks relative to (and within) the StreamingAssets folder. 可在构建游戏时使用其将生成的 SoundBank 复制到工程中。If the Unity Addressables package is installed in your project, this option does not appear. Instead, you must specify the Generated SoundBanks Path.

Generated SoundBanks Path: Location of the generated SoundBanks in your project. This option only appears if the Addressables package is installed in your project. Ensure that the path is under the project's Assets folder so that SoundBanks are imported properly.

Copy SoundBanks at pre-Build step: If selected, SoundBanks are copied to the location specified by SoundBanks Path during building and deployment. We recommend that you select this option. If the Unity Addressables package is installed in your project, this option does not appear.

Generate SoundBanks at pre-Build step：此项用于在执行预构建操作的过程中在复制前生成 SoundBank。If SoundBanks are generated on a specific build machine, we recommend that you do not select this option. If the Unity Addressables package is installed in your project, this option does not appear.

Create WwiseGlobal GameObject：WwiseGlobal 对象是一个包含 Wwise 声音引擎 Initializing 和 Terminating 脚本的游戏对象。在 Editor 工作流中，会将其添加到每一场景，以便在 Editor 中正常预览。在游戏中，只会在第一个场景中创建一个实例。该实例将在整个游戏当中保持有效。建议将此方框保留为选中状态。

Add Listener to Main Camera：为了能够正常定位，需要将 AkAudioListener 脚本关联到每一场景中的主镜头。若想将听者绑定到另一 GameObject，请取消选中此方框。

Auto-delete WwiseObjectReferences：对于引用 Event、SoundBank 和 Bus 等 Wwise 对象的组件，将使用 Wwise/ScriptableObjects 文件夹中创建的 WwiseObjectReference 素材追踪这些引用。若在选中此选项的情况下从 Wwise 工程中移除了 Wwise 对象，则在解析 Wwise 工程结构时将删除 Wwise/ScriptableObjects 文件夹中的对应素材。

Show Spatial Audio Warnings：在没有配置 Spatial Audio 正常运行所需的 Wwise 组件时显示警告消息。建议将此方框保留为选中状态。

WAAPI 设置

Connect to Wwise：若选中此项，则 Editor 将反复尝试与 Wwise 设计工具实例建立 WAAPI 连接。

WAAPI Port：此项表示所要连接到的端口。可在 Wwise 设计工具中确认（Project > User Settings 下）。默认值为 8080。

WAAPI IP address：此项表示运行 Wwise 设计工具的设备的 IP 地址。若其在同一机器上运行，则使用 127.0.0.1。

Wwise Error Message Translator Settings

The Error Translators purpose is to transform numerical IDs in error messages into human-readable names, whenever the information is available. There are two methods available: through SoundBanksInfo.xml and through WAAPI.

If the SoundBanksInfo.xml file is present beside the soundbank files (it is optional), using the XML method is faster.

WAAPI has the advantage of reading directly from an instance of Wwise, with the latest information. But the network communication can be very slow. Because of that it is disabled by default.

XML Translator Timeout Maximum time alloted to search for IDs (milliseconds) for the XML file reader. Set to 0 to disable.

WAAPI Translator Timeout Maximum time alloted to search for IDs (milliseconds) through the WAAPI connection. Set to 0 to disable.


Wwise Unity Integration Documentation: 调整 Wwise Initialization Settings

调整 Wwise Initialization Settings

Wwise Initialization Settings 与 Wwise 声音引擎的 C/C++ SDK 内的以下结构成员对应：

  • AkCommSettings
  • AkDeviceSettings
  • AkInitSettings
  • AkMemSettings
  • AkMusicSettings
  • AkPlatformInitSettings
  • AkSpatialAudioInitSettings
  • AkStreamMgrSettings

这些设置包括路径、语言、采样率、队列大小、内存阈值、内存池大小等等。一般情况下，只要使用默认设置就可以了。不过，根据不同的项目要求，有时可能需要访问并调整部分 Wwise Initialization Settings。

访问 Wwise Initialization Settings

现在 Unity Editor 中暴露了 Wwise Initialization Settings。不再需要使用脚本来实施更改。

这些设置可在 Wwise Initialization 分区下的 Project Settings Window (Edit > Project Settings...) 中找到。

Wwise Initialization Settings

在 Project Settings 窗口中，Wwise Initialization Settings 分成了四组设置：Common User Settings, Common Advanced Settings、Wwise Communication Settings 和 Platform Specific Advanced Settings（ Platform 与当前操作的平台对应）。无论是字段、复选框还是滑杆，都可在界面中直接进行编辑。为方便起见，所有设置都包含有工具提示，便于查看参数本身及可用值的其他相关信息。

Common User Settings 显示有便捷的工具提示

平台特定设置

Common User Settings、Common Advanced Settings 和 Wwise Communication Settings 包含各个平台的设置值。为了便于访问，将所有平台的设置归集到了一起。这些值将统一应用于选中的所有平台；如需为某个平台单独设置值，可取消选中该平台。

Platform Specific Advanced Settings 会按照 Wwise 自定义平台来显示，方便用户单独配置每一平台。

Common Advanced Settings 及平台数值差异
备注： 在播放并停止声音引擎之后，针对 Initialization Settings 所做的更改才会生效。


Wwise Unity Integration Documentation: Managing SoundBanks

Managing SoundBanks

The Wwise Unity Integration provides several options for SoundBank management, and has several unique requirements as well. If you use the integration, be aware of the following things:

  • The recommended SoundBank location varies depending on whether you use Unity Addressables or not (在 Unity 中使用 Wwise Addressables Package). If you use Addressables, you must specify a location within your project's Assets folder to ensure that the SoundBanks are imported propertly. If you are not using Addressables, you can specify a location outside of the project. Refer to Setting the SoundBank Location and Installing the Wwise Unity Addressables Package for more information.
  • You can generate SoundBanks in Unity through the Wwise Picker. Refer to Wwise Picker for more information.
  • Unity developers can use the AkBank class to perform various SoundBank operations such as loading, unloading, and decoding.
  • Auto-defined SoundBanks are not supported, so you must ensure that the appropriate option is disabled in the Wwise project. In Wwise Authoring, go to Project > Project Settings > SoundBanks and ensure that Enable Audo Defined SoundBanks is cleared. Refer to SoundBanks Tab.


Wwise Unity Integration Documentation: 使用 Wwise Unity 集成

使用 Wwise Unity 集成

Unity Integration 提供 Wwise 专用组件，可直接用在 Unity Scene GameObject 上。这些组件可以满足大部分声音设计情境的需求。虽然组件为自定义 C# 脚本，但并不需要通过编程来编辑其公共属性。

添加 Wwise 组件

将 Wwise 组件添加到 Unity GameObject：

  • 转到已经加载了场景中所选 GameObject 的 Unity Inspector 窗口 (Ctrl+3)。
  • 单击 Add Component 来打开 Component 列表。
  • 单击 Wwise 来打开子列表，然后选择所需 Wwise 组件 。
    技巧： 若要快速访问包含所有 Wwise 组件的列表，请在组件的搜索字段中键入 ak。

Wwise Picker 添加 Wwise 组件

为了将组件添加到游戏中，您可以把 Wwise 对象从 Wwise Picker 拖到 Inspector 中或所加载场景的 Hierarchy 中列出的游戏对象上。

参见
  • Wwise 组件
  • Wwise Picker

WwiseGlobal 对象

WwiseGlobal 对象是一个包含 Wwise 声音引擎 Initializing 和 Terminating 脚本的游戏对象。在 Editor 工作流中，会将其添加到每一场景，以便在 Editor 中正常预览。在游戏中，只会在第一个场景中创建一个实例。该实例将在整个游戏当中保持有效。在初始化器脚本中，有一些可自定义的选项。

若要禁用此行为，请依次转到 Edit > Project Settings > Wwise Editor，然后取消选中 Create WwiseGlobal GameObject。在此之后，您需要自行将 Initializer 脚本绑定到游戏当中始终有效的对象上。

将听者添加到主镜头

为了能够正常定位，需要将 Ak Audio Listener 脚本关联到每一场景中的主镜头。在默认情况下，会将听者自动添加到主镜头。若要禁用此行为，请依次转到 Edit > Project Settings > Wwise Editor，然后取消选中 Automatically add Listener to Main Camera。

参见
  • For information about using a Distance Probe in third-person perspective games, refer to Using the Ak Listener Distance Probe Component to Customize Listeners in Third-Person Games.

Wwise Types

这个集成还提供了一些类，适用于常见场景以外的大多数应用场景，需要极少量的编程：

  • AK.Wwise.AuxBus
    This type represents an auxiliary send in the Master-Mixer Hierarchy.
  • AK.Wwise.Bank
    This type can be used to load/unload SoundBanks.
  • AK.Wwise.CallbackFlags
    This type represents the values of the flags used when posting an Event with a callback.
  • AK.Wwise.Event
    This type can be used to post Events to the sound engine.
  • AK.Wwise.RTPC
    This type can be used to set game parameter values to the sound engine.
  • AK.Wwise.State
    This type can be used to set Wwise States.
  • AK.Wwise.Switch
    This type can be used to set Switch values on gameobjects.
  • AK.Wwise.Trigger
    This type can be used to post triggers to the sound engine.
  • AK.Wwise.AcousticTexture
    This type represents an Acoustic Texture.
参见
  • Wwise Types

Wwise Authoring API (WAAPI) 客户端

本机 WAAPI 客户端可通过 C# API 从 Unity 内部连接到 WAAPI。目前提供 Windows 和 macOS 版本。Wwise Authoring API 会通过 JSON 对象发送消息。在 Unity 中，客户端是通过字符串整合的。您可以根据需要灵活地构建有效的 JSON 字符串，然后将其提供给 WAAPI 客户端。

参见
  • WAAPI 实用工具

如何将 Wwise 声音添加到游戏对象上

共有四种方法可以将声音添加到您的游戏中：

  • 使用 Wwise Picker 。在所有将声音添加到一个对象的方法中，该方法是最简单的。将一个 Event 从 Wwise Picker 窗口拖动到 Unity Viewer 或者 Inspector 中的一个对象上。这样将自动在目标 Game Object 上创建一个 AkAmbient 组件。
  • 使用 Add Component 菜单。 将 AkAmbient 或者 AkEvent 组件添加到任意 Unity Game Object 上。
  • 使用 Wwise Types 。 从 C# 脚本中随时调用 AK.Wwise.Event.Post() 。
  • 使用脚本。 从 C# 脚本中随时调用 AkSoundEngine.PostEvent()。
参见
  • 使用 C# 代码来控制声音引擎

在 Unity Timeline 中使用 Wwise

在 Unity 的 Timeline 中，可使用自定义 Wwise Track 来触发 Wwise 事件，并设置 Wwise RTPC 值。

参见
  • Wwise Timeline Integration


Wwise Unity Integration Documentation: Wwise 组件

Wwise 组件

通用组件

AkAmbient
使用此组件来将 Wwise Event 关联到场景中的对象。这样可以依据所选 Unity Trigger 来在不同时机播放声音。该组件尤其适用于环境声（与场景中的对象关联的声音），不过也可另作他用。 AkAmbient 以 AkEvent 为基类，提供有 Play/Stop、Play Multiple、Stop Multiple 和 Stop All 按钮，方便预览关联的 Wwise Event。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkAmbient 。

AkAudioListener
将此脚本绑定到代表听者的游戏对象上。该组件一般会添加到 Camera 或 Player 对象，但也可在运用 3D 总线时添加到其他游戏对象。 isDefaultListener 决定游戏对象是否会被视为默认听者。该听者将自动监听所有 AkGameObjListenerList 中未绑定听者的游戏对象。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkAudioListener 。

AkBank
在指定时机加载和卸载 SoundBank。您可以使用 Decode Compressed Data 选项在指定时机解压 Vorbis 声音。在这种情况下，会用准备的方式加载 SoundBank。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkBank 。
另请参阅 SDK 文档：加载 SoundBank。

AkEmitterObstructionOcclusion
在当前游戏对象对应的发声体和听者之间至少有一个障碍物时完全阻挡/遮蔽发声体。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkEmitterObstructionOcclusion 。

AkEnvironment
使用此组件来定义混响区域。为了确保能够正常工作，必须将该组件添加到 Collider 对象。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone) 。

AkEnvironmentPortal
使用此组件来定义两个不同 AkEnvironment 区域的重叠区，以便在两个区域之间进行混音。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone) 。

AkEvent
辅助类知道一个 Wwise 事件，以及何时在 Unity 中触发它。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkEvent 。

AkGameObj
此组件代表场景中的声音对象，用来追踪其位置和其他 Game Sync（如 Switch 以及 RTPC）和环境变量。您可以将该组件添加至任何发声体对象，它也会自动添加到已附加 AkAudioListener 组件的对象上。注意，若没有该组件，则 Wwise 会将其自动添加到传给 Wwise 的 Unity Game Object，并且使用默认值。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkGameObj 。

AkInitializer
此组件用于初始化 Wwise 声音引擎并更新音频帧。它被标记为 DontDestroyOnLoad ，因此在整个游戏当中都会始终保持有效，并非只作用于一个场景。您可以通过修改此脚本来更改声音引擎的初始化参数。其中有些已经暴露在属性检视器中。为了确保能够正常初始化音频，在游戏开始时必须已将其绑定到一个 Game Object 上。在执行该脚本之后，才能执行其他使用 AkSoundEngine 的 MonoBehavior。

参见
  • 调整 Wwise Initialization Settings
  • Wwise SDK 文档：初始化声音引擎的不同模块
  • AK::SoundEngine::Init()
  • AK::SoundEngine::Term()
  • AkCallbackInfo

AkListenerDistanceProbe
This component assigns a Game Object as the Distance Probe for a specified listener Game Object. Primarily used in third-person perspective games, a Distance Probe applies attenuation to sounds based on a different location than that of the listener.
See Using the Ak Listener Distance Probe Component to Customize Listeners in Third-Person Games for a description of its public properties.

AkState
此组件会在每次触发所选 Unity Event 时调用 ak.soundengine.setState()。比如，您可以将该组件添加到 Unity Collider 以便在有对象进入时进行触发。
有关公共属性的说明，请参阅 在 Inspector 中使用 AkState 章节。

AkSwitch
此组件会在每次触发所选 Unity Event 时调用 ak.soundengine.setSwitch()。比如，您可以将该组件添加到 Unity Collider 以便在有对象进入时进行触发。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkSwitch 。

Spatial Audio 组件

AkEarlyReflections
将此脚本绑定到代表发声体的游戏对象上。此游戏对象发出的声音会在 AkSurfaceReflector 附近产生早期反射。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkEarlyReflections 。

AkRadialEmitter
将此脚本绑定到代表发声体的游戏对象上。此游戏对象发出的声音将依据以游戏对象所在位置为中心的内外半径应用散布效果。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkRadialEmitter 。

AkRoom
AkRoom 是一个封闭的环境，仅可通过 AkRoomPortal 与外部/其他 Room 互通。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkRoom 。

AkRoomAwareObject
该游戏对象会感知 AkRoom 组件。将此脚本绑定到 Spatial Audio Listener 以及发出 Spatial Audio 声音的 GameObject 上。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkRoomAwareObject 。

AkRoomPortal
AkRoomPortal 可将两个 AkRoom 组件互连，并在两者之间传播声音。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkRoomPortal 和 AkRoomPortalObstruction 。

AkRoomPortalObstruction
在当前游戏对象对应的 Spatial Audio Portal 和 Spatial Audio Listener 之间至少有一个障碍物时完全阻挡来自 Spatial Audio Portal 的声音。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkRoomPortal 和 AkRoomPortalObstruction 。

AkSpatialAudioDebugDraw
将此脚本绑定到通过 Spatial Audio 发出声音的游戏对象上。该脚本可在当前游戏对象和 Spatial Audio Listener 之间绘制早期反射或衍射路径以方便进行调试。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkSpatialAudioDebugDraw 。

AkSpatialAudioListener
将此脚本绑定到代表听者的游戏对象上。
有关其公共属性的说明，请参阅 在 Inspector 中使用 AkSpatialAudioListener 。

AkSurfaceReflector
此组件会将 GameObject 几何构造所含的三角形转换为声音反射表面。
有关公共属性的说明，请参阅 在 Inspector 中使用 AkSurfaceReflector 章节。

参见
  • 为 Wwise Events 添加新的 Trigger。

组件代码

如需查看 Wwise 组件的代码，请通过组件的“设置”按钮打开对应的 C# 脚本。

若想为自己的 Wwise Unity Integration 工程编写自定义脚本，建议使用 Wwise Types 来实现。

参见
  • 添加 Wwise 组件


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkAmbient

在 Inspector 中使用 AkAmbient
备注： AkAmbient 基于 AkEvent 构建，允许进行多点定位。
  • Trigger On：提供用来触发 Wwise Event 的 Unity Event 列表。您可以选择多个 Unity Event。这时该字段会显示为 Mixed...。您可以选择多个 Unity Event。这时该字段会显示为 Mixed...。您可以使用的不止这些事件。您可以随时触发事件，方法是在代码的任何位置调用 AkSoundEngine.PostEvent 。您也可以自己编写触发器代码，这样您的触发器会出现在您同事可使用的列表中。请参阅 为 Wwise Events 添加新的 Trigger。 。
  • Action On Event：允许用户直接在 Unity 内覆盖 Wwise 中定义的一些 Event 参数。这样方便重复使用现有 Event 而无需另外新建。
    若禁用该项，则表示您将发送 Event。若启用该项，则不得启用 Use Callback。 另请参阅 SDK 文档中的 AK::SoundEngine::ExecuteActionOnEvent 条目。
    • Action On Event Type：覆盖 Event 的 Action Type。
    • Curve Interpolation：覆盖插值曲线。
    • Fade Time（淡变时间）：覆盖声音的淡变时间。
  • Use Callback（使用回调）：提供一种简单的方法使游戏对象对事件回调作出反应。若启用该项，则不得启用 Use Callback。
    • Game Object：用于接收回调的游戏对象。如果要选中一个游戏对象，将它从层级结构中拖放到游戏对象区域。
    • Callback Function：在发生回调时将由 Game Object 调用此函数。为了选中这个函数，要在 Callback Function 的文本字段中输入它的名字。 为了起效果，Game Object 必须在它的一个组件中定义 Callback Function。 该函数仅可接收一个 AkEventCallbackMsg 参数。
    • Callback Flags：选择标志来指定何时调用 Callback Function。可以一次选中多个标志。如果想了解各个标志的更多信息，请参阅 Wwise SDK 文档 中的 AkCallbackType 枚举量。
    • Add：创建新的回调。
  • Play / Stop：可用于在 Edit 模式下预览 Wwise Event。
  • Stop All：停止当前播放的所有 Wwise Event。
  • Position Type：定义如何将 Event 的位置发送到声音引擎。
    • Simple_Mode：Event 的位置将与其所绑定的游戏对象相同。
    • Large_Mode：Event 可以有多个位置，这些位置由一组点来定义。您可以通过单击 Inspector 中的 Add Large Mode 按钮来添加位置点。此时会将子游戏对象添加到 AkAmbient 游戏对象。然后，您就可以使用法线变换工具来移动位置点。另外，也可手动添加 AkAmbientLargeModePositioner 组件并单击 Inspector 中的 Pick 按钮，来使用现有游戏对象。此模式适合某种声音在同一时间从多个位置传来的情形，在大海中央聆听水声就是一个很好的例子。
    • MultiPosition_Mode：此模式允许只为使用同一 Event 的所有 AkAmbient 实例生成一个声音实例，以便节省内存。所有使用该模式的 AkAmbient 实例，如果都使用同一个事件，那么会自动被检测到，并且会实际使用同一个声音实例，而不是多次加载相同的声音。
      备注： 在该模式下，使用同一 Event 的所有 AkAmbient 实例都将采用相同的 Trigger（参阅 AkEvent 中的 Trigger On）。因此，如果改变其中一个 AkAmbient 的触发器，则将会自动改变同一事件其它 AkAmbient 的触发器。
  • Show Attenuation Sphere：显示球体来表示 Event 所播放声音的可听范围。不过，在 Play in Editor 模式下将无法看到该球体。
    为了起效果，您必须启用 Wwise 工程中 SoundBank 设置里的 Max Attenuation（Project > Project Settings > Soundbanks > Max attenuation）。
    • Dont_Show：不显示衰减球体。
    • Current_Event_Only：显示在当前模式下调用 AkSoundEngine.PostEvent 之后，播放的所有声音的衰减范围。
      • 如果在 Simple_Mode 之下，那么只有该游戏对象上的声音的衰减范围会显示出来。
      • 如果在 Large_Mode之下，那么每个点都会显示一个衰减范围。
      • 如果在 MultiPosition_Mode 之下，那么对于同一事件 MultiPosition_Mode 中每隔一个 AkAmbient 显示其衰减范围。
    • All_Events：为场景中所有 AkAmbient 实例显示衰减曲线。
  • Name：单击该项来选择已在 WwiseProject > Events 中定义的 Event。若要添加新的 Event，请在 Wwise Project Explorer 的 Events 选项卡中单击 Create new 'Event' 按钮。
备注： 对于 Large_Mode 和 MultiPosition_Mode 定位类型，需要考虑其中的一些限制。因为 AkSoundEngine.SetMultiplePositions 调用发生在后，所以不可在 Awake 状态下触发声音。这两种多点定位模式适用于静止对象。强烈建议将所属 UnityEngine.GameObject 设为静态。
参见
  • Wwise SDK doc: Integration Details - 3D Positions
  • AK::SoundEngine::SetMultiplePositions
  • AK::SoundEngine::SetPosition
  • Wwise Help: Managing Events


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkAudioListener

在 Inspector 中使用 AkAudioListener
  • Is Default Listener：将所选 GameObject 设为其他 GameObject 的默认听者，除非通过调用为其设置另一听者来覆盖默认听者。Default Listener 一般会应用于中心对象（如 Camera）。
参见
  • Wwise SDK doc: Integrating Listeners in Wwise
  • Wwise-301: Audio Listener


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkBank

在 Inspector 中使用 AkBank
  • Load On：游戏加载 SoundBank 的时机。单击该项来选择以下若干选项：
    • Start：场景加载时。此项为默认设置，一般会通过该方式加载 SoundBank。
    • Nothing：Unity 中的默认选项，不建议使用。
    • Everything：Unity 中的默认选项，不建议使用。
    • Awake：当前游戏对象变为活跃对象时。
    • Destroy：场景结束时。专门用于卸载 SoundBank。
    • AkTrigger 选项：AkTrigger 选项有好几个。比如，可运用 AkTriggerEnter 来在玩家进入房间时加载 SoundBank。注意，如果在需要房间声音时未加载 SoundBank ，可能会产生声音延迟问题。有关如何利用 Trigger 加载 SoundBank 的详细信息，请参阅 Wwise 301 的“利用 Trigger 加载 SoundBank”章节。
  • Unload On：游戏卸载 SoundBank 的时机。单击该项来选择以下若干选项：
    • Start：场景加载时。专门用于加载 SoundBank。
    • Nothing：Unity 中的默认选项，不建议使用。
    • Everything：Unity 中的默认选项，不建议使用。
    • Awake：当前游戏对象变为活跃对象时。专门用于加载 SoundBank。
    • Destroy：场景结束时。此项为默认设置，一般会通过该方式卸载 SoundBank。
    • AkTrigger 选项：AkTrigger 选项有好几个。比如，可运用 AkTriggerExit 来在玩家离开房间时卸载 SoundBank。
  • Asynchronous：立刻返回 LoadBank 函数调用，指示是否成功将加载请求添加到了队列中，并允许一边执行其他操作一边在后台继续运行实际加载任务。若禁用 Asynchronous，则将中断主处理线程，直到完成加载。Asynchronous 调用尤其适用于不需要立刻加载的大 SoundBank。
    参见
    • SDK 参考文档中有关 LoadBank 的 Asynchronous 说明。
  • Decode compressed data：解压所有 SoundBank 的 Vorbis 和 Opus 压缩文件。
    参见
    • Wwise Help: About Audio Formats
    • Wwise SDK doc: Preparing Banks
    • AK::SoundEngine::PrepareBank
  • Save decoded bank：将所有未压缩文件存储到磁盘上，以便在卸载 SoundBank 后快速加载。
  • Name：单击该项来选择已在 WwiseProject > Banks 中定义的 SoundBank。若要添加新的 SoundBank，请在 Wwise Project Explorer 的 SoundBanks 选项卡中单击 Create new 'SoundBank' 按钮。
参见
  • Wwise Help: Managing SoundBanks
    • Creating a SoundBank
  • Wwise-301: Managing SoundBanks in Unity


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkEmitterObstructionOcclusion

在 Inspector 中使用 AkEmitterObstructionOcclusion

在游戏对象和听者之间的路径当中存在另一对象时，可通过将 AkEmitterObstructionComponent 绑定到 GameObject 来实现声障/声笼效果。

在发声体被阻挡或遮蔽时，AkEmitterObstructionOcclusion 组件会调用 SetObjectObstructionAndOcclusion()，并将值设为 1。您可以在 Wwise Project Settings 中定义声障曲线（Obstruction Volume、Obstruction LPF 和 Obstruction HPF）和声笼曲线（Occlusion Volume、Occlusion LPF 和 Occlusion HPF）。

若地图中不使用 Spatial Audio（即未添加任何 AkRoom 组件），则 AkEmitterObstructionOcclusion 组件将仅使用 Wwise 定义的声笼曲线。反之，若地图中使用 Spatial Audio，则 GameObject 将仅使用 Wwise 定义的声障曲线。

  • Fade Time：淡入和淡出的时长（单位为秒）。
  • Layer Mask：指示将哪些分层用作声障/声笼。
  • Max Distance：执行声障/声笼检查的最大距离。负值将被视为距离无限远。
  • Refresh Interval：执行声障/声笼检查的间隔（单位为秒）。若设为 0，则连续不停地执行声障/声笼检查。
备注： 若为 Spatial Audio 启用了 衍射，请不要使用 AkEmitterObstructionOcclusion。
参见
  • A. Emitter Obstruction/Occlusion
  • AK::SoundEngine::SetObjectObstructionAndOcclusion


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone)

在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone)

Wwise 需要利用 Auxiliary Bus 来搭载混响效果器并以此实现 Reverb Zone。您可以在 Auxiliary Bus 上应用任何 Wwise 效果器，所以 Reverb Zone 的作用并不限于使用混响效果器。

AkEnvironment 组件包含一个非常简单的环境区域。您可以在任何类型的碰撞体上附加一个 AkEnvironment。如果想将一个 AkEnvironment 添加到您的场景：

  • 使用 Wwise Picker 。 这是最简单的添加 AkEnvironment 的方式。将某个 AuxBus 从 Wwise Picker 窗口拖到 Unity Viewer 或者 Inspector 的一个对象上。这将自动在目标 Game Object 上创建一个 AkEnvironment 组件。
  • 使用 "Add Component" 菜单。 将一个 AkEnvironment 组件添加到任意 Unity Game Object。从 Inspector 的选择器中选择需要的环境。
  • 使用脚本。 您可以在任意时间从 C# 脚本调用 AkSoundEngine.SetGameObjectAuxSendValues()。

我们还有一些门户（portal）可以用来合并两个环境的影响。这两个环境中每个环境对效果的贡献都是和它们与游戏对象间距离相关的。 如果游戏对象站在两个房间之间，或者站在连接两个环境的隧道中，那么这种功能是很有用的。

  • 如果想添加一个环境门户到您的工程中，请前往 Unity 菜单栏中的 GameObject > Wwise > Environment Portal。

如果想使用环境和环境门户，您需要一个游戏对象和能觉察到环境的（environment aware） AkGameObj 组件。 AkEnvironmentPortal 会自动探测到和它重叠的 AkEnvironment 对象。重叠的环境将出现在门户 inspector 的两个选择列表中。如果有太多的环境与门户重叠， 您则可以选择让门户和哪些环境混合在一起。

在 Wwise Unity Integration 中，同一时间最多只能有 4 个活跃的 AkEenvironment。您可以按照如下所述来选择这 4 个 AkEenvironment：

  • 连接到门户的环境和具有最高优先级的环境将被选择，直到我们选择了 4 个环境，或者直到没有环境连接到门户为止。
  • 如果并没有 4 个选中的环境，我们将按照下面的方式来选择没有连接到门户的环境：
    • 选取最高优先级的环境，直到我们选满 4 个环境为止（如果没有设置 Default 和 Exclude Others 标志）。
    • 只有在没有选中其它环境的情况下，Default 才会被选中。
    • 如果您的游戏对象在有着 Exclude Others 标志的环境中，那么该环境将被选中，而其它所有环境将会被废弃。
  • AkEnvironment 组件：同一时间最多只能有 4 个活跃的环境。
    • Priority：定义环境的优先级。该数字越小，代表优先级越高。
      如果一个游戏对象处在多于 4 个环境中，只有具有最高优先级的 4 个环境会处于活跃状态（如果没有设置 Default 和 Exclude Others 标志）。
    • Default：默认环境只有作为唯一包含游戏对象的环境时才会处于活跃状态。
      如果您的游戏对象处于一个以上的默认环境中，那么只有具有最高优先级的默认环境会处于活跃状态。
    • Exclude Others：带有此标志的环境不会与其他环境重叠。
      如果您的游戏对象处于一个有着 Exclude Others 标志的环境中，那么其它所有环境将被废弃。
      如果您的游戏对象处于一个以上的有着 Exclude Others 标志的环境中，那么只有那个具有最高优先级的环境会处于激活状态。
    • AuxBus Name：指定当前 AuxBus 的名称。如果想选中一个 AuxBus，那么点击当前 AuxBus 的名字，以打开 AuxBus 选择窗口。接下来，您可以点击想选的 AuxBus 然后点击 OK 按钮，或者双击来选中它。您也可以将想选的 AuxBus 从 Wwise Picker 拖放到当前 AuxBus 的名字上，以选中新的这个 AuxBus。
  • AkEnvironmentPortal 组件：您可以通过依次转到 GameObject > Wwise > Environment Portal 来在 Unity 中创建环境门户。
    您可以在两个环境之间放置一个环境门户，当您的游戏对象在门户中时，门户就可以将两个环境的效果结合起来。为了生效，门户必须与这两个环境有交集。
    这两个环境中每个环境对效果的贡献都是和它们与游戏对象间距离相关的。游戏对象离环境越近，环境对最终效果的影响就越大。
    • Environment #1：门户会自动检测所有与其存在重叠的环境。在这些环境中，放置在门户负面一侧（与选择的轴的方向相反）的那些环境将在下拉菜单中可用。之所以采用按这种方式来给环境排序，是为了在运行时确定每个环境的贡献时减少所需的计算量。
    • Environment #2：门户会自动检测所有与其存在重叠的环境。在这些环境中，放置在门户正面一侧（与选择的轴的方向相同）的那些环境将在菜单中可用。 之所以采用按这种方式来给环境排序，是为了在运行时确定每个环境的贡献时减少所需的计算量。
    • Axis：轴用于计算各个环境的贡献。例如，如果选择了 z 轴，那么沿着 x 轴移动对于各个环境的贡献没有任何影响。只有 z 轴上的移动才会对它们的贡献产生影响。
      备注： 轴处在对象空间中。旋转门户的话，轴也会旋转。
参见
  • Wwise SDK doc: Integrating Environments and Game-defined Auxiliary Sends
  • AK::SoundEngine::SetGameObjectAuxSendValues


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkEvent

在 Inspector 中使用 AkEvent
备注： AkAmbient 基于 AkEvent 构建，允许进行多点定位。
  • Trigger On：提供用来设置 Wwise Event 的 Unity Event 列表。您可以选择多个 Unity Event。这时该字段会显示为 Mixed...。您可以使用的不止这些事件。您可以通过在代码中任意位置调用 AkSoundEngine.PostEvent 来随时设置 Event。您也可以自己编写触发器代码，这样您的触发器会出现在您同事可使用的列表中。请参阅 为 Wwise Events 添加新的 Trigger。 。
    • Action On Event：允许用户直接在 Unity 内覆盖 Wwise 中定义的一些 Event 参数。这样方便重复使用现有 Event 而无需另外新建。
      若禁用该项，则表示您将发送 Event。若启用该项，则不得启用 Use Callback。 另请参阅 SDK 文档中的 AK::SoundEngine::ExecuteActionOnEvent 条目。
      • Action On Event Type：覆盖 Event 的 Action Type。
      • Curve Interpolation（曲线插值）：不沿用插值曲线。
      • Fade Time（淡变时间）：覆盖声音的淡变时间。
    • Use Callback（使用回调）：提供一种简单的方法使游戏对象对事件回调作出反应。若启用该项，则不得启用 Use Callback。
      • Game Object：用于接收回调的游戏对象。如果要选中一个游戏对象，将它从层级结构中拖放到游戏对象区域。
      • Callback Function：在发生回调时将由 Game Object 调用此函数。为了选中这个函数，要在 Callback Function 的文本字段中输入它的名字。 为了起效果，Game Object 必须在它的一个组件中定义 Callback Function。 该函数仅可接收一个 AkEventCallbackMsg 参数。
      • Callback Flags：选择标志来指定何时调用 Callback Function。可以一次选中多个标志。如果想了解各个标志的更多信息，请参阅 Wwise SDK 文档 中的 AkCallbackType 枚举量。
      • Add：创建新的回调。
  • Play / Stop：可用于在 Edit 模式下预览 Wwise Event。
  • Stop All：停止当前播放的所有 Wwise Event。
  • Name：单击该项来选择已在 Wwise Picker 的 WwiseProject > States 中定义的 Event。若要添加新的 Event，请在 Wwise Project Explorer 的 Events 选项卡中单击 Create new 'Event' 按钮。
参见
  • AK::SoundEngine::SetPosition
  • Wwise Help: Managing Events


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkGameObj

在 Inspector 中使用 AkGameObj
  • Apply Position Offset：为游戏对象应用二次 Transform，以便指定一个不同于游戏对象实际位置的音频计算位置。
    • Position Offset：按照 X（左右）、Y（上下）和 Z（前后）字段中输入的游戏单位来移动游戏对象二次 Transform 的位置。
    • Hide Main Transform：从视图中移除一次 Transform，以便仅显示应用了偏置的二次 Transform。
  • Envrionment Aware：将游戏对象的音频设为受环境、房间和门户影响。若要设置该项，则 AkGameObj 必须具有 Rigidbody。
    备注： 此选项只有在播放场景之前选中才会生效。
    • Add Rigidbody：在 GameObject 上添加 Rigidbody 组件。
  • Use Default Listeners：Default Listener 一般会应用于中心对象（如 Camera）。它将监听所有未绑定听者的游戏对象。
    • Add Listener：另外指定一个听者。单击该按钮来打开 Select AkAudioListener 对话框，以便选择绑定有 AkAudioListener 的游戏对象。
      备注： 必须至少存在一个听者。若不使用默认听者或另外指定一个听者，则 Wwise Settings 对话框 (Edit > Project Settings > Wwise Editor) 将自动使用默认的 "Automatically add Listener to Main Camera" Asset Management 设置来加以保存。
参见
  • 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone)
  • SDK doc: Integrating Listeners in Wwise


Wwise Unity Integration Documentation: Using the Ak Listener Distance Probe Component to Customize Listeners in Third-Person Games

Using the Ak Listener Distance Probe Component to Customize Listeners in Third-Person Games
备注： Before proceeding with this example, refer to Working with Listeners in Third-Person Perspective Games for a general introduction to using Distance Probes in Wwise.

The following example assumes that you have a Unity project that is set up for a third-person perspective game. You must have a camera GameObject that will be used as the listener, and a player character or other GameObject that will be assigned as the Distance Probe. Note that by default, an Ak Audio Listener component is added automatically to the main camera.

  1. Navigate to the GameObject that will be assigned as the Distance Probe. In most cases, this will be the player character GameObject.
    1. Ensure that the Ak Game Obj component is attached to the GameObject. The component can be added by clicking Add Component in the Inspector and choosing Ak Game Obj.

  2. Navigate to the camera GameObject that is used as the listener.

    1. In the Inspector, click on Add Component. Select Ak Listener Distance Probe. If they do not already exist, both the Ak Audio Listener and Ak Game Obj scripts are automatically added to the GameObject.
    2. In the Inspector, navigate to the Ak Listener Distance Probe component. Click on the Distance Probe field to assign the Ak Game Obj that you want to use as the Distance Probe.
      • If the GameObject is not available in the selection menu, then it has not been assigned an Ak Game Obj component. See step 1.

You can now use the Wwise Authoring tool to connect to the game and confirm that the Distance Probe is set up correctly. Refer to Profiling the Distance Probe for details.


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkState

在 Inspector 中使用 AkState
  • Trigger On：提供用来触发 State 的 Unity Event 列表。您可以选择多个 Unity Event。这时该字段会显示为 Mixed...。您可以使用的不止这些事件。您可以通过在代码中任意位置调用 AkSoundEngine.SetState 来随时触发 State。您也可以自己编写触发器代码，这样您的触发器会出现在您同事可使用的列表中。请参阅 为 Wwise Events 添加新的 Trigger。 。
  • Name ：单击该项来选择已在 Wwise Picker 的 WwiseProject > States 中定义的 State。若要添加新的 State，请在 Wwise Project Explorer 的 Game Syncs 选项卡中单击 Create new 'State' 按钮。
参见
  • Wwise Help: Working with States
    • Creating a State
  • Wwise SDK doc: Integration Details - States
  • AkSoundEngine.SetState()


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkSwitch

在 Inspector 中使用 AkSwitch
  • Trigger On：提供用来触发 Switch 的 Unity Event 列表。您可以选择多个 Unity Event。这时该字段会显示为 Mixed...。您可以使用的不止这些事件。您可以通过在代码中任意位置调用 AkSoundEngine.SetSwitch 来随时触发 Switch。您也可以自己编写触发器代码，这样您的触发器会出现在您同事可使用的列表中。请参阅 为 Wwise Events 添加新的 Trigger。 。
  • Use Other Object：此属性仅适用于结合使用 Collider 的情形。若启用，则 Action 的目标为另一碰撞对象。若禁用，则为当前对象。
  • Name：单击该项来选择已在 Wwise Picker 的 WwiseProject > Switches 中定义的 Switch。若要添加新的 Switch，请在 Wwise Project Explorer 的 Game Syncs 选项卡中单击 Create new 'Switch' 按钮。
参见
  • 脚步演示
  • Wwise Help: Working with Switches
    • Creating a Switch
  • Wwise SDK doc: Integration Details - Switches
  • AkSoundEngine.SetSwitch()


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkEarlyReflections

在 Inspector 中使用 AkEarlyReflections

AkEarlyReflections 为可选组件。该组件可针对游戏对象发出的所有声音统一启用早期反射。它会调用 SetEarlyReflectionsAuxSend() 和 SetEarlyReflectionsVolume()。

此外，也可在设计工具内的 Sound Property Editor 中针对每个声音单独启用早期反射。就优先级来说，设计工具中应用于声音的 Reflect Auxiliary Bus 要高于通过 AkEarlyReflections 组件定义的早期反射。

  • Reflections Aux Bus：为当前游戏对象设置早期反射辅助总线。该组件会依据所选辅助总线调用 AK::SpatialAudio::SetEarlyReflectionsAuxSend()。辅助总线参数将被应用到游戏对象所播放但未在设计工具中指定早期反射辅助总线的声音。针对各个声音指定的早期反射辅助总线参数在优先级上高于此处传递的值。
  • Reflections Volume：为当前游戏对象设置早期反射发送音量。它可以用来控制早期反射发送的音量。该组件会依据所输入的音量值调用 AK:SpatialAudio::SetEarlyReflectionsVolume()。该值将连同设计工具中指定的早期反射音量一并应用到游戏对象播放的所有声音。有效值为 [0, 1]。若将音量设为 0，则针对此游戏对象禁用所有反射处理。

此组件同样需要反射表面。有关更多详细信息，请参阅 AkSurfaceReflector 和 在 Inspector 中使用 AkSurfaceReflector 章节。


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkRadialEmitter

在 Inspector 中使用 AkRadialEmitter

此组件可基于游戏对象添加内外半径来模拟 Radial Emitter。同时，依据内外半径和发声体与听者之间的距离自动计算声音的散布。在应用衰减曲线时，使用听者与内径所构成球体上最近点之间的距离。

该组件会依据参数中指定的内外半径值调用 AK:SpatialAudio::SetGameObjectRadius()。

备注： 此功能仅适用于 Spatial Audio，也就是说场景中必须有 AkSpatialAudioListener。
  • Outer Radius：将字段设为所需外径大小。该数值将直接发给 Spatial Audio 调用而不进行任何转换。若启用 Gizmos 并选中当前游戏对象，则围绕该游戏对象所在位置绘制黄色球体，以此直观地反映所输入的数值大小。
  • Inner Radius：将字段设为所需内径大小。该值不得大于外径大小。该数值将直接发给 Spatial Audio 调用而不额外进行任何转换。若启用 Gizmos 并选中当前游戏对象，则围绕该游戏对象所在位置绘制黄色球体，以此直观地反映所输入的数值大小。

若针对带有 AkRadialEmitter 的游戏对象将 AkAmbient 组件的 Position Type 设为 Large_Mode，则将面向周围添加内外半径。此外，AkRadialEmitter 还可用于多点定位。


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkRoom

在 Inspector 中使用 AkRoom

Room 是 Spatial Audio 的基本组成部分。它在各项 Spatial Audio 相关概念中扮演着重要的作用。

  • Reverb Aux Bus：单击该项来选择已在 Wwise Picker 的 WwiseProject > AuxiliaryBusses 中定义的 Auxiliary Bus。若要添加新的 Auxiliary Bus，请转到 Wwise Project Explorer 的 Audio 选项卡，接着在 Master-Mixer Hierarchy 下选中 Audio Bus，然后单击 Create new 'Auxiliary Bus' 按钮。
  • Reverb Level：直接将滑杆或字段设为 Auxiliary Bus 的 Auxliary Sends Volume 的倍数（在设为 0 时表示无辅助发送，在设为 1 时最大，允许精确到七个小数位）。比如，若同时为 Large Room 和 Small Room 设置了 Auxiliary Bus，则一般会降低 Small Room 的音量电平，因为其混响效果相对来说不明显。
  • Transmission Loss：将滑杆或字段 (0 ~ 1) 设为要与此 Room 关联的透射损失值。透射损失用于模拟声音穿透障碍物时的能量损耗。若使用声笼模拟透射（参见 Spatial Audio Initialization Settings 章节），则透射损失值将使用 Wwise Project Settings 中的所有 Occlusion 曲线（Occlusion Volume、Occlusion LPF 和 Occlusion HPF）对声音实施滤波。比如，0.75 的 Transmission Loss 对应于相应 Wwise Occlusion 坐标图中 Occlusion 轴上的 75% 标记点。具体到下图中，则意味着音量为 -12.0 dB。
    通常，较低的透射损失适合薄弱的墙壁，较高的透射损失适合厚实的墙壁。
  • Priority：设置 Room 的优先级以在游戏对象处于不止一个 Room 内时供 AK::SpatialAudio::SetGameObjectInRoom() 选用。注意，数值越大表示优先级越高。比如，在两个 Room 的 Priority 分别为 1 和 2 时会优先选用后者。

Room Tone

  • Trigger On：提供用来触发 Wwise Event 的 Unity Event 列表。您可以选择多个 Unity Event。这时该字段会显示为 Mixed...。您可以使用的不止这些事件。您可以通过在代码中任意位置调用 AkSoundEngine.PostEvent 来随时触发 Event。您也可以自己编写触发器代码，这样您的触发器会出现在您同事可使用的列表中。请参阅 为 Wwise Events 添加新的 Trigger。 。
  • Room Tone Event：单击该项来选择已在 Wwise Picker 的 WwiseProject > Events 中定义的 Event。若要添加新的 Event，请在 Wwise Project Explorer 的 Events 选项卡中单击 Create new 'Event' 按钮。所选 Event 将应用于 Room 游戏对象。
  • Room Tone Aux Send：直接将滑杆或字段设为作用于 Room 戏对象的声音的发送电平。其中，0 表示禁用辅助发送，1 表示设为满度值。

Room 的边界由 AkRoom 组件所管理的同一游戏对象上绑定的 Collider 决定。带有该 Collider 的 Trigger 会使用 AK::SpatialAudio::SetGameObjectInRoom() 设置 Room 中的其他游戏对象。

另外，Room 还可透过墙壁传播其内的湿声。Room 的形状由围绕 Portal 创建的边界框定义。除此之外，还可通过将几何构造与 Room 关联来指定 Room 的形状。在 Unity 中，可依据 Collider 的形状或同一游戏对象上的 AkSurfaceReflector 组件自动将几何构造与 Room 关联。

行为如下：

  • 若没有 AkSurfaceReflector 组件且 Collider 为 Mesh、Box、Sphere 或 Capsule，则 AkRoom 组件将依据 Collider 的形状创建几何构造以供发送到 Spatial Audio（仅用于计算 Room 边界并直观地予以呈现）。比如，在 Collider 为 Capsule 时，将发送箱形 Mesh。您可以在 Game Object 3D Viewer 中查看该几何构造。它看起来跟其他几何构造差不多，只不过带有特定颜色，表明其为 Room。
  • 若有处于启用状态的 AkSurfaceReflector 组件，则会把其 ID 直接添加到 the AkRoomParams 来将对应的几何构造与 Room 关联。
    备注： AkSurfaceReflector 组件的 Mesh 最好与 Room 的 Collider 相似。Room 的 Collider 用于设置 Room 中的游戏对象。如果两个 Volume 不一样，几何包含关系检测和 Room 透射之间就会出现差异。而且，Game Object 3D Viewer 中 Room 周围显示的几何构造也会跟游戏对象被视为处于 Room 内的 Volume 不一样。
  • 若以上两个条件均不满足，则将在 Inspector 中显示警告。

Wwise 中将生成由关联几何构造的顶点构成的边界框。此 Volume 会影响散布。在该 Volume 之外，Room 的湿声透射散布将介于 0 ~ 180 度之间。在该 Volume 之内，散布会达到 100。此 Volume 称为 Room 的边界。您可以通过在 Game Object 3D Viewer Settings 中启用 Room Extent 来将其显示到 Game Object 3D Viewer 中。

参见
  • 在 Unity 中使用 Spatial Audio
    • Room 和 Portal 教程
      • B. Room
  • AkRoom
  • AkRoomParams
  • Room 和 Portal 文档
  • Wwise Help：为工程定义声障和声笼曲线
  • 透射
  • Room 透射


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkRoomAwareObject

在 Inspector 中使用 AkRoomAwareObject

Rigidbody

  • 要想在带有 AkRoomAwareObject 组件的 GameObject 和带有 AkRoom 组件的 GameObject 之间进行交互，两者之中至少有一个需要同时添加 Rigidbody 组件。单击 Add Rigidbody 按钮来进行添加。

Collider

  • 带有 AkRoomAwareObject 组件的 GameObject 需要添加 Collider 组件。为了识别包含 GameObject 的 Room 并将相应信息发送到 Spatial Audio，需要调用 AK::SpatialAudio::SetGameObjectInRoom() 函数。一旦 GameObject 的 Collider 与 AkRoom 组件的 Collider 交叠，便会在 Room 中设置 GameObject（假如该 Room 具有比 GameObject 当前所在 Room 更高的优先级）。此时，可相应地缩放 GameObject 的 Collider。建议将其缩放到 0。
参见
  • 在 Unity 中使用 Spatial Audio
    • Room 和 Portal 教程


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkRoomPortal 和 AkRoomPortalObstruction

在 Inspector 中使用 AkRoomPortal 和 AkRoomPortalObstruction

Portal 在 Spatial Audio 中扮演着重要的作用。Unity Integration 提供两个与 Portal 有关的 Wwise 组件：AkRoomPortal 和辅助/非必选的 AkRoomPortalObstruction 。

AkRoomPortal

  • Initial State：将 Portal 设为在开始时处于关闭或打开状态。
    • Open On：提供用来打开 Portal 的 Unity Event 列表。您可以选择多个 Unity Event。这时该字段会显示为 Mixed...。您也可以自己编写触发器代码，这样您的触发器会出现在您同事可使用的列表中。请参阅 为 Wwise Events 添加新的 Trigger。 。
    • Close On：提供用来关闭 Portal 的 Unity Event 列表。您可以选择多个 Unity Event。这时该字段会显示为 Mixed...。您也可以自己编写触发器代码，这样您的触发器会出现在您同事可使用的列表中。请参阅 为 Wwise Events 添加新的 Trigger。 。另请参阅 SDK 文档：使用房间和门户。
  • Back Room：使用 AkRoomPortal 连通两个 Room。在 Portal 的反面（与局部 Z 轴的方向相反），会自动为 Back Room 赋予最高优先级并将其设为活跃和启用状态。在运行时不会选择被禁用的 Room。
  • Front Room：使用 AkRoomPortal 连通两个 Room。在 Portal 的正面（与局部 Z 轴的方向相同），会自动为 Front Room 赋予最高优先级并将其设为活跃和启用状态。在运行时不会选择被禁用的 Room。

AkRoomPortalObstruction

此可选组件会在 Portal 和听者之间的路径上有对象阻挡时向来自 Portal 的声音应用声障。如能向阻挡对象添加启用了衍射的 AkSurfaceReflector，便可实现更加精准的衍射滤波效果。请参阅 在 Inspector 中使用 AkSurfaceReflector 。

在当前 GameObject 的 Spatial Audio 门户和 Spatial Audio 听者之间至少存在一个对象时，可通过调用 SetPortalObstructionAndOcclusion() 来实现声障效果。在当前 GameObject 和 Spatial Audio Listener 之间有障碍物时，此脚本会调用 SetObjectObstructionAndOcclusion()，并将声障值设为 1。

仅可将 AkRoomPortalObstruction 添加到绑定有 AkRoomPortal 组件的 GameObject。另外，若未注册 Spatial Audio 听者，则不会添加任何声障效果。

  • Fade Time：淡入和淡出的时长（单位为秒）。
  • Layer Mask：指示要将哪些分层用作声障。
  • Max Distance：执行阻挡的最大距离。负值将被视为距离无限远。
  • Refresh Interval：执行声障检查的间隔（单位为秒）。若设为 0，则连续不停地执行声障检查。
备注： 若为 Spatial Audio 启用了 衍射，请不要使用 AkRoomPortalObstruction。
参见
  • A. Emitter Obstruction/Occlusion
  • 在 Unity 中使用 Spatial Audio
    • Room 和 Portal 教程
      • C. Portal
  • Wwise Help: Using the User-Defined Auxiliary Sends
  • Wwise Help：使用 Game-Defined Auxiliary Sends
  • SDK doc: Obstruction and Occlusion versus Portals' Transmission and Diffraction
  • AkPortalParams
  • SetPortalObstructionAndOcclusion()


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkSpatialAudioDebugDraw

在 Inspector 中使用 AkSpatialAudioDebugDraw
  • Draw First Order Reflections：绘制在声音到达听者所在位置前遇到最后一个表面时产生的反射路线。
  • Draw Second Order Reflections：绘制在声音到达听者所在位置前遇到最后两个表面时产生的反射路线。
  • Draw Higher Order Reflections：绘制在声音到达听者所在位置前遇到最后三个或更多表面时产生的反射路线。
    警告：生成的反射次数随阶数呈指数级增长。
  • Draw Diffraction Paths：绘制代表几何衍射的线条。
参见
  • Using the Geometry API for simulating diffraction
  • AkEmitterSettings::reflectionsOrder


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkSpatialAudioListener

在 Inspector 中使用 AkSpatialAudioListener

添加 Spatial Audio 听者以便在游戏中使用 Spatial Audio。若对象尚未绑定 AkAudioListener，则 Unity Integration 将自动添加，因为 AkSpatialAudioListener 需要此组件。

该组件一般会添加到 Camera 或 Player 对象，但必要的话也可添加到其他游戏对象。

Unity Integration 会提示 Spatial Audio 仅支持一个活跃的 AkSpatialAudioListener（如截图所示）。请慎重决定用在何处。

参见
  • 在 Unity 中使用 Spatial Audio
    • 3. Unity 工程准备工作


Wwise Unity Integration Documentation: 在 Inspector 中使用 AkSurfaceReflector

在 Inspector 中使用 AkSurfaceReflector

此组件会将几何构造发送到 Spatial Audio。这样就可以用来影响声音传播的衍射和透射。如有 Wwise Reflect 插件，还可模拟早期反射。

  • Mesh：将 Mesh 用于声音的早期反射、衍射和透射。若保留为 None，则使用 GameObject 所关联的 MeshFilter 组件的 Mesh（如适用）。
  • Acoustic Textures：针对每个 Submesh 选择已在 Wwise Picker 的 WwiseProject > VirtualAcoustics 中定义的 Acoustic Texture。若要添加新的 Acoustic Texture，请转到 Wwise Project Explorer 的 ShareSets 选项卡，接着在 Virtual Acoustics 内选择 Work Unit 或 Virtual Folder，然后单击 Create new 'Acoustic Texture' 按钮。若想获得未经滤波的早期反射，请保留为 None。
  • Transmission Loss Values：选择各个 Submesh 的透射损失值 (0 ~ 1)。一般来说，值为 1.0 时表示声音被损耗殆尽，值为 0.0 时表示声音可无损穿透几何构造。
  • Enable Diffraction：在 Mesh 的边缘设置几何衍射。
  • Enable Diffraction On Boundary Edges：在边界边缘设置几何衍射。其中，Boundary Edge 代表仅连有一个三角形的边缘。
  • Associated Room：单击该按钮来打开 Select AkRoom 对话框，以便选择场景中的“房间”游戏对象。
参见
  • 在 Unity 中使用 Spatial Audio
    • Surface Reflector 教程
    • A. Surface Reflector 和 Portal
  • Wwise Help: Wwise Reflect - Acoustic Textures
  • Wwise Help：Wwise Reflect – 使用衍射
  • Wwise SDK 文档：Spatial Audio – 衍射
  • AK::SpatialAudio::SetGeometry


Wwise Unity Integration Documentation: 为 Wwise Events 添加新的 Trigger。

为 Wwise Events 添加新的 Trigger。

在大多数用于 Unity 的 Wwise 组件中，有一个 "Trigger On" 属性，从中您可以选择哪个 Unity 通知/事件将触发 Wwise 组件（Event、Switch、State 等）。这个列表只包含在 Unity 中可以做到的一部分。但是，触发系统是可扩展的，且不需要修改集成代码本身。

如果想添加一个新的触发器，您只需编写一个来自于 AkTriggerBase 的 C# 类。从 AkTriggerBase 派生的所有类都将通过反射找到，并添加到 "Trigger On" 下拉列表中。这个类包含一个委托，triggerDelegate(GameObject in_target)，当触发器的条件发生时，您必须调用该委托。"目标" 对象是可选的，目前用于碰撞体场合下提供碰撞对象。这使得 Wwise 组件可以在“被撞对象”上发送事件，而不是在碰撞体上发送。

虽然这个系统完全是可选的，但您也可以使用这个系统来触发游戏代码中的音频组件。只要出现触发条件或关联有自定义函数，就可直接从代码调用 GetComponent<YourTriggerClass>().triggerDelegate(GameObject in_target) 。

备注： 目前，AkTriggerBase 子类的最大数量是 32。

下面是一个含有自定义函数的示例：

public class TriggerOnGunHit : AkTriggerBase
{
void Hit()
{
if(triggerDelegate != null)
{
triggerDelegate(null);
}
}
}

在您的游戏代码中，您可以加入这段代码：

if (playerIsShot)
{
GetComponent<TriggerOnGunHit>().Hit();
}

任何连接到 TriggerOnGunHit 触发器的 Wwise 组件就可以正常运行了。注意，在很多简单情况下，这种做法完全是多余的；除此之外，您也可以直接通过 AkSoundEngine.PostEvent("GunHit", gameObject) 来调用基础 Wwise SDK，然后让声音设计师在 Wwise 中处理此 Event 的效果。

AkTriggerBase.triggerDelegate
Trigger triggerDelegate
All components reacting to the trigger will be registered in this delegate.
Definition: AkTriggerBase.cs:30
AkTriggerBase
Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use ...
Definition: AkTriggerBase.cs:23


Wwise Unity Integration Documentation: Wwise Picker

Wwise Picker

Wwise Picker 窗口将用同样的结构来显示您的 Wwise 工程中可用的对象（如 Events 和 Switches）。 Wwise Picker 视图中显示的工程与 Wwise Settings 窗口 (Edit > Project Settings > Wwise Editor) 中输入的工程相同。 通常，会在 Unity 中安装 Wwise 插件时指定该工程。

  • 功能
    • 使用 Picker 在您的场景中添加音频
    • 搜索和浏览
    • 生成 SoundBank
    • 在场景中查找引用
    • 自动填充
    • 在 Wwise Picker 中选择对象
  • WAAPI 功能
    • 同步选择
    • Event 播放
    • 重命名 Wwise 对象
    • 打开包含该内容的文件夹
    • 打开 SoundBank 文件夹
    • 刷新工程
    • 连接状态

自 2021.1 版本起，Wwise Picker 包含两种模式：File System 和 Wwise Authoring。您可以使用 Picker 窗口左上角的菜单更改所述模式。

在 File System 模式下，会在保存 Wwise 工程时更新 Wwise Picker 视图中的可用对象。 若未显示所创建的对象，有可能是没有保存工程。 通过单击 Refresh Project，您可以强制刷新 Wwise Picker 视图。 注意，这也刷新了所有与 Wwise 相关的数据，包括在生成 SoundBank 时创建的 XML 元数据文件中的数据。

备注： 请不要将 AkWwiseProjectData.asset添加到版本控制系统中！ 它只是 Wwise 工程数据的临时缓存文件，目的在于避免 Wwise Picker 反复解析 Work Unit 文件。假如将其添加到版本控制系统中，可能会 出现问题。
备注： 在 Wwise Settings 对话框中，必须指定 Wwise Windows Installation Path（或者 Mac 上的 Wwise Application ）。当在 Unity 中点击 Generate SoundBanks 时，Unity 需要用到 Wwise 的路径。

在 Wwise Authoring 模式下，Picker 使用 WAAPI 与 Wwise 中打开的工程进行通信。除 File System 模式下可用的功能外，该模式还提供以下功能：

  • 在 Wwise 设计工具中实施修改时立即更新可用对象。
  • 在 Picker 内播放声音 Event。
  • 在 Unity 和 Wwise 之间同步所作选择。
  • 在 Unity 内重命名和删除 Wwise 对象。
注意： 为确保此模式能够正常运行，须在 Wwise 设计工具中打开 Wwise 工程，并正确配置 WAAPI 设置。 有关如何针对工程设置 WAAPI 的详细信息，请参阅 WAAPI 实用工具 页面。

功能

以下章节所述功能在 File System 和 Wwise Authoring 模式下均可使用。

使用 Picker 在您的场景中添加音频

若要将 Wwise Picker 中的任何对象添加到您的场景中，要将对象拖拽到现有的 Game Object 上 或 Inspector 窗口中。 有关各个组件的详细信息，请分别参阅组件的文档：

  • 拖放一个 Event 将创建一个 AkAmbient 。
  • 拖放一个 SoundBank 将创建一个 AkBank 。
  • 拖放一个 Switch Value 将创建一个 AkSwitch 。
  • 拖放一个 State Value 将创建一个 AkState 。
  • 拖放一条 Aux Bus 将创建一个 AkEnvironment 。

搜索和浏览

使用 Wwise Picker 顶部附近的筛选器框来搜索特定的项。 只要写下您要找的东西的名字，然后 Picker 会自动过滤掉那些与您的搜索不匹配的条目。

您可以通过单击 + 和 - 按钮或双击项目名称来展开和关闭项目。 此外，还可使用键盘上的方向键来选择和展开条目。

如果您要寻找的对象有一个关闭了的父级，那么可能需要展开一些项。

生成 SoundBank

单击 Generate SoundBanks，为所有平台和语言生成全部的 SoundBank。 生成的 SoundBank 将出现在 Wwise Picker 的 SoundBanks 文件夹下，如同是从 Wwise 中生成的一样。 此外，Unity 状态栏还会根据具体情况显示以下消息：

  • WwiseUnity: SoundBanks generation successful（如无错误或警告）；
  • WwiseUnity: SoundBanks generation has warning(s) （如有警告）；
  • WwiseUnity: SoundBanks generation error（如有错误）。 点击消息，将焦点移动到 Console 选项卡，该选项卡显示来自 SoundBank 生成过程的信息。

在场景中查找引用

在 Picker 中右键单击 Wwise 对象时，可选择相应选项以在场景中查找引用。 这样会将自定义搜索添加到 Hierarchy 窗口中，并单独列出包含 Wwise 对象引用的 GameObject。 除此之外，也可通过选中条目并按下 Shift + R 来实现此操作。

自动填充

Auto Populate 选项只在 File System 模式下显示。若启用，则一旦在 Wwise 工程文件中检测到更改（一般会在保存工程时触发此操作），Picker 便会马上更新其内容。 若禁用，则须单击 Refresh Project 按钮来更新 Picker 内容。

在 Wwise Picker 中选择对象

在右键单击引用 Wwise 对象的 Wwise 组件时，现在 Picker 中会显示用于选择对象的菜单选项。这样可以在 Picker 窗口中高亮显示被引用的对象。

WAAPI 功能

在 Wwise Authoring 模式下，Picker 窗口中会即时反映对 Wwise 对象所作的修改。 若在 Wwise Project Explorer 中复制、重命名、删除或移动对象，则 Picker 窗口的内容将同步发生变化。 在 Picker 窗口中右键单击条目时，还可选用很多其他功能：

同步选择

Autosync selection 选项允许设定是否在 Unity 和 Wwise 设计工具之间同步所作选择。 这样便于在程序之间快速过渡，因为最后选中的条目是一样的。

Event 播放

您可以在 WAAPI Picker 中右键单击并试听 Event。 在启动后，还可使用同一选项来停止当前正在播放的 Event。

快捷方式：空格键或快速双击。

若忘记当前都在播放哪些 Event，可在 Picker 中右键单击任意条目，然后选择 Stop All。

重命名 Wwise 对象

您可以在 Picker 窗口内从快捷菜单选择相应选项来重命名 Wwise 对象。

快捷方式：F2 或慢速双击。

备注： 无法重命名 Work Unit 或 Physical Folder。

打开包含该内容的文件夹

快捷菜单中的 Open Containing Folder 选项允许在文件资源管理器中打开 Wwise 对象的 Work Unit 所在的文件夹。

快捷方式：Ctrl + O

打开 SoundBank 文件夹

若所选条目为 SoundBank，则会显示用于打开 SoundBank 文件夹的附加选项。这样可打开文件资源管理器并转到与 Wwise 设计工具中当前激活平台对应的 Generated SoundBanks 文件夹。

备注： 若尚未生成 SoundBank，则将打开操作系统的根目录。

刷新工程

在 Wwise Authoring 模式下，若单击 Refresh 按钮，则将清空 Picker 窗口，并使用 WAAPI 重新获取工程内容。

连接状态

Wwise Picker 窗口的右上角会显示连接状态以及因 WAAPI 请求失败而产生的错误消息。

有关如何针对工程设置 WAAPI 的详细信息，请参阅 WAAPI 实用工具 页面。 若启用了 WAAPI 但 Unity 工程无法成功打开 WebSocket 连接，则 Wwise Picker 窗口中将显示相应的错误消息。

连接错误消息：

  • Connection refused
    • 原因为没有打开工程。
  • 原因为在 Unity 或 Wwise WAAPI 设置中指定了错误的端口/IP地址。
  • 原因为在 Wwise 设计工具的 User Preferences 中禁用了 WAAPI。
  • The wrong project is open in Wwise
    • 确保打开了正确的工程。
  • No project is open in Wwise yet
    • 确保已打开工程。

其他错误消息：

  • Cannot execute call because Wwise has an exclusive lock
    • 原因为在 Wwise 设计工具中打开了模式或设置窗口。

在每次连接失败后，Unity Integration 都会在 2^N 秒后尝试重新连接。其中 N 为尝试连接失败的次数。此等待时间最多不会超过 32 秒。


Wwise Unity Integration Documentation: Wwise Types

Wwise Types

Wwise Types 表示 Wwise 中的核心对象类的集合，如 SoundBank、Event、Game Parameter、State 和 Switch。每个类都有一个关联的属性抽屉，可以让用户轻松地选择所需的对象。Wwise Type 还包含一个支持类，其代表可在发送 Event 时发送到声音引擎的回调标记。

下面是一个示例脚本，它使用了一些 Wwise Types：

public class WwiseTypesExample : UnityEngine.MonoBehaviour
{
public AK.Wwise.Bank MyBank = null;
public AK.Wwise.Event MyEvent = null;
public AK.Wwise.RTPC MyRTPC = null;
public void Awake()
{
MyBank.Load();
}
public void Start()
{
MyEvent.Post(gameObject);
}
private float CalculateMyValue()
{
return (float)System.Math.Sin(System.Math.PI * UnityEngine.Time.timeSinceLevelLoad);
}
public void Update()
{
MyRTPC.SetValue(gameObject, CalculateMyValue());
}
}

以上脚本自动生成下面的 inspector：

为了使用 marker 回调，可以对 WwiseTypesExample 类做如下的更改：

public AK.Wwise.CallbackFlags MyCallbackFlags = null;
public void Start()
{
MyEvent.Post(gameObject, MyCallbackFlags, EventCallback);
}
private void EventCallback(object cookie, AkCallbackType type, AkCallbackInfo info)
{
if (type == AkCallbackType.AK_Marker)
{
var markerInfo = info as AkMarkerCallbackInfo;
if (markerInfo != null)
{
// ...
}
}
}
AK.Wwise.RTPC
This type can be used to set game parameter values to the sound engine.
Definition: AkWwiseRtpc.cs:25
AK
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Bank
This type can be used to load/unload SoundBanks.
Definition: AkWwiseBank.cs:29
AK.Wwise.CallbackFlags
This type represents the values of the flags used when posting an Event with a callback.
Definition: AkWwiseCallbackFlags.cs:25


Wwise Unity Integration Documentation: 使用 C# 代码来控制声音引擎

使用 C# 代码来控制声音引擎

大多数 Wwise SDK 函数可以通过 AkSoundEngine 类在 Unity 中使用。将它想象为 C++ 命名空间 AK::SoundEngine、AK::MusicEngine 等等的替代。想了解与原始 SDK 相比，API 绑定中所做的更改，请参考 API 变化和限制 。 对于更复杂的情况，您需要从代码中调用 Wwise 函数。在 API 中，所有函数中的 GameObjectID 被Unity 风格的 GameObject 所替代。在运行时，这个 GameObject 中将自动添加一个 AkGameObj 组件，除非您之前已经手动添加过了。

对于 Event 和 Bank 使用数字 ID，而不是字符串。

原生 Wwise API 使用字符串或 ID 来触发 Wwise 工程中的事件和其它有名字的对象。您仍然可以在 C# 环境下这样做，方法是将文件 Wwise_IDs.h 转码为 Wwise_IDs.cs。点击 Assets > Wwise > Convert Wwise SoundBank IDs。为了完成上述操作，您需要安装 Python。

将 MIDI 发送到 Wwise

如需将 MIDI 发送到 Wwise，可为 AkMIDIPostArray 类的 AkMIDIPost 成员赋值，并调用以下任一方法：

  • AkMIDIPostArray.PostOnEvent()
  • AkSoundEngine.PostMIDIOnEvent()
  • AK.Wwise.Event.PostMIDI()

以下是一个将 MIDI 消息发送到声音引擎的简单脚本：

public class MyMIDIBehaviour : UnityEngine.MonoBehaviour
{
public AK.Wwise.Event SynthEvent;
private void Start()
{
AkMIDIPostArray MIDIPostArrayBuffer = new AkMIDIPostArray(6);
AkMIDIPost midiEvent = new AkMIDIPost();
midiEvent.byType = AkMIDIEventTypes.NOTE_ON;
midiEvent.byChan = 0;
midiEvent.byOnOffNote = 56;
midiEvent.byVelocity = 127;
midiEvent.uOffset = 0;
MIDIPostArrayBuffer[0] = midiEvent;
midiEvent.byOnOffNote = 60;
MIDIPostArrayBuffer[1] = midiEvent;
midiEvent.byOnOffNote = 64;
MIDIPostArrayBuffer[2] = midiEvent;
midiEvent.byType = AkMIDIEventTypes.NOTE_OFF;
midiEvent.byOnOffNote = 56;
midiEvent.byVelocity = 0;
midiEvent.uOffset = 48000 * 8;
MIDIPostArrayBuffer[3] = midiEvent;
midiEvent.byOnOffNote = 60;
MIDIPostArrayBuffer[4] = midiEvent;
midiEvent.byOnOffNote = 64;
MIDIPostArrayBuffer[5] = midiEvent;
SynthEvent.PostMIDI(gameObject, MIDIPostArrayBuffer);
}
}

在 Unity 中进行离线渲染

Unity Integration 暴露了 Wwise SDK 中的离线渲染功能并简化了音频样本的检索方式。

注意： 务必确保在启用离线渲染时仅从主线程中异步调用 AkSoundEngine.LoadBank 和 AkSoundEngine.UnloadBank API。有关详细信息，请参阅自由调度音频渲染任务章节。

AkSoundEngine.StartDeviceCapture 会设置用于捕获的特定输出音频设备，以便通过调用 AkSoundEngine.UpdateCaptureSampleCount 来确定可用样本数，并通过调用 AkSoundEngine.GetCaptureSamples 来检索音频样本数。

以下示例阐释了如何使用 Unity Integration 来结合 Unity 的屏幕捕获功能执行离线音频渲染。在实现此功能后，可轻松执行多路复用后期处理步骤，并将捕获的音频样本和视频帧合并为电影文件。

public abstract class WwiseOfflineRenderer : UnityEngine.MonoBehaviour
{
public bool IsOfflineRendering { get; set; }
public bool StartWithOfflineRenderingEnabled = false;
private bool IsCurrentlyOfflineRendering = false;
public float FrameRate = 25.0f;
protected ulong OutputDeviceId = 0;
public abstract string GetUniqueScreenshotFileName(int frameCount);
public abstract void ProcessAudioSamples(float[] buffer);
protected void Start()
{
OutputDeviceId = AkSoundEngine.GetOutputID(AkSoundEngine.AK_INVALID_UNIQUE_ID, 0);
if (StartWithOfflineRenderingEnabled)
{
IsOfflineRendering = true;
Update();
}
}
private void LogAudioFormatInfo()
{
var sampleRate = AkSoundEngine.GetSampleRate();
var channelConfig = new AkChannelConfig();
var audioSinkCapabilities = new Ak3DAudioSinkCapabilities();
AkSoundEngine.GetOutputDeviceConfiguration(OutputDeviceId, channelConfig, audioSinkCapabilities);
UnityEngine.Debug.LogFormat("Sample Rate: {0}, Channels: {1}", sampleRate, channelConfig.uNumChannels);
}
protected void Update()
{
if (IsOfflineRendering != IsCurrentlyOfflineRendering)
{
IsCurrentlyOfflineRendering = IsOfflineRendering;
if (IsOfflineRendering)
{
#if UNITY_EDITOR
// 确保 Editor 更新不会调用 AkSoundEngine.RenderAudio()。
AkSoundEngineController.Instance.DisableEditorLateUpdate();
#endif
LogAudioFormatInfo();
AkSoundEngine.ClearCaptureData();
AkSoundEngine.StartDeviceCapture(OutputDeviceId);
}
else
{
AkSoundEngine.StopDeviceCapture(OutputDeviceId);
#if UNITY_EDITOR
// 恢复 Editor 更新对 AkSoundEngine.RenderAudio() 的调用。
AkSoundEngineController.Instance.EnableEditorLateUpdate();
#endif
}
}
var frameTime = IsOfflineRendering && FrameRate != 0.0f ?1.0f / FrameRate : 0.0f;
UnityEngine.Time.captureDeltaTime = frameTime;
AkSoundEngine.SetOfflineRenderingFrameTime(frameTime);
AkSoundEngine.SetOfflineRendering(IsOfflineRendering);
if (!IsOfflineRendering)
return;
UnityEngine.ScreenCapture.CaptureScreenshot(GetUniqueScreenshotFileName(UnityEngine.Time.frameCount));
var sampleCount = AkSoundEngine.UpdateCaptureSampleCount(OutputDeviceId);
if (sampleCount <= 0)
return;
var buffer = new float[sampleCount];
var count = AkSoundEngine.GetCaptureSamples(OutputDeviceId, buffer, (uint)buffer.Length);
if (count <= 0)
return;
ProcessAudioSamples(buffer);
}
}

在 Unity 中使用 Audio Input 源插件

您可以通过 C# 脚本来调用 Audio Input 源插件。请参阅 Audio Input Source Plug-in from the Wwise SDK documentation.

以下是一个将测试音发送到 Audio Input 源插件的简单脚本：

public class MyAudioInputBehaviour : UnityEngine.MonoBehaviour
{
public AK.Wwise.Event AudioInputEvent;
public uint SampleRate = 48000;
public uint NumberOfChannels = 1;
public uint SampleIndex = 0;
public uint Frequency = 880;
private bool IsPlaying = true;
// 通过该回调填充音频采样 – 此函数会在每一帧针对各声道调用。
bool AudioSamplesDelegate(uint playingID, uint channelIndex, float[] samples)
{
for (uint i = 0; i < samples.Length; ++i)
samples[i] = UnityEngine.Mathf.Sin(Frequency * 2 * UnityEngine.Mathf.PI * (i + SampleIndex) / SampleRate);
if (channelIndex == NumberOfChannels - 1)
SampleIndex = (uint)(SampleIndex + samples.Length) % SampleRate;
// 返回 false 表示已无更多数据可提供。与此同时，会停止关联事件。
return IsPlaying;
}
// 通过该回调设置音频格式 - 在请求提供样本之前会调用此函数一次。
.
audioFormat.channelConfig.uNumChannels = NumberOfChannels;
audioFormat.uSampleRate = SampleRate;
}
private void Start()
{
// The AudioInputEvent event, that is setup within Wwise to use the Audio Input plug-in, is posted on gameObject.
// 调用 AudioFormatDelegate 一次，并在每一帧调用 AudioSamplesDelegate 一次，直到返回 false。
AkAudioInputManager.PostAudioInputEvent(AudioInputEvent, gameObject, AudioSamplesDelegate, AudioFormatDelegate);
}
// 可通过其他脚本调用此方法以停止回调
public void StopSound()
{
IsPlaying = false;
}
private void OnDestroy()
{
AudioInputEvent.Stop(gameObject);
}
}

在 Unity 中应用自定义定位

在默认情况下，会将 AkGameObj 组件关联到特定的 Unity gameObject ，并使用其变换功能（可选偏置）进行全面定位。这对很多游戏（如第一人称射击游戏）来说基本上就够了。不过，对于采用自定义镜头角度的游戏（如各种第三人称游戏）来说，假如只是简单地将音频听者关联到单个游戏对象（如 Unity 中的主镜头），定位的距离衰减和空间化这两个方面可能会不好协调。其他游戏可能还要给玩家提供别的自定义定位体验。

为此，AkGameObj 组件类允许用户重写定位。通过 GetPosition()、 GetForward() 和 GetUpward() 这三种虚方法，用户可选择继承 AkGameObj 的子类，并使用这些子类组件来灵活地自定义任意数量 Unity gameObject 的定位。

这里有一个简单的示例，展示了如何使用自定义组件来重写默认的 AkAudioListener 行为。对这个整合了 Wwise 的第三人称游戏项目，可移除现有的 AkAudioListener 及其关联的 AkGameObj 。然后，将以下脚本关联到 MainCamera 对象，并关联 AkAudioListener 。最后，指定音频听者位置所要跟随的目标 gameObject （如玩家角色）。如此一来，所有发声体的距离衰减都会将所选目标 Unity gameObject 的位置作为听者位置（画面内的距离听者），而所有发声体的朝向仍会将主镜头朝向作为听者朝向（画面外的朝向听者）。

#if !(UNITY_DASHBOARD_WIDGET || UNITY_WEBPLAYER || UNITY_WII || UNITY_WIIU || UNITY_NACL || UNITY_FLASH || UNITY_BLACKBERRY) // Disable under unsupported platforms.
//
// Copyright (c) 2017 Audiokinetic Inc. / All Rights Reserved
//
using UnityEngine;
using System;
using System.Collections.Generic;
[AddComponentMenu ("Wwise/AkGameObj3rdPersonCam")]
[ExecuteInEditMode] // 需要通过 ExecuteInEditMode 来正确维护 isStaticObject 的状态。
public class AkGameObj3rdPersonCam : AkGameObj
{
public Transform target; // 指定此镜头所要跟随的位置。用户可在 Inspector 中将其指定为玩家角色的 Unity gameObject。
// 将镜头位置设为玩家位置，据此处理距离衰减。
public override Vector3 GetPosition ()
{
return target.GetComponent<AkGameObj> ().GetPosition ();
}
}
#endif // #if !(UNITY_DASHBOARD_WIDGET || UNITY_WEBPLAYER || UNITY_WII || UNITY_WIIU || UNITY_NACL || UNITY_FLASH || UNITY_BLACKBERRY) // Disable under unsupported platforms.
AK
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AkGameObj
This component represents a sound object in your scene tracking its position and other game syncs suc...
Definition: AkGameObj.cs:32
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AkGameObj.GetPosition
virtual UnityEngine.Vector3 GetPosition()
Definition: AkGameObj.cs:221


Wwise Unity Integration Documentation: Wwise Timeline Integration

Wwise Timeline Integration

Timeline 是 Unity 的一款过场动画内容编辑工具。它可以用来创建游戏序列、音频序列和其他过场动画内容。

有关 Timeline 的详细信息，请参阅 Unity 的 Timeline 文档。

有关如何创建 Timeline Asset 和 Timeline instance 的说明，请参阅 Timeline 用法。

备注： 自 Unity 2019.3 起，将通过 Unity Package Manager 提供 Timeline 数据包。若想卸载 Timeline 数据包，请确保将 AK_DISABLE_TIMELINE Scripting Define Symbol 添加到所有平台的 Player Settings。

Wwise Timeline Track

Wwise Unity Integration 添加了两个新的 Timeline Track（AkTimelineEventTrack 和 AkTimelineRtpcTrack ），并弃用了原有的两个 Timeline Track（AkEventTrack 和 AkRTPCTrack ）。

AkTimelineEventTrack 用于发送 Wwise Event，AkTimelineRtpcTrack 则用于设置 Game Parameter 值。两种类型的 Track 都可通过使用 Add 下拉按钮或右键单击 Timeline 窗口的 Track 标题分区添加到 Timeline。

Adding AK tracks to Timeline
备注： AkEventTrack 和 AkRTPCTrack 及关联的 Playable Clip 只是为了方便向下兼容，并不建议继续使用。
弃用的 AkEventTrack

Ak Track 对象绑定

AkTimelineEventTrack 和 AkTimelineRtpcTrack 包含对象绑定，可设为任意 Game Object。在显式设置时，Track 绑定会指定目标 Game Object。若未对 Track 绑定进行设置（设为 None），则 Track 将指向 Timeline 所属的 Game Object（即该 Game Object 包含 PlayableDirector 组件，可用于触发 Timeline）。这时，Event 的发送及 RTPC 的修改将以此 GameObject 为目标。

备注： 为了减少运行时的分配次数，请确保将 AkGameObj 添加到所有要发送 Event 或修改 RTPC 的 GameObject 。

Wwise Timeline Playable Clip

AkTimelineEventTrack 和 AkTimelineRtpcTrack 分别存在相应的 Clip：AkTimelineEventPlayable 和 AkTimelineRtpcPlayable 。您可以使用 Track 的菜单或通过右键单击 Track 来将这些 Clip 添加到 Track 中。

Adding AK clips to AK tracks

Timeline Clip 属性

Timeline 中的所有 Clip 都有计时属性，显示在检视器的顶部分区中。有关这些属性的详细信息，请参阅 Clip 属性。

AkTimelineEventPlayable Clip 属性

您可以在 AkTimelineEventPlayable Clip 对应的检视器中访问以下属性：

AkTimelineEventPlayable Clip 属性
  • Event：要通过此 Clip 触发的 Wwise Event。
  • Blend In Curve：在发送 Event 时使用的 AkCurveInterpolation 值。此值仅在 Clip 的 Ease In Duration 大于零时生效。
  • Blend Out Curve：在停止 Event 时使用的 AkCurveInterpolation 值。此值仅在 Clip 的 Ease Out Duration 大于零时生效。
  • Use Wwise Event Duration：若选中此项，则 Event 将在其完全结束之前保持触发状态，而不会由 API 调用以显式方式停止，并且以下两个参数将不可用。
  • Stop Event At End Of Clip：若选中此项，则 Event 将在 Clip 结束时停止。也就是说，会针对将要生效的 Blend Out Curve 适时调用 stop API 函数。若取消选中此项，则 Blend Out Curve 不生效，Event 会一直播放到其正常结束。
  • Loop：若选中此项且 Clip 的时长大于 Event 的时长，则 Event 会在每次完成播放并即将到达 Clip 结尾之前重新触发，直到 Clip 结束。

AkTimelineRtpcPlayable Clip 属性

您可以在 AkTimelineRtpcPlayable Clip 对应的检视器中访问以下属性：

AkTimelineRtpcPlayable Clip 属性
  • RTPC：要在与此 Track 关联的 GameObject 上设置的 Wwise Game Parameter。
  • Set Globally：若选中此项，则针对所有对象统一设置 RTPC。
  • Animated Value: Value：由此 Clip 驱动的值。

AkTimelineRtpcPlayable Clip 曲线

在开始驱动发送到 Track 目标的 RTPC 值之前，需要执行以下步骤：

  1. 适时创建适当时长的 Clip。
  2. 对用于录制的 Track 进行预备。
  3. 将 Timeline 播放光标放在 Clip 区段内。
  4. 在 Clip 对应的检视器中，右键单击 Value 来打开上下文菜单，以便添加、移除或修改键值。
  5. 在添加第一个键值之后，双击 Clip 来打开 Animation 窗口，以便更加精细地编辑曲线及其键值。
备注： 有关如何在 Timeline 中修改动画曲线的详细信息，请参阅 Recording basic animation with an Infinite clip。
为录制做预备并显示曲线按钮
AkTimelineRtpcPlayable 做了录制预备并显示了曲线

已知问题和限制

目前在 Unity Editor 中支持在 Edit 和 Play 模式下拖动播放。不过，在程序集重载当间无法进行播放。

Wwise 工程设置

为了确保在 AkTimelineEventTrack 中正确表示 Event 长度，需要对 Wwise 工程进行相应设置，以便估算音频 Event 的时长。同时，还必须生成 XML 元数据。若要启用这些工程全局设置，请转到 Project Settings 的 SoundBanks 选项卡。在 Metadata Options 分组框内选中 Estimated duration 复选框，并在 SoundBank Settings 分组框内选中 Generate XML Metadata 复选框（如下所示）。

AkTimelineEventTrack 所需的 Project Settings 配置


Wwise Unity Integration Documentation: 为目标平台构建您的 Unity 游戏

为目标平台构建您的 Unity 游戏

现在，使用 Unity 的标准管线或构建脚本的话，为目标平台构建 Unity 游戏就像构建应用程序一样简单。您可以在 Edit > Project Settings > Wwise Editor 中启用/禁用 SoundBank 生成、复制和删除的前后构建步骤。

Wwise 插件部署

Unity 构建系统会自动将 Wwise 插件打包到游戏中。默认情况下，使用插件的 Profile 配置。这是游戏开发最实用的配置，因为它允许您将 Wwise 与您的游戏连接起来进行分析。但是，当您准备发布游戏时，请前往 Assets > Wwise > Activate Plugins 菜单，将 Wwise 插件配置更改为 Release 选项。

备注： Debug 只用于调试与声音引擎有关的特定问题，并且通常是在 Audiokinetic 客户支持的帮助下完成的。
参见
  • 有关平台的特定信息

StreamingAssets 文件夹

Unity 一般会在 Unity 工程的 Assets 文件夹中创建一个 StreamingAssets 文件夹，（如果在您的 Unity 工程中不存在此文件夹，那么就手动创建一个），如下所示：<UNITY_PROJECT_ROOT>\Assets\StreamingAssets。Unity 自动将这个文件夹的内容部署到目标装置上。详情请参阅 Unity 的 StreamingAssets 功能。

默认的 SoundBanks 路径，Audio\GeneratedSoundBanks，可以在 StreamingAssets 文件夹中找到。在这条路径的最后，Unity 为当前平台添加一个文件夹，这是由于它是在您 Wwise 工程的 Platform Manager 中命名的。因此，最终的完整路径为 <UNITY_PROJECT_ROOT>\Assets\StreamingAssets\Audio\GeneratedSoundBanks\<平台名>。

在必要时，可在 Common User Settings 中修改 Base Path。

当在 Unity 编辑器中运行时，SoundBanks 的路径总是设置为指向 Wwise 工程的 GeneratedSoundBank 路径，该路径是在 Wwise 的 Project Settings 对话框中定义的。这样一来，当在 Windows 或 Mac 上集成声音时，就可以避免 bank 部署问题。

在单平台工程中部署 SoundBanks

如果您在开发面向单一平台的游戏，就不用手动将生成好的 SoundBank 文件移动到 StreamingAssets 文件夹中，而是可以在 Wwise 工程中将 SoundBank 的输出路径设置为 StreamingAssets 文件夹 下的文件夹，这样 SoundBank 可以直接生成在需要的位置。使用此方法时，一定要在 Wwise Settings 窗口中禁用与生成和复制 SoundBank 相关的预构建步骤。

在多平台工程中部署 SoundBank

对于在多个平台上发布的产品，预构建步骤可以生成 SoundBank，并在构建二进制文件之前将它们复制到 StreamingAssets 文件夹中，然后在构建后的步骤中删除 SoundBank，以确保只部署目标平台的 SoundBank。

具体的实现方式应该由游戏开发者决定，以适应对复杂管理的潜在需求。

为参考平台处理多个自定义平台

如果在您的 Wwise 工程中，您已经定义了同一个参考平台的多个版本，比如针对 iOS 的 iPad 和 iPhone 平台，那么还需要更多的脚本。请参阅 在 Unity 中使用 Wwise 自定义平台 以了解更多信息。

排除 SoundBank 元数据

Wwise 会生成各种 SoundBank 元数据文件（如 TXT 和 XML）。这些文件始终命名为 SoundbanksInfo 。它们包含关于其它管线工具使用的 SoundBank 的信息，但是这些信息对于游戏来说是无用的。没有必要将它们复制到最终的 StreamingAssets 文件夹中。


Wwise Unity Integration Documentation: 用 Wwise 和 Unity 制作 DLC

用 Wwise 和 Unity 制作 DLC

使用 Wwise 文件包（File Package）

使用 Wwise 支持 DLC 的默认方法是使用文件包。 Authoring 文档中对该方法有部分解释：Wwise Help > 完善工程 > 管理 File Package > 可下载内容（DLC）概述。简单来说，这些包可以包含替换的 BNK 和 WEM 或者附加文件，它们可以随意加载和卸载来启用或禁用 DLC。这个包的格式是可选的，但是它现在内置在 Wwise / Unity 插件中。如果您想编写自己的包格式，则需要编写新的 Low-Level IO 来替换默认的。

要在 Unity 中使用包，您只需将它们放置在 Base Path 中，即您 bank 的所在路径，该路径是在 AkInitializer 的属性中定义的。然后调用 AkSoundEngine.LoadFilePackage()。Wwise 将始终尝试先通过文件包加载文件，加载的顺序是以相反的顺序（最后添加的是第一个搜索到的）。

该方法将适用于在游戏发布之后，所有支持向磁盘写入 Base Path 的平台。遗憾的是，iOS 和 Android 不满足这个条件。

在 Android 和 iOS 上，由于所有数据都被打包到一个只读文件系统，所以需要将您的文件包放在另一个不同的目录中。这是通过在 AkSoundEngine.LoadFilePackage() 之前调用 AkSoundEngine.AddBasePath() 来完成的。您可以添加多条路径，最后添加的将首先搜索。请查看恰当的操作系统文档，以找出有哪些限制。下面的代码是一则例程，用于选择可存储您文件的路径：

#if UNITY_IPHONE
string fileNameBase = Application.dataPath.Substring(0, Application.dataPath.LastIndexOf('/'));
fileName = fileNameBase.Substring(0, fileNameBase.LastIndexOf('/')) + "/Documents/" + FILE_NAME;
#elif UNITY_ANDROID
fileName = Application.persistentDataPath + "/" + FILE_NAME ;
#else
fileName = Application.dataPath + "/" + FILE_NAME;
#endif

注意，在 Android 上还有其它一些可写的路径，比如 SD 卡或类似的存储设备。

使用 Addressables 系统

Unity Addressables 系统可用于打包和分发 SoundBank 及流播放媒体文件。 有关详细信息，请参阅 在 Unity 中使用 Wwise Addressables Package 页面。

利用 UnityWebRequest 以流媒体形式加载 SoundBank

除此之外，还可利用 Unity 中的 UnityWebRequest 类来直接获取并加载 DLC 音频文件。 这是通过在内存中加载 bank 来完成的，就像在 AkMemBankLoader.cs 中演示的那样。 对于旧版 Unity，AkMemBankLoader 还可通过 WWW 类（现已弃用）加载 SoundBank。 若要将现有 SoundBank 替换为新的 SoundBank，必须先卸载之前的 SoundBank；否则 Wwise IO 系统无法理解相应代码，导致没法确定您是错误地重新加载了同一 SoundBank 还是想要替换它。


Wwise Unity Integration Documentation: 从源代码构建原生集成插件

从源代码构建原生集成插件

Wwise-Unity 集成是一层很薄的从 C# 调用原生 Wwise API 的调用层。它自带对所有平台的支持。大多数情况下，没有必要重新构建集成插件。但是，如果有源代码，您可能想对它自定义，以便将自定义更改集成到原生声音引擎中，或者修改与声音引擎接口的 C++ 代码。这应该交给有 C++ 知识的程序员来完成。

步骤

  1. 使用 Audiokinetic Launcher 为您希望构建的平台安装 Wwise SDK。请确保先登出并再次登录。
  2. 找到您正在使用的操作系统（ Windows 或 Mac ）的源码压缩包。在您添加 Wwise 集成时，Launcher 将源码压缩包安装在您的 Unity 工程中（压缩包后缀为_Src.zip）。
  3. 找到您希望构建的平台的源码压缩包（如果该平台与 Windows 或 Mac 不同）。
  4. 验证构建集成的先决条件。请参阅 前提条件 了解更多详情。
  5. 解压缩所有源码压缩包 到同一文件夹中。请参阅 在 Unity 工程中安装或升级集成 了解更多详情。
  6. 使用以下两种方法之一启动构建过程：使用控制台工具来构建 或者 使用 Integrated Development Environment (IDE) 来构建 。
  7. 等待构建完毕。如果构建成功，那么在 API/Runtime/Plugin 文件夹中的插件和 API 绑定将会更新，如果它们之前不存在，则将会被创建。

备注

  • 在构建过程中，您可以监控警告、错误或关键消息，方法是阅读 构建日志 中的详细日志消息。

构建集成的必要条件：

平台 | 需要的组件
所有平台
  • Unity。对于最新 Unity 版本，请参阅 Unity QA - Long Term Support。
  • 和您的目标平台兼容的 Wwise SDK。请参阅 版本说明 - Wwise Unity Integration 2022.1.2.8150.2694 。
  • 和您的目标平台兼容的平台 SDK。请参阅 Wwise SDK 帮助（Reference Materials 一节> 平台 要求）。
  • Python 3.9.x 及 Python 可执行文件夹（存放在系统可执行路径下）。
Android
  • Android SDK: 对 32 位系统，最小 API 为14，对 64 位系统，最小 API 为21。
  • Android NDK r17c.
  • Apache Ant 1.8.4.
  • Wwise SDK 的完整路径中不能包含任何空 格。
  • Unity 工程根目录的完整路径不能包含 任何空格。
  • 环境变量：
    • ANDROID_HOME 应该指向 Android SDK 根文件夹。
    • ANDROID_NDK_HOME 应该指向 Android NDK 根文件夹。
    • NDKROOT 应该指向 Android NDK 根文件夹。
    • ANT_HOME 应该指向 Apache Ant 根文件夹。
iOS
  • Xcode 11 或者以上。
  • Wwise SDK for iOS 及指向它的 WWISESDK 环境变量
Linux
  • 必备构建环境 (sudo apt-get install build-essential)
  • Wwise SDK for Linux 及指向它的 WWISESDK 环境变量
Mac
  • Xcode 11 或更高版本。
  • 针对 Mac 的 Wwise SDK 及指向它的 WWISESDK 环境变量
PS4 | Visual Studio 2017 或更高版本。
Windows | Visual Studio 2017 或更高版本。
Windows Store | Visual Studio 2017 或更高版本。
Xbox One | Visual Studio 2017 或更高版本。

如何安装源码包

解压源码包。然后，您可以使用源码包和针对安装好的目标平台 Wwise SDK 来重新构建和生成集成的内容。根据情况，您可以在 Unity 项目的 Assets 文件夹中，将 Wwise 文件夹中的解压缩内容与导入的 Unity 集成包（.unitypackage）合并在一起。但是，这样做的话，可能会在 Assets 文件夹中生成不需要的中间文件，这些文件需要手动清除。

安装好的集成包文件夹结构

  • StreamingAssets：文件夹，用于自动的 SoundBank 部署。
  • Wwise：顶层文件夹。
    • API：您的应用程序中使用的主要集成文件。
      • Runtime：C++ 到 C# 的绑定文件。这是原生 Wwise SDK 的翻译。
      • Editor：仅与 Editor 有关的 API 内容。
      • Plug-ins：含有各种配置的 Unity 插件库及其调试符号数据库。
        • Platform
          • Architecture：由多体系结构平台的体系结构所共享的文件。
            • Debug：插件二进制库的 Debug 版本。请参阅 Wwise 插件部署 了解更多详情。
            • Profile：插件二进制库的 Profile 版本。请参阅 Wwise 插件部署 了解更多详情。
            • Release：插件二进制库的 Release 版本。请参阅 Wwise 插件部署 了解更多详情。
            • DSP：Wwise 效果器和源插件。
    • MonoBehaviour：可以直接使用的 Unity 组件脚本，并可作为自定义组件的示例。
    • 文档：集成的全部用户文档。

安装好的源码包文件夹结构

  • Wwise：顶层文件夹。
    • AkSoundEngine：构建集成所需的源代码和 IDE 工程，按各个平台来组织的。
      • Common：所有平台共用的源代码和构建脚本。
      • Platform：用于目标平台的 IDE 解决方案或工程、源代码和平台特定的构建脚本。
    • Integration/Assets/Wwise/API：用于您的应用程序的主要集成文件。
      • Runtime：API 绑定的根文件夹。
        • Generated：在 SWIG 绑定步骤中生成的 API 绑定文件。
        • Handwritten：手写的 API 绑定文件。
    • MonoBehaviour：可以直接使用的出厂 Unity 组件脚本，并可作为自定义组件的示例。

使用控制台工具来构建

您可以使用构建脚本从命令行来构建集成，构建脚本可以在 Wwise\AkSoundEngine\Common\BuildWwiseUnityIntegration.py 找到。这对于持续集成很有用。如果您要查看使用和示例，假设当前的工作文件夹是脚本的父文件夹，那么请在计算机的命令控制台中输入：

python BuildWwiseUnityIntegration.py -h

使用 Integrated Development Environment (IDE) 来构建

在 Wwise Unity Integration 源码包中位于：

WwiseUnityIntegration_version_platform_Src.zip\Wwise\AkSoundEngine\YourPlatform

解决方案（或 Xcode 工程）可以让您在受支持的 IDE 中构建目标平台的集成。

用 Xcode 为 Mac 或 iOS 平台构建

当从命令行构建集成时，WWISESDK 路径会根据两个设置中的一个来自动提供给 Xcode，其中一个是环境变量 $WWISESDK 中的某个设置，另外一个是使用 -w 选项提供给构建脚本的设置。但是，在使用 Xcode IDE 时，必须手动设置 WWISESDK 路径。为此，请打开 Mac 或 iOS 平台的 Xcode 工程，在工程导航器中选择 AkSoundEngine{platform} 工程。选择 Build Settings 页。在页面的底部，显示了有着 WWISESDK 设置键的 User-Defined 区域。把 WWISESDK 的路径填到设置中，以构建集成（ex: /Users/myUser/Wwise/SDK ）。

为 Linux 平台构建

提供了通过 premake5 生成的 makefile。要从源代码中构建 Linux 插件，只需将以下命令输入到终端中：

  • cd <Integration source location>/AkSoundEngine/Linux
  • make config=<config>

其中， <config> 可以是 debug_x64、profile_x64、 或者 release_x64。所生成的插件将位于 <Integration source location>/API/Runtime/Plugins/Linux。

部署新的库

所得到的二进制文件将位于 Wwise\API\Runtime\Plugins\[Platform]。如果您还没有解压 Assets\Wwise 文件夹中的源代码，那么请将新二进制文件从该文件夹中复制到您工程的 Assets 文件夹的相应文件夹中。

底层细节

在打包用于构建集成代码的源代码之前，我们使用 SWIG 在 Wwise SDK 的 Unity 中生成 API 绑定。 大多数用户永远不需要用到 SWIG 来在 Unity 中使用 Wwise。即使是那些可以访问 Wwise for Unity 源代码的高级用户，如果想用这些源代码来构建集成代码（包含转码的 API），也不需要安装或使用 SWIG。惟二的例外是，将更改集成到声音引擎，或修改与之接口的 C++ 代码。在这些罕见的情况下，我们建议在您继续之前，先联系客户支持。

构建流程会执行以下任务：

  1. Wwise SDK 库被封装到一个单独的库作为 Unity 插件：Windows 上的动态库（.dll）、在 Mac OS X 上的可加载包（.bundle）、在 iOS 上的静态库（.a）或在 Android 上的共享库（.so）。它们将被直接构建到 Deployment 文件夹中。想了解文件夹结构，请参阅 在 Unity 工程中安装或升级集成 。
参见
  • 有关平台的特定信息
  • 构建日志
  • 当您修改了插件的 C++ 代码时，将 Wwise 集成包 更新/升级到一个较新的版本


Wwise Unity Integration Documentation: 构建日志

构建日志

警告和错误消息显示在 Unity Editor 控制台和构建日志中。构建日志文件中包含了在构建集成时发出的更详细的消息。 构建日志存储在以下位置：

UNITY_PROJECT_ROOT\Assets\Wwise\Logs\BuildWwiseUnityIntegration.log

日志消息以以下格式显示：

时间: 消息类型: 源代码文件名 (模块名): 行数: 消息正文

示例：

2013-09-26 09:29:56,490: INFO: BuildWwiseUnityIntegration.py (WindowsBuilder): 91: Building: Windows (Win32, Debug) ...

一个小时后，日志文件会累积并循环到一个新文件。您可以更改循环行为，方法是从 Wwise Unity 集成源包的下列文件中配置 BuildUtil.CreateLogger() 函数：

WwiseUnityIntegration_version_platform_Src.zip\Wwise\AkSoundEngine\Common\AkSoundEngine\Common\BuildUtil.py

想了解更多信息，请参考 Python logging.handlers 模块。

在某些平台上，IDE（例如 Visual Studio）可能生成额外的日志文件。这些额外的文件可以在同一个文件夹中找到，它们的文件名中有关键词 IDE。


Wwise Unity Integration Documentation: 当您修改了插件的 C++ 代码时，将 Wwise 集成包 更新/升级到一个较新的版本

当您修改了插件的 C++ 代码时，将 Wwise 集成包 更新/升级到一个较新的版本
警告：建议
  • Unity 迁移操作是不可逆的。在您继续之前，请确保已经备份了 Unity 工程。
  • 如果 Unity 工程有版本控制，请确保在开始迁移之前 check-out 整个 Unity 工程文件夹。否则，迁移会失败，因为它无法成功地修改文件。
  • 在安装 Wwise 集成之前，需要确保您的 Unity 工程可以成功编译。（出现警告是正常的。）

这个安装过程假定您已有了一个包含以前的 Wwise 集成包的 Unity 工程。如果想了解新安装，请参阅 第一次安装 Wwise 集成包 页面。与其它的 Unity 插件不同，您需要留下之前安装的 Wwise 集成包，以便升级到新版本。Launcher 将安装新的功能和错误修正，然后将以前的 Wwise 集成迁移到新版本。

警告： 在安装新版本之前，不要删除之前的 Wwise 集成，因为那样的话，您将 Wwise 音频集成到游戏中的所有努力就白费了。

升级过程分为 3 步。首先，您需要将 Wwise 工程更新到您希望使用的新版本，然后也要对 Unity 工程升级。

将您的 Unity 工程更新到新的 Wwise 版本

使用 Audiokinetic Launcher 将您的 Unity 项目更新到新的 Wwise 版本。

将您的 Wwise 工程更新到新版本

  1. 启动 Wwise 版本，该版本要与您打算在 Unity 中使用的新的 Wwise 集成版本相匹配。
  2. 打开 Wwise 工程。
  3. 当提示将您的 Wwise 工程更新到当前版本时，请回答 “Yes” 。
  4. 完成后，确保在更新 Unity 工程之后，重新生成 Wwise SoundBank，以便能继续您的工作。
  5. 将生成的 SoundBank 复制到 Unity 工程的 StreamingAssets 文件夹中。

更新您的 C++ 代码修改

  1. 对于所有需要的平台，在您的机器上安装更新的 Wwise SDK。
  2. 对于所有需要的平台，找到那些复制到 Unity 工程的 Unity 集成源码压缩包。
  3. 将所有下载的 Unity 集成源码压缩包解压到同一个文件夹中。
  4. 将您对 Unity 集成源码的修改合并到更新的位置。
  5. 编译已更新和合并的集成源代码。


Wwise Unity Integration Documentation: API 变化和限制

API 变化和限制

以下原生 Wwise SDK 的一些特性和函数在 Unity 集成中是不支持的，或者它们的行为在集成中已经修改过了（先列出的为最近的变化）：

  • UnloadBank() 不再使用单一参数重载版本。必须用第二个参数提供一个内存位置的指针。
  • Windows 版本的 GetGameObjectFromPlayingID() 对 Windows 32 位和 64 位（截尾）返回 32 位的 GameObject ID。
  • PostEvent() 和 GameObject 相关的 API 现在接受 null 作为 GameObject 这个输入变量来影响全局范围。
  • PostEvent() 的所有回调是序列化的，并出现在下一个游戏帧的开始，而不是从音频线程中调用。因此并不需要同步机制。
  • AK::Monitoring::SetLocalOutput() 被 AkCallbackManager.SetMonitoringCallback() 所取代。
  • AK::SoundEngine::SetPosition() 被 AkSoundEngine.SetObjectPosition() 所取代。
  • 在从磁盘加载关卡数据时，不能同时处理声音的流播放。
  • 一些 AK::SoundEngine::DynamicSequence API 函数在它们的 Unity API 绑定中重命名了，以保持清晰明确。这是一种补救措施，补偿由 SWIG 引起的名字空间扁平化这个副作用。比如，在生成的 API 中，AK::SoundEngine::DynamicSequence::Open() 会变为 AkSoundEngine.Open()。因此，我们将它在 API 绑定中重命名为 AkSoundEngine.DynamicSequenceOpen()。
  • C++ 重载的操作符被重命名为 Unity 脚本语言中的函数；比如，AkArray::operator[] 变为 AkPlaylistArray.ItemAtIndex(uint uiIndex) 。这是根据 SWIG 处理 C++ 重载操作符方面的设计来实现的。
  • 不支持的 API 和组件：
    • iOS 音频输入回调 API
    • AkSpeakerVolumeMatrixCallbackInfo
    • AkSpeakerVolumeMatrixBusCallbackInfo
    • AkBusCallbackFunc
    • AK::SoundEngine::RegisterBusVolumeCallback
    • AK::SoundEngine::RegisterCodec
    • AK::SoundEngine::RegisterGlobalCallback
    • AK::SoundEngine::RegisterPlugin
    • AK::SoundEngine::Query::AkGameObjectsList
    • AK::SoundEngine::Query::GetActiveGameObjects()
    • AK::SoundEngine::Query::GameObjDst
    • AK::SoundEngine::Query::AkRadiusList
    • AK::SoundEngine::Query::GetMaxRadius(AkRadiusList& io_RadiusList)
    • 所有接受回调或 Event 名称的 AK::SoundEngine::DynamicDialogue::ResolveDialogueEvent 的变体。
参见
  • 有关平台的特定信息.


Wwise Unity Integration Documentation: 有关平台的特定信息

有关平台的特定信息

以下页面包含有关平台的特定信息。

Windows 和 Windows Store Apps

  • 有关 Windows 的特定信息

自定义平台

  • 在 Unity 中使用 Wwise 自定义平台


Wwise Unity Integration Documentation: 有关 Windows 的特定信息

有关 Windows 的特定信息

关于 Windows Store Apps 的特殊信息

  • Universal Windows Platform 使用普通的 Windows SoundBank。这两个平台使用同样的 SoundBank 平台文件夹。
  • Wwise 无法与同一机器上运行的 Windows Store App 进行通信。
  • 若要实现 Wwise 和 App 之间的通信，必须设置 PrivateNetworkClientServer 功能。为此，可依次选择以下菜单项： Assets > Wwise > WSA > Enable PrivateNetworkClientServer Capability
参见
  • Windows 版本说明


Wwise Unity Integration Documentation: Windows 版本说明

Windows 版本说明

以下页面包含有关针对 Wwise 所作 Windows 特定改进的信息。若有 Wwise 版本未显示在以下列表中，则表示该版本中没有特定于 Windows 的改进。

Windows 和 Windows Store Apps 2021.1


Wwise Unity Integration Documentation: Windows 和 Windows Store Apps 2021.1

Windows 和 Windows Store Apps 2021.1

以下各节列举并阐述了针对 Wwise 2021.1 所作的 Windows 和 Windows Store Apps 特定改进。

  • 新增功能

新增功能

  • WG-48244 System Audio Device 现在支持通过 Microsoft Spatial Sound 来应用 3D Audio。


Wwise Unity Integration Documentation: 在 Unity 中使用 Wwise 自定义平台

在 Unity 中使用 Wwise 自定义平台

默认情况下，Wwise Unity 集成假设关联的 Wwise 工程中的定义的平台用的都是默认名称。如果您希望给平台自定义的名称或为一个基本平台定义多个自定义平台，则将需要创建一个 C# 脚本来实现此目标。

备注： 在此页面中，假设生成 SoundBank 的子文件夹与您的平台名称相同。如果名称不同，那么请注意，GetPlatformName 方法返回的字符串实际上被用作游戏中的 SoundBank 子文件夹名。

定义自定义平台

默认的平台解析脚本可以在文件 <UNITY_PROJECT_ROOT>/Assets/Wwise/API/Runtime/Handwritten/Common/AkBasePathGetter.cs 中找到。在 GetPlatformName() 方法中可以看到，所有平台的默认名称都由这个函数返回。若想使用自己命名的平台名称，则须注册 GetCustomPlatformName 委托方法。建议使用通过 RuntimeInitializeOnLoadMethod 属性调用的静态方法来注册委托。

示例

这个示例只涵盖了 iOS 平台的一个用例。在这个例子中，您希望有三个不同的自定义平台：一个是 ipod，一个是 iphone，一个是 ipad。

  1. 首先，在 Wwise 工程中，您将在 Platform Manager（平台管理器）中添加三个不同的平台："iPod"、"iPhone" 和 "iPad"。（关于 Wwise 的 Platform Manager 的更多信息，请参见 Wwise Help > 设置工程 > 管理多平台 一节）。
  2. 然后，在 Unity 中创建用来注册 GetCustomPlatformName 委托的 C# 脚本。该文件的内容应类似于：
    public partial class MyCustomBasePathGetter
    {
    [UnityEngine.RuntimeInitializeOnLoadMethod(UnityEngine.RuntimeInitializeLoadType.BeforeSceneLoad)]
    static void RegisterCustomPlatformName()
    {
    AkBasePathGetter.GetCustomPlatformName = GetCustomPlatformName;
    }
    static partial void GetCustomPlatformName(ref string platformName)
    {
    #if UNTIY_IOS
    switch(UnityEngine.iOS.Device.generation)
    {
    case UnityEngine.iOS.DeviceGeneration.iPodTouch1Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch2Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch3Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch4Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouch5Gen:
    case UnityEngine.iOS.DeviceGeneration.iPodTouchUnknown:
    platformName = "iPod";
    break;
    case UnityEngine.iOS.DeviceGeneration.iPad1Gen:
    case UnityEngine.iOS.DeviceGeneration.iPad2Gen:
    case UnityEngine.iOS.DeviceGeneration.iPad3Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadMini1Gen:
    case UnityEngine.iOS.DeviceGeneration.iPad4Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadAir1:
    case UnityEngine.iOS.DeviceGeneration.iPadMini2Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadMini3Gen:
    case UnityEngine.iOS.DeviceGeneration.iPadAir2:
    case UnityEngine.iOS.DeviceGeneration.iPadUnknown:
    platformName = "iPad";
    break;
    case UnityEngine.iOS.DeviceGeneration.iPhone:
    case UnityEngine.iOS.DeviceGeneration.iPhone3G:
    case UnityEngine.iOS.DeviceGeneration.iPhone3GS:
    case UnityEngine.iOS.DeviceGeneration.iPhone4:
    case UnityEngine.iOS.DeviceGeneration.iPhone4S:
    case UnityEngine.iOS.DeviceGeneration.iPhone5:
    case UnityEngine.iOS.DeviceGeneration.iPhone5C:
    case UnityEngine.iOS.DeviceGeneration.iPhone5S:
    case UnityEngine.iOS.DeviceGeneration.iPhone6:
    case UnityEngine.iOS.DeviceGeneration.iPhone6Plus:
    case UnityEngine.iOS.DeviceGeneration.iPhoneUnknown:
    default:
    platformName = "iPhone";
    break;
    }
    #endif
    }
    }
    备注： 如果 platformName 未修改，则当前激活状态的 Unity 平台将使用默认平台名称。
  3. 或者，（a）创建一个 C::，它将扩展 AkBuildPreprocessor，或（b）创建一个 C::，它将使用 AkBuildPreprocessor 内的功能。该文件的内容可以类似于：
    public class WwiseIOSBuildPreprocessor : IPreprocessBuild, IPostprocessBuild
    {
    public int callbackOrder { get { return 0; } }
    string iPodDestinationSoundBankFolder = string.Empty;
    string iPadDestinationSoundBankFolder = string.Empty;
    string iPhoneDestinationSoundBankFolder = string.Empty;
    public void OnPreprocessBuild(BuildTarget target, string path)
    {
    if (target == BuildTarget.iOS)
    {
    AkBuildPreprocessor.CopySoundbanks(true, "iPod", iPodDestinationSoundBankFolder);
    AkBuildPreprocessor.CopySoundbanks(true, "iPad", iPadDestinationSoundBankFolder);
    AkBuildPreprocessor.CopySoundbanks(true, "iPhone", iPhoneDestinationSoundBankFolder);
    }
    }
    public void OnPostprocessBuild(BuildTarget target, string path)
    {
    DeleteSoundbanks(iPodDestinationSoundBankFolder);
    DeleteSoundbanks(iPadDestinationSoundBankFolder);
    DeleteSoundbanks(iPhoneDestinationSoundBankFolder);
    }
    }
  4. 或者在 Wwise 中，为全部三个平台 "iPhone"、"iPod" 和 "iPad" 生成 SoundBank，将生成的三个文件夹复制到 UNITY_PROJECT_ROOT/Assets/StreamingAssets/Audio/GeneratedSoundBanks 中。
  5. 在 Unity 中，为 iOS 平台构建您的游戏。
  6. 从现在开始，根据使用的设备类型，将使用不同的 SoundBank 集合。


Wwise Unity Integration Documentation: Demo Game

Demo Game

包含 Wwise Unity 集成的一个演示场景，可以从 Audiokinetic Launcher 的 UNITY 页面下载，具体是在 "Recent Unity Projects" 标题下的上下文菜单下面。这个简单的场景是全部使用 Unity 的标准素材创建的，它演示了如何使用集成的一些基本功能。

安装

Wwise Demo Game 是一个独立的工程。它可以在 Audiokinetic Launcher 中下载。您的游戏不能用它作为基础。为此，使用 Audiokinetic Launcher 将 Wwise 集成到一个新的 Unity 工程中。

备注：
  • 文件包中包含生成的 SoundBank。
  • 您可以在 <DEMO_SCENE_ROOT>/WwiseProject 下找到与场景关联的 Wwise Project。不建议将这个 Wwise 工程放在游戏的 Assets 文件夹中，但在这个演示中，为了打包目的，这样做是必要的。

部署

Wwise Demo Game 的目的在于展示如何在 Unity Editor 中使用 Wwise Unity Integration。

若要将其中一个 Wwise Demo Game 场景部署到游戏主机或移动设备，请执行以下步骤：

  1. 在 Launcher 的 Unity 选项卡中，在 Wwise Demo Game Unity Project 下选择 Modify Wwise in Project... 选项。
    1. Launcher 的 Unity 集成页面打开了。
  2. 添加所需的 Deployment Platforms 并单击 Modify。
  3. 在 Unity 中打开工程的最新版本。
  4. 为平台生成 SoundBank。
  5. 将 Generated SoundBanks 文件夹复制到 StreamingAssets/Audio 文件夹。
  6. 在 Unity 中，为您想要的平台构建场景然后部署到设备上。

Unity Demo Game 包含两项教程：

  • Wwise 演示场景
  • 在 Unity 中使用 Spatial Audio


Wwise Unity Integration Documentation: Wwise 演示场景

Wwise 演示场景

这个 First-Person 3D 地图包含一些沿着一条道路的"站点"。对于每一站点，旁边的指示牌上都显示有简短说明。为了便于引用，各个站点的素材都嵌套在场景层级结构中。

脚步演示

步道和第一站演示了如何使用脚本和触发器来创建脚步系统。

在 Wwise 工程中，已经按照推荐的方式实现了脚步：每个表面类型的 Random container，嵌套在一个 Switch Container 下。您可以利用 Footstep 事件来触发脚步声，并通过 "Footstep_material" Switch Group 控制地表材质。

场景的地形被描绘成四种不同的材质：草、砂石、木头和泥土。在不同的表面上行走会相应地改变脚步的声音。

为了实现这一目标，各个区域都放置了 Box Collider。然后，只需简单地将一个 Switch Value 从 Wwise Picker Window 拖动到一个 Box Collider 上，就设置好了 Footstep_Material 切换开关。为了在 First Person Controller 进入碰撞体时在其上设置切换开关，我们需要在 "AkTriggerEnter" 触发器上触发 Ak Switch 脚本，并确保启用了 "Use Other Object" 复选框（如 Inspector Window 中所示）。

一个非常基本的脚步脚本就实现好了，当玩家走动时，它会每隔 0.3 秒发布一个Footstep 事件。这个脚本已经附加到 First Person Controller 了。以上过程展示了一种通过脚本将事件发布到 Wwise SoundEngine 的方法。

字幕演示

接下来将用这个站点演示如何在 Unity 中创建自定义事件触发器，以及使用事件回调。

一个简单的按钮脚本包含一个指令，当玩家离按钮足够近的时候按下键盘或控制器上的键，该指令就会运行。另一个脚本，AkTriggerButtonPress，会在该指令上注册，然后从它的父类 AkTriggerBase 调用 triggerDelegate。从 AkTriggerBase 继承，可以使自定义触发器在 Wwise Component Inspector 窗口中显示在 "触发器” 列表上（例如，附加在按钮上的 Ak Ambient）。有关自定义触发器的更多信息，请参见 为 Wwise Events 添加新的 Trigger。 。

事件开始播放一个包含 WAV marker 的声音文件。注册与事件关联的 marker 回调，可以使得字幕在面板上更新显示。为了实现这一点，在 Ak Ambient 的 inspector 中，勾选了 "Use Callback" 选项。然后，该 GameObject （SubtitleSign）包含一个脚本（SubtitleDemo.cs），整个被拖放到了 "Game Object" 框中。当回调被触发时会执行 Callback Function（MarkerCallback），它的名称是手动输入的，且 Callback Flag 选为 "Marker"。查看 SubtitleDemo 的代码，可以看到 Callback 函数的实现很简单，就是使用 MarkerCallback 的 uIdentifier 字段作为索引，从预定义的字符串数组中读取字幕。参见 在 Inspector 中使用 AkAmbient 以获取更多关于回调的信息。

环境演示

该站点演示了如何对场景的一个区域内所有声音施加效果器。两个洞穴包含一个 EnvironmentZone（同样是用 Box Collider 作为触发器），在这个环境上添加了一条 AuxBus（从 Wwise Picker 窗口中拖放）。

在 Wwise 中，已经创建了两条 Auxiliary Bus，分别包含不同的效果。此外，脚步和 Little Sequence 都选中了 "Use game-defined Auxiliary sends"。

当一个 Wwise 事件从 EnvironmentZone 中发出时，它的声音会连通到该区域关联的 AuxBus。

本站点还演示了 Environment Portal 组件。它可以实现在两个环境之间进行空间过渡。本演示中的三个按钮用于说明 Environment Portal 如何影响 Auxiliary Bus 的混合。

要创建一个环境门户，首先创建一个 Box Collider，它在它的一个轴上连接两个 Ak Environment（在这个演示中，门户会接触到 "z" 轴上的红色区域和蓝色区域）。然后添加 Ak Environment Portal 组件，并选择正确的轴。这两个环境将被混合，并被自动填充。

想了解有关 Environments 和 Environment Portal 的更多信息，请参阅 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone) 。

Timeline Demo

此站点演示了如何在 Unity 中的 Timeline 内使用 AkEventTrack 和 AkRTPCTrack。在按下按钮后，会有两个 Cube 相向移动直到相撞。

若要查看 Timeline，请依次选择 Window > Timeline。接着，在 Hierarchy 中依次展开 TimelineDemo 和 Timeline Demo Button 对象。然后，选择 Button 对象。此时，Timeline 编辑器将显示相应的 Timeline，用于控制这两个 Cube 的动画和 Wwise Event。该 Timeline 由 Button 对象的 Playable Director 组件控制。

Timeline 中包含两个 Animation Track，每个 Cube 对应一个。这两个 Track 用于模拟 Cube 的 z 轴位置随时间的变化。另外，Timeline 还包含 AkEventTrack 和 AkRTPCTrack，两者分别显示有白色和红色旗标。AkEventTrack 包含两个 AkEventPlayable Clip：第一个用于触发 PlayCubeMovement Wwise Event，第二个用于触发 PlayImpact Wwise Event。这些 Wwise Event 的名称会显示在 Clip 中。为了正确显示名称，可能需要增大 Timeline 编辑器视图的大小，并放大显示窗口内容。PlayCubeMovement Wwise Event 会播放正弦波音频源，其音高受 RTPC 影响。此 RTPC 的名称为 CubeAcceleration。在两个 Cube 相向移动时，AkRTPCTrack 会逐渐增大此 RTPC。此时，正弦波的音高会逐渐升高，这个简单的声音效果用来表现两个 Cube 的加速移动。

另外，此站点还演示了 Motion 功能。注意，在玩家层级结构中有一个名为 Motion listener 游戏对象。此游戏对象用于设置所支持平台上 Motion 设备的输出。所有输出都需要一组听者来接收数据。因此，Motion listener 同时具有 Ak Game Object 和 Ak Audio Listener。若要在 Cube 相撞时生成 Motion 效果，必须完成下述两项操作。第一，需要在 Wwise 工程中使用 Wwise Motion ShareSet 将撞击声发送到输出总线。第二，需要将 Motion 输出的听者添加到发送撞击事件发声体的听者。如需了解如何添加输出，请查看 AkMotionListener 脚本。

备注： 为了在 Android 上支持 Motion 功能，应用程序清单必须包含振动权限。Unity 会根据应用程序的内容自动生成清单。通过添加 Handheld.Vibrate() 调用，可在清单中添加所需权限。

有关 Timeline Integration 的详细信息，请参阅 Wwise Timeline Integration 。


Wwise Unity Integration Documentation: 在 Unity 中使用 Spatial Audio

在 Unity 中使用 Spatial Audio

本章将概括阐述如何使用 Unity Integration 的 Spatial Audio 功能。内容分为以下几个部分：

  • 准备页面 – 在开始学习教程前，需做好相应的准备：
    • Spatial Audio 教程准备工作
  • 两个独立的教程：
    • Surface Reflector 教程
    • Room 和 Portal 教程
  • 补充页面 – 其他 Spatial Audio 功能的说明：
    • Spatial Audio 附加功能
    • Obstruction 和 Occlusion
备注： 在完成章节的过程中使用 Wwise Reflect 插件时，需要获取相应的授权。
参见
  • Spatial Audio 组件
  • Spatial Audio SDK 文档


Wwise Unity Integration Documentation: Spatial Audio 教程准备工作

Spatial Audio 教程准备工作

为了成功完成 Spatial Audio 教程，请务必执行以下步骤：

  • 1. 创建 Unity 工程
  • 2. Wwise 工程准备工作
  • 3. Unity 工程准备工作
  • 4. 验证设置
备注： 假如您不想从头开始新建工程，可直接通过 Audiokinetic Launcher 下载 Demo Game Unity Demo Game 。它包含有 SpatialAudioTutorial 场景，并涵盖了教程中阐述的所有步骤。

1. 创建 Unity 工程

安装最新版本的 Wwise 和 Unity，并按照以下步骤构建工作环境。

  1. 启动 Unity 并创建一个新的工程。
  2. 关闭 Unity。
  3. Start the Audiokinetic Launcher and integrate Wwise into your Unity project.

2. Wwise 工程准备工作

对于所述教程，您需要添加 Sound SFX，然后创建用于播放的 Event，并生成 SoundBank。

  1. 启动 Launcher，并选择在 Wwise 中打开工程。
  2. 在 Actor Mixer Hierarchy 的 Default Work Unit 下添加 Sound SFX。
    1. 为其导入声音。
    2. 打开 Sound Property Editor：
      1. 在 General Settings 选项卡中，选中 Use game-defined auxiliary sends。

        Sound Property Editor General Settings tab
      2. 在 Positioning 选项卡中，选中 Listener Relative Routing，并将 3D Spatialization 设为 Position + Orientation。添加 Attenuation 并合理设置 Max Distance。

        Sound Property Editor Positioning tab
  3. 右键单击 Actor-Mixer Hierarchy 中的 Sound SFX，然后依次选择 New Event > Play 。

    Event Editor
  4. 转到 SoundBank 布局（快捷键 F7），并添加新的 SoundBank。将 Event 拖入新的 SoundBank。
  5. 保存工程。

3. Unity 工程准备工作

在本节中，我们将创建游戏区域及其中的对象。我们需要设置听者、发声体和两个房间。

首先，启动 Launcher 并选择在 Unity 中打开工程。然后，打开 Wwise Picker (Windows > Wwise Picker)，点击 Refresh Project，然后选择 Generate SoundBanks。

Wwise Picker
  1. 根据需要自行创建一个角色。
    1. 移除所有 Unity Audio Source。
    2. 将 AkSpatialAudioListener 组件添加到用作听者的 GameObject。
      AkSpatialAudioListener 组件
    3. 在添加 AkSpatialAudioListener 组件后，会自动创建 AkAudioListener、AkRoomAwareObject 和 AkGameObj 组件。
      AkAudioListener 组件
      AkGameObj 组件
      AkRoomAwareObject 组件
      1. 在 AkGameObj 组件中：
        1. 取消选中 Environment Aware 复选框。
        2. 选中 Use Default Listener 选项。
      2. 在 AkRoomAwareObject 组件中，最多可能会看到两条警告消息。因为尚未使用 AkRoom 组件，所以现在先不用理会。我们可以等到学习 Room 和 Portal 教程 时再来处理。倘若根本不打算在游戏中使用 AkRoom 组件，直接禁用即可。
  2. 根据需要灵活地创建地面、由两个房间组成的建筑以及外部障碍物。
    在 SpatialAudioTutorial 场景中，我们为建筑使用了 Mesh，并为地面和障碍物使用了 Cube ( GameObject > 3D Object > Cube )。

    SpatialAudioTutorial Scene
  3. 根据需要灵活地创建发声体。在 Wwise Unity Demo Scene 中，我们使用 Cylinder 创建了 Button ( GameObject > 3D Object > Cylinder )。然后，分别在每个房间的外部和内部添加了一个 Button。

    针对每个发声体：
    1. 添加 AkAmbient 组件：
      1. 在 Trigger On 中选择所需声音触发方式。
      2. 在 Name 中选择 Event。
        AkAmbient 组件
    2. 在 AkGameObj 组件中（该组件在添加 AkAmbient 组件后由系统自动添加）：
      1. 选中 Use Default Listener 选项。
        AkGameObj 组件
    3. 添加 AkBank 组件：
      1. 将上一节中创建的 SoundBank 添加到 Name。
        AkBank 组件

4. 验证设置

  1. 启动游戏并连接到 Wwise，然后执行以下步骤：
    1. 打开 Profiler 布局（快捷键 F6）。
      1. 播放 Button 声音。此时，应会听到 Wwise 工程中导入的声音。
      2. 在 Voices Graph 选项卡中，应会看到以下声部图：
        Button Outside Voice Graph with no Effect
      3. 在 Profiler Settings 中（可通过 Advanced Profiler 视图右上角的齿轮图标打开），确保选中 Spatial Audio 以便在 Game Object 3D Viewer 中查看 Spatial Audio 图像显示（下一步）。
        Profiler Settings
    2. 打开 Game Object Profiler 布局（快捷键 F12）
      1. 在 Game Object 3D Viewer 中，应可看到相应的游戏对象。注意，查看器中不会显示尚未发声的游戏对象。
        Game Object 3D Viewer
  2. 将场景保存到合适位置。


Wwise Unity Integration Documentation: Surface Reflector 教程

Surface Reflector 教程

本教程以下步骤将展示如何在 Unity 中结合 Spatial Audio 使用 Reflect 插件。您需要获取 Reflect 插件授权才能生成 SoundBank，不过仍可在连接到 Wwise 设计工具时试用该插件。

  • A. Wwise Project（工程）
  • B. Unity 工程
  • C. 验证设置
备注： 本教程假定您已完成 Spatial Audio 教程准备工作 。

A. Wwise Project（工程）

我们需要在 Wwise 工程中添加 Auxiliary Bus 并为其应用 Reflect 插件，另外还要导入 Acoustic Texture。

  1. 导入出厂素材来访问 Auxiliary Bus 预设和出厂 Acoustic Texture。
    1. 依次转到 Project > Import Factory Assets...。
    2. 选中 Reflect 和 Acoustic Textures 并按下 OK。
  2. Acoustic Texture 位于 Project Explorer 视图内 ShareSets 选项卡中的 Virtual Acoustics 文件夹中。
    Factory Reflect Acoustic Textures in the Project Explorer ShareSets tab
    1. (可选) 在 Default Work Unit 下的 Virtual Acoustics 文件夹中，可添加自定义 Acoustic Texture。
  3. 添加用于早期反射的 Auxiliary Bus。
    1. 右键单击 Master Audio Bus，然后依次转到 New Child > Presets，并选择 Early Reflection Auxiliary Bus。
  4. 修改 Spatial Audio 教程准备工作 中添加的 Sound SFX
    1. 在 General Settings 选项卡中，在 Early Reflections 方框内添加刚才创建并应用了 Reflect 的 Auxiliary Bus。
      在 Sound Property Editor 的 General Settings 选项卡中指定 Reflect Auxiliary Bus
  5. 保存工程。

B. Unity 工程

您可以使用 AkSurfaceReflector 组件来模拟早期反射。比如，您可以将 Surface Reflector 组件添加到游戏的现有 Mesh。不过，若形状过于复杂，则会向 Spatial Audio API 发送太多三角形，进而拖慢游戏运行速度。在这种情况下，可在 AkSurfaceReflector 组件本身中添加不同的 Mesh（如 Collision Mesh）。另外，您还可以通过创建新的 GameObject 来添加反射表面。在 Wwise Unity Demo Scene 提供的场景中，Surface Reflector 使用了新的对象。因为 Room 是 Cube 形状的，所以我们使用了不带 Mesh 渲染器的 Cube。

  1. 创建 Cube：GameObject > 3D Object > Cube
    1. 移除 Mesh Renderer 组件。
    2. 在 Box Collider 组件中选中 Is Trigger。
    3. 添加 AkSurfaceReflector 组件。
      1. 若要使用 MeshFilter 组件中的 Mesh，则 Mesh 参数可保留为 None。若不使用，则可在此添加想要的 Mesh。
      2. 在 Acoustic Textures 数组中，针对每个 Submesh 选择声学材质（Cube 只有一个 Submesh），或保留为 None 以便获得未经滤波的反射声。
      3. 在 Transmission Loss Values 数组中，可为每个 Submesh 的表面设置透射损失值。这些值将被用于对穿过 Mesh 的声音进行滤波。有关更多详细信息，请参阅 D. 透射 章节。
      4. 您可以使用 Enable Diffraction 复选框来启用衍射。有关更多详细信息，请参阅 C. 衍射 章节。
      5. 最后，还可设置关联的 Room（可暂时保留为 None）。有关更多详细信息，请参阅 E. 将 Room 与 Surface Reflector 关联（优化） 章节。
        AkSurfaceReflector 组件
  2. 在 AkWwiseInitializationSettings 的 Spatial Audio Settings 下设置反射阶数。
    1. Reflection Order 默认设为 1。最高可设为 4。
      Spatial Audio Init Settings
  3. 若要查看场景中绘制的反射路径，请将 AkSpatialAudioDebugDraw 组件添加到发声体。
    1. 勾选所要绘制的反射阶数。
      AkSpatialAudioDebugDraw 组件

C. 验证设置

  1. 在 Wwise Picker (Windows > Wwise Picker) 中：
    1. 生成 SoundBank
      Wwise Picker
  2. 启动游戏并播放其中一个发声体。
    1. 在 Wwise 中连接游戏，并转到 Profiler 布局。Voice Graph 应如下图所示：
      Voice Graph 中显示 Reflect Effect
    2. 在 Voice Graph 中的 Auxiliary Bus 节点下，双击高亮显示的 Wwise Reflect，打开 Reflect Effect Editor。在播放声音时，应会在 Voice Graph 和列表中看到当前的反射声。在 Texture(s) 列下显示两种材质时，表示其为二阶反射。
      1. 在此，可修改这些反射的衰减曲线。
      2. 若未看到任何反射，请确保 Max Distance 与发声体和听者之间的反射距离相比足够大。
        Reflect Effect Editor View
    3. 转到 Game Object Profiler 布局（快捷键 F12）
      1. 确保在 Game Object 3D Viewer Settings 中启用 Diffraction Paths 和 Reflection Image Sources（如尚未启用）。
        在 Game Object 3D Viewer Settings 中配置 Reflect
      2. 在 Game Object 3D Viewer 中，应会看到正在播放的发声体和 Spatial Audio 听者之间的 Surface Reflector 和反射路径。
        Game Object 3D Viewer
备注： 若无法在 Game Object 3D Viewer 中看到任何几何构造，则可能需要在 Initialization Settings 中调大 Monitor Queue Pool Size。请参阅 调整 Wwise Initialization Settings 页面。
备注： 注意，在建筑表面为 Cube 形状的 Surface Reflector 时，若发声体位于建筑内部而听者位于其外部（反之亦然），则即便该发声体正在播放，也无法获取其反射路径。这是因为建筑开口是反射表面的一部分。为了解决这一问题，可选择只将建筑的 Mesh 用作 Surface Reflector，或者在开口附近设置 Portal。有关 Portal 的详细信息，请参阅 Room 和 Portal 教程 。
参见
  • Spatial Audio 组件
  • Reflect 文档
  • 使用 Geometry API 模拟早期反射


Wwise Unity Integration Documentation: Room 和 Portal 教程

Room 和 Portal 教程

本教程将展示如何结合 Spatial Audio 使用 Room 和 Portal。以下章节会详细讲解相关步骤：

  • A. Wwise 工程
  • B. Room
  • C. Portal
  • D. 验证设置
  • E. Portal 和 Reverb
备注： 本教程假定您已完成 Spatial Audio 教程准备工作 。不过，并不要求完成 Surface Reflector 教程 ；两个教程并不相干。假如您已完成 Surface Reflector 教程 并希望接着学习本教程，直接使用原有工程即可，无需对场景做任何改动。如果您想重新开始且已完成 Surface Reflector 教程 ，那么仍可沿用相同的场景。

A. Wwise 工程

对于本教程，为了在发声体被障碍物阻挡时通过 Portal 传播衍射声音，我们需要添加 Reverb Effect，并修改 Obstruction 曲线。

  1. 使用 Room 预设添加两条 Auxiliary Bus。
    1. 右键单击 Master Audio Bus，然后依次转到 New Child > Presets，并选择 Room Auxiliary Bus。
    2. 在 Effects 选项卡中，为每个 Room 选择不同的效果器。比如，为 SmallRoom 选择 Rooms/Room_Medium，为 LargeRoom 选择 Cathedrals/Medium。
      Auxiliary Bus Property Editor Effects tab for rooms
  2. 修改 Spatial Audio 教程准备工作 中添加的 Sound SFX
    1. 在 Positioning 选项卡中，确保启用 Diffraction and Transmission。
      在 Sound Property Editor 的 Positioning 选项卡中启用 Diffraction and Transmission
  3. 在默认情况下，衍射由声障实施滤波，透射损失由声笼实施滤波。依次转到 Project > Project Settings > Obstruction/Occlusion。
    1. 根据需要调节 Obstruction Volume 和 Obstruction LPF 曲线。比如，我们在 Wwise Unity Demo Scene 工程中使用了如下曲线：
      Curve | Point 1 | Point 2 | Curve Type
      X | Y | X | Y
      Obstruction Volume | 0 | 0 | 100 | -3 | Linear
      Obstruction LPF | 0 | 0 | 100 | 60 | Linear
      Occlusion Volume | 0 | 0 | 100 | -12 | Sine (Constant Power Fade In)
      Occlusion LPF | 0 | 0 | 100 | 75 | Sine (Constant Power Fade Out)
    2. Obstruction Volume 曲线如下图所示：
      Wwise Project Settings 中的 Obstruction/Occlusion 曲线
  4. 保存工程。
  5. 在 Unity 工程中，在 Wwise Picker (Windows > Wwise Picker) 内刷新 SoundBank
    1. 生成 SoundBank
      Wwise Picker

B. Room

我们需要指定 Room 在场景中的位置。为此，我们将使用 AkRoom 组件。

  1. 在 Wwise Unity Demo Scene 的教程场景中，我们添加了 Cube Mesh 来代表建筑中每个 Room 的内侧。假如您刚完成 Surface Reflector 教程 ，可使用带有 AkSurfaceReflector 组件的 GameObject。
    1. 添加 Cube (GameObject > 3D Object > Cube)
    2. 移除 Mesh Renderer 组件。
    3. 在 Box Collider 组件中选中 Is Trigger。
    4. 添加 AkRoom 组件。
      1. 为 Reverb Aux Bus 选取相应的 Auxiliary Bus。
      2. 警告消息会提示将 Rigidbody 组件添加到 Room。注意，执行该操作后将允许在 AkRoom 和 AkRoomAwareObject 组件之间进行交互。我们可以按照下一步所述来添加这些组件。
        AkRoom 组件

因为要使用 Room，所以必须通过添加 AkRoomAwareObject 组件来将所有听者和发声体设为 Room Aware。

  1. 已经有 AkRoomAwareObject 组件自动添加到了 Spatial Audio 听者，请确保该组件处于启用状态。
    AkRoomAwareObject 组件
  2. 您可能会看到两条警告消息（如上图所示）。
    1. 第一条提示需要将 Rigidbody 组件添加到 Room 或当前对象。若 Room 尚未绑定该组件，请单击 Add Rigidbody。
    2. 第二条是关于 Collider 的警告消息。每个 AkRoomAwareObject 都要具有 Collider 才能与 AkRoom 组件进行交互。

C. Portal

  1. 在听者和发声体不在同一 Room 时，声音会被 Room 的墙壁阻挡。您可以为其设置透射损失值（详见 /ref pg_obs_occ 章节）。否则，便需添加 Portal 以便通过所需开口传播直达声音。在 SpatialAudioTutorial 场景中，有两个可以放置 Portal 的开口：一个设在外部区域和 Small Room 之间的开口上，另一个设在两个 Room 之间。
  2. 创建两个 AkRoomPortal 组件 (GameObject > Wwise > Room Portal)，并将其放在开口附近。
  3. 在 Scene 窗口中，Portal 周围显示有黄色条带（用来指示门户大小）及其所应设置的朝向。红色线条用来划分 Portal 的前后区域。其中，局部 Z 轴所指方向为前部。
    在 Scene 窗口中创建 AkRoomPortal 组件
  4. 在 AkRoomPortal 组件中：
    1. 将 Open On 设为 Start。
    2. 将 Close On 设为 Nothing。
    3. 确保 Back Room 和 Front Room 显示正确的 AkRoom 组件。
  5. Small Room 和外部区域之间的 Portal 的 AkRoomPortal 组件应如下图所示：
    AkRoomPortal 组件

D. 验证设置

  1. 若要查看场景中绘制的声音传播路径，请将 AkSpatialAudioDebugDraw 组件添加到发声体。
    1. 勾选 Draw Diffraction Paths 选项。
      AkSpatialAudioDebugDraw 组件
  2. 启动游戏并连接到 Wwise。
    1. 按下其中一个 Room 中的按钮，来试听混响效果。
      1. Voices Graph 应如下图所示：
        Voice Graph 中显示 Room
    2. 走到 Room 外面并移动位置，使隔壁 Room 内正在播放的发声体处于视线内和视线外，从而试听声音的衍射效果。在听者相对于 Portal 的角度不同时，您会听到或多或少的衍射声音。
      1. 在 Unity 的 Scene 窗口中，应可看到代表声音穿过 Portal 的路径。衍射点处会显示应用于声音的衍射百分比。
        衍射路径穿过 Portal – 俯视图
    3. 打开设计工具的 Game Object Profiler 布局（快捷键 F12）。
      1. 确保在 Game Object 3D Viewer Settings 中启用 Diffraction Paths（如尚未启用）。
        在 Game Object 3D Viewer Settings 中为 Portal 启用 Diffraction Paths
    4. 在 Game Object 3D Viewer 中，应可看到：
      1. Room 和 Portal 的模型。
      2. 声音从发声体穿过 Portal 到达听者所在位置的衍射路径。每个边缘都会显示衍射百分比。注意图中以绿色虚像标识的虚声源，其代表声音的实际听感位置。
      3. 穿过 Room 墙壁的透射路径及透射损失百分比。
      4. 显示 Room 湿声部分的房屋图标。在图中，一个代表穿过 Portal 的声音，一个代表穿透 Room 墙壁的声音。
      5. 每个发声体/听者都会在其名称中显示与之对应的 Room。听者不在 Room 内，因此默认放在了 "Outdoors" Room 中。
        1. 将听者移动到某个 Room，并在 Game Object 3D Viewer 中的“听者”游戏对象下查看 Room 名称变化。
          Game Object 3D Viewer 中显示穿过 Portal 的衍射路径
备注： 若要在 Room 外部添加混响效果器，则可围绕整个区域添加一个 Room。确保 Room 的优先级低于场景中的其他 AkRoom 组件。

E. Portal 和 Reverb

通过 Portal 传播的声音还可使用来自听者所在 Room 的混响效果器。我们称之为 Room Coupling（房间耦合）。

  1. 打开 Room 对应的 Auxiliary Bus Property Editor，并确保在 General Settings 选项卡中选中 Use game-defined auxiliary sends。这样可以将 Room 的混响效果发送到场景中的其他混响效果中。
  2. 假如在播放小房间发声体时走进大房间，将会看到小房间的混响效果被馈送到了大房间的混响效果中来。
    Voices Graph 中显示 Room Coupling
备注：

Wwise Unity Demo Scene 涵盖了 Surface Reflector 教程 和 Room 和 Portal 教程 以及衍射。有关详细信息，请参阅 Spatial Audio 附加功能 。

参见
  • 房间耦合

F. Room Tone

有时，Room 内会有像空调嗡嗡声这样的特定环境声。为了重现这种效果，您可以针对 Spatial Audio Room 游戏对象发送 Event。在听者和发声体处在同一 Room 时，声音会被定位在听者所在位置。在听者和发声体处在不同 Room 时，听者会通过连通两个 Room 的 Portal 听到房间底噪 (Room Tone)。

  1. 在 Wwise 工程中：
    1. 创建新的 Sound SFX 并用于房间底噪。
      1. 确保启用游戏定义的辅助发送来将房间底噪发送到 Room 混响效果中。
    2. 右键单击 Sound SFX，然后依次选择 New Event > Play，来创建带有房间底噪的 Play Event。
    3. 保存工程。
  2. 在 Unity 中：
    1. 将此 Event 添加到其中一个 Room 所绑定的 AkRoom 组件的 Room Tone Event 参数。
      1. 调节 Aux Send Level 来将部分声音馈送到该 Room 的混响效果中。
      2. 您可以选择如何触发 Event。
        在 Spatial Audio Volume 的 AkEvent 分区中启用 Room
  3. 生成 SoundBank。
  4. 启动场景并连接到 Wwise 设计工具。
  5. 确认可以听到房间底噪。
    1. 在 Advanced Profiler 视图中，应会看到当前触发的 Event。
      在听者处在带有房间底噪的 Room 中时查看 Advanced Profiler 视图
    2. 在 3D Game Object Viewer 中，可一边来回移动听者，一边察看 Room 游戏对象。
      1. 若听者和发声体处在同一 Room，则 Room 会在听者所在位置播放声音。您会看到 Room 游戏对象跟随“听者”游戏对象。
      2. 若听者和发声体处在不同 Room，则会将 Room 游戏对象定位在 Portal 位置，并在其与 “听者”游戏对象之间绘制路径。
        在 Game Object 3D Viewer 中察看 Room 游戏对象
参见
  • Spatial Audio 组件
  • Spatial Audio Room 和 Portal 文档


Wwise Unity Integration Documentation: Spatial Audio 附加功能

Spatial Audio 附加功能
  • A. Surface Reflector 和 Portal
  • B. Surface Reflector 和 Reverb
  • C. 衍射
  • D. 透射
  • E. 将 Room 与 Surface Reflector 关联（优化）
备注： 此页面涉及的内容假定您已完成 Spatial Audio 教程准备工作 以及 Surface Reflector 教程 和 Room 和 Portal 教程 。

A. Surface Reflector 和 Portal

正如 Portal 会为 Room 区域创建开口以便声音从中穿过一样，在反射表面上也可用 Portal 实现类似的功能。在 Surface Reflector 教程 结尾，我们注意到：在将简单 Cube 用作 Surface Reflector 时，Mesh 开口上会产生反射。为了解决这一问题，Spatial Audio Portal 也能够处理反射路径，允许反射声穿过。反射路径甚至会在 Portal 边界发生衍射。

  1. 设置起来很简单，直接放置穿透 Room 的 Portal 以及 Surface Reflector 即可。
    Game Object 3D Viewer 中显示反射路径穿过 Portal

B. Surface Reflector 和 Reverb

在带有后期混响的 Room 中，可将早期反射馈送到混响效果器，使后期混响具有更多房间几何构造的特征。

  1. 在 Wwise 工程中，打开应用有 Reflect Effect 的 Auxiliary Bus。
    1. 在 General Settings 选项卡中，确保选中 Use game-defined auxiliary sends。
      Auxiliary Bus Property Editor General Settings tab to send early reflection to the room reverb
  2. 启动场景并按下小房间中的按钮。在玩家进入 Small Room 后，Voices Graph 应如下图所示：
    Voices Graph 中显示 Small Room 中的早期反射被发送到了 Small Room 的混响效果器

C. 衍射

在有物体出现在发声体和听者之间时，Spatial Audio 可创建绕过该物体衍射路径。根据声音绕过障碍物边缘时的路径角度，声音会被衰减，以此模拟 Obstruction 作用。您可以针对每个 Sound 和 Surface Reflector 启用衍射。对于启用了衍射的声音，在发声体发出声音时仅会在启用了衍射的反射表面边缘产生衍射。

  1. 针对 Sound 启用衍射：
    1. 在 Positioning 选项卡中，确保选中 Enable Diffraction 复选框。
      针对 Sound 启用衍射
  2. 为 AkSurfaceReflector 组件启用衍射：
    1. 选中 Enable Diffraction。这样会在发送到 Wwise Spatial Audio 的几何构造上生成衍射边缘。在将 Wwise 连接到游戏时，这些衍射边缘会显示在游戏对象查看器中。
    2. 另外可能还希望选中 Enable Diffraction On Boundary Edges。此复选框会在选中前述复选框后显示。其中，Boundary Edge 代表仅连有一个三角形的边缘。比如，Unity Quad 3D Object 周围的边缘便被视为 Boundary Edge。
      为 AkSurfaceReflector 启用了衍射
  3. 在 Wwise Unity Demo Scene 中，室外发声体、障碍物和建筑外侧启用了衍射。其中，衍射路径显示为紫色。它们都会在声音的听感位置创建一个虚声源。
    Game Object 3D Viewer 中显示衍射路径
    参见
    • Spatial Audio 衍射
    • 使用 Geometry API 模拟衍射

D. 透射

在发声体和听者之间存在障碍物时，可能会有部分声音透射到障碍物的另一侧。Spatial Audio 可通过在声音的直达路径上应用滤波来模拟这一现象。在发声体处于 Room 内时，Room 的墙壁会对声音起到阻挡作用。在这种情况下，可通过在声音的直达和湿声路径上应用滤波来模拟透射。透射损失值 (0 ~ 1) 可作用于 AkSurfaceReflector 和 AkRoom 组件。在默认情况下，透射使用工程的 Occlusion Volume、Occlusion LPF 和 Occlusion HPF 曲线。一般来说，值为 1.0 时表示声音被损耗殆尽，值为 0.0 时表示声音可无损穿透几何构造。

  1. 在 Spatial Audio Settings 中启用 Use Occlusion。这样可将透射损失值与 Wwise 工程的声笼曲线关联起来。
    Spatial Audio Init Settings
  2. 当声音在从发声体到听者的直达路径上遇到 AkSurfaceReflector 或 AkRoom 组件时，滤波当中应用的最终透射损失值等于相应组件所发送全部表面的最大透射损失值。
    1. 在 AkSurfaceReflector 组件上，通过填充 Transmission Loss Values 数组为 Surface Reflector Mesh 的每个 Submesh 关联透射损失值。
      AkSurfaceReflector 组件上的 Transmission Loss Values 数组
    2. 在 AkRoom 组件上，更改 Transmission Loss 参数中的透射损失值。
      AkRoom 组件上的 Transmission Loss 参数
  3. 若使用声笼模拟透射，则在 Wwise 设计工具内 Project Settings 的 Obstruction/Occlusion 选项卡中调节声笼曲线。
    Wwise Project Settings 中的 Occlusion 曲线
    参见
    • Spatial Audio 透射
    • Room 和 Portal 透射

E. 将 Room 与 Surface Reflector 关联（优化）

对于每个添加到 Spatial Audio 的 Surface Reflector，都会实施衍射边缘和可见性分析。为了优化这一步骤，可为每个 Room 设置一组互连的 Surface Reflector。假如这些 Surface Reflector 仅与某个特定 Room 关联，那么从其他 Room 是看不到它们的。如有 Surface Reflector 被某个 Room 完全包围，且该 Room 不与其他 Room 共用 Surface Reflector，则应将上述特定 Surface Reflector 关联到该 Room。您可以自由选择是否在 Room 和 Surface Reflector 之间设定关联。若未选择任何 Room，则将 Surface Reflector 添加到 Surface Reflector 全局组。通过将 Surface Reflector 与 Room 关联，可限制反射和衍射计算中执行的射线投射的搜索范围。

  1. 在 AkSurfaceReflector 组件中的 Associated Room 下选择要与其关联的 Room。
    为 AkSurfaceReflector 关联了 Room
AkEvent
Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017....
Definition: AkEvent.cs:47
AkSurfaceReflector.RemoveGeometryInstance
void RemoveGeometryInstance()
Remove this component's geometry instance from Spatial Audio.
Definition: AkSurfaceReflector.cs:307
AkEnvironmentPortal.axis
UnityEngine.Vector3 axis
The axis used to find the contribution of each environment
Definition: AkEnvironmentPortal.cs:28
TransportState
Used to deserialize transport-state information receieved from the transport.stateChanged topic.
Definition: AkWaapiHelper.cs:186
AkSpatialAudioEmitter
(DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb c...
Definition: AkSpatialAudioEmitter.cs:26
AkWaapiUtilities.Disconnecting
static System.Action< bool > Disconnecting
Fired when the connection is closing or closed, the bool parameter represents whether the socket conn...
Definition: AkWaapiUtilities.cs:42
AK.Wwise.RTPC
This type can be used to set game parameter values to the sound engine.
Definition: AkWwiseRtpc.cs:25
AkSurfaceReflector.SetGeometryFromMesh
static void SetGeometryFromMesh(UnityEngine.Mesh mesh, ulong geometryID, bool enableDiffraction, bool enableDiffractionOnBoundaryEdges, bool enableTriangles, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="")
Convert the mesh into a geometry consisting of vertices, triangles, surfaces, acoustic textures and t...
Definition: AkSurfaceReflector.cs:77
AkWwiseTreeWAAPIDataSource
This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object h...
Definition: AkWwiseTreeWAAPIDataSource.cs:31
AkListenerDistanceProbe
Add this script on a listener game object to assign another game object as a distance probe....
Definition: AkListenerDistanceProbe.cs:28
AkRadialEmitter
A radial emitter is for sounds that are not point sources, but instead originate from a region of spa...
Definition: AkRadialEmitter.cs:26
AK.Wwise.AcousticTexture
This type represents an Acoustic Texture.
Definition: AkWwiseAcousticTexture.cs:25
ak.wwise.core
Definition: Uri.cs:114
ArgsObject
WAAPI arguments containing an object identfier.
Definition: AkWaapiHelper.cs:56
AkBank.decodeBank
bool decodeBank
Decode this SoundBank upon load
Definition: AkBank.cs:31
AK
Definition: AkWwiseAcousticTexture.cs:21
AkSurfaceReflector.AcousticTextures
AK.Wwise.AcousticTexture[] AcousticTextures
The acoustic texture per submesh. The acoustic texture represents the surface of the geometry....
Definition: AkSurfaceReflector.cs:36
AkSurfaceReflector.TransmissionLossValues
float[] TransmissionLossValues
The transmission loss value per submesh. The transmission loss value is a control value used to adjus...
Definition: AkSurfaceReflector.cs:41
AkWaapiUtilities.QueueCommandWithReturnWwiseObjects< T >
static void QueueCommandWithReturnWwiseObjects< T >(WaqlArgs args, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a command with a payload that desirializes the list of wwise objects from the response.
Definition: AkWaapiUtilities.cs:559
ak.wwise
Definition: Uri.cs:84
AkBank.loadAsynchronous
bool loadAsynchronous
Check this to load the SoundBank in the background. Be careful, if Events are triggered and the Sound...
Definition: AkBank.cs:34
AK.Wwise.Event.StopMIDI
void StopMIDI()
Stops all MIDI Events on this Event.
Definition: AkWwiseEvent.cs:232
AkWaapiUtilities.GetWwiseObject< T >
static void GetWwiseObject< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a Wwise object with custom return options.
Definition: AkWaapiUtilities.cs:577
ak.wwise.core.undo
Definition: Uri.cs:204
ak.wwise.error
Definition: Uri.cs:86
Wamp.ErrorException
Exception thrown during WAMP operations.
Definition: Wamp.cs:56
AK.Wwise.Event.PostMIDI
void PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array, int count)
Posts MIDI Events on this Event associated with a GameObject.
Definition: AkWwiseEvent.cs:213
AkSpatialAudioDebugDraw.drawDiffractionPaths
bool drawDiffractionPaths
This allows you to visualize geometric diffraction sound paths between an obstructed emitter and the ...
Definition: AkSpatialAudioDebugDraw.cs:35
AkRoomPortal.ClosePortal
void ClosePortal(UnityEngine.GameObject in_gameObject)
Closes the portal on trigger event
Definition: AkRoomPortal.cs:174
AkRoomPortal.GetID
ulong GetID()
Access the portal's ID
Definition: AkRoomPortal.cs:134
AkRoom.reverbLevel
float reverbLevel
The reverb control value for the send to the reverb aux bus.
Definition: AkRoom.cs:47
AkTriggerBase.triggerDelegate
Trigger triggerDelegate
All components reacting to the trigger will be registered in this delegate.
Definition: AkTriggerBase.cs:30
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm
Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:
Definition: AkEnvironment.cs:86
AkWaapiUtilities.SelectObjectInAuthoring
static void SelectObjectInAuthoring(System.Guid guid)
Select the object in Wwise Authoring. Creates a WaapiCommand object containing a lambda call to Selec...
Definition: AkWaapiUtilities.cs:723
AK.Wwise.Event.PostMIDI
void PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array)
Posts MIDI Events on this Event associated with a GameObject.
Definition: AkWwiseEvent.cs:201
AkWaapiUtilities.Search< T >
static void Search< T >(string searchString, WwiseObjectType objectType, ReturnOptions options, GetResultListDelegate< T > callback)
Composes a WAQL "search" request based on the parameters and enqueues a WAAPI command....
Definition: AkWaapiUtilities.cs:660
AkEnvironment.AkEnvironment_CompareByPriority
Sorts AkEnvironments based on their priorities.
Definition: AkEnvironment.cs:72
AkEvent.transitionDuration
float transitionDuration
Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction()
Definition: AkEvent.cs:83
AkSpatialAudioEmitter.reflectionsAuxBusGain
float reflectionsAuxBusGain
(DEPRECATED) As of 2019.2, the early reflections send volume can be set per sound,...
Definition: AkSpatialAudioEmitter.cs:37
AkGameObj.GetUpward
virtual UnityEngine.Vector3 GetUpward()
Definition: AkGameObj.cs:239
AkSurfaceReflector
This component converts the provided mesh into Spatial Audio Geometry.
Definition: AkSurfaceReflector.cs:27
JsonSerializable
Base class for Json serializable objects. Implements implicit cast to string using UnityEngine....
Definition: AkWaapiHelper.cs:26
AkSpatialAudioEmitter.roomReverbAuxBusGain
float roomReverbAuxBusGain
(DEPRECATED) As of 2019.2, the Room Reverb Aux Bus Gain is set by the Game-Defined Auxiliary Sends Vo...
Definition: AkSpatialAudioEmitter.cs:45
AkSpatialAudioEmitter.diffractionMaxPathLength
uint diffractionMaxPathLength
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.
Definition: AkSpatialAudioEmitter.cs:56
AkWaapiUtilities.GetChildren< T >
static void GetChildren< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Get the children of a given object.
Definition: AkWaapiUtilities.cs:681
AkSpatialAudioListener.SpatialAudioListeners
static SpatialAudioListenerList SpatialAudioListeners
Returns the list of active Unity Game Objects that are designated to be spatial audio listeners.
Definition: AkSpatialAudioListener.cs:47
AK.Wwise.BaseGroupType
This type represents the base for all Wwise Types that also require a group GUID, such as State and S...
Definition: AkWwiseBaseGroupType.cs:25
AkSpatialAudioEmitter.drawDiffractionPaths
bool drawDiffractionPaths
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:72
AkSpatialAudioListener.SpatialAudioListenerList
This class represents the list of active Unity Game Objects that are designated to be spatial audio l...
Definition: AkSpatialAudioListener.cs:71
AkMemBankLoader.isLocalizedBank
bool isLocalizedBank
Is the bank localized (situated in the language-specific folders)
Definition: AkMemBankLoader.cs:31
ArgsPlay
WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback.
Definition: AkWaapiHelper.cs:118
AkSurfaceReflector.UpdateGeometry
void UpdateGeometry()
Update this component's geometry instance
Definition: AkSurfaceReflector.cs:291
ak.wwise.ui.commands
Definition: Uri.cs:308
AkWaapiUtilities.TogglePlayEvent
static void TogglePlayEvent(WwiseObjectType objectType, System.Guid guid)
Play or pause an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to...
Definition: AkWaapiUtilities.cs:871
AkSurfaceReflector.SetGeometryInstance
static void SetGeometryInstance(ulong geometryInstanceID, ulong geometryID, ulong associatedRoomID, UnityEngine.Transform transform)
Add or update an instance of the geometry by sending the transform of this component to Wwise....
Definition: AkSurfaceReflector.cs:211
AkSpatialAudioEmitter.drawSecondOrderReflections
bool drawSecondOrderReflections
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:66
ak.wwise.core.transport
Definition: Uri.cs:241
AK.Wwise.Event
This type can be used to post Events to the sound engine.
Definition: AkWwiseEvent.cs:29
AkMemBankLoader.LoadNonLocalizedBank
void LoadNonLocalizedBank(string in_bankFilename)
Load a SoundBank from WWW object
Definition: AkMemBankLoader.cs:56
WwiseRenameInfo
Used to deserialize information published on the ak.wwise.core.@object.nameChanged topic.
Definition: AkWaapiHelper.cs:245
AkSpatialAudioEmitter.reflectAuxBus
AK.Wwise.AuxBus reflectAuxBus
(DEPRECATED) As of 2019.2, the early reflections auxiliary bus can be set per sound,...
Definition: AkSpatialAudioEmitter.cs:30
AkWaapiUtilities.IsPlayable
static bool IsPlayable(WwiseObjectType type)
Checks if Wwise object is playable.
Definition: AkWaapiUtilities.cs:860
AK.Wwise.Event.Post
uint Post(UnityEngine.GameObject gameObject)
Posts this Event on a GameObject.
Definition: AkWwiseEvent.cs:61
AkWaapiUtilities.GetWwiseObjects< T >
static void GetWwiseObjects< T >(List< System.Guid > guids, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a list of Wwise objects with custom return options.
Definition: AkWaapiUtilities.cs:589
AkRadialEmitter.outerRadius
float outerRadius
Definition: AkRadialEmitter.cs:38
AkGameObj
This component represents a sound object in your scene tracking its position and other game syncs suc...
Definition: AkGameObj.cs:32
AkAudioListener
Add this script on the game object that represent a listener. This is normally added to the Camera ob...
Definition: AkAudioListener.cs:27
AkSurfaceReflector.EnableDiffractionOnBoundaryEdges
bool EnableDiffractionOnBoundaryEdges
Switch to enable or disable geometric diffraction on boundary edges for this mesh....
Definition: AkSurfaceReflector.cs:49
AkWaapiUtilities.WaapiCommand
A simple structure containing an async payload function that will be executed when it is consumed by ...
Definition: AkWaapiUtilities.cs:97
AkWaapiUtilities.Unsubscribe
static void Unsubscribe(uint id)
Unsubscribe from an existing subscription. Creates a WaapiCommand object containing a lambda call to ...
Definition: AkWaapiUtilities.cs:1036
AkSurfaceReflector.SetGeometry
void SetGeometry()
Call AkSurfaceReflector::SetGeometryFromMesh() with this component's mesh.
Definition: AkSurfaceReflector.cs:252
SelectedWwiseObjects
Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic.
Definition: AkWaapiHelper.cs:236
Wamp.WampNotConnectedException
Definition: Wamp.cs:47
AkSpatialAudioEmitter.diffractionMaxPaths
uint diffractionMaxPaths
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.
Definition: AkSpatialAudioEmitter.cs:53
AK.Wwise.TypeMigration
Definition: AkWwiseTypeMigration.cs:31
AkSpatialAudioEmitter.drawFirstOrderReflections
bool drawFirstOrderReflections
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:63
ErrorMessage
Used to deserialize WAAPI error messages.
Definition: AkWaapiHelper.cs:198
AkRoomAwareObject.ExitedRoom
void ExitedRoom(AkRoom room)
Called when exiting a room.
Definition: AkRoomAwareObject.cs:99
AK.Wwise.Event.StopMIDI
void StopMIDI(UnityEngine.GameObject gameObject)
Stops MIDI Events on this Event associated with a GameObject.
Definition: AkWwiseEvent.cs:223
AkBank.UnloadBank
void UnloadBank(UnityEngine.GameObject in_gameObject)
Unloads a SoundBank
Definition: AkBank.cs:86
AkTriggerBase.Trigger
delegate void Trigger(UnityEngine.GameObject in_gameObject)
Delegate declaration for all Wwise Triggers.
Wamp.PublishHandler
delegate void PublishHandler(string json)
Publish events are delegates registered with Subscribe.
AkEnvironmentPortal.EnvListWrapper
This enables us to detect intersections between portals and environments in the editor
Definition: AkEnvironmentPortal.cs:91
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21
AkSpatialAudioListener.SpatialAudioListenerList.Remove
bool Remove(AkSpatialAudioListener listener)
Removes listeners from the list
Definition: AkSpatialAudioListener.cs:107
AkRoom.reverbAuxBus
AK.Wwise.AuxBus reverbAuxBus
The reverb auxiliary bus.
Definition: AkRoom.cs:43
AkWaapiUtilities.GetResultDelegate< T >
delegate void GetResultDelegate< T >(T result)
Generic delegate function for callbacks that expect to receive a single object in response to a WAAPI...
AkMemBankLoader.LoadLocalizedBank
void LoadLocalizedBank(string in_bankFilename)
Load a language-specific bank from WWW object
Definition: AkMemBankLoader.cs:63
AkBank.HandleEvent
override void HandleEvent(UnityEngine.GameObject in_gameObject)
Loads the SoundBank
Definition: AkBank.cs:77
AK.Wwise.Switch
This type can be used to set Switch values on gameobjects.
Definition: AkWwiseSwitch.cs:25
Wamp.TimeoutException
Exception thrown during WAMP operations when the timeout is reached.
Definition: Wamp.cs:39
AkSwitch
This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered....
Definition: AkSwitch.cs:28
AkSpatialAudioDebugDraw.drawSecondOrderReflections
bool drawSecondOrderReflections
This allows you to visualize second order reflection sound paths.
Definition: AkSpatialAudioDebugDraw.cs:29
AK.Wwise.Trigger
This type can be used to post triggers to the sound engine.
Definition: AkWwiseTrigger.cs:25
AkGameObj.m_positionOffsetData
AkGameObjPositionOffsetData m_positionOffsetData
When not set to null, the position will be offset relative to the Game Object position by the Positio...
Definition: AkGameObj.cs:49
AkSurfaceReflector.SetGeometryInstance
void SetGeometryInstance()
Call AkSurfaceReflector::SetGeometryInstance() with this component's tranform.
Definition: AkSurfaceReflector.cs:279
AkWaapiUtilities.ParseRenameObject
static WwiseRenameInfo ParseRenameObject(string json)
Deserializes the object published by the ak.wwise.core.object.nameChanged topic.
Definition: AkWaapiUtilities.cs:1073
AkGameObj.GetForward
virtual UnityEngine.Vector3 GetForward()
Definition: AkGameObj.cs:232
AkEventCallbackMsg.sender
UnityEngine.GameObject sender
GameObject from whom the callback function was called
Definition: AkEvent.cs:29
ArgsDisplayName
WAAPI arguments containing an object identfier and name used when deleting an object.
Definition: AkWaapiHelper.cs:87
ArgsRename
WAAPI arguments containing an object identfier and new value used when renaming an object.
Definition: AkWaapiHelper.cs:71
TransportOptions
WAAPI options used to specify the transport ID when subscribing.
Definition: AkWaapiHelper.cs:163
AkRoom
An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoom...
Definition: AkRoom.cs:25
AkWaapiUtilities.ParseObjectInfo
static List< WwiseObjectInfo > ParseObjectInfo(List< WwiseObjectInfoJsonObject > returnObjects)
Parse the response WwiseObjectInfoJsonObject of a "from object" request and implicit cast the objects...
Definition: AkWaapiUtilities.cs:708
AK.Wwise.Bank
This type can be used to load/unload SoundBanks.
Definition: AkWwiseBank.cs:29
AkWaapiUtilities.Disconnected
static void Disconnected()
Invoked after the client has disconnected from Wwise authoring.
Definition: AkWaapiUtilities.cs:437
ArgsTransport
WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands.
Definition: AkWaapiHelper.cs:130
AkWaapiUtilities.QueueConsumed
static System.Action QueueConsumed
Fired when all commands in the queue have been executed.
Definition: AkWaapiUtilities.cs:52
AK.Wwise.CallbackFlags
This type represents the values of the flags used when posting an Event with a callback.
Definition: AkWwiseCallbackFlags.cs:25
AkWaapiUtilities.ParseSelectedObjects
static List< WwiseObjectInfo > ParseSelectedObjects(string json)
Deserializes the objects published by the ak.wwise.ui.selectionChanged topic.
Definition: AkWaapiUtilities.cs:1057
AkGameObj.GetPosition
virtual UnityEngine.Vector3 GetPosition()
Definition: AkGameObj.cs:221
AkEarlyReflections.reflectionsAuxBus
AK.Wwise.AuxBus reflectionsAuxBus
Definition: AkEarlyReflections.cs:32
AkSpatialAudioListener
Add this script on the game object that represent a listener. This is normally added to the Camera ob...
Definition: AkSpatialAudioListener.cs:30
ak.wwise.ui
Definition: Uri.cs:297
AkRoomAwareObject.EnteredRoom
void EnteredRoom(AkRoom room)
Called when entering a room.
Definition: AkRoomAwareObject.cs:90
AkWaapiUtilities.OpenWorkUnitInExplorer
static void OpenWorkUnitInExplorer(System.Guid guid)
Open the OS file browser to the folder containing this object's Work Unit. Creates a WaapiCommand obj...
Definition: AkWaapiUtilities.cs:746
AK.Wwise.State
This type can be used to set Wwise States.
Definition: AkWwiseState.cs:25
AkWaapiUtilities.Delete
static void Delete(System.Guid guid)
Delete an object in wwise authoring. Work Units cannot be deleted in this manner. Creates a WaapiComm...
Definition: AkWaapiUtilities.cs:833
AkBank.unloadTriggerList
System.Collections.Generic.List< int > unloadTriggerList
Reserved.
Definition: AkBank.cs:40
AkSpatialAudioEmitter.reflectionsOrder
uint reflectionsOrder
(DEPRECATED) As of 2019.2, the Reflection Order is set in the Spatial Audio Initialization Settings.
Definition: AkSpatialAudioEmitter.cs:40
ReturnTransport
Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transpo...
Definition: AkWaapiHelper.cs:177
AkWwiseTreeWAAPIDataSource.SubscribeTopics
void SubscribeTopics()
Subscribes to nameChanged, childAdded, childRemoved, and selectionChanged WAAPI events in order to ke...
Definition: AkWwiseTreeWAAPIDataSource.cs:390
AkWaapiUtilities.QueueCommandWithReturnType< T >
static void QueueCommandWithReturnType< T >(string uri, GetResultDelegate< T > callback, string args=null, string options=null)
Use this function to enqueue a command with an expected return object of type T. The command will des...
Definition: AkWaapiUtilities.cs:543
WaapiKeywords.WwiseObjectTypeStrings
static ReadOnlyDictionary< WwiseObjectType, string > WwiseObjectTypeStrings
Maps WwiseObjectType to strings.
Definition: AkWaapiHelper.cs:463
AkRoomAwareManager
This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit.
Definition: AkRoomAwareManager.cs:22
WwiseObjectInfoParent
Contains the GUID of the returned object's parent.
Definition: AkWaapiHelper.cs:327
AkEventCallbackMsg
Event callback information. Event callback functions can receive this structure as a parameter
Definition: AkEvent.cs:24
AkEventCallbackMsg.info
AkCallbackInfo info
For more information about the event callback, see the classes derived from AkCallbackInfo.
Definition: AkEvent.cs:26
AkState
This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered....
Definition: AkState.cs:28
AkRoom.PriorityList
Definition: AkRoom.cs:430
AkSurfaceReflector.Mesh
UnityEngine.Mesh Mesh
The mesh to send to Spatial Audio as a Geometry Set. We recommend using a simplified mesh.
Definition: AkSurfaceReflector.cs:32
AkMemBankLoader.bankName
string bankName
Name of the bank to load
Definition: AkMemBankLoader.cs:28
AkEnvironmentPortal.environments
AkEnvironment[] environments
Definition: AkEnvironmentPortal.cs:33
AkSpatialAudioDebugDraw.drawHigherOrderReflections
bool drawHigherOrderReflections
This allows you to visualize third or higher order reflection sound paths.
Definition: AkSpatialAudioDebugDraw.cs:32
WaapiHelper
Contains a helper function GetWwiseObjectTypeFromString.
Definition: AkWaapiHelper.cs:353
AkRoom.GetID
ulong GetID()
Access the room's ID
Definition: AkRoom.cs:112
AkSurfaceReflector.RemoveGeometry
void RemoveGeometry()
Remove this component's geometry and corresponding instance from Spatial Audio.
Definition: AkSurfaceReflector.cs:299
AkRoomPortal.HandleEvent
override void HandleEvent(UnityEngine.GameObject in_gameObject)
Opens the portal on trigger event
Definition: AkRoomPortal.cs:168
AkSurfaceReflector.AssociatedRoom
AkRoom AssociatedRoom
Optional room with which this surface reflector is associated. It is recommended to associate geometr...
Definition: AkSurfaceReflector.cs:53
AkRoom.roomToneEvent
AK.Wwise.Event roomToneEvent
Wwise Event to be posted on the room game object.
Definition: AkRoom.cs:54
AkMemBankLoader
This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory....
Definition: AkMemBankLoader.cs:22
AkRoom.transmissionLoss
float transmissionLoss
Loss value modeling transmission through walls.
Definition: AkRoom.cs:51
Args
Abstract base class for WAAPI command arguments.
Definition: AkWaapiHelper.cs:35
WaapiKeywords.FolderDisplaynames
static ReadOnlyDictionary< string, string > FolderDisplaynames
Maps root folder names to displayed strings.
Definition: AkWaapiHelper.cs:486
AkRoom.priority
int priority
Definition: AkRoom.cs:40
AkSpatialAudioDebugDraw.drawFirstOrderReflections
bool drawFirstOrderReflections
This allows you to visualize first order reflection sound paths.
Definition: AkSpatialAudioDebugDraw.cs:26
AkEnvironment
Use this component to define a reverb zone. This needs to be added to a collider object to work prope...
Definition: AkEnvironment.cs:34
Wamp
WAMP protocol implementation using only strings and regular expressions. This implements only a subse...
Definition: Wamp.cs:36
AkEventCallbackMsg.type
AkCallbackType type
AkSoundEngine.PostEvent callback flags. See the AkCallbackType enumeration for a list of all callback...
Definition: AkEvent.cs:32
AkEvent.enableActionOnEvent
bool enableActionOnEvent
Enables additional options to reuse existing events. Use it to transform a Play event into a Stop eve...
Definition: AkEvent.cs:55
AkTriggerBase
Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use ...
Definition: AkTriggerBase.cs:23
AkWaapiUtilities.Subscribe
static void Subscribe(string topic, Wamp.PublishHandler subscriptionCallback, System.Action< SubscriptionInfo > handshakeCallback)
Subscribe to WAAPI topic. Refer to WAAPI reference documentation for a list of topics and their optio...
Definition: AkWaapiUtilities.cs:1010
AkEvent.curveInterpolation
AkCurveInterpolation curveInterpolation
Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction()
Definition: AkEvent.cs:52
AkWaapiUtilities.Rename
static void Rename(System.Guid guid, string newName)
Rename an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to Rename...
Definition: AkWaapiUtilities.cs:808
AkGameObj.isEnvironmentAware
bool isEnvironmentAware
Is this object affected by Environment changes? Set to false if not affected in order to save some us...
Definition: AkGameObj.cs:36
ReturnWwiseObjects
Generic class to deserialize a WAAPI response containing Wwise objects with custom return options.
Definition: AkWaapiHelper.cs:227
ReturnOptions
WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects.
Definition: AkWaapiHelper.cs:149
AkWaapiUtilities.Connected
static System.Action Connected
Fired when the connection is established, should be used by external classes to subscribe to topics t...
Definition: AkWaapiUtilities.cs:47
AkWaapiUtilities
This class wraps the client that communicates with the Wwise Authoring application via WAAPI....
Definition: AkWaapiUtilities.cs:34
AkSpatialAudioEmitter.reflectionMaxPathLength
float reflectionMaxPathLength
(DEPRECATED) As of 2019.2, the Reflection Max Path Length is set by the sound's Attenuation Max Dista...
Definition: AkSpatialAudioEmitter.cs:33
AkInitializer
This script deals with initialization, and frame updates of the Wwise audio engine....
Definition: AkInitializer.cs:37
AK.Wwise.Event.Post
uint Post(UnityEngine.GameObject gameObject, CallbackFlags flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject.
Definition: AkWwiseEvent.cs:88
AkSpatialAudioListener.SpatialAudioListenerList.Add
bool Add(AkSpatialAudioListener listener)
Uniquely adds listeners to the list
Definition: AkSpatialAudioListener.cs:85
AkEmitterObstructionOcclusion
Completely obstructs/occludes the emitter of the current game object from its listeners if at least o...
Definition: AkEmitterObstructionOcclusion.cs:23
AkSpatialAudioEmitter.diffractionMaxEdges
uint diffractionMaxEdges
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.
Definition: AkSpatialAudioEmitter.cs:50
AkSpatialAudioEmitter.drawHigherOrderReflections
bool drawHigherOrderReflections
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.
Definition: AkSpatialAudioEmitter.cs:69
AkWaapiUtilities.GetWwiseObjectAndDescendants< T >
static void GetWwiseObjectAndDescendants< T >(System.Guid guid, ReturnOptions options, int depth, GetResultListDelegate< T > callback)
Enqueues a waapi comand to fetch the specified object and all of its descendants in the hierarchy to ...
Definition: AkWaapiUtilities.cs:623
AkRoom.roomToneAuxSend
float roomToneAuxSend
Send level for sounds that are posted on the room game object; adds reverb to ambience and room tones...
Definition: AkRoom.cs:59
AkEvent.soundEmitterObject
UnityEngine.GameObject soundEmitterObject
Game object onto which the Event will be posted. By default, when empty, it is posted on the same obj...
Definition: AkEvent.cs:80
WwiseObjectInfo
Class containing the information returned by a WAAPI request for an object.
Definition: AkWaapiHelper.cs:337
AkEarlyReflections.reflectionsVolume
float reflectionsVolume
Definition: AkEarlyReflections.cs:39
AkRoomPortal.MAX_ROOMS_PER_PORTAL
const int MAX_ROOMS_PER_PORTAL
AkRoomPortals can only connect a maximum of 2 rooms.
Definition: AkRoomPortal.cs:26
AkAmbientLargeModePositioner
Use this component to add a Large Mode position to any AkAmbient in a Scene.
Definition: AkAmbientLargeModePositioner.cs:24
AkRoomManager
This manager tracks AkRoomPortals and the rooms that they connect (front and back room).
Definition: AkRoomManager.cs:22
WaapiKeywords.typeStringDict
static ReadOnlyDictionary< string, WwiseObjectType > typeStringDict
Maps strings to WwiseObjectType.
Definition: AkWaapiHelper.cs:499
AkWaapiUtilities.IsConnected
static bool IsConnected()
Check whether the client is currently connected.
Definition: AkWaapiUtilities.cs:174
AkWaapiUtilities.GetProject< T >
static void GetProject< T >(GetResultListDelegate< T > callback, ReturnOptions options)
Get the WwiseObjectInfo for the project.
Definition: AkWaapiUtilities.cs:696
AkSpatialAudioDebugDraw
Add this script on a GameObject to print Spatial Audio paths.
Definition: AkSpatialAudioDebugDraw.cs:23
AkRoomPortalObstruction
Completely obstructs the spatial audio portal of the current game object from the spatial audio liste...
Definition: AkRoomPortalObstruction.cs:24
AkWaapiUtilities.QueueCommand
static void QueueCommand(string uri, string args, string options)
Use this function to enqueue a command with no expected return object.
Definition: AkWaapiUtilities.cs:528
AK.Wwise.IMigratable
Definition: AkWwiseTypeMigration.cs:25
AkWaapiUtilities.GetWwiseObjectAndAncestors< T >
static void GetWwiseObjectAndAncestors< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a waapi command to fetch the specified object and all of its ancestors in the hierarchy....
Definition: AkWaapiUtilities.cs:608
AkRoomPortal
An AkRoomPortal can connect two AkRoom components together.
Definition: AkRoomPortal.cs:24
AK.Wwise.Event.Post
uint Post(UnityEngine.GameObject gameObject, uint flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject.
Definition: AkWwiseEvent.cs:117
Options
Abstract base class for WAAPI command options.
Definition: AkWaapiHelper.cs:140
AkEnvironmentPortal.envList
EnvListWrapper[] envList
Unity can't serialize an array of list so we wrap the list in a serializable class
Definition: AkEnvironmentPortal.cs:96
AkEnvironmentPortal
Use this component to define an area that straddles two different AkEnvironment's zones and allow mix...
Definition: AkEnvironmentPortal.cs:24
AK.Wwise.BaseType
This type represents the base for all Wwise Types that require a GUID.
Definition: AkWwiseBaseType.cs:25
ErrorDetails
Used to deserialize details in WAAPI error messages.
Definition: AkWaapiHelper.cs:208
WaqlArgs
WAAPI arguments containing a WAQL string.
Definition: AkWaapiHelper.cs:43
AkRoomAwareObject
This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms,...
Definition: AkRoomAwareObject.cs:28
AkWaapiUtilities.StopAllTransports
static void StopAllTransports()
Stops all playing transports. Creates a WaapiCommand object containing a lambda call to StopAllTransp...
Definition: AkWaapiUtilities.cs:984
AkWaapiUtilities.SubscriptionInfo
Class used to store information about a specific subscription.
Definition: AkWaapiUtilities.cs:113
AkRadialEmitter.innerRadius
float innerRadius
Definition: AkRadialEmitter.cs:44
AkWaapiUtilities.GetResultListDelegate< T >
delegate void GetResultListDelegate< T >(List< T > result)
Generic delegate function for callbacks that expect to receive a list of objects in response to a WAA...
ak
URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK docume...
Definition: Uri.cs:31
AK.Wwise.AuxBus
This type represents an auxiliary send in the Master-Mixer Hierarchy.
Definition: AkWwiseAuxBus.cs:25
AK.Wwise.Event.Post
uint Post(ulong gameObjectId)
Posts this Event on a GameObject ID.
Definition: AkWwiseEvent.cs:143
AkSpatialAudioListener.TheSpatialAudioListener
static AkAudioListener? TheSpatialAudioListener
Returns the "single" spatial audio listener.
Definition: AkSpatialAudioListener.cs:39
WwiseChildModifiedInfo
Used to deserialize information published on the ak.wwise.core.@object.childAdded and ak....
Definition: AkWaapiHelper.cs:263
WaapiKeywords
Contains fields for specific WAAPI keywords.
Definition: AkWaapiHelper.cs:376
AkBank
Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified...
Definition: AkBank.cs:27
WwiseObjectInfoJsonObject
Used to deserialize information from a request for a Wwise object. Implements an implicit cast to Wwi...
Definition: AkWaapiHelper.cs:283
AkAmbient
Use this component to attach a Wwise Event to any object in a scene. The sound can be started at vari...
Definition: AkAmbient.cs:47
AkEarlyReflections
Set an early reflections auxiliary bus and send volume for a particular game object.
Definition: AkEarlyReflections.cs:25
AkWaapiUtilities.GetStatusString
static string GetStatusString()
Returns a rich text string representing the current WAAPI connection status.
Definition: AkWaapiUtilities.cs:476
AkBank.saveDecodedBank
bool saveDecodedBank
Save the decoded SoundBank to disk for faster loads in the future
Definition: AkBank.cs:37
AkWaapiUtilities.OpenSoundBankInExplorer
static void OpenSoundBankInExplorer(System.Guid guid)
Open the OS file browser to the folder containing the generated SoundBank. Creates a WaapiCommand obj...
Definition: AkWaapiUtilities.cs:757
ArgsCommand
WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities....
Definition: AkWaapiHelper.cs:102
AkEvent.actionOnEventType
AkActionOnEventType actionOnEventType
Replacement action. See AK::SoundEngine::ExecuteEventOnAction()
Definition: AkEvent.cs:49
AkWaapiUtilities.ParseChildAddedOrRemoved
static WwiseChildModifiedInfo ParseChildAddedOrRemoved(string json)
Deserializes the object published by the ak.wwise.core.object.childAdded or ak.wwise....
Definition: AkWaapiUtilities.cs:1085
AkSurfaceReflector.EnableDiffraction
bool EnableDiffraction
Switch to enable or disable geometric diffraction for this mesh.
Definition: AkSurfaceReflector.cs:45
AK.Wwise.Event.ExecuteAction
void ExecuteAction(UnityEngine.GameObject gameObject, AkActionOnEventType actionOnEventType, int transitionDuration, AkCurveInterpolation curveInterpolation)
Executes various actions on this event associated with a GameObject.
Definition: AkWwiseEvent.cs:175


Wwise Unity Integration Documentation: Obstruction 和 Occlusion

Obstruction 和 Occlusion

在 Unity 中，可阻挡或遮蔽声音。您可以使用：

  • Spatial Audio Diffraction。
    • 参见 Spatial Audio 附加功能 以及 C. 衍射 部分
  • 以下章节中的简单 Obstruction/Occlusion 组件：
    • A. Emitter Obstruction/Occlusion
    • B. Portal Obstruction

A. Emitter Obstruction/Occlusion

在将 AkEmitterObstructionOcclusion 组件添加到 GameObject 后，可在 Unity 中为 Emitter 应用 Obstruction 或 Occlusion。在发声体和听者之间的路径中有障碍物时，该组件会调用 SetObjectObstructionAndOcclusion()，并将声障/声笼值设为 1。若地图中不使用 Spatial Audio（即未添加任何 AkRoom 组件），则 AkEmitterObstructionOcclusion 组件将使用声笼。在空间音频场景中，该组件仅对空间音频听者（即添加了 AkSpatialAudioListener 组件的 GameObject）应用声障。Emitter Obstruction 仅作用于空间音频听者所在房间内的发声体。

AkEmitterObstructionOcclusion 组件

为了确保为所需对象应用 Obstruction 或 Occlusion，可使用 Layer Mask。比如，您可以为 Player 对象指定 Layer，同时在 AkEmitterObstructionOcclusion 组件中弃用。如此一来，听者的身体便不会阻挡或遮蔽声音。

在 Ak Emitter Obstruction Occlusion 组件中设置 Layer Mask 选项

B. Portal Obstruction

另外，过门户传播的声音也可以被阻挡。若未使用 Spatial Audio Diffraction，则可将 GameObject AkRoomPortalObstruction 组件添加到带有 AkRoomPortal 的 GameObject。在 Portal 和 Spatial Audio Listener 之间的路径中有障碍物时，该组件会调用 SetObjectObstructionAndOcclusion()，并将声障值设为 1。

AkRoomPortalObstruction 组件

Portal 所连 Room 的 Mesh 将借助 AkRoomPortalObstruction 组件产生 Obstruction 作用。若使用了 Surface Reflector，则其可能也会阻挡 Portal 开口。确保将其放入不同的 Layer，以便从 AkRoomPortalObstruction 组件的 Layer Mask 中排除。

在 Ak Room Portal Obstruction 组件中设置 Layer Mask 选项


Wwise Unity Integration Documentation: 在 Unity 中使用 Wwise Addressables Package

在 Unity 中使用 Wwise Addressables Package

关于 Unity Addressables

Unity Addressables 是一个围绕 AssetBundle 构建的系统，用于将游戏素材与玩家内容分开打包。 该系统在 DLC 开发当中特别有用，方便将额外的素材存储到外部服务器上。

对于刚开始使用 Addressables 的用户，建议先参阅官方文档和相关教程。

要设置 Wwise Unity Addressables Package，建议从这里开始：

  • Installing the Wwise Unity Addressables Package
  • DLC 打包基础教程

以下章节介绍了如何使用 Wwise Addressables Package：

  1. Addressables 系统特别注意事项
  2. 已知问题和限制
  3. Wwise Addressable 示例
  4. Wwise Addressables 素材详解
    1. SoundBank 和 AddressableSoundBank
    2. Addressable Bank Manager
    3. WwiseBankReference
    4. Wwise 素材导入程序
    5. 流播放媒体
注意： 此 Package 为实验包。 作为 Unity Integration 的新增功能，对 Addressables 的支持可能会有变更。
注意： 不支持 Unity 2018。 鉴于在 Unity 2018 中使用外部包比较容易出现问题，我们不保证此数据包能在 2019 之前的 Unity 版本中正常使用。

Addressables 系统特别注意事项

在使用 Addressables 系统时应特别注意以下事项：

  • “使用 Addressables 加载素材”本身属于异步操作：倘若加载的 SoundBank 和发送的 Event 被关联到了同一 Trigger，有可能会出现问题。在需要精确设定 Event 时机的情况下，建议先加载 SoundBank，再触发关联 Event。Init Soundbank 是个特例，其必须在场景中的所有其他 SoundBank 之前加载。若以远程方式更新 Init Soundbank 素材，则在场景启动并加载 SoundBank 时会稍有延迟，因为要先使用 Addressables 从 Web 服务器获取新的 Init Soundbank。
  • 不可在场景中直接引用 Addressables 素材：Addressables 素材必须使用 Addressables 系统在场景中动态加载。场景中直接引用的素材会构建到场景的 AssetBundle 中，而不会通过 Addressables 加载。若将素材直接放在场景中，同时使用 Addressables 打包该素材，则游戏数据中将会有两份不同的素材：场景的 AssetBundle 中一份，Addressables 分组的 AssetBundle 中一份。

已知问题和限制

  • 工程中的所有平台必须共用同一 Generated SoundBanks Path 根目录。
  • 在 Unity 工程中设置 Generated SoundBank Path 不会自动更改 External Source 的输出路径。
  • 暂不支持保存和加载 Decoded SoundBank。
  • 暂不支持 Prepared Event。
  • 暂不支持 External Source。

Wwise Addressable 示例

Wwise Addressables 示例 页面提供有关如何参照代码示例管理 Wwise Addressables 素材的附加信息。

Wwise Addressables 素材详解

Wwise 素材导入程序

在创建后，由 WwiseBankImporter 和 WwiseStreamingAssetImporter 类处理 .bnk 和 .wem 文件。 此脚本会创建包含所述文件二进制数据的素材。随后，我们的自定义素材后处理程序 WwiseBankPostProcess 会将新素材添加到相应平台的 Addressables 分组。 接着，针对每个平台将 Init SoundBank 添加到其各自的 Addressables 分组。之所以分开添加 Init SoundBank，是因为在发布后对工程实施更改（比如添加新的音频总线）时必须予以更新。 通过将 Init SoundBank 打包到各自的 Addressables 素材包，我们可以最大限度地缩短使用托管服务获取新版素材所需的时间。 若想自定义要将素材添加到哪个 Addressables 分组以及将哪些标签应用于素材，请参阅 Wwise Addressables 示例 页面。

SoundBank 和 AddressableSoundBank

素材后处理程序还会为工程中的每个 SoundBank 创建一个 WwiseAddressableSoundBank。 此素材包含用来将平台名称映射到相应 SoundBank 和流播放媒体素材的词典。

  • WwiseAddressableSoundBank 存放在 Generated SoundBanks 文件夹的根目录下。
  • WwiseAddressableSoundBank 类使用 AssetReferenceT 指向 SoundBank 和媒体文件。
  • 在构建工程时，将把 WwiseAddressableSoundBank 的 Current Platfrom Assets 字段设为目标构建平台。
注意： WwiseAddressableSoundBank 中 SoundBank 和流播放媒体的引用为软引用。这些文件将使用 Addressables 加载且必须打包到 Addressables 分组中。
注意： 若意外删除 WwiseAddressableSoundBank，则须删除并重新生成与之关联的 SoundBank，以便另行新建并正确设置引用。

Init Bank Holder

在针对 Init SoundBank 创建 WwiseAddressableSoundBank 时，将向场景中的 “WwiseGlobal” GameObject 添加 InitBankHolder 组件。 此组件只是简单地存储 WwiseAddressableSoundBank 以便 AddressableBankManager 轻松找到它。

Addressable Bank Manager

在使用 Wwise Addressables 时，由 AkAddressableBankManager 负责内存中 SoundBank 的加载和卸载。此类会存储对正在和已经加载的 AddressableSoundBank 的引用，并确保始终最先加载 Init SoundBank。 若在完成加载 SoundBank 前触发了 AkEvent，则此类将存储所触发调用的参数，并在加载 SoundBank 后再次触发相应的 Event。

在加载 SoundBank 时，将通过 Addressables 加载与当前平台对应的 SoundBank 素材。一旦完成加载便会锁定 SoundBank 数据，并使用 AkSoundEngine.LoadBankMemoryCopy() 将内存副本加载到声音引擎中。

在 Editor 中进入游戏模式时，将使用 AssetDatabase 而非 Addressables 来同步加载 SounBank。也就是说，只能在构建好的游戏中测试异步加载。

WwiseBankReference

WwiseBankReference 类用在 Ak.Wwise.Bank 组件的自定义检视器中。 WwiseBankReference 包含对 WwiseAddressableSoundBank 的硬引用。 在通过 AkAssetUtilities.AddressableBankUpdated 委托创建 WwiseAddressableSoundBank Asset 时，会更新此引用。 若在 WwiseAddressableSoundBank 之后创建 WwiseBankReference ，则将在 SoundBanks 文件夹中搜索与 SoundBank 名称匹配的 WwiseAddressableSoundBank 素材。 序列化的 WwiseBankReference 存储在 Assets\Wwise\ScriptableObjects\SoundBank 下。

备注： 游戏对象直接引用的素材会随该游戏对象一并打包。 AkBank 组件包含对 WwiseBankReference 的硬引用，WwiseBankReference 则包含对对应 WwiseAddressableSoundBank 的硬引用。 若将带有 AkBank 组件的游戏对象放在 Addressables 分组中，则将随之一并打包 WwiseBankReference 和 WwiseAddressableSoundBank（无须显式添加到分组中）。

流播放媒体

流播放媒体（.wem 文件）同样由 WwiseBankImporter 脚本处理。 WwiseAddressableSoundBank 包含一系列对 SoundBank 关联平台专用流播放媒体素材的引用。 在加载 SoundBank 时会通过 Addressables 加载媒体素材，并将其复制到 the Application.persistentDataPath 文件夹中。 若文件夹中已存在同名文件，则对两者的哈希值进行比对。若两个文件不同，则使用 AssetBundle 中的文件加以覆盖。


Wwise Unity Integration Documentation: Installing the Wwise Unity Addressables Package

Installing the Wwise Unity Addressables Package

目录

  • 通过 Unity Package Manager 和 GitHub 安装 Wwise Addressables Package
    • 更新 Wwise Unity Addressables Package
    • 与 Unity Addressables Package 的兼容性
    • 所需执行的附加步骤
  • 使用 Wwise Addressables Package 设置并构建脚本
  • 构建工程
  • 移除 Wwise Addressables Package

通过 Unity Package Manager 和 GitHub 安装 Wwise Addressables Package

Wwise Addressables Package 的官方存储目录为 https://github.com/audiokinetic/WwiseUnityAddressables。

  • 打开 Unity Package Manager，单击 + 图标并选择 Add package from git URL...。
  • 在文本字段中粘贴 https://github.com/audiokinetic/WwiseUnityAddressables.git，并单击 Add。

如需进一步了解如何使用 Git 存储库中托管的数据包，请参阅 Unity 文档。

备注： 若显示 No "git" executable was found 错误消息，则须将 git.exe 可执行文件存储目录添加到系统环境，并在必要时重启系统以使更改生效。
备注： 为确保能够正常使用 Wwise Addressables，须同时将 Unity Addressables Package 添加到工程中。该数据包被列为 Wwise Addressables Package 的依赖项，应当会自动安装。

更新 Wwise Unity Addressables Package

在更新到新的 Wwise 版本时，建议先更新 Unity Integration，再更新 Wwise Unity Addressables Package。

在发布 Wwise 小版本或大版本的同时，也会发布对 Wwise Unity Addressables Package 的更新。不过，不一定要那么频繁地进行更新。每项更新都标记有发布和测试时使用的 Wwise 版本。我们的目的是保证新的 Unity Integration 版本和老的 Wwise Unity Addressables Package 版本之间的兼容性（除非需要实施重大更改）。比如，Wwise Unity Integration 2021.1.7 及更高版本跟 21.1.7 标签之前的 Wwise Unity Addressables Package 版本之间是不兼容的。每个 GitHub 标签在存储库的版本页面上都有一个对应的条目，其描述了所作的更改以及版本兼容性。

与 Unity Addressables Package 的兼容性

Wwise Unity Addressables Package 应当与最新的 Unity Addressables Package 版本兼容。而且，跟老的版本应当也兼容。不过，1.16.0 之前的版本并未经过测试。在默认情况下，Wwise Unity Addressables Package 使用针对 Unity Integration 支持的最低 Unity 版本验证的最新版本 Addressables Package。有关支持的 Unity 版本列表，请参阅 版本说明 - Wwise Unity Integration 2022.1.2.8150.2694 章节。

所需执行的附加步骤

若使用 Unity 2018.x，请依次转到 Project Settings > Player > Other Settings，并将 AK_WWISE_ADDRESSABLES 和 UNITY_ADDRESSABLES 添加到 Scripting Define Symbols。

警告： 此数据包不受 Unity 2018 官方支持。如使用此版本，相关风险自负。

使用 Wwise Addressables Package 设置并构建脚本

步骤 1：在 Project Settings > Wwise Editor > Generated SoundBanks Path 中，设置所生成 SoundBank 的目标目录。

注意： 为了确保能够正常导入 SoundBank，请务必将此目录设在 Assets 文件夹内。
  • 在本例中，我们将目标目录设为 Assets\WwiseData\Banks。
  • 若更改此路径，则将自动修改 Wwise 中的输出目标目录。
  • 在执行此更改后打开 Wwise 设计工具时，将显示对话框并提示重新加载工程。

步骤 2：在 Wwise 设计工具内或使用 Wwise Picker 生成 SoundBank。

  • 这时 .bnk 和 .wem 文件的自定义素材导入程序将创建与所生成 SoundBank 和流播放媒体文件对应的 Unity 素材。
  • AddressableAssetsData 目录下会自动生成元数据文件和平台专用分组。
  • 您可以通过检查 Generated SoundBanks Path 下的文件来确认是否正确导入了素材。
  • 有关更多详细信息，请参阅 Wwise Addressables 素材详解 章节。

步骤 3：依次单击 Window > Asset Management > Addressables > Groups。这时将打开 Wwise Addressables Groups 窗口。

在默认情况下，会针对每个部署平台创建一个包含平台专用 SoundBank 素材的分组。 另外，还会针对每个部署平台创建仅包含 Init SoundBank 的单独分组。

若检视场景中的 WwiseGlobal 对象，会发现其添加了 Init Bank Holder 组件。

步骤 4：为 Addressables 创建 Wwise Build Script。

  • 建议将其与默认构建脚本一并放在 AddressableAssetsData/DataBuilders 下。
  • 在浏览器中任意位置右键单击，并依次选择 Create > Addressables > Content Builders > Wwise Build Script。
  • 这时将创建名为 BuildScriptWwisePacked 的素材。

步骤 5：检查 Addressables 设置。

  • 在默认情况下，其位于 AddressableAssetsData/AddressableAssetSettings
  • 从 Addressables Groups 窗口：Tools > Inspect System Settings
  • 从 Unity Editor：Window > AssetManagement > Addressables> Settings

步骤 6：将 BuildScriptWwisePacked 添加到 Addressables 构建脚本。 在 AddressableAssetSettings 所对应的 Inspector 中，将步骤 4 创建的 BuildScriptWwisePacked 素材添加到 Build and Play Mode 脚本。

构建工程

您可以在 Addressables Groups 窗口中使用 Wwise Build Script 构建 Addressables 素材包。 这样会在 Library\com.unity.Addressables\StreamingAssetsCopy\aa\<Platform Name> 下生成所有通用素材包（如 Default Local Group）及平台专用素材包。

注意： Wwise Build Script 会修改 WwiseData 分组架构的 Include in Build 属性。 若分组名称中带有 WwiseData，则只有该名称同时带有目标构建平台名称才会将其包含其中。 您可以在 BuildScriptWwisePacked.cs 脚本中修改此行为。 若要通过 Include in Build 属性手动控制将哪些分组包含在内，则可直接使用默认构建脚本。

一旦完成 Addressables 素材构建，就可以照常构建工程了。

注意： 在修改工程或向其添加新的 SoundBank 后，须重新构建 Addressables 分组。 此外，在切换平台后也要重新构建 Addressables 分组。

在构建目录下：

  • Addressables 素材包将被复制到 StreamingAssets\aa\ 。

移除 Wwise Addressables Package

在移除此数据包后，需执行一些附加步骤来确保 Wwise Integration 能够正常工作。

  • 从 Unity 素材文件夹中移除包含所生成 SoundBank 的文件夹。
  • 通过 Unity Package Manager 卸载数据包，或删除 <UnityProject>\Packages\manifest.json 文件中的对应行。
  • 在 Wwise Project Settings 中，将 SoundBank Paths 设为 Assets 之外的路径。
  • 重新生成 SoundBank。
  • 若仍使用 Unity Addressables Package，请务必清理 Addressables 分组。
备注： 若使用 Unity 2018，请依次转到 Project Settings > Player > Other Settings，并从 Scripting Define Symbols 中移除 AK_WWISE_ADDRESSABLES 和 UNITY_ADDRESSABLES。


Wwise Unity Integration Documentation: DLC 打包基础教程

DLC 打包基础教程

目录

  • 安装 Addressables Demo Scene
  • 快速入门
  • 通过 Addressables 加载素材
  • 通过 Addressables 加载场景
  • 更改语言
  • 设置 Addressables Hosting
  • 更新 Addressables 素材

在本例中，我们将展示如何将某些素材（如新的物品或角色）分开存放到使用 Addressables 打包的对应 DLC 素材包中。

安装 Addressables Demo Scene

若尚未在工程中设置 Wwise Unity Addressables Package，请参照 Installing the Wwise Unity Addressables Package 页面所述进行设置。

本教程中所用 Addressables Demo Scene 的官方存储目录为 https://github.com/audiokinetic/WwiseUnityAddressablesDemoScene。 该 Demo Scene 会用到 Unity Demo Game 中的素材，因此必须先通过 Audiokinetic Launcher 予以安装。

步骤：

  • 通过 Audiokinetic Launcher 安装最新 Unity Demo Game（版本不低于 2021.1.0）。
  • 将 Wwise Unity Addressables Demo Scene 克隆到所用电脑上。
  • 在 Unity 中打开 Demo Game。
  • 在 Unity Package Manager 中，将 Wwise Unity Addressables Package 添加到工程中（详见 通过 Unity Package Manager 和 GitHub 安装 Wwise Addressables Package 章节）。
  • 最后，使用 Package Manager 中的 Add package from disk 选项添加 Wwise Unity Addressables Demo Scene 数据包。
备注： 此数据包无法通过 Add package from git URL 来添加，因为这样安装的话会无法打开数据包中包含的场景。

快速入门

我们专门为此教程在 Wwise 工程中创建了两个音效、两个 Event 和一个 SoundBank。

我们使用 AkBank 和 AkEvent 组件创建了两个 GameObject Prefab：DlcAssetHighImpact 和 DlcAssetLowImpact。 这两个 Prefab 会加载 “DLC” SoundBank，并在实例化时播放对应的音效。

除此之外，我们还创建了两个场景：AddressablesDemoScene 和 AddressablesSubScene。 AddressablesDemoScene 是个简单的 Unity 场景，里面包含了一些互动按钮，方便测试 Addressables 素材的加载和卸载。 AddressablesSubScene 则是个仅包含 “DlcAssetLowImpact” Prefab 的场景。我们可使用其来对“通过 Addressables 加载包含 Wwise 对象的场景”进行测试。

备注： AddressablesDemoScene 还包含一个有关如何借助 Wwise Addressables Package 使用本地化语音并更改语言的示例。

所有这些素材以及下节所述脚本均存放在 WwiseUnityAddressablesDemoScene 数据包中。

您可以通过在对应 Inspector 中启用 Addressable 复选框来将以下三项标记为 Addressables 素材：

  • AddressablesSubScene.unity
  • Prefabs/DlcAssetHighImpact.prefab
  • Prefabs/DlcAssetLowImpact.prefab
注意： 若从工程中移除 Unity Addressables Package，则将从所有素材移除 Addressable 字段。在重新安装该数据包时，并不会保留该复选框的状态。

在 Addressables Groups 窗口内，可看到 Default Local Group 中默认替换了这些 Addressables 素材。

如需创建新的分组，可右键单击 Addressables Groups 窗口并选择 Create New Group，或从菜单中依次选择 Create > Group > Packed Assets。 为 DLC 素材创建两个新的分组：

  • DLC_Assets – 用于 Prefab 和子场景。
  • DLC_WwiseData_Windows – 用于平台专用 Soundbank 素材。
备注： 在本例中，我们只为 Windows 平台创建了一个附加 SoundBank 分组。不过，一般来说每个所要部署到的平台都要创建一个。
  • 将 DlcAssetHighImpact、DlcAssetLowImpact 和 AddressablesSubScene 从 Default Local Group 移到 DLC_Assets 分组。
  • 将平台专用 “DLC” SoundBank 素材从 WwiseData_Windows 移到 DLC_WwiseData_Windows 分组。
备注： 我们确保了会在平台专用分组名称中包含字符串 WwiseData 和平台名称 Windows，以便在构建 Addressables 时由 BuildWwiseData 脚本正确地进行处理。

在 Addressables Groups 窗口中，将 Play Mode Script 设为 Use Existing Build，并通过 Wwise Build Script 构建新的 Addressables 数据包（如 构建工程 章节所述）。

现在，打开 AddressablesDemoScene。

通过 Addressables 加载素材

在此场景中，有两个按钮：

  • 左侧按钮用于通过 Addressables 加载 “DlcAssetHighImpact” Prefab 并将其实例化。
  • 右侧按钮用于加载 AddressableSubScene 并将其实例化。
  • 此场景包含 DlcAssetLowImpact 素材。

若检视 “Loading DLC Assets Demo” GameObject，会看到我们创建了一个 AssetLoader 对象，并且其包含 AddressablePrefabLoader 组件。

using UnityEngine;
using UnityEngine.AddressableAssets;
using UnityEngine.ResourceManagement.AsyncOperations;
public class AddressablePrefabLoader : MonoBehaviour
{
public AssetReference reference;
public void Load()
{
Addressables.LoadAssetAsync<GameObject>(reference).Completed += asyncOp =>
{
if (asyncOp.Status == AsyncOperationStatus.Succeeded)
{
Instantiate(asyncOp.Result,this.transform);
}
};
}
}

此组件包含 AssetReference。我们已在对应 Inspector 中将其设为 “DlcAssetHighImpact” Prefab。

在运行游戏并按下左侧按钮时，将调用 AddressablePrefabLoader 上的设定 Load 方式：从 DLC_Assets 加载，并将 “DlcAssetHighImpact” Prefab 实例化。 一旦实例化，AkBank 组件便会从 DLC_WwiseData_Windows 素材包加载 SoundBank。

通过 Addressables 加载场景

若检视 “Loading DLC Scene Demo” GameObject，会看到我们创建了一个 SceneLoader 对象，并且其包含 AddressableSceneLoader 组件。

using UnityEngine;
using UnityEngine.AddressableAssets;
using UnityEngine.ResourceManagement.AsyncOperations;
using UnityEngine.ResourceManagement.ResourceProviders;
using UnityEngine.SceneManagement;
public class AddressableSceneLoader : MonoBehaviour
{
public AssetReference scene;
private AsyncOperationHandle<SceneInstance> sceneHandle;
public void Awake()
{
DontDestroyOnLoad(gameObject);
}
public void LoadScene()
{
if (!sceneHandle.IsValid() )
{
scene.LoadSceneAsync( LoadSceneMode.Additive).Completed += SceneLoadComplete;
}
else
{
UnloadScene();
}
}
public void UnloadScene()
{
Addressables.UnloadSceneAsync(sceneHandle).Completed += op =>
{
if (op.Status == AsyncOperationStatus.Succeeded)
{
Debug.Log("Successfully unloaded scene");
}
};
}
private void SceneLoadComplete(AsyncOperationHandle<SceneInstance> obj)
{
sceneHandle = obj;
if (obj.Status == AsyncOperationStatus.Succeeded)
{
Debug.Log(obj.Result.Scene.name + " successfully loaded");
}
}
}

此组件使用 AssetReference 保存对 AddressablesSubScene 的引用。 在第一次按下按钮时，会调用 LoadSceneMethod，进而采用 LoadSceneAsync 方式加载场景，并将其添加到当前场景中。 在第二次按下按钮时，将卸载场景。

AddressablesSubScene 仅包含 “DlcAssetLowImpact” Prefab，其在实例化时会加载 “DLC” Soundbank 并播放对应的 Event。

更改语言

在此场景中的第三个示例中，可在 English 和 French 之间切换语言，并播放本地化声音样本。 此示例使用 AkWwiseSetLocalization 脚本。在按下绿色或蓝色按钮时，会调用 AkAddressableBankManager.SetLanguageAndReloadLocalizedBanks 函数，并将语言更改为 English 或 French。

此函数执行以下操作：

  • 卸载所有本地化 SoundBank
  • 卸载 Init SoundBank
  • 使用 AkSoundEngine.SetCurrentLanguage 设置语言
  • 重新加载 Init SoundBank
  • 重新加载本地化 SoundBank
using UnityEngine;
public class AkWwiseSetLocalization : MonoBehaviour
{
public string LanguageString;
public void SetLanguage()
{
Debug.Log($"Setting language to {LanguageString}");
AK.Wwise.Unity.WwiseAddressables.AkAddressableBankManager.Instance.SetLanguageAndReloadLocalizedBanks(LanguageString);
}
}

接下来便可构建 AddressablesDemoScene 并测试按钮，以此确保构建好的游戏能够正常加载这些素材。

设置 Addressables Hosting

下面我们来配置 Unity 以使用内置托管服务处理 Addressables DLC 素材。这样无需重新构建玩家内容便可对“通过 Addressables 更新素材”进行测试。

首先，构建 AddressablesDemoScene，并确保其能够正常工作。 在构建窗口中，须通过 Add open scenes 按钮添加 AddressablesDemoScene，并选择将其作为所要构建的场景。

接着，我们来配置 Addressables Hosting（可从 Tools 菜单访问）。

下面来创建 Local Hosting 服务，并选中 Enable 复选框以启用该服务。

通过菜单打开 Addressables Profiles 窗口 (Profile > Manage Profiles)，并新建一个名为 Editor Hosted 的配置文件。

然后，将 Path 分别设为：

  • LocalBuildPath：HostedData/[BuildTarget]
  • LocalLoadPath：http://[PrivateIpAddress]:[HostingServicePort]
  • RemoteBuildPath：HostedData/[BuildTarget]
  • RemoteLoadPath：http://[PrivateIpAddress]:[HostingServicePort]

然后，通过右键单击 Editor Hosted 并选择 Set Active 来激活此配置文件。

备注： 有关如何使用 Addressables 托管服务的详细信息，请参阅官方文档。

检视 DLC_WwiseData_Windows 分组素材，并确保已更新其 Build Path 和 Load Path。

打开 Addressable Asset Settings，并启用 Build Remote Catalog 。分别将 Build Path 和 Load Path 设为 LocalBuildPath 和 LocalLoadPath。

使用 Wwise Build Script 重新构建 Addressables 素材。注意要在 <Unity Project Path>\HostedData 下创建新的 Addressables 素材包。

接下来重新构建 AddressablesDemoScene 以测试是否能够正常处理素材。

打开 Addressables Hosting 窗口，来在运行游戏时查看传入请求。在第一次按下按钮时，窗口底部的事件日志中应会显示请求。

更新 Addressables 素材

下面我们来使用 Addressables 更新 DlcAssetHighImpact 音效。

首先，在 Wwise 中调节 imp_axe_stone_high 声音样本的 Pitch 值来使变化更加明显。然后，重新生成 SoundBank。

然后，在 Addressables Groups 窗口中依次选择 Build >Update a previous build。在打开的选择窗口中，在 AddressableAssetsData/Windows 下选择 addressables_content_state.bin 文件。

最后，再次运行构建好的游戏（无需重新构建）。在打开时，应会在 Addressables Hosting 窗口中看到目录更新请求。

这时按下左侧按钮，应会听到按照新 Pitch 值播放的音效。

有关 Addressables 目录和预定开发周期的详细信息，请参阅官方文档。

备注： 此教程中提供的脚本仅可满足对“通过 Addressables 加载素材”进行测试的最低要求。 在自己的工程中加载素材时，最好选用更为稳妥的解决方案。 如需查看更多进阶示例，请转至 Unity Addressables Sample 存储库。
AK
Definition: AkWwiseAcousticTexture.cs:21
AK.Wwise
Definition: AkWwiseAcousticTexture.cs:21


Wwise Unity Integration Documentation: Wwise Addressables 示例

Wwise Addressables 示例

目录

  • Wwise Addressable Asset Metadata Preserver
    • 工作原理
    • 示例代码

Wwise Addressable Asset Metadata Preserver

在使用 Wwise Addressables 素材时，要想确保更新 WwiseAddressableBank 素材，最简单的方法是删除生成的 SoundBanks 文件夹并重新生成 SoundBank。在删除 Addressables 素材时，会清除 Addressables 分组的内容。在重新导入时，其父组和标签将会丢失。Wwise Unity Addressables Package 中包含的这个示例脚本提供相应功能来保留 Addressables 素材元数据（如父组和标签）。

工作原理

我们添加了一项可选设置可供启用来帮助恢复丢失的分组和标签。该设置可在 Unity 工程设置的 Wwise Addressables 下找到。在启用后，可指定元数据的目标目录。此目录应设在 Unity 工程的 Assets 文件夹内。

WwiseAssetMetadataPreserver 脚本会在 Assets/Wwise/Addressables 下添加一个菜单触发器，以便保存工程中所有 Wwise Addressables 素材的元数据。在触发时，会针对每个 Wwise Addressables 素材创建 AddressableMetadata 素材，并将父组和标签的名称序列化。脚本还会通过 WwiseBankPostProcess.GetAssetMetadataDelegate 函数对自身进行注册。此委托允许外部代码在通过 WwiseBankPostProcess 自定义导入器导入时填入用于设置素材字段的元数据结构。该导入器会在添加到 Unity 工程时导入 .bnk 和 .wem 文件。

借助这两种机制，可在执行清理前将素材元数据序列化，并在生成 Soundbank 后重新导入时重新应用于素材。

备注：

此脚本只是为了展示如何做到这一点。您可以根据自身制作要求来编写元数据填入代码。

示例代码

#if AK_WWISE_ADDRESSABLES && UNITY_ADDRESSABLES
using UnityEditor.AddressableAssets;
using UnityEditor.AddressableAssets.Settings;
using System.Collections.Generic;
using UnityEditor;
using UnityEngine;
using System.IO;
namespace AK.Wwise.Unity.WwiseAddressables
{
/*
此类提供相应功能来保留并恢复 Wwise Addressables 素材分组和标签元数据。
在删除素材时，此信息会丢失。要想修复损坏的 WwiseAddressableSounbanks，最简单的方法是清除 Wwise Addressables 素材文件夹。
此类只是为了展示如何实现这一功能，并不是一个完善的解决方案。
*/
[InitializeOnLoad]
class WwiseAddressableAssetMetadataPreserver
{
static WwiseAddressableAssetMetadataPreserver()
{
if (AkAddressablesEditorSettings.Instance.UseSampleMetadataPreserver)
{
BindMetadataDelegate();
}
}
//在 WwiseBankPostProcess AssetPostProcessor 上设置 GetAssetMetadataDelegate（处理 .bnk 和 .wem 文件的导入）
public static void BindMetadataDelegate()
{
WwiseBankPostProcess.GetAssetMetadataDelegate += GetMetadata;
}
//取消设置委托（在禁用功能时）
public static void UnbindMetaDataDelegate()
{
WwiseBankPostProcess.GetAssetMetadataDelegate -= GetMetadata;
}
为每个 Wwise Addressables 素材创建 AddressableMetadata 素材来追踪分组和标签。
//按照与 Wwise 素材匹配的层级结构来在对应文件夹下创建元数据素材
//文件夹层级结构和素材名称用于在导入时与素材进行匹配
[UnityEditor.MenuItem("Assets/Wwise/Addressables/Serialize addressable asset metadata")]
public static void PreserveAllWwiseAssetMetadata()
{
AddressableAssetSettings addressableSettings = AddressableAssetSettingsDefaultObject.Settings;
foreach (AddressableAssetGroup group in addressableSettings.groups)
{
foreach (AddressableAssetEntry assetEntry in group.entries)
{
if (assetEntry.MainAsset)
{
if (assetEntry.MainAsset.GetType().IsSubclassOf(typeof(WwiseAsset)))
{
CreateMetadataAsset(assetEntry.AssetPath, assetEntry.labels, group.name);
}
}
}
}
}
[UnityEditor.MenuItem("Assets/Wwise/Addressables/Preserve addressable asset metadata", true)]
public static bool ValidatePreserveAllWwiseAssetMetadata()
{
return AkAddressablesEditorSettings.Instance.UseSampleMetadataPreserver;
}
//创建必要的子文件夹和元数据素材
public static void CreateMetadataAsset(string assetPath, HashSet<string> assetLabels, string groupName)
{
string soundbankPath = assetPath.Replace(AkAssetUtilities.GetSoundbanksPath(), "");
var splitBankPath = soundbankPath.Split('/');
AddressableMetadata metaDataAsset = ScriptableObject.CreateInstance<AddressableMetadata>();
metaDataAsset.labels = new List<string>(assetLabels);
metaDataAsset.groupName = groupName;
var rootPath = AkAddressablesEditorSettings.Instance.MetadataPath;
if (!Directory.Exists(Path.Combine(Application.dataPath, rootPath)))
{
UnityEditor.AssetDatabase.CreateFolder("Assets", rootPath);
}
for (int i = 1; i < splitBankPath.Length - 1; i++)
{
if (!Directory.Exists(Path.Combine(Application.dataPath, Path.Combine(rootPath, splitBankPath[i]))))
{
AssetDatabase.CreateFolder(Path.Combine("Assets", rootPath), splitBankPath[i]);
}
rootPath = Path.Combine(rootPath, splitBankPath[i]);
}
string assetMetadataPath = Path.Combine("Assets", rootPath, Path.GetFileNameWithoutExtension(assetPath) + ".asset");
AddressableMetadata oldAsset = AssetDatabase.LoadAssetAtPath<AddressableMetadata>(assetMetadataPath);
if (oldAsset)
{
if (!metaDataAsset.IsDifferent(oldAsset))
{
return;
}
}
UnityEditor.AssetDatabase.CreateAsset(metaDataAsset, assetMetadataPath);
}
我们可以根据平台和语言来确定元数据素材的存放位置。
public static AddressableMetadata FindMetadataAsset(string assetName, string platformName, string languageName)
{
string MetadataAssetPath;
if (languageName !="SFX")
{
MetadataAssetPath = Path.Combine("Assets", AkAddressablesEditorSettings.Instance.MetadataPath, platformName, languageName, Path.GetFileNameWithoutExtension(assetName) + ".asset");
}
else
{
MetadataAssetPath = Path.Combine("Assets", AkAddressablesEditorSettings.Instance.MetadataPath, platformName, Path.GetFileNameWithoutExtension(assetName) + ".asset");
}
return AssetDatabase.LoadAssetAtPath<AddressableMetadata>(MetadataAssetPath);
}
//在导入 .bnk 和 .wem 文件时调用。将尝试查找并加载工程中存在的元数据对象。
public static bool GetMetadata(string assetName, string platformName, string languageName, ref AddressableMetadata metaData )
{
AddressableMetadata asset = FindMetadataAsset(assetName, platformName, languageName);
if ( asset )
{
metaData = asset;
return true;
}
return false;
}
}
}
#endif


Wwise Unity Integration Documentation: 故障排除

故障排除
  • Wwise Components/Types 显示的数据过时或不一致
  • 安装后的编译错误
  • 在 Unity 控制台中的 DllNotFoundException
  • 没有任何声音
  • 无法连接 Wwise Profiler
  • 安装过程中的错误 —— 在 Unity 控制台中访问路径被拒绝
  • 在用于 Mac 的 Wwise 上，在生成 SoundBank 过程中出现错误 —— 不能写入 Wwise_IDs.h
  • 错误：插件没有注册
  • 在 Mac 上，Unity Console 中显示 "Multiple plugins with the same name"
  • 在安装了 Google Play Services 的工程中无法整合或迁移 Wwise

Wwise Components/Types 显示的数据过时或不一致

若发现 Wwise Components（如 AkAmbient 或 AkState）丢失对 Wwise 对象的引用，则表示您可能将 AkWwiseProjectData.asset 添加到了版本控制系统中。若 AkWwiseProjectData.asset 被锁定（在将其添加到版本控制系统中时经常会出现此问题），则将按照 AkWwiseProjectData##.asset 形式创建新的文件。若出现这种情况，请将其全部删除，然后在 Wwise Picker 中单击 Auto populate，以便重新生成文件。

备注： 请不要将 AkWwiseProjectData.asset添加到版本控制系统中！ 它只是 Wwise 工程数据的临时缓存文件，目的在于避免 Wwise Picker 反复解析 Work Unit 文件。

安装后的编译错误

如果刚从以前的 Wwise 版本升级到了新版本，那么您可能会有重复的脚本。在版本 2013.2.8 中，UNITY_PROJECT_ROOT\Assets\Wwise\Deployment\Examples 文件夹重命名为 Components。如果您没有对 Examples 文件夹中的脚本作出任何更改，那么只需要删除它。

另外，如果您是在多个平台上开发，请确保已经为每个开发平台安装了 UnityPackage。有一些脚本是特定于平台的。

在 Unity 控制台中的 DllNotFoundException

如果您在 Windows 的 Unity 控制台中看到一个关于 AkSoundEngine 的 DllNotFoundException 消息，这可能是由两个缺失的依赖项引起的：

  • 确保您的机器上安装了DirectX。
  • 如果您正在使用 Wwise-Unity Integration 的 Debug config，那么还需要安装Microsoft Visual Studio 2010 Debug Redistributables。通常情况下，默认会安装 Profile 配置，所以这应该不是问题，除非您时手动安装的 Debug config。

没有任何声音

如果您在游戏中没有听到任何声音，请检查以下内容：

  • 如果在单机上运行游戏时没有声音，请试着在 Windows 或 Mac 的 Editor 中运行您的游戏。先在编辑器中解决问题会比较容易。
  • 确保您的 SoundBank 已经正确地生成了，并且 Unity 能够找到它们。如果您在编辑器中运行该游戏，那么集成将从 Wwise 工程中的 Generated SoundBanks 路径中寻找 SoundBank。如果没有找到，它接下来将会查看 StreamingAssets 文件夹。注意，如果您选择在 Wwise 中不沿用工程 SoundBank 路径，那么集成将无法自动加载它们。想了解关于该问题的更多信息，请参阅 为目标平台构建您的 Unity 游戏
  • 确保在发出任何其它音频调用之前，Sound Engine 已经正确地初始化了，并在所有引擎调用完成后，Sound Engine 终止了。您需要确保针对 AkInitializer 正确设置 Script Execution Order (Edit > Project Settings > Script Execution Order)。
  • Ensure that the Enable Auto-Defined SoundBanks option is deselected in the Wwise Project Settings dialog.
  • 确保 Unity Console 中没有报告错误。
  • 如果在运行游戏时连接到 Wwise Profiler（在 Wwise 中是 F7），那么在 Capture Log 中有错误报告吗？
  • 在 Wwise Profiler 的 SoundBank 选项卡中，您可以看到加载的库吗？如果看不到选项卡，打开 Profiling Settings（Alt-G）并启用 SoundBank。如果它们没有装载，应该检查您何时以及如何装载它们。查找 AkBank 组件和 AkSoundEngine.LoadBank 调用。
  • 在 Wwise Profiler 中，在 Capture Log 中，您可以看到预期要发布的 Event 吗？如果没有，您应该检查 SoundBank 是否包含这些 Event，以及它们是否正确加载了（请参阅前面的要点）。如果库已经被加载了，那么应该检查您游戏脚本中的 AkEvent，AkAmbient 组件和 AkSoundEngine.PostEvent 调用。

无法连接 Wwise Profiler

如果您的游戏运行在 Windows 上，请检查以下内容：

  • 验证 Unity 中， Run in background 设置已经启用（menu File > Build Settings > Player Settings）。
  • 验证您机器上的防火墙允许端口 24024，以及 Wwise 设置为一个特例。如果防火墙被禁用了，那么就不是这个问题了。
  • 您正在运行 Wwise-Unity Plug-in 的哪个配置？只有 Debug 和 Profile 启用了通信代码。
  • 打开 Task Manager，杀死任何名为 "adb.exe" 的进程。这是 Android 驱动程序，它锁定 TCP 端口。即使您开发的不是 Android 系统或连接了任何 Android 设备，这都是一定的。（这是 Google 的问题。）

如果您的游戏在另一台计算机或控制台上运行，请检查以下内容：

  • 您的 Wwise 电脑和游戏机在同一子网上吗？如果没有，游戏将不会出现在 Remote Connection 对话框中。手动输入 IP，和 Connect To IP 按钮。
  • 您的网络允许端口 24024 上的 traffic 或动态端口分配吗？

安装过程中的错误 —— 在 Unity 控制台中访问路径被拒绝

如果您在 Unity 控制台中看到 Wwise: Error during installation: Access to the path is denied 消息，请检查以下内容：

  • 您是否立即尝试过从 Assets > Wwise > Install Plugins 菜单安装一个新的插件配置（ Debug ， Profile ， Release ）：
    • 从 Wwise Setup 窗口安装新的 Unity Integration？
    • 在 Unity Editor 中预览一个 Scene？
  • 立即重新打开您的 Unity 工程并安装新的 Plug-in 配置（ Debug ， Profile ， Release ）。

在用于 Mac 的 Wwise 上，在生成 SoundBank 过程中出现错误 —— 不能写入 Wwise_IDs.h

如果在使用用于 Mac 的 Wwise，在生成 SoundBank 过程中您看到一个错误，即不能写入 Wwise_IDs.h，那么检查如下内容：

  • 打开 Wwise 工程。
  • 在工程设置中，前往 SoundBanks 选项卡。
  • 将 Header file path 设置到 SoundBank 生成的地方。

错误：插件没有注册

您的 Wwise 工程使用了一个需要授权的插件，而它还没有包含在您的 AkSoundEngine 动态库中。请参阅 添加插件 。

在 Mac 上，Unity Console 中显示 "Multiple plugins with the same name"

使用用于 Mac 的 Unity，在导入 Integration 时，Unity Console 可能会显示很多如下的错误：

Multiple plug-ins with the same name 'aksoundengine' (found at 'Assets/Wwise/API/Runtime/Plugins/Mac/Release/AkSoundEngine.bundle' and 'Assets/Wwise/API/Runtime/Plugins/Mac/Debug/AkSoundEngine.bundle'). 这意味着一个或多个插件将设置为与 Editor 兼容。Editor 一次只能使用一个插件。

这些错误可以被忽略，这很安全，因为安装过程将正确地激活正确的插件。

在安装了 Google Play Services 的工程中无法整合或迁移 Wwise

在将构建目标设为 Android 时，在安装了 Google Play Services 的 Unity 工程中，Audiokinetic Launcher 无法整合或迁移 Wwise。若要摆脱此限制，请打开 Unity 工程并将构建目标设为 Android 以外的平台，然后关闭 Unity 并通过 Launcher 重新实施整合或迁移。


Wwise Unity Integration Documentation: WAAPI 实用工具

WAAPI 实用工具

自 2018.1 版本起，我们将对 Wwise Authoring API (WAAPI) 的支持嵌入到了 Unity Integration 中（有关详细信息，请参阅使用 Wwise Authoring API (WAAPI)）。 在 2021.1 版本中，为了更好地整合 Wwise Picker 并提高整体的易用性，我们对 Wwise Authoring API (WAAPI) 进行了重新设计。 有关如何结合 Wwise Picker 使用 WAAPI 的详细信息，请参阅 Wwise Picker 文档页面。

  1. WAAPI 设置
    1. 故障排除
  2. 在 Unity 中使用 WAAPI
    1. 使用 WAAPI 获取 Wwise 对象
    2. 订阅主题
    3. 断开连接
    4. 其他 WAAPI 命令

WAAPI 设置

WAAPI 设置可在 Project Settings > Wwise Editor > Wwise Authoring API 中找到。

若未选中 Connect to Wwise 复选框，则将禁用 WAAPI 功能。 在默认情况下，WAAPI 客户端会连接到本地主机 (127.0.0.1) 上的 8080 端口。 若在连接 WAAPI 时更改这些设置，则将关闭当前连接并尝试连接到新的目标地址。

故障排除

下面列出了无法正常连接到工程时的一些解决方案。

  • 检查是否在 Wwise 设计工具中打开了正确的工程。
  • 检查 Project Settings > Wwise Editor > Wwise Project 中的 Wwise Project Path 是否正确。
  • 若打开了多个 Wwise 设计工具实例，则其中一个可能会阻断另一个的 WAAPI 端口。
  • 检查是否在 Wwise 设计工具中启用了 WAAPI，以及允许的连接和端口有无错误。
    • WAAPI 设置可在 User Preferences 中找到。

在 Unity 中使用 WAAPI

AKWaapiClient 类通过 WebSocket 连接与 Wwise 设计工具进行通信。WAAPI 消息为 JSON 对象。 WAAPI 调用为异步操作。因为对 WAAPI 的调用可能来自 GUI 之类的线程，而我们不能无限期地等待其作出响应。 WebSocket 实现也只能等待一次作出一个响应。为此，我们使用 AkWaapiUtilities 类对 WAAPI 客户端进行了封装。 此类提供一系列函数来创建 WAAPI 请求并予以排序，然后在更新循环过程中按次序加以调用。 WAAPI 请求封装在 WaapiCommand 中，其仅包含异步函数指针负载。在接收命令时，将执行其负载。

AkWaapiUtilities 中内置的函数应可满足大部分需求。若想按其他方式使用 WAAPI，则不妨自行加以实现。有关详细信息，请参阅 其他 WAAPI 命令 章节。

注意： 大部分内置 WAAPI 调用使用 Wwise Authoring Query Language (WAQL)。 有关 WAQL 的详细信息，请参阅 WAQL 简介和 WAQL 参考页面。

使用 WAAPI 获取 Wwise 对象

AkWaapiUtilities 已经包含用来获取 Wwise 对象的内置 WAAPI 调用：

  • AkWaapiUtilities.GetWwiseObject<T>
  • AkWaapiUtilities.GetWwiseObjectAndDescendants<T>
  • AkWaapiUtilities.GetWwiseObjectAndAncestors<T>
  • AkWaapiUtilities.Search<T>
  • AkWaapiUtilities.GetChildren<T>

这些调用会返回一系列包含返回选项中所指定属性的对象。如需查看返回选项的完整列表，请参阅 WAAPI 文档。

Wwise Picker 使用 WwiseObjectInfoJsonObject 作为这些函数的模板类型。这些对象随后会由 AkWaapiUtilities.ParseObjectInfo 转换为 WwiseObjectInfo。

若要获取未包含在 WwiseObjectInfo 中的对象属性，则需为所要访问的属性创建一个自定义类。 比如，若只想获取 Notes 字段，则可按照以下方式创建类：

public class WwiseObjectNotes
{
public string notes;
}

随后便可调用 AkWaapiUtilities.GetWwiseObject<T>（或前面列出的任何其他函数），来使用 ReturnOptions 对象仅列出 Notes 字段，同时通过回调来接收一系列 WwiseObjectNotes。

{
var callback = ( List<WwiseObjectNotes> notes ) => {
// do something
};
var options = new ReturnOptions(new string[] { "notes" });
var objectGuid = System.Guid.Empty(); //Put an actual guid from your project here
AkWaapiUtilities.GetWwiseObject<WwiseObjectNotes>( objectGuid, options, callback);
}

AkWwiseTreeWAAPIDataSource 类包含多个有关如何使用 WAAPI 获取 Wwise 对象以填充 Wwise Picker 的示例。

订阅主题

您可以使用 AkWaapiUtilities.Subscribe 订阅 WAAPI 主题。 URI 会识别所要订阅的主题。回调参数将以函数形式接收 JSON 字符串参数以供发布主题时调用。 在成功注册订阅时会调用 handshakeCallback。它将接收包含订阅标识符的 AkWaapiUtilities.SubscriptionInfo 对象。 请求订阅的类应当存储此信息。

注意： 调用 AkWaapiUtilities.Subscribe 的类负责在其生命周期结束时清理订阅。 此操作通过调用 AkWaapiUtilities.Unsubscribe 来实现。

有关 Integration 中所用订阅的示例，请参阅 AkWwiseTreeWAAPIDataSource 类。

  • AkWwiseTreeWAAPIDataSource.SubscribeTopics
  • AkWwiseTreeWAAPIDataSource.UnsubscribeTopics

有关可用对象的详细信息，请参阅 >Wwise Authoring API 参考。

  • 大部分主题 URI 可在 Uri.cs 中找到。

断开连接

在将要或突然关闭 WAAPI 连接时，将调用 AkWaapiUtilities.Disconnection 委托。 该委托的布尔参数会指示连接是否仍处于激活状态。

备注： 应将订阅 WAAPI 主题的类与此委托绑定，以确保其能够在连接中断前取消订阅。

其他 WAAPI 命令

AkWaapiUtilities 类包含以下附加函数。您可以利用其在 Unity 内与 WAAPI 工程进行交互。

  • AkWaapiUtilities.SelectObjectInAuthoring
  • AkWaapiUtilities.OpenWorkUnitInExplorer
  • AkWaapiUtilities.OpenSoundBankInExplorer
  • AkWaapiUtilities.Rename
  • AkWaapiUtilities.Delete
  • AkWaapiUtilities.TogglePlayEvent
  • AkWaapiUtilities.StopAllTransports

您可以在 AkWwisePicker 和 AkWwiseTreeView 中找到这些命令的使用示例。

若所要执行的 WAAPI 命令尚未整合到 AkWaapiUtilities 中，则不妨根据需要自行创建相应的命令。 为了开始进行 WAAPI 调用并接收响应，必须构建并解析 JSON 参数。

对于无需通过响应解析数值的命令，使用 AkWaapiUtilities.QueueCommand

对于需要通过响应解析数值的命令，使用 AkWaapiUtilities.QueueCommandWithReturnType<T>

利用 Unity JsonUtility 类，可以轻松地在 C# 类和 JSON 字符串之间进行转换。对于必须转换成 JSON 字符串的参数和选项，使用 JsonSerializable 作为基类。

public class JsonSerializable
{
public static implicit operator string(JsonSerializable o) => UnityEngine.JsonUtility.ToJson(o);
}

然后，可对此类进行扩展，以便提供用于特定 WAAPI 模式的 C# 封装器。如需查看相关使用示例，可参阅我们如何使用 WAAPI 创建所需架构类来播放 Event 并订阅 Transport：

参数和选项架构

  • ArgsPlay
  • ArgsObject
  • TransportOptions

返回的对象架构

  • ReturnTransport
  • TransportState

您可以在 AkWaapiUtilities.TogglePlayWwiseEventAsync 和 AkWaapiUtilities.CreateTransport 中查看相关使用示例。

JsonSerializable
Base class for Json serializable objects. Implements implicit cast to string using UnityEngine....
Definition: AkWaapiHelper.cs:26
ReturnOptions
WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects.
Definition: AkWaapiHelper.cs:149
AkWaapiUtilities
This class wraps the client that communicates with the Wwise Authoring application via WAAPI....
Definition: AkWaapiUtilities.cs:34


Wwise Unity Integration Documentation: 命名空间列表

命名空间列表
这里列出了所有文档化的命名空间定义,附带简要说明:
[详情级别 12]
▼N AK
N Wwise


Wwise Unity Integration Documentation: AK 命名空间参考

命名空间
AK 命名空间参考


Wwise Unity Integration Documentation: AK.Wwise 命名空间参考

  • AK
  • Wwise
类
AK.Wwise 命名空间参考

类

class | AcousticTexture
This type represents an Acoustic Texture. 更多...
class | AuxBus
This type represents an auxiliary send in the Master-Mixer Hierarchy. 更多...
class | Bank
This type can be used to load/unload SoundBanks. 更多...
class | BaseGroupType
This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch. 更多...
class | BaseType
This type represents the base for all Wwise Types that require a GUID. 更多...
class | CallbackFlags
This type represents the values of the flags used when posting an Event with a callback. 更多...
class | Event
This type can be used to post Events to the sound engine. 更多...
class | RTPC
This type can be used to set game parameter values to the sound engine. 更多...
class | State
This type can be used to set Wwise States. 更多...
class | Switch
This type can be used to set Switch values on gameobjects. 更多...
class | Trigger
This type can be used to post triggers to the sound engine. 更多...


Wwise Unity Integration Documentation: 类列表

类列表
这里列出了所有类、结构、联合以及接口定义等，并附带简要说明:
[详情级别 123]
▼N AK |
▼N Wwise |
C AcousticTexture | This type represents an Acoustic Texture
C AuxBus | This type represents an auxiliary send in the Master-Mixer Hierarchy
C Bank | This type can be used to load/unload SoundBanks
C BaseGroupType | This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch
C BaseType | This type represents the base for all Wwise Types that require a GUID
C CallbackFlags | This type represents the values of the flags used when posting an Event with a callback
C Event | This type can be used to post Events to the sound engine
C RTPC | This type can be used to set game parameter values to the sound engine
C State | This type can be used to set Wwise States
C Switch | This type can be used to set Switch values on gameobjects
C Trigger | This type can be used to post triggers to the sound engine
C ak | URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation
C AkAmbient | Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event
C AkAmbientLargeModePositioner | Use this component to add a Large Mode position to any AkAmbient in a Scene
C AkAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C AkBank | Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared
C AkEarlyReflections | Set an early reflections auxiliary bus and send volume for a particular game object
C AkEmitterObstructionOcclusion | Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them
▼C AkEnvironment | Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone)
C AkEnvironment_CompareByPriority | Sorts AkEnvironments based on their priorities
C AkEnvironment_CompareBySelectionAlgorithm | Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:
▼C AkEnvironmentPortal | Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone)
C EnvListWrapper | This enables us to detect intersections between portals and environments in the editor
C AkEvent | Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object
C AkEventCallbackMsg | Event callback information. Event callback functions can receive this structure as a parameter
C AkGameObj | This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise
C AkInitializer | This script deals with initialization, and frame updates of the Wwise audio engine. It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings
C AkListenerDistanceProbe | Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera
C AkMemBankLoader | This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory. This would be useful for situations where you use the WWW class
C AkRadialEmitter | A radial emitter is for sounds that are not point sources, but instead originate from a region of space
C AkRoom | An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals
C AkRoomAwareManager | This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit
C AkRoomAwareObject | This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component
C AkRoomManager | This manager tracks AkRoomPortals and the rooms that they connect (front and back room)
C AkRoomPortal | An AkRoomPortal can connect two AkRoom components together
C AkRoomPortalObstruction | Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them
C AkSpatialAudioDebugDraw | Add this script on a GameObject to print Spatial Audio paths
C AkSpatialAudioEmitter | (DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring
▼C AkSpatialAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C SpatialAudioListenerList | This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time
C AkState | This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it
C AkSurfaceReflector | This component converts the provided mesh into Spatial Audio Geometry
C AkSwitch | This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it
C AkTriggerBase | Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in 为 Wwise Events 添加新的 Trigger。
▼C AkWaapiUtilities | This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages
C SubscriptionInfo | Class used to store information about a specific subscription
C WaapiCommand | A simple structure containing an async payload function that will be executed when it is consumed by the command queue
C AkWwiseTreeWAAPIDataSource | This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions
C Args | Abstract base class for WAAPI command arguments
C ArgsCommand | WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync()
C ArgsDisplayName | WAAPI arguments containing an object identfier and name used when deleting an object
C ArgsObject | WAAPI arguments containing an object identfier
C ArgsPlay | WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback
C ArgsRename | WAAPI arguments containing an object identfier and new value used when renaming an object
C ArgsTransport | WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands
C ErrorDetails | Used to deserialize details in WAAPI error messages
C ErrorMessage | Used to deserialize WAAPI error messages
C JsonSerializable | Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson
C Options | Abstract base class for WAAPI command options
C ReturnOptions | WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects
C ReturnTransport | Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID
C ReturnWwiseObjects | Generic class to deserialize a WAAPI response containing Wwise objects with custom return options
C ReturnWwiseObjects | Class used to deserialize a WAAPI response containing Wwise objects
C SelectedWwiseObjects | Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic
C TransportOptions | WAAPI options used to specify the transport ID when subscribing
C TransportState | Used to deserialize transport-state information receieved from the transport.stateChanged topic
C WaapiHelper | Contains a helper function GetWwiseObjectTypeFromString
C WaapiKeywords | Contains fields for specific WAAPI keywords
▼C Wamp | WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise
C ErrorException | Exception thrown during WAMP operations
C TimeoutException | Exception thrown during WAMP operations when the timeout is reached
C WaqlArgs | WAAPI arguments containing a WAQL string
C WwiseChildModifiedInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics
C WwiseObjectInfo | Class containing the information returned by a WAAPI request for an object
C WwiseObjectInfoJsonObject | Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo
C WwiseObjectInfoParent | Contains the GUID of the returned object's parent
C WwiseRenameInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic


Wwise Unity Integration Documentation: AK.Wwise.AcousticTexture类 参考

  • AK
  • Wwise
  • AcousticTexture
所有成员列表
AK.Wwise.AcousticTexture类 参考

This type represents an Acoustic Texture. 更多...

类 AK.Wwise.AcousticTexture 继承关系图:
AK.Wwise.BaseType

详细描述

This type represents an Acoustic Texture.


Wwise Unity Integration Documentation: AK.Wwise.AuxBus类 参考

  • AK
  • Wwise
  • AuxBus
所有成员列表
AK.Wwise.AuxBus类 参考

This type represents an auxiliary send in the Master-Mixer Hierarchy. 更多...

类 AK.Wwise.AuxBus 继承关系图:
AK.Wwise.BaseType

详细描述

This type represents an auxiliary send in the Master-Mixer Hierarchy.


Wwise Unity Integration Documentation: AK.Wwise.Bank类 参考

  • AK
  • Wwise
  • Bank
所有成员列表
AK.Wwise.Bank类 参考

This type can be used to load/unload SoundBanks. 更多...

类 AK.Wwise.Bank 继承关系图:
AK.Wwise.BaseType

详细描述

This type can be used to load/unload SoundBanks.


Wwise Unity Integration Documentation: AK.Wwise.BaseGroupType类 参考

  • AK
  • Wwise
  • BaseGroupType
所有成员列表
AK.Wwise.BaseGroupType类 参考

This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch. 更多...

类 AK.Wwise.BaseGroupType 继承关系图:
AK.Wwise.BaseType AK.Wwise.State AK.Wwise.Switch

详细描述

This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch.


Wwise Unity Integration Documentation: AK.Wwise.BaseType类 参考

  • AK
  • Wwise
  • BaseType
所有成员列表
AK.Wwise.BaseType类 参考

This type represents the base for all Wwise Types that require a GUID. 更多...

类 AK.Wwise.BaseType 继承关系图:
AK.Wwise.AcousticTexture AK.Wwise.AuxBus AK.Wwise.Bank AK.Wwise.BaseGroupType AK.Wwise.Event AK.Wwise.RTPC AK.Wwise.Trigger AK.Wwise.State AK.Wwise.Switch

详细描述

This type represents the base for all Wwise Types that require a GUID.


Wwise Unity Integration Documentation: AK.Wwise.CallbackFlags类 参考

  • AK
  • Wwise
  • CallbackFlags
所有成员列表
AK.Wwise.CallbackFlags类 参考

This type represents the values of the flags used when posting an Event with a callback. 更多...

详细描述

This type represents the values of the flags used when posting an Event with a callback.


Wwise Unity Integration Documentation: AK.Wwise.Event类 参考

  • AK
  • Wwise
  • Event
Public 成员函数 | 所有成员列表
AK.Wwise.Event类 参考

This type can be used to post Events to the sound engine. 更多...

类 AK.Wwise.Event 继承关系图:
AK.Wwise.BaseType

Public 成员函数

uint | Post (UnityEngine.GameObject gameObject)
Posts this Event on a GameObject. 更多...
uint | Post (UnityEngine.GameObject gameObject, CallbackFlags flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject. 更多...
uint | Post (UnityEngine.GameObject gameObject, uint flags, AkCallbackManager.EventCallback callback, object cookie=null)
Posts this Event on a GameObject. 更多...
uint | Post (ulong gameObjectId)
Posts this Event on a GameObject ID. 更多...
void | ExecuteAction (UnityEngine.GameObject gameObject, AkActionOnEventType actionOnEventType, int transitionDuration, AkCurveInterpolation curveInterpolation)
Executes various actions on this event associated with a GameObject. 更多...
void | PostMIDI (UnityEngine.GameObject gameObject, AkMIDIPostArray array)
Posts MIDI Events on this Event associated with a GameObject. 更多...
void | PostMIDI (UnityEngine.GameObject gameObject, AkMIDIPostArray array, int count)
Posts MIDI Events on this Event associated with a GameObject. 更多...
void | StopMIDI (UnityEngine.GameObject gameObject)
Stops MIDI Events on this Event associated with a GameObject. 更多...
void | StopMIDI ()
Stops all MIDI Events on this Event. 更多...

详细描述

This type can be used to post Events to the sound engine.


Wwise Unity Integration Documentation: AK.Wwise.Event.ExecuteAction

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ ExecuteAction()

void AK.Wwise.Event.ExecuteAction | ( | UnityEngine.GameObject | gameObject,
 |  | AkActionOnEventType | actionOnEventType,
 |  | int | transitionDuration,
 |  | AkCurveInterpolation | curveInterpolation
 | ) |  |
inline

Executes various actions on this event associated with a GameObject.

参数
gameObject The GameObject
actionOnEventType
transitionDuration
curveInterpolation


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [1/4]

uint AK.Wwise.Event.Post ( ulong gameObjectId )
inline

Posts this Event on a GameObject ID.

参数
gameObjectId The GameObject ID
返回
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [2/4]

uint AK.Wwise.Event.Post ( UnityEngine.GameObject gameObject )
inline

Posts this Event on a GameObject.

参数
gameObject The GameObject
返回
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [3/4]

uint AK.Wwise.Event.Post | ( | UnityEngine.GameObject | gameObject,
 |  | CallbackFlags | flags,
 |  | AkCallbackManager.EventCallback | callback,
 |  | object | cookie = null
 | ) |  |
inline

Posts this Event on a GameObject.

参数
gameObject | The GameObject
flags
callback
cookie | Optional cookie received by the callback
返回
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.Post

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ Post() [4/4]

uint AK.Wwise.Event.Post | ( | UnityEngine.GameObject | gameObject,
 |  | uint | flags,
 |  | AkCallbackManager.EventCallback | callback,
 |  | object | cookie = null
 | ) |  |
inline

Posts this Event on a GameObject.

参数
gameObject | The GameObject
flags
callback
cookie | Optional cookie received by the callback
返回
Returns the playing ID.


Wwise Unity Integration Documentation: AK.Wwise.Event.PostMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ PostMIDI() [1/2]

void AK.Wwise.Event.PostMIDI | ( | UnityEngine.GameObject | gameObject,
 |  | AkMIDIPostArray | array
 | ) |  |
inline

Posts MIDI Events on this Event associated with a GameObject.

参数
gameObject | The GameObject
array | The array of AkMIDIPost that are posted.


Wwise Unity Integration Documentation: AK.Wwise.Event.PostMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ PostMIDI() [2/2]

void AK.Wwise.Event.PostMIDI | ( | UnityEngine.GameObject | gameObject,
 |  | AkMIDIPostArray | array,
 |  | int | count
 | ) |  |
inline

Posts MIDI Events on this Event associated with a GameObject.

参数
gameObject | The GameObject
array | The array of AkMIDIPost that are posted.
count | The number of elements from the array that will be posted.


Wwise Unity Integration Documentation: AK.Wwise.Event.StopMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ StopMIDI() [1/2]

void AK.Wwise.Event.StopMIDI ( )
inline

Stops all MIDI Events on this Event.


Wwise Unity Integration Documentation: AK.Wwise.Event.StopMIDI

  • AK
  • Wwise
  • Event
ExecuteAction
Post
Post
Post
Post
PostMIDI
PostMIDI
StopMIDI
StopMIDI

◆ StopMIDI() [2/2]

void AK.Wwise.Event.StopMIDI ( UnityEngine.GameObject gameObject )
inline

Stops MIDI Events on this Event associated with a GameObject.

参数
gameObject The GameObject


Wwise Unity Integration Documentation: AK.Wwise.RTPC类 参考

  • AK
  • Wwise
  • RTPC
所有成员列表
AK.Wwise.RTPC类 参考

This type can be used to set game parameter values to the sound engine. 更多...

类 AK.Wwise.RTPC 继承关系图:
AK.Wwise.BaseType

详细描述

This type can be used to set game parameter values to the sound engine.


Wwise Unity Integration Documentation: AK.Wwise.State类 参考

  • AK
  • Wwise
  • State
所有成员列表
AK.Wwise.State类 参考

This type can be used to set Wwise States. 更多...

类 AK.Wwise.State 继承关系图:
AK.Wwise.BaseGroupType AK.Wwise.BaseType

详细描述

This type can be used to set Wwise States.


Wwise Unity Integration Documentation: AK.Wwise.Switch类 参考

  • AK
  • Wwise
  • Switch
所有成员列表
AK.Wwise.Switch类 参考

This type can be used to set Switch values on gameobjects. 更多...

类 AK.Wwise.Switch 继承关系图:
AK.Wwise.BaseGroupType AK.Wwise.BaseType

详细描述

This type can be used to set Switch values on gameobjects.


Wwise Unity Integration Documentation: AK.Wwise.Trigger类 参考

  • AK
  • Wwise
  • Trigger
所有成员列表
AK.Wwise.Trigger类 参考

This type can be used to post triggers to the sound engine. 更多...

类 AK.Wwise.Trigger 继承关系图:
AK.Wwise.BaseType

详细描述

This type can be used to post triggers to the sound engine.


Wwise Unity Integration Documentation: ak类 参考

ak类 参考

URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation. 更多...

详细描述

URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation.


Wwise Unity Integration Documentation: AkAmbient类 参考

Public 属性 | 静态 Public 属性 | 所有成员列表
AkAmbient类 参考

Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event. 更多...

类 AkAmbient 继承关系图:
AkEvent

Public 属性

AkActionOnEventType | actionOnEventType = AkActionOnEventType.AkActionOnEventType_Stop
Replacement action. See AK::SoundEngine::ExecuteEventOnAction() 更多...
AkCurveInterpolation | curveInterpolation = AkCurveInterpolation.AkCurveInterpolation_Linear
Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction() 更多...
bool | enableActionOnEvent = false
Enables additional options to reuse existing events. Use it to transform a Play event into a Stop event without having to define one in the Wwise Project. 更多...
UnityEngine.GameObject | soundEmitterObject
Game object onto which the Event will be posted. By default, when empty, it is posted on the same object on which the component was added. 更多...
float | transitionDuration = 0.0f
Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction() 更多...
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 更多...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 更多...

静态 Public 属性

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 更多...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 更多...

详细描述

Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event.

参见
  • 在 Inspector 中使用 AkAmbient
  • AkGameObj
  • AkEvent
  • Integration Details - Events (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkAmbientLargeModePositioner类 参考

所有成员列表
AkAmbientLargeModePositioner类 参考

Use this component to add a Large Mode position to any AkAmbient in a Scene. 更多...

继承自 MonoBehaviour .

详细描述

Use this component to add a Large Mode position to any AkAmbient in a Scene.

参见
  • 在 Inspector 中使用 AkAmbient
  • AkAmbient


Wwise Unity Integration Documentation: AkAudioListener类 参考

所有成员列表
AkAudioListener类 参考

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's. 更多...

继承自 MonoBehaviour .

详细描述

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's.

参见
  • Integrating Listeners (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkBank类 参考

Public 成员函数 | Public 属性 | 静态 Public 属性 | 所有成员列表
AkBank类 参考

Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared. 更多...

继承自 AkTriggerHandler , 以及 AK.Wwise.IMigratable .

Public 成员函数

override void | HandleEvent (UnityEngine.GameObject in_gameObject)
Loads the SoundBank 更多...
void | UnloadBank (UnityEngine.GameObject in_gameObject)
Unloads a SoundBank 更多...

Public 属性

bool | decodeBank = false
Decode this SoundBank upon load 更多...
bool | loadAsynchronous = false
Check this to load the SoundBank in the background. Be careful, if Events are triggered and the SoundBank hasn't finished loading, you'll have "Event not found" errors. 更多...
bool | saveDecodedBank = false
Save the decoded SoundBank to disk for faster loads in the future 更多...
System.Collections.Generic.List< int > | unloadTriggerList
Reserved. 更多...
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 更多...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 更多...

静态 Public 属性

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 更多...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 更多...

详细描述

Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared.


Wwise Unity Integration Documentation: AkBank.HandleEvent

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ HandleEvent()

override void AkBank.HandleEvent ( UnityEngine.GameObject in_gameObject )
inline

Loads the SoundBank

引用了 decodeBank, loadAsynchronous , 以及 saveDecodedBank.


Wwise Unity Integration Documentation: AkBank.UnloadBank

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ UnloadBank()

void AkBank.UnloadBank ( UnityEngine.GameObject in_gameObject )
inline

Unloads a SoundBank


Wwise Unity Integration Documentation: AkBank.decodeBank

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ decodeBank

bool AkBank.decodeBank = false

Decode this SoundBank upon load

被这些函数引用 HandleEvent().


Wwise Unity Integration Documentation: AkBank.loadAsynchronous

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ loadAsynchronous

bool AkBank.loadAsynchronous = false

Check this to load the SoundBank in the background. Be careful, if Events are triggered and the SoundBank hasn't finished loading, you'll have "Event not found" errors.

被这些函数引用 HandleEvent().


Wwise Unity Integration Documentation: AkBank.saveDecodedBank

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ saveDecodedBank

bool AkBank.saveDecodedBank = false

Save the decoded SoundBank to disk for faster loads in the future

被这些函数引用 HandleEvent().


Wwise Unity Integration Documentation: AkBank.unloadTriggerList

  • AkBank
decodeBank
HandleEvent
loadAsynchronous
saveDecodedBank
UnloadBank
unloadTriggerList

◆ unloadTriggerList

System.Collections.Generic.List<int> AkBank.unloadTriggerList

Reserved.


Wwise Unity Integration Documentation: AkEarlyReflections类 参考

Public 属性 | 所有成员列表
AkEarlyReflections类 参考

Set an early reflections auxiliary bus and send volume for a particular game object. 更多...

继承自 MonoBehaviour .

Public 属性

AK.Wwise.AuxBus | reflectionsAuxBus = new AK.Wwise.AuxBus()
float | reflectionsVolume = 1

详细描述

Set an early reflections auxiliary bus and send volume for a particular game object.


Wwise Unity Integration Documentation: AkEarlyReflections.reflectionsAuxBus

  • AkEarlyReflections
reflectionsAuxBus
reflectionsVolume

◆ reflectionsAuxBus

AK.Wwise.AuxBus AkEarlyReflections.reflectionsAuxBus = new AK.Wwise.AuxBus()

The early reflections auxiliary bus for this particular game object. Geometrical reflection calculation inside spatial audio is enabled for a game object if any sound playing on the game object has a valid early reflections aux bus specified in the authoring tool, or if an aux bus is specified via this parameter. The early reflection auxiliary bus specified in the authoring tool has precedence. Users may apply this function to avoid duplicating sounds in the actor-mixer hierarchy solely for the sake of specifying a unique early reflection bus, or in any situation where the same sound should be played on different game objects with different early reflection aux buses (the early reflection bus must be left blank in the authoring tool if the user intends to specify it through the API).


Wwise Unity Integration Documentation: AkEarlyReflections.reflectionsVolume

  • AkEarlyReflections
reflectionsAuxBus
reflectionsVolume

◆ reflectionsVolume

float AkEarlyReflections.reflectionsVolume = 1

The early reflections send volume for this particular game object. This parameter is used to control the volume of the early reflections send. It is combined with the early reflections volume specified in the authoring tool, and is applied to all sounds playing on the game object. Setting to 0.f will disable all reflection processing for this game object. Valid range 0.f-1.f.


Wwise Unity Integration Documentation: AkEmitterObstructionOcclusion类 参考

Public 属性 | 所有成员列表
AkEmitterObstructionOcclusion类 参考

Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them. 更多...

继承自 AkObstructionOcclusion .

Public 属性

float | fadeTime = 0.5f
The number of seconds for fade ins and fade outs. 更多...
UnityEngine.LayerMask | LayerMask = -1
Indicates which layers act as obstructers/occluders. 更多...
float | maxDistance = -1.0f
The maximum distance at which to perform obstruction/occlusion. A negative value will be interpreted as inifinite distance. 更多...
float | refreshInterval = 1
The number of seconds between obstruction/occlusion checks. 更多...

详细描述

Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them.


Wwise Unity Integration Documentation: AkEnvironment类 参考

类 | 所有成员列表
AkEnvironment类 参考

Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone). 更多...

继承自 MonoBehaviour , 以及 AK.Wwise.IMigratable .

类

class | AkEnvironment_CompareByPriority
Sorts AkEnvironments based on their priorities. 更多...
class | AkEnvironment_CompareBySelectionAlgorithm
Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows: 更多...

详细描述

Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone).

This component can be attached to any collider. You can specify a roll-off to fade-in/out of the reverb.
The reverb parameters will be defined in the Wwise project, by the sound designer. All AkGameObj that are "environment"-aware will receive a send value when entering the attached collider.

参见
  • 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone)
  • Integrating Environments and Game-defined Auxiliary Sends (Note: This is described in the Wwise SDK documentation.)
  • AK::SoundEngine::SetGameObjectAuxSendValues (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkEnvironment.AkEnvironment_CompareByPriority类 参考

  • AkEnvironment
  • AkEnvironment_CompareByPriority
所有成员列表
AkEnvironment.AkEnvironment_CompareByPriority类 参考

Sorts AkEnvironments based on their priorities. 更多...

类 AkEnvironment.AkEnvironment_CompareByPriority 继承关系图:
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm

详细描述

Sorts AkEnvironments based on their priorities.


Wwise Unity Integration Documentation: AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm类 参考

  • AkEnvironment
  • AkEnvironment_CompareBySelectionAlgorithm
所有成员列表
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm类 参考

Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows: 更多...

类 AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm 继承关系图:
AkEnvironment.AkEnvironment_CompareByPriority

详细描述

Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:

  1. Environments have priorities.
  2. Environments have a "Default" flag. This flag effectively says that this environment will be bumped out if any other is present.
  3. Environments have an "Exclude Other" flag. This flag will tell that this env is not overlappable with others. So, only one (the highest priority) should be selected.


Wwise Unity Integration Documentation: AkEnvironmentPortal类 参考

类 | Public 属性 | 所有成员列表
AkEnvironmentPortal类 参考

Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone) 更多...

继承自 MonoBehaviour .

类

class EnvListWrapper
This enables us to detect intersections between portals and environments in the editor 更多...

Public 属性

UnityEngine.Vector3 | axis = UnityEngine.Vector3.right
The axis used to find the contribution of each environment 更多...
AkEnvironment[] | environments = new AkEnvironment[MAX_ENVIRONMENTS_PER_PORTAL]
EnvListWrapper[] envList
Unity can't serialize an array of list so we wrap the list in a serializable class 更多...

详细描述

Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone)


Wwise Unity Integration Documentation: AkEnvironmentPortal.EnvListWrapper类 参考

  • AkEnvironmentPortal
  • EnvListWrapper
所有成员列表
AkEnvironmentPortal.EnvListWrapper类 参考

This enables us to detect intersections between portals and environments in the editor 更多...

详细描述

This enables us to detect intersections between portals and environments in the editor


Wwise Unity Integration Documentation: AkEnvironmentPortal.axis

  • AkEnvironmentPortal
axis
environments
envList

◆ axis

UnityEngine.Vector3 AkEnvironmentPortal.axis = UnityEngine.Vector3.right

The axis used to find the contribution of each environment


Wwise Unity Integration Documentation: AkEnvironmentPortal.environments

  • AkEnvironmentPortal
axis
environments
envList

◆ environments

AkEnvironment [] AkEnvironmentPortal.environments = new AkEnvironment[MAX_ENVIRONMENTS_PER_PORTAL]

The array is already sorted by position. The first environment is on the negative side of the portal(opposite to the direction of the chosen axis) The second environment is on the positive side of the portal


Wwise Unity Integration Documentation: AkEnvironmentPortal.envList

  • AkEnvironmentPortal
axis
environments
envList

◆ envList

EnvListWrapper [] AkEnvironmentPortal.envList

Unity can't serialize an array of list so we wrap the list in a serializable class


Wwise Unity Integration Documentation: AkEvent类 参考

Public 属性 | 静态 Public 属性 | 所有成员列表
AkEvent类 参考

Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object. 更多...

类 AkEvent 继承关系图:
AkAmbient

Public 属性

AkActionOnEventType | actionOnEventType = AkActionOnEventType.AkActionOnEventType_Stop
Replacement action. See AK::SoundEngine::ExecuteEventOnAction() 更多...
AkCurveInterpolation | curveInterpolation = AkCurveInterpolation.AkCurveInterpolation_Linear
Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction() 更多...
bool | enableActionOnEvent = false
Enables additional options to reuse existing events. Use it to transform a Play event into a Stop event without having to define one in the Wwise Project. 更多...
UnityEngine.GameObject | soundEmitterObject
Game object onto which the Event will be posted. By default, when empty, it is posted on the same object on which the component was added. 更多...
float | transitionDuration = 0.0f
Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction() 更多...
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 更多...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 更多...

静态 Public 属性

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 更多...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 更多...

详细描述

Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object.

参见
  • Edit 模式支持
  • 在 Inspector 中使用 AkAmbient
  • Integration Details - Events (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkEvent.actionOnEventType

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ actionOnEventType

AkActionOnEventType AkEvent.actionOnEventType = AkActionOnEventType.AkActionOnEventType_Stop

Replacement action. See AK::SoundEngine::ExecuteEventOnAction()


Wwise Unity Integration Documentation: AkEvent.curveInterpolation

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ curveInterpolation

AkCurveInterpolation AkEvent.curveInterpolation = AkCurveInterpolation.AkCurveInterpolation_Linear

Fade curve to use with the new Action. See AK::SoundEngine::ExecuteEventOnAction()


Wwise Unity Integration Documentation: AkEvent.enableActionOnEvent

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ enableActionOnEvent

bool AkEvent.enableActionOnEvent = false

Enables additional options to reuse existing events. Use it to transform a Play event into a Stop event without having to define one in the Wwise Project.


Wwise Unity Integration Documentation: AkEvent.soundEmitterObject

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ soundEmitterObject

UnityEngine.GameObject AkEvent.soundEmitterObject

Game object onto which the Event will be posted. By default, when empty, it is posted on the same object on which the component was added.


Wwise Unity Integration Documentation: AkEvent.transitionDuration

  • AkEvent
actionOnEventType
curveInterpolation
enableActionOnEvent
soundEmitterObject
transitionDuration

◆ transitionDuration

float AkEvent.transitionDuration = 0.0f

Duration of the fade. See AK::SoundEngine::ExecuteEventOnAction()


Wwise Unity Integration Documentation: AkEventCallbackMsg类 参考

Public 属性 | 所有成员列表
AkEventCallbackMsg类 参考

Event callback information. Event callback functions can receive this structure as a parameter 更多...

Public 属性

AkCallbackInfo | info
For more information about the event callback, see the classes derived from AkCallbackInfo. 更多...
UnityEngine.GameObject | sender
GameObject from whom the callback function was called 更多...
AkCallbackType | type
AkSoundEngine.PostEvent callback flags. See the AkCallbackType enumeration for a list of all callbacks 更多...

详细描述

Event callback information. Event callback functions can receive this structure as a parameter


Wwise Unity Integration Documentation: AkEventCallbackMsg.info

  • AkEventCallbackMsg
info
sender
type

◆ info

AkCallbackInfo AkEventCallbackMsg.info

For more information about the event callback, see the classes derived from AkCallbackInfo.


Wwise Unity Integration Documentation: AkEventCallbackMsg.sender

  • AkEventCallbackMsg
info
sender
type

◆ sender

UnityEngine.GameObject AkEventCallbackMsg.sender

GameObject from whom the callback function was called


Wwise Unity Integration Documentation: AkEventCallbackMsg.type

  • AkEventCallbackMsg
info
sender
type

◆ type

AkCallbackType AkEventCallbackMsg.type

AkSoundEngine.PostEvent callback flags. See the AkCallbackType enumeration for a list of all callbacks


Wwise Unity Integration Documentation: AkGameObj类 参考

Public 成员函数 | Public 属性 | 所有成员列表
AkGameObj类 参考

This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise. 更多...

继承自 MonoBehaviour .

Public 成员函数

virtual UnityEngine.Vector3 | GetPosition ()
virtual UnityEngine.Vector3 | GetForward ()
virtual UnityEngine.Vector3 | GetUpward ()

Public 属性

bool | isEnvironmentAware = true
Is this object affected by Environment changes? Set to false if not affected in order to save some useless calls. Default is true. 更多...
AkGameObjPositionOffsetData | m_positionOffsetData
When not set to null, the position will be offset relative to the Game Object position by the Position Offset 更多...

详细描述

This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise.

参见
  • Integration Details - Game Objects (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - Events (Note: This is described in the Wwise SDK documentation.)
  • Integrating Listeners (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - Switches (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - States (Note: This is described in the Wwise SDK documentation.)
  • Integration Details - Environments and Game-defined Auxiliary Sends (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkGameObj.GetForward

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ GetForward()

virtual UnityEngine.Vector3 AkGameObj.GetForward ( )
inlinevirtual

Gets the orientation forward vector. User can also override this method to calculate an arbitrary vector.

返回
The forward vector of orientation.


Wwise Unity Integration Documentation: AkGameObj.GetPosition

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ GetPosition()

virtual UnityEngine.Vector3 AkGameObj.GetPosition ( )
inlinevirtual

Gets the position including the position offset, if applyPositionOffset is enabled. User can also override this method to calculate an arbitrary position.

返回
The position.

引用了 m_positionOffsetData.


Wwise Unity Integration Documentation: AkGameObj.GetUpward

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ GetUpward()

virtual UnityEngine.Vector3 AkGameObj.GetUpward ( )
inlinevirtual

Gets the orientation upward vector. User can also override this method to calculate an arbitrary vector.

返回
The upward vector of orientation.


Wwise Unity Integration Documentation: AkGameObj.isEnvironmentAware

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ isEnvironmentAware

bool AkGameObj.isEnvironmentAware = true

Is this object affected by Environment changes? Set to false if not affected in order to save some useless calls. Default is true.


Wwise Unity Integration Documentation: AkGameObj.m_positionOffsetData

  • AkGameObj
GetForward
GetPosition
GetUpward
isEnvironmentAware
m_positionOffsetData

◆ m_positionOffsetData

AkGameObjPositionOffsetData AkGameObj.m_positionOffsetData

When not set to null, the position will be offset relative to the Game Object position by the Position Offset

被这些函数引用 GetPosition().


Wwise Unity Integration Documentation: AkInitializer类 参考

所有成员列表
AkInitializer类 参考

This script deals with initialization, and frame updates of the Wwise audio engine.
It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings. 更多...

继承自 MonoBehaviour .

详细描述

This script deals with initialization, and frame updates of the Wwise audio engine.
It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings.

参见
  • Initialize the Different Modules of the Sound Engine (Note: This is described in the Wwise SDK documentation.)
  • AK::SoundEngine::Init() (Note: This is described in the Wwise SDK documentation.)
  • AK::SoundEngine::Term() (Note: This is described in the Wwise SDK documentation.)
  • AkCallbackManager


Wwise Unity Integration Documentation: AkListenerDistanceProbe类 参考

所有成员列表
AkListenerDistanceProbe类 参考

Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera. 更多...

继承自 MonoBehaviour .

详细描述

Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera.


Wwise Unity Integration Documentation: AkMemBankLoader类 参考

Public 成员函数 | Public 属性 | 所有成员列表
AkMemBankLoader类 参考

This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory.
This would be useful for situations where you use the WWW class 更多...

继承自 MonoBehaviour .

Public 成员函数

void | LoadNonLocalizedBank (string in_bankFilename)
Load a SoundBank from WWW object 更多...
void | LoadLocalizedBank (string in_bankFilename)
Load a language-specific bank from WWW object 更多...

Public 属性

string | bankName = ""
Name of the bank to load 更多...
bool | isLocalizedBank = false
Is the bank localized (situated in the language-specific folders) 更多...

详细描述

This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory.
This would be useful for situations where you use the WWW class


Wwise Unity Integration Documentation: AkMemBankLoader.LoadLocalizedBank

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ LoadLocalizedBank()

void AkMemBankLoader.LoadLocalizedBank ( string in_bankFilename )
inline

Load a language-specific bank from WWW object


Wwise Unity Integration Documentation: AkMemBankLoader.LoadNonLocalizedBank

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ LoadNonLocalizedBank()

void AkMemBankLoader.LoadNonLocalizedBank ( string in_bankFilename )
inline

Load a SoundBank from WWW object


Wwise Unity Integration Documentation: AkMemBankLoader.bankName

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ bankName

string AkMemBankLoader.bankName = ""

Name of the bank to load


Wwise Unity Integration Documentation: AkMemBankLoader.isLocalizedBank

  • AkMemBankLoader
bankName
isLocalizedBank
LoadLocalizedBank
LoadNonLocalizedBank

◆ isLocalizedBank

bool AkMemBankLoader.isLocalizedBank = false

Is the bank localized (situated in the language-specific folders)


Wwise Unity Integration Documentation: AkRadialEmitter类 参考

Public 属性 | 所有成员列表
AkRadialEmitter类 参考

A radial emitter is for sounds that are not point sources, but instead originate from a region of space. 更多...

继承自 MonoBehaviour .

Public 属性

float | outerRadius = 0.0f
float | innerRadius = 0.0f

详细描述

A radial emitter is for sounds that are not point sources, but instead originate from a region of space.

A radial emitter is described by an inner and outer radius. The radii are used in spread and distance calculations, simulating a radial sound source. Since all game objects have a position and orientation, the position (center) and local axes are defined by the AkGameObj component required by this component.


Wwise Unity Integration Documentation: AkRadialEmitter.innerRadius

  • AkRadialEmitter
innerRadius
outerRadius

◆ innerRadius

float AkRadialEmitter.innerRadius = 0.0f

Define an inner radius around each sound position to simulate a radial sound source. If the listener is inside the inner radius, the spread is 100%. Note that transmission and diffraction calculations in Spatial Audio always use the center of the sphere (the position(s) passed into AK::SoundEngine::SetPosition or AK::SoundEngine::SetMultiplePositions) for raycasting. To obtain accurate diffraction and transmission calculations for radial sources, where different parts of the volume may take different paths through or around geometry, it is necessary to pass multiple sound positions into AK::SoundEngine::SetMultiplePositions to allow the engine to 'sample' the area at different points.


Wwise Unity Integration Documentation: AkRadialEmitter.outerRadius

  • AkRadialEmitter
innerRadius
outerRadius

◆ outerRadius

float AkRadialEmitter.outerRadius = 0.0f

Define an outer radius around each sound position to simulate a radial sound source. The distance used for applying attenuation curves is taken as the distance between the listener and the point on the sphere, defined by the sound position and the outer radius, that is closest to the listener. The spread for each sound position is calculated as follows:

  • If the listener is outside the outer radius, the spread is defined by the area that the sphere takes in the listener field of view. Specifically, this angle is calculated as 2.0*asinf( outerRadius / distance ), where distance is the distance between the listener and the sound position.
  • When the listener intersects the outer radius (the listener is exactly outerRadius units away from the sound position), the spread is exactly 50%.
  • When the listener is in between the inner and outer radius, the spread interpolates linearly from 50% to 100% as the listener transitions from the outer radius towards the inner radius. Note that transmission and diffraction calculations in Spatial Audio always use the center of the sphere (the position(s) passed into AK::SoundEngine::SetPosition or AK::SoundEngine::SetMultiplePositions) for raycasting. To obtain accurate diffraction and transmission calculations for radial sources, where different parts of the volume may take different paths through or around geometry, it is necessary to pass multiple sound positions into AK::SoundEngine::SetMultiplePositions to allow the engine to 'sample' the area at different points.


Wwise Unity Integration Documentation: AkRoom类 参考

Public 成员函数 | Public 属性 | 静态 Public 属性 | 所有成员列表
AkRoom类 参考

An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals 更多...

继承自 AkTriggerHandler .

Public 成员函数

ulong GetID ()
Access the room's ID 更多...

Public 属性

int | priority = 0
AK.Wwise.AuxBus | reverbAuxBus = new AK.Wwise.AuxBus()
The reverb auxiliary bus. 更多...
float | reverbLevel = 1
The reverb control value for the send to the reverb aux bus. 更多...
float | transmissionLoss = 1
Loss value modeling transmission through walls. 更多...
AK.Wwise.Event | roomToneEvent = new AK.Wwise.Event()
Wwise Event to be posted on the room game object. 更多...
float | roomToneAuxSend = 0
Send level for sounds that are posted on the room game object; adds reverb to ambience and room tones. Valid range: (0.f-1.f). A value of 0 disables the aux send. 更多...
System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 更多...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 更多...

静态 Public 属性

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 更多...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 更多...

详细描述

An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals

The AkRoom component uses its required Collider component to determine when AkRoomAwareObjects enter and exit the room using the OnTriggerEnter and OnTriggerExit callbacks.


Wwise Unity Integration Documentation: AkRoom.GetID

  • AkRoom
GetID
priority
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
transmissionLoss

◆ GetID()

ulong AkRoom.GetID ( )
inline

Access the room's ID


Wwise Unity Integration Documentation: AkRoom.priority

  • AkRoom
GetID
priority
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
transmissionLoss

◆ priority

int AkRoom.priority = 0

In cases where a game object is in an area with two rooms, the higher priority room will be chosen for AK::SpatialAudio::SetGameObjectInRoom() The higher the priority number, the higher the priority of a room.


Wwise Unity Integration Documentation: AkRoom.reverbAuxBus

  • AkRoom
GetID
priority
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
transmissionLoss

◆ reverbAuxBus

AK.Wwise.AuxBus AkRoom.reverbAuxBus = new AK.Wwise.AuxBus()

The reverb auxiliary bus.


Wwise Unity Integration Documentation: AkRoom.reverbLevel

  • AkRoom
GetID
priority
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
transmissionLoss

◆ reverbLevel

float AkRoom.reverbLevel = 1

The reverb control value for the send to the reverb aux bus.


Wwise Unity Integration Documentation: AkRoom.roomToneAuxSend

  • AkRoom
GetID
priority
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
transmissionLoss

◆ roomToneAuxSend

float AkRoom.roomToneAuxSend = 0

Send level for sounds that are posted on the room game object; adds reverb to ambience and room tones. Valid range: (0.f-1.f). A value of 0 disables the aux send.


Wwise Unity Integration Documentation: AkRoom.roomToneEvent

  • AkRoom
GetID
priority
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
transmissionLoss

◆ roomToneEvent

AK.Wwise.Event AkRoom.roomToneEvent = new AK.Wwise.Event()

Wwise Event to be posted on the room game object.


Wwise Unity Integration Documentation: AkRoom.transmissionLoss

  • AkRoom
GetID
priority
reverbAuxBus
reverbLevel
roomToneAuxSend
roomToneEvent
transmissionLoss

◆ transmissionLoss

float AkRoom.transmissionLoss = 1

Loss value modeling transmission through walls.


Wwise Unity Integration Documentation: AkRoomAwareManager类 参考

所有成员列表
AkRoomAwareManager类 参考

This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit. 更多...

详细描述

This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit.

At the end of the frame, the AkRoomAwareObject is set in the highest priority AkRoom in Spatial Audio.


Wwise Unity Integration Documentation: AkRoomAwareObject类 参考

Public 成员函数 | 所有成员列表
AkRoomAwareObject类 参考

This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component. 更多...

继承自 MonoBehaviour .

Public 成员函数

void | EnteredRoom (AkRoom room)
Called when entering a room. 更多...
void | ExitedRoom (AkRoom room)
Called when exiting a room. 更多...

详细描述

This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component.


Wwise Unity Integration Documentation: AkRoomAwareObject.EnteredRoom

  • AkRoomAwareObject
EnteredRoom
ExitedRoom

◆ EnteredRoom()

void AkRoomAwareObject.EnteredRoom ( AkRoom room )
inline

Called when entering a room.

参数
room The room.


Wwise Unity Integration Documentation: AkRoomAwareObject.ExitedRoom

  • AkRoomAwareObject
EnteredRoom
ExitedRoom

◆ ExitedRoom()

void AkRoomAwareObject.ExitedRoom ( AkRoom room )
inline

Called when exiting a room.

参数
room The room.


Wwise Unity Integration Documentation: AkRoomManager类 参考

所有成员列表
AkRoomManager类 参考

This manager tracks AkRoomPortals and the rooms that they connect (front and back room). 更多...

详细描述

This manager tracks AkRoomPortals and the rooms that they connect (front and back room).

At the end of the frame, the AkRoomPortals which rooms might have changed are updated and sent to Spatial Audio.


Wwise Unity Integration Documentation: AkRoomPortal类 参考

Public 成员函数 | Public 属性 | 静态 Public 属性 | 所有成员列表
AkRoomPortal类 参考

An AkRoomPortal can connect two AkRoom components together. 更多...

继承自 AkTriggerHandler .

Public 成员函数

ulong | GetID ()
Access the portal's ID 更多...
override void | HandleEvent (UnityEngine.GameObject in_gameObject)
Opens the portal on trigger event 更多...
void | ClosePortal (UnityEngine.GameObject in_gameObject)
Closes the portal on trigger event 更多...

Public 属性

System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 更多...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 更多...

静态 Public 属性

const int | MAX_ROOMS_PER_PORTAL = 2
AkRoomPortals can only connect a maximum of 2 rooms. 更多...
const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 更多...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 更多...

详细描述

An AkRoomPortal can connect two AkRoom components together.


Wwise Unity Integration Documentation: AkRoomPortal.ClosePortal

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ ClosePortal()

void AkRoomPortal.ClosePortal ( UnityEngine.GameObject in_gameObject )
inline

Closes the portal on trigger event


Wwise Unity Integration Documentation: AkRoomPortal.GetID

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ GetID()

ulong AkRoomPortal.GetID ( )
inline

Access the portal's ID


Wwise Unity Integration Documentation: AkRoomPortal.HandleEvent

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ HandleEvent()

override void AkRoomPortal.HandleEvent ( UnityEngine.GameObject in_gameObject )
inline

Opens the portal on trigger event


Wwise Unity Integration Documentation: AkRoomPortal.MAX_ROOMS_PER_PORTAL

  • AkRoomPortal
ClosePortal
GetID
HandleEvent
MAX_ROOMS_PER_PORTAL

◆ MAX_ROOMS_PER_PORTAL

const int AkRoomPortal.MAX_ROOMS_PER_PORTAL = 2
static

AkRoomPortals can only connect a maximum of 2 rooms.


Wwise Unity Integration Documentation: AkRoomPortalObstruction类 参考

Public 属性 | 所有成员列表
AkRoomPortalObstruction类 参考

Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them. 更多...

继承自 AkObstructionOcclusion .

Public 属性

float | fadeTime = 0.5f
The number of seconds for fade ins and fade outs. 更多...
UnityEngine.LayerMask | LayerMask = -1
Indicates which layers act as obstructers/occluders. 更多...
float | maxDistance = -1.0f
The maximum distance at which to perform obstruction/occlusion. A negative value will be interpreted as inifinite distance. 更多...
float | refreshInterval = 1
The number of seconds between obstruction/occlusion checks. 更多...

详细描述

Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them.

If no spatial audio listener has been registered, there will be no obstruction.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw类 参考

Public 属性 | 所有成员列表
AkSpatialAudioDebugDraw类 参考

Add this script on a GameObject to print Spatial Audio paths. 更多...

继承自 MonoBehaviour .

Public 属性

bool | drawFirstOrderReflections = false
This allows you to visualize first order reflection sound paths. 更多...
bool | drawSecondOrderReflections = false
This allows you to visualize second order reflection sound paths. 更多...
bool | drawHigherOrderReflections = false
This allows you to visualize third or higher order reflection sound paths. 更多...
bool | drawDiffractionPaths = false
This allows you to visualize geometric diffraction sound paths between an obstructed emitter and the listener. 更多...

详细描述

Add this script on a GameObject to print Spatial Audio paths.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawDiffractionPaths

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawDiffractionPaths

bool AkSpatialAudioDebugDraw.drawDiffractionPaths = false

This allows you to visualize geometric diffraction sound paths between an obstructed emitter and the listener.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawFirstOrderReflections

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawFirstOrderReflections

bool AkSpatialAudioDebugDraw.drawFirstOrderReflections = false

This allows you to visualize first order reflection sound paths.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawHigherOrderReflections

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawHigherOrderReflections

bool AkSpatialAudioDebugDraw.drawHigherOrderReflections = false

This allows you to visualize third or higher order reflection sound paths.


Wwise Unity Integration Documentation: AkSpatialAudioDebugDraw.drawSecondOrderReflections

  • AkSpatialAudioDebugDraw
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections

◆ drawSecondOrderReflections

bool AkSpatialAudioDebugDraw.drawSecondOrderReflections = false

This allows you to visualize second order reflection sound paths.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter类 参考

Public 属性 | 所有成员列表
AkSpatialAudioEmitter类 参考

(DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring. 更多...

继承自 MonoBehaviour , 以及 AK.Wwise.IMigratable .

Public 属性

AK.Wwise.AuxBus | reflectAuxBus = new AK.Wwise.AuxBus()
(DEPRECATED) As of 2019.2, the early reflections auxiliary bus can be set per sound, in the Authoring tool, or per game object, with the AkEarlyReflections component. 更多...
float | reflectionMaxPathLength = 1000
(DEPRECATED) As of 2019.2, the Reflection Max Path Length is set by the sound's Attenuation Max Distance value in the Authoring tool. 更多...
float | reflectionsAuxBusGain = 1
(DEPRECATED) As of 2019.2, the early reflections send volume can be set per sound, in the Authoring tool, or for all sunds playing on a game object, with the AkEarlyReflections component. 更多...
uint | reflectionsOrder = 1
(DEPRECATED) As of 2019.2, the Reflection Order is set in the Spatial Audio Initialization Settings. 更多...
float | roomReverbAuxBusGain = 1
(DEPRECATED) As of 2019.2, the Room Reverb Aux Bus Gain is set by the Game-Defined Auxiliary Sends Volume in the Sound Property Editor in the Authoring tool. 更多...
uint | diffractionMaxEdges = 0
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool. 更多...
uint | diffractionMaxPaths = 0
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool. 更多...
uint | diffractionMaxPathLength = 0
(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool. 更多...
bool | drawFirstOrderReflections = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. 更多...
bool | drawSecondOrderReflections = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. 更多...
bool | drawHigherOrderReflections = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. 更多...
bool | drawDiffractionPaths = false
(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component. 更多...

详细描述

(DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring.

Some functionalities were moved to different components. See the AkEarlyReflections and AkSpatialAudioDebugDraw components for more details.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.diffractionMaxEdges

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ diffractionMaxEdges

uint AkSpatialAudioEmitter.diffractionMaxEdges = 0

(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.diffractionMaxPathLength

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ diffractionMaxPathLength

uint AkSpatialAudioEmitter.diffractionMaxPathLength = 0

(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.diffractionMaxPaths

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ diffractionMaxPaths

uint AkSpatialAudioEmitter.diffractionMaxPaths = 0

(DEPRECATED) As of 2019.2, diffraction is enabled in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawDiffractionPaths

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawDiffractionPaths

bool AkSpatialAudioEmitter.drawDiffractionPaths = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawFirstOrderReflections

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawFirstOrderReflections

bool AkSpatialAudioEmitter.drawFirstOrderReflections = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawHigherOrderReflections

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawHigherOrderReflections

bool AkSpatialAudioEmitter.drawHigherOrderReflections = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.drawSecondOrderReflections

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ drawSecondOrderReflections

bool AkSpatialAudioEmitter.drawSecondOrderReflections = false

(DEPRECATED) Spatial Audio Debug Drawing were moved to the new AkSpatialAudioDebugDraw component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectAuxBus

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectAuxBus

AK.Wwise.AuxBus AkSpatialAudioEmitter.reflectAuxBus = new AK.Wwise.AuxBus()

(DEPRECATED) As of 2019.2, the early reflections auxiliary bus can be set per sound, in the Authoring tool, or per game object, with the AkEarlyReflections component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectionMaxPathLength

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectionMaxPathLength

float AkSpatialAudioEmitter.reflectionMaxPathLength = 1000

(DEPRECATED) As of 2019.2, the Reflection Max Path Length is set by the sound's Attenuation Max Distance value in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectionsAuxBusGain

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectionsAuxBusGain

float AkSpatialAudioEmitter.reflectionsAuxBusGain = 1

(DEPRECATED) As of 2019.2, the early reflections send volume can be set per sound, in the Authoring tool, or for all sunds playing on a game object, with the AkEarlyReflections component.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.reflectionsOrder

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ reflectionsOrder

uint AkSpatialAudioEmitter.reflectionsOrder = 1

(DEPRECATED) As of 2019.2, the Reflection Order is set in the Spatial Audio Initialization Settings.


Wwise Unity Integration Documentation: AkSpatialAudioEmitter.roomReverbAuxBusGain

  • AkSpatialAudioEmitter
diffractionMaxEdges
diffractionMaxPathLength
diffractionMaxPaths
drawDiffractionPaths
drawFirstOrderReflections
drawHigherOrderReflections
drawSecondOrderReflections
reflectAuxBus
reflectionMaxPathLength
reflectionsAuxBusGain
reflectionsOrder
roomReverbAuxBusGain

◆ roomReverbAuxBusGain

float AkSpatialAudioEmitter.roomReverbAuxBusGain = 1

(DEPRECATED) As of 2019.2, the Room Reverb Aux Bus Gain is set by the Game-Defined Auxiliary Sends Volume in the Sound Property Editor in the Authoring tool.


Wwise Unity Integration Documentation: AkSpatialAudioListener类 参考

类 | 属性 | 所有成员列表
AkSpatialAudioListener类 参考

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's. 更多...

继承自 MonoBehaviour , 以及 AK.Wwise.IMigratable .

类

class SpatialAudioListenerList
This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time. 更多...

属性

static AkAudioListener? | TheSpatialAudioListener [get]
Returns the "single" spatial audio listener. 更多...
static SpatialAudioListenerList | SpatialAudioListeners [get]
Returns the list of active Unity Game Objects that are designated to be spatial audio listeners. 更多...

详细描述

Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's.

参见
  • Integrating Listeners (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListenerList类 参考

  • AkSpatialAudioListener
  • SpatialAudioListenerList
Public 成员函数 | 所有成员列表
AkSpatialAudioListener.SpatialAudioListenerList类 参考

This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time. 更多...

Public 成员函数

bool | Add (AkSpatialAudioListener listener)
Uniquely adds listeners to the list 更多...
bool | Remove (AkSpatialAudioListener listener)
Removes listeners from the list 更多...

详细描述

This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time.


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListenerList.Add

  • AkSpatialAudioListener
  • SpatialAudioListenerList
Add
Remove

◆ Add()

bool AkSpatialAudioListener.SpatialAudioListenerList.Add ( AkSpatialAudioListener listener )
inline

Uniquely adds listeners to the list

参数
listener
返回


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListenerList.Remove

  • AkSpatialAudioListener
  • SpatialAudioListenerList
Add
Remove

◆ Remove()

bool AkSpatialAudioListener.SpatialAudioListenerList.Remove ( AkSpatialAudioListener listener )
inline

Removes listeners from the list

参数
listener
返回


Wwise Unity Integration Documentation: AkSpatialAudioListener.SpatialAudioListeners

  • AkSpatialAudioListener
SpatialAudioListeners
TheSpatialAudioListener

◆ SpatialAudioListeners

SpatialAudioListenerList AkSpatialAudioListener.SpatialAudioListeners
staticget

Returns the list of active Unity Game Objects that are designated to be spatial audio listeners.


Wwise Unity Integration Documentation: AkSpatialAudioListener.TheSpatialAudioListener

  • AkSpatialAudioListener
SpatialAudioListeners
TheSpatialAudioListener

◆ TheSpatialAudioListener

AkAudioListener? AkSpatialAudioListener.TheSpatialAudioListener
staticget

Returns the "single" spatial audio listener.


Wwise Unity Integration Documentation: AkState类 参考

Public 属性 | 静态 Public 属性 | 所有成员列表
AkState类 参考

This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it. 更多...

继承自 AkDragDropTriggerHandler , 以及 AK.Wwise.IMigratable .

Public 属性

System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 更多...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 更多...

静态 Public 属性

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 更多...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 更多...

详细描述

This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it.

参见
  • Integration Details - States (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkSurfaceReflector类 参考

Public 成员函数 | 静态 Public 成员函数 | Public 属性 | 所有成员列表
AkSurfaceReflector类 参考

This component converts the provided mesh into Spatial Audio Geometry. 更多...

继承自 MonoBehaviour , 以及 AK.Wwise.IMigratable .

Public 成员函数

void | SetGeometry ()
Call AkSurfaceReflector::SetGeometryFromMesh() with this component's mesh. 更多...
void | SetGeometryInstance ()
Call AkSurfaceReflector::SetGeometryInstance() with this component's tranform. 更多...
void | UpdateGeometry ()
Update this component's geometry instance 更多...
void | RemoveGeometry ()
Remove this component's geometry and corresponding instance from Spatial Audio. 更多...
void | RemoveGeometryInstance ()
Remove this component's geometry instance from Spatial Audio. 更多...

静态 Public 成员函数

static void | SetGeometryFromMesh (UnityEngine.Mesh mesh, ulong geometryID, bool enableDiffraction, bool enableDiffractionOnBoundaryEdges, bool enableTriangles, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="")
Convert the mesh into a geometry consisting of vertices, triangles, surfaces, acoustic textures and transmission loss values. Send it to Wwise with the rest of the AkGeometryParams to add or update a geometry in Spatial Audio. It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation. See SetGeometryInstance(). 更多...
static void | SetGeometryInstance (ulong geometryInstanceID, ulong geometryID, ulong associatedRoomID, UnityEngine.Transform transform)
Add or update an instance of the geometry by sending the transform of this component to Wwise. A geometry instance is a unique instance of a geometry set with a specified transform (position, rotation and scale). It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation. 更多...

Public 属性

UnityEngine.Mesh | Mesh
The mesh to send to Spatial Audio as a Geometry Set. We recommend using a simplified mesh. 更多...
AK.Wwise.AcousticTexture[] | AcousticTextures = new AK.Wwise.AcousticTexture[1]
The acoustic texture per submesh. The acoustic texture represents the surface of the geometry. An acoustic texture is a set of absorption levels that will filter the sound reflected from the geometry. 更多...
float[] | TransmissionLossValues = new[] { 1.0f }
The transmission loss value per submesh. The transmission loss value is a control value used to adjust sound parameters. Typically, a value of 1.0 represents total sound loss, and a value of 0.0 indicates that sound can be transmitted through the geometry without any loss. Default value : 1.0. 更多...
bool | EnableDiffraction = true
Switch to enable or disable geometric diffraction for this mesh. 更多...
bool | EnableDiffractionOnBoundaryEdges = false
Switch to enable or disable geometric diffraction on boundary edges for this mesh. Boundary edges are edges that are connected to only one triangle. 更多...
AkRoom | AssociatedRoom = null
Optional room with which this surface reflector is associated. It is recommended to associate geometry with a particular room if the geometry is fully contained within the room and the room does not share any geometry with any other rooms. Doing so reduces the search space for ray casting performed by reflection and diffraction calculations. 更多...

详细描述

This component converts the provided mesh into Spatial Audio Geometry.

This component takes a mesh as a parameter. The triangles of the mesh are sent to Spatial Audio by calling SpatialAudio::AddGeometrySet(). The triangles reflect sounds that have an associated early reflections bus. If diffraction is enabled on this component, spatial audio also finds edges on the provided mesh, which diffract sounds that are diffraction enabled.


Wwise Unity Integration Documentation: AkSurfaceReflector.RemoveGeometry

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ RemoveGeometry()

void AkSurfaceReflector.RemoveGeometry ( )
inline

Remove this component's geometry and corresponding instance from Spatial Audio.


Wwise Unity Integration Documentation: AkSurfaceReflector.RemoveGeometryInstance

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ RemoveGeometryInstance()

void AkSurfaceReflector.RemoveGeometryInstance ( )
inline

Remove this component's geometry instance from Spatial Audio.


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometry

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometry()

void AkSurfaceReflector.SetGeometry ( )
inline

Call AkSurfaceReflector::SetGeometryFromMesh() with this component's mesh.

引用了 AcousticTextures, EnableDiffraction, EnableDiffractionOnBoundaryEdges, Mesh, SetGeometryFromMesh() , 以及 TransmissionLossValues.


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometryFromMesh

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometryFromMesh()

static void AkSurfaceReflector.SetGeometryFromMesh | ( | UnityEngine.Mesh | mesh,
 |  | ulong | geometryID,
 |  | bool | enableDiffraction,
 |  | bool | enableDiffractionOnBoundaryEdges,
 |  | bool | enableTriangles,
 |  | AK.Wwise.AcousticTexture[] | acousticTextures = null,
 |  | float[] | transmissionLossValues = null,
 |  | string | name = ""
 | ) |  |
inlinestatic

Convert the mesh into a geometry consisting of vertices, triangles, surfaces, acoustic textures and transmission loss values. Send it to Wwise with the rest of the AkGeometryParams to add or update a geometry in Spatial Audio. It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation. See SetGeometryInstance().

参数
mesh | The mesh representing the geometry to be used for diffraction and reflection simulation.
geometryID | A unique ID representing the geometry.
enableDiffraction | Enable the edges of this geometry to become diffraction edges.
enableDiffractionOnBoundaryEdges | Enable the boundary edges of this geometry to become diffraction edges. Boundary edges are edges that are connected to only one triangle.
enableTriangles | When enabled, the geometry triangles are indexed for ray computation and used to computed reflection and diffraction. Set EnableTriangles to false when using a geometry set only to describe a room, and not for reflection and diffraction calculation.
acousticTextures | The acoustic texture of each surface of the geometry. Acoustic textures describe the filtering when sound reflects on the surface.
transmissionLossValues | The transmission loss value of each surface of the geometry. Transmission loss is the filtering when the sound goes through the surface.
name | A name for the geometry.

被这些函数引用 SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometryInstance

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometryInstance() [1/2]

void AkSurfaceReflector.SetGeometryInstance ( )
inline

Call AkSurfaceReflector::SetGeometryInstance() with this component's tranform.

引用了 AssociatedRoom.

被这些函数引用 UpdateGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.SetGeometryInstance

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ SetGeometryInstance() [2/2]

static void AkSurfaceReflector.SetGeometryInstance | ( | ulong | geometryInstanceID,
 |  | ulong | geometryID,
 |  | ulong | associatedRoomID,
 |  | UnityEngine.Transform | transform
 | ) |  |
inlinestatic

Add or update an instance of the geometry by sending the transform of this component to Wwise. A geometry instance is a unique instance of a geometry set with a specified transform (position, rotation and scale). It is necessary to create at least one geometry instance for each geometry set that is to be used for diffraction and reflection simulation.

参数
geometryInstanceID | A unique ID to for the geometry instance. It must be unique amongst all geometry instances, including geometry instances referencing different geometries.
geometryID | The ID of the geometry referenced by this instance.
associatedRoomID | The ID of the room this geometry is encompassed in, if any.
transform | The transform to be applied to the geometry to convert it in world positions.


Wwise Unity Integration Documentation: AkSurfaceReflector.UpdateGeometry

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ UpdateGeometry()

void AkSurfaceReflector.UpdateGeometry ( )
inline

Update this component's geometry instance

引用了 SetGeometryInstance().


Wwise Unity Integration Documentation: AkSurfaceReflector.AcousticTextures

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ AcousticTextures

AK.Wwise.AcousticTexture [] AkSurfaceReflector.AcousticTextures = new AK.Wwise.AcousticTexture[1]

The acoustic texture per submesh. The acoustic texture represents the surface of the geometry. An acoustic texture is a set of absorption levels that will filter the sound reflected from the geometry.

被这些函数引用 SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.AssociatedRoom

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ AssociatedRoom

AkRoom AkSurfaceReflector.AssociatedRoom = null

Optional room with which this surface reflector is associated. It is recommended to associate geometry with a particular room if the geometry is fully contained within the room and the room does not share any geometry with any other rooms. Doing so reduces the search space for ray casting performed by reflection and diffraction calculations.

被这些函数引用 SetGeometryInstance().


Wwise Unity Integration Documentation: AkSurfaceReflector.EnableDiffraction

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ EnableDiffraction

bool AkSurfaceReflector.EnableDiffraction = true

Switch to enable or disable geometric diffraction for this mesh.

被这些函数引用 SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.EnableDiffractionOnBoundaryEdges

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ EnableDiffractionOnBoundaryEdges

bool AkSurfaceReflector.EnableDiffractionOnBoundaryEdges = false

Switch to enable or disable geometric diffraction on boundary edges for this mesh. Boundary edges are edges that are connected to only one triangle.

被这些函数引用 SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.Mesh

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ Mesh

UnityEngine.Mesh AkSurfaceReflector.Mesh

The mesh to send to Spatial Audio as a Geometry Set. We recommend using a simplified mesh.

被这些函数引用 SetGeometry().


Wwise Unity Integration Documentation: AkSurfaceReflector.TransmissionLossValues

  • AkSurfaceReflector
AcousticTextures
AssociatedRoom
EnableDiffraction
EnableDiffractionOnBoundaryEdges
Mesh
RemoveGeometry
RemoveGeometryInstance
SetGeometry
SetGeometryFromMesh
SetGeometryInstance
SetGeometryInstance
TransmissionLossValues
UpdateGeometry

◆ TransmissionLossValues

float [] AkSurfaceReflector.TransmissionLossValues = new[] { 1.0f }

The transmission loss value per submesh. The transmission loss value is a control value used to adjust sound parameters. Typically, a value of 1.0 represents total sound loss, and a value of 0.0 indicates that sound can be transmitted through the geometry without any loss. Default value : 1.0.

被这些函数引用 SetGeometry().


Wwise Unity Integration Documentation: AkSwitch类 参考

Public 属性 | 静态 Public 属性 | 所有成员列表
AkSwitch类 参考

This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it. 更多...

继承自 AkDragDropTriggerHandler , 以及 AK.Wwise.IMigratable .

Public 属性

System.Collections.Generic.List< int > | triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
List containing the enabled triggers. 更多...
bool | useOtherObject = false
This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object. 更多...

静态 Public 属性

const int | MAX_NB_TRIGGERS = 32
Since our mask is a 32 bits integer, we can't have more than 32 triggers 更多...
static System.Collections.Generic.Dictionary< uint, string > | triggerTypes = AkTriggerBase.GetAllDerivedTypes()
Will contain the types of all the triggers derived from AkTriggerBase at runtime 更多...

详细描述

This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it.

参见
  • Integration Details - Switches (Note: This is described in the Wwise SDK documentation.)


Wwise Unity Integration Documentation: AkTriggerBase类 参考

Public 成员函数 | Public 属性 | 所有成员列表
AkTriggerBase类 参考

Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in 为 Wwise Events 添加新的 Trigger。 更多...

继承自 MonoBehaviour .

被 AkTriggerCollisionEnter, AkTriggerCollisionExit, AkTriggerDisable, AkTriggerEnable, AkTriggerEnter, AkTriggerExit, AkTriggerMouseDown, AkTriggerMouseEnter, AkTriggerMouseExit , 以及 AkTriggerMouseUp 继承.

Public 成员函数

delegate void Trigger (UnityEngine.GameObject in_gameObject)
Delegate declaration for all Wwise Triggers. 更多...

Public 属性

Trigger triggerDelegate = null
All components reacting to the trigger will be registered in this delegate. 更多...

详细描述

Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in 为 Wwise Events 添加新的 Trigger。


Wwise Unity Integration Documentation: AkTriggerBase.Trigger

  • AkTriggerBase
Trigger
triggerDelegate

◆ Trigger()

delegate void AkTriggerBase.Trigger ( UnityEngine.GameObject in_gameObject )

Delegate declaration for all Wwise Triggers.

参数
in_gameObject in_gameObject is used to pass "Collidee" objects when Colliders are used. Some components have the option "Use other object", this is the object they'll use.


Wwise Unity Integration Documentation: AkTriggerBase.triggerDelegate

  • AkTriggerBase
Trigger
triggerDelegate

◆ triggerDelegate

Trigger AkTriggerBase.triggerDelegate = null

All components reacting to the trigger will be registered in this delegate.


Wwise Unity Integration Documentation: AkWaapiUtilities类 参考

类 | Public 成员函数 | 静态 Public 成员函数 | 静态 Public 属性 | 所有成员列表
AkWaapiUtilities类 参考

This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages. 更多...

类

class | SubscriptionInfo
Class used to store information about a specific subscription. 更多...
struct | WaapiCommand
A simple structure containing an async payload function that will be executed when it is consumed by the command queue. 更多...

Public 成员函数

delegate void | GetResultListDelegate< T > (List< T > result)
Generic delegate function for callbacks that expect to receive a list of objects in response to a WAAPI request. 更多...
delegate void | GetResultDelegate< T > (T result)
Generic delegate function for callbacks that expect to receive a single object in response to a WAAPI request. 更多...

静态 Public 成员函数

static bool | IsConnected ()
Check whether the client is currently connected. 更多...
static void | Disconnected ()
Invoked after the client has disconnected from Wwise authoring. 更多...
static string | GetStatusString ()
Returns a rich text string representing the current WAAPI connection status. 更多...
static void | QueueCommand (string uri, string args, string options)
Use this function to enqueue a command with no expected return object. 更多...
static void | QueueCommandWithReturnType< T > (string uri, GetResultDelegate< T > callback, string args=null, string options=null)
Use this function to enqueue a command with an expected return object of type T. The command will deserialize the respone as type T and pass it to the callback. /// 更多...
static void | QueueCommandWithReturnWwiseObjects< T > (WaqlArgs args, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a command with a payload that desirializes the list of wwise objects from the response. 更多...
static void | GetWwiseObject< T > (System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a Wwise object with custom return options. 更多...
static void | GetWwiseObjects< T > (List< System.Guid > guids, ReturnOptions options, GetResultListDelegate< T > callback)
Generic function for fetching a list of Wwise objects with custom return options. 更多...
static void | GetWwiseObjectAndAncestors< T > (System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Enqueues a waapi command to fetch the specified object and all of its ancestors in the hierarchy. Passes the list of WwiseObjectInfo containing the specified object and ancestors to the callback. 更多...
static void | GetWwiseObjectAndDescendants< T > (System.Guid guid, ReturnOptions options, int depth, GetResultListDelegate< T > callback)
Enqueues a waapi comand to fetch the specified object and all of its descendants in the hierarchy to a specified depth. Passes the list of WwiseObjectInfo containing the specified object and descendants to the callback. 更多...
static void | GetWwiseObjectAndDescendants< T > (string identifier, ReturnOptions options, int depth, GetResultListDelegate< T > callback)
Composes a WAQL "from object" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the results to the callback 更多...
static void | Search< T > (string searchString, WwiseObjectType objectType, ReturnOptions options, GetResultListDelegate< T > callback)
Composes a WAQL "search" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the search results to the callback 更多...
static void | GetChildren< T > (System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback)
Get the children of a given object. 更多...
static void | GetProject< T > (GetResultListDelegate< T > callback, ReturnOptions options)
Get the WwiseObjectInfo for the project. 更多...
static List< WwiseObjectInfo > | ParseObjectInfo (List< WwiseObjectInfoJsonObject > returnObjects)
Parse the response WwiseObjectInfoJsonObject of a "from object" request and implicit cast the objects to WwiseObjectInfo. 更多...
static void | SelectObjectInAuthoring (System.Guid guid)
Select the object in Wwise Authoring. Creates a WaapiCommand object containing a lambda call to SelectObjectInAuthoringAsync and adds it to the waapiCommandQueue. 更多...
static void | OpenWorkUnitInExplorer (System.Guid guid)
Open the OS file browser to the folder containing this object's Work Unit. Creates a WaapiCommand object containing a lambda call to OpenWorkUnitInExplorerAsync and adds it to the waapiCommandQueue. 更多...
static void | OpenSoundBankInExplorer (System.Guid guid)
Open the OS file browser to the folder containing the generated SoundBank. Creates a WaapiCommand object containing a lambda call to OpenSoundBankInExplorer and adds it to the waapiCommandQueue. 更多...
static void | Rename (System.Guid guid, string newName)
Rename an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to RenameAsync and adds it to the waapiCommandQueue. 更多...
static void | Delete (System.Guid guid)
Delete an object in wwise authoring. Work Units cannot be deleted in this manner. Creates a WaapiCommand object containing a lambda call to DeleteAsync and adds it to the waapiCommandQueue. 更多...
static bool | IsPlayable (WwiseObjectType type)
Checks if Wwise object is playable. 更多...
static void | TogglePlayEvent (WwiseObjectType objectType, System.Guid guid)
Play or pause an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to TogglePlayEventAsync and adds it to the waapiCommandQueue. /summary>

参数
objectType | Used to check whether the object is playable.
guid | GUID of the object to be played.
更多...
static void | StopAllTransports ()
Stops all playing transports. Creates a WaapiCommand object containing a lambda call to StopAllTransportsAsync and adds it to the waapiCommandQueue. 更多...
static void | Subscribe (string topic, Wamp.PublishHandler subscriptionCallback, System.Action< SubscriptionInfo > handshakeCallback)
Subscribe to WAAPI topic. Refer to WAAPI reference documentation for a list of topics and their options. Creates a WaapiCommand object containing a lambda call to SubscribeAsync and adds it to the waapiCommandQueue. 更多...
static void | Unsubscribe (uint id)
Unsubscribe from an existing subscription. Creates a WaapiCommand object containing a lambda call to UnsubscribeAsync and adds it to the waapiCommandQueue. 更多...
static List< WwiseObjectInfo > | ParseSelectedObjects (string json)
Deserializes the objects published by the ak.wwise.ui.selectionChanged topic. 更多...
static WwiseRenameInfo | ParseRenameObject (string json)
Deserializes the object published by the ak.wwise.core.object.nameChanged topic. 更多...
static WwiseChildModifiedInfo | ParseChildAddedOrRemoved (string json)
Deserializes the object published by the ak.wwise.core.object.childAdded or ak.wwise.core.object.childRemoved topic. 更多...

静态 Public 属性

static System.Action< bool > | Disconnecting
Fired when the connection is closing or closed, the bool parameter represents whether the socket connection is still open (for cleaning up subscriptions). 更多...
static System.Action | Connected
Fired when the connection is established, should be used by external classes to subscribe to topics they are interested in. 更多...
static System.Action | QueueConsumed
Fired when all commands in the queue have been executed. 更多...

详细描述

This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages.


Wwise Unity Integration Documentation: AkWaapiUtilities.SubscriptionInfo类 参考

  • AkWaapiUtilities
  • SubscriptionInfo
所有成员列表
AkWaapiUtilities.SubscriptionInfo类 参考

Class used to store information about a specific subscription. 更多...

详细描述

Class used to store information about a specific subscription.


Wwise Unity Integration Documentation: AkWaapiUtilities.WaapiCommand结构体 参考

  • AkWaapiUtilities
  • WaapiCommand
所有成员列表
AkWaapiUtilities.WaapiCommand结构体 参考

A simple structure containing an async payload function that will be executed when it is consumed by the command queue. 更多...

详细描述

A simple structure containing an async payload function that will be executed when it is consumed by the command queue.


Wwise Unity Integration Documentation: AkWaapiUtilities.Delete

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Delete()

static void AkWaapiUtilities.Delete ( System.Guid guid )
inlinestatic

Delete an object in wwise authoring. Work Units cannot be deleted in this manner. Creates a WaapiCommand object containing a lambda call to DeleteAsync and adds it to the waapiCommandQueue.

参数
guid GUID of the object to be deleted.


Wwise Unity Integration Documentation: AkWaapiUtilities.Disconnected

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Disconnected()

static void AkWaapiUtilities.Disconnected ( )
inlinestatic

Invoked after the client has disconnected from Wwise authoring.

引用了 Disconnecting.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetChildren< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetChildren< T >()

static void AkWaapiUtilities.GetChildren< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Get the children of a given object.

参数
guid | GUID of the target object.
options | Specifies which object properties to include in the response
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetProject< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetProject< T >()

static void AkWaapiUtilities.GetProject< T > | ( | GetResultListDelegate< T > | callback,
 |  | ReturnOptions | options
 | ) |  |
inlinestatic

Get the WwiseObjectInfo for the project.

参数
callback | Function accepting a list of WwiseObjectInfo. The first element of the list will be the project info.
options | Specifies which object properties to include in the response


Wwise Unity Integration Documentation: AkWaapiUtilities.GetResultDelegate< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetResultDelegate< T >()

delegate void AkWaapiUtilities.GetResultDelegate< T > ( T result )

Generic delegate function for callbacks that expect to receive a single object in response to a WAAPI request.

参数
result


Wwise Unity Integration Documentation: AkWaapiUtilities.GetResultListDelegate< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetResultListDelegate< T >()

delegate void AkWaapiUtilities.GetResultListDelegate< T > ( List< T > result )

Generic delegate function for callbacks that expect to receive a list of objects in response to a WAAPI request.

参数
result


Wwise Unity Integration Documentation: AkWaapiUtilities.GetStatusString

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetStatusString()

static string AkWaapiUtilities.GetStatusString ( )
inlinestatic

Returns a rich text string representing the current WAAPI connection status.

返回


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObject< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObject< T >()

static void AkWaapiUtilities.GetWwiseObject< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Generic function for fetching a Wwise object with custom return options.

模板参数
T Type of the object to be deserialized from the response.
参数
guid | GUID of the target object.
options | Specifies which object properties to include in the response
callback | Function accteping a list of T objects.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjectAndAncestors< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjectAndAncestors< T >()

static void AkWaapiUtilities.GetWwiseObjectAndAncestors< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Enqueues a waapi command to fetch the specified object and all of its ancestors in the hierarchy. Passes the list of WwiseObjectInfo containing the specified object and ancestors to the callback.

参数
guid | GUID of the target object.
options | Specifies which object properties to include in the response
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjectAndDescendants< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjectAndDescendants< T >() [1/2]

static void AkWaapiUtilities.GetWwiseObjectAndDescendants< T > | ( | string | identifier,
 |  | ReturnOptions | options,
 |  | int | depth,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Composes a WAQL "from object" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the results to the callback

参数
identifier | Can bethe target object GUID or path within the hierarchy.
options | Specifies which object properties to include in the response
depth | Depth of descendants to fetch. If -1, fetches all descendants.
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjectAndDescendants< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjectAndDescendants< T >() [2/2]

static void AkWaapiUtilities.GetWwiseObjectAndDescendants< T > | ( | System.Guid | guid,
 |  | ReturnOptions | options,
 |  | int | depth,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Enqueues a waapi comand to fetch the specified object and all of its descendants in the hierarchy to a specified depth. Passes the list of WwiseObjectInfo containing the specified object and descendants to the callback.

参数
guid | GUID of the target object.
options | Specifies which object properties to include in the response
depth | Depth of descendants to fetch. If -1, fetches all descendants.
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.GetWwiseObjects< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ GetWwiseObjects< T >()

static void AkWaapiUtilities.GetWwiseObjects< T > | ( | List< System.Guid > | guids,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Generic function for fetching a list of Wwise objects with custom return options.

模板参数
T Type of the object to be deserialized from the response.
参数
guids | GUIDs of the target objects.
options | Specifies which object properties to include in the response
callback | Function accteping a list of T objects.


Wwise Unity Integration Documentation: AkWaapiUtilities.IsConnected

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ IsConnected()

static bool AkWaapiUtilities.IsConnected ( )
inlinestatic

Check whether the client is currently connected.

返回


Wwise Unity Integration Documentation: AkWaapiUtilities.IsPlayable

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ IsPlayable()

static bool AkWaapiUtilities.IsPlayable ( WwiseObjectType type )
inlinestatic

Checks if Wwise object is playable.

参数
type WwiseObjectType of object to check.
返回
True if playable

被这些函数引用 TogglePlayEvent().


Wwise Unity Integration Documentation: AkWaapiUtilities.OpenSoundBankInExplorer

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ OpenSoundBankInExplorer()

static void AkWaapiUtilities.OpenSoundBankInExplorer ( System.Guid guid )
inlinestatic

Open the OS file browser to the folder containing the generated SoundBank. Creates a WaapiCommand object containing a lambda call to OpenSoundBankInExplorer and adds it to the waapiCommandQueue.

参数
guid GUID of the SoundBank to be found.


Wwise Unity Integration Documentation: AkWaapiUtilities.OpenWorkUnitInExplorer

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ OpenWorkUnitInExplorer()

static void AkWaapiUtilities.OpenWorkUnitInExplorer ( System.Guid guid )
inlinestatic

Open the OS file browser to the folder containing this object's Work Unit. Creates a WaapiCommand object containing a lambda call to OpenWorkUnitInExplorerAsync and adds it to the waapiCommandQueue.

参数
guid GUID of the object to be found.


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseChildAddedOrRemoved

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseChildAddedOrRemoved()

static WwiseChildModifiedInfo AkWaapiUtilities.ParseChildAddedOrRemoved ( string json )
inlinestatic

Deserializes the object published by the ak.wwise.core.object.childAdded or ak.wwise.core.object.childRemoved topic.

参数
json Json string containing the message.
返回
WwiseChildModifiedInfo containing parent and child object information.


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseObjectInfo

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseObjectInfo()

static List<WwiseObjectInfo> AkWaapiUtilities.ParseObjectInfo ( List< WwiseObjectInfoJsonObject > returnObjects )
inlinestatic

Parse the response WwiseObjectInfoJsonObject of a "from object" request and implicit cast the objects to WwiseObjectInfo.

参数
returnObjects
返回


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseRenameObject

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseRenameObject()

static WwiseRenameInfo AkWaapiUtilities.ParseRenameObject ( string json )
inlinestatic

Deserializes the object published by the ak.wwise.core.object.nameChanged topic.

参数
json Json string containing the message.
返回
WwiseRenameInfo containing the object information and the new name.


Wwise Unity Integration Documentation: AkWaapiUtilities.ParseSelectedObjects

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ ParseSelectedObjects()

static List<WwiseObjectInfo> AkWaapiUtilities.ParseSelectedObjects ( string json )
inlinestatic

Deserializes the objects published by the ak.wwise.ui.selectionChanged topic.

参数
json Json string containing the message.
返回
List of WwiseObjectInfo objects.


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueCommand

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueCommand()

static void AkWaapiUtilities.QueueCommand | ( | string | uri,
 |  | string | args,
 |  | string | options
 | ) |  |
inlinestatic

Use this function to enqueue a command with no expected return object.

参数
uri | The URI of the waapi command
args | The command-specific arguments
options | The command-specific options


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueCommandWithReturnType< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueCommandWithReturnType< T >()

static void AkWaapiUtilities.QueueCommandWithReturnType< T > | ( | string | uri,
 |  | GetResultDelegate< T > | callback,
 |  | string | args = null,
 |  | string | options = null
 | ) |  |
inlinestatic

Use this function to enqueue a command with an expected return object of type T. The command will deserialize the respone as type T and pass it to the callback. ///

模板参数
T Type of the expected return object
参数
uri | The URI of the waapi command
args | The command-specific arguments
options | The command-specific options
callback | Function accepting an argument of type T


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueCommandWithReturnWwiseObjects< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueCommandWithReturnWwiseObjects< T >()

static void AkWaapiUtilities.QueueCommandWithReturnWwiseObjects< T > | ( | WaqlArgs | args,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Enqueues a command with a payload that desirializes the list of wwise objects from the response.

参数
args
options
callback


Wwise Unity Integration Documentation: AkWaapiUtilities.Rename

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Rename()

static void AkWaapiUtilities.Rename | ( | System.Guid | guid,
 |  | string | newName
 | ) |  |
inlinestatic

Rename an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to RenameAsync and adds it to the waapiCommandQueue.

参数
guid | GUID of the object to be renamed.
newName | New name for the wwise object.


Wwise Unity Integration Documentation: AkWaapiUtilities.Search< T >

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Search< T >()

static void AkWaapiUtilities.Search< T > | ( | string | searchString,
 |  | WwiseObjectType | objectType,
 |  | ReturnOptions | options,
 |  | GetResultListDelegate< T > | callback
 | ) |  |
inlinestatic

Composes a WAQL "search" request based on the parameters and enqueues a WAAPI command. Passes the list of WwiseObjectInfo containing the search results to the callback

参数
searchString | Characters to search for.
options | Specifies which object properties to include in the response
objectType | An optional object type used to filter search results.
callback | Function accepting a list of WwiseObjectInfo.


Wwise Unity Integration Documentation: AkWaapiUtilities.SelectObjectInAuthoring

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ SelectObjectInAuthoring()

static void AkWaapiUtilities.SelectObjectInAuthoring ( System.Guid guid )
inlinestatic

Select the object in Wwise Authoring. Creates a WaapiCommand object containing a lambda call to SelectObjectInAuthoringAsync and adds it to the waapiCommandQueue.

参数
guid GUID of the object to be selected.


Wwise Unity Integration Documentation: AkWaapiUtilities.StopAllTransports

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ StopAllTransports()

static void AkWaapiUtilities.StopAllTransports ( )
inlinestatic

Stops all playing transports. Creates a WaapiCommand object containing a lambda call to StopAllTransportsAsync and adds it to the waapiCommandQueue.


Wwise Unity Integration Documentation: AkWaapiUtilities.Subscribe

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Subscribe()

static void AkWaapiUtilities.Subscribe | ( | string | topic,
 |  | Wamp.PublishHandler | subscriptionCallback,
 |  | System.Action< SubscriptionInfo > | handshakeCallback
 | ) |  |
inlinestatic

Subscribe to WAAPI topic. Refer to WAAPI reference documentation for a list of topics and their options. Creates a WaapiCommand object containing a lambda call to SubscribeAsync and adds it to the waapiCommandQueue.

参数
topic | The topic URI to subscribe to.
subscriptionCallback | Delegate function to call when the topic is published.
handshakeCallback | Action to be executed once the subscription has been made. This should store the subscription ID so that the subscription can be cleaned up when it is no longer needed.

被这些函数引用 AkWwiseTreeWAAPIDataSource.SubscribeTopics().


Wwise Unity Integration Documentation: AkWaapiUtilities.TogglePlayEvent

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ TogglePlayEvent()

static void AkWaapiUtilities.TogglePlayEvent | ( | WwiseObjectType | objectType,
 |  | System.Guid | guid
 | ) |  |
inlinestatic

Play or pause an object in Wwise authoring. Creates a WaapiCommand object containing a lambda call to TogglePlayEventAsync and adds it to the waapiCommandQueue. /summary>

参数
objectType | Used to check whether the object is playable.
guid | GUID of the object to be played.

引用了 IsPlayable().


Wwise Unity Integration Documentation: AkWaapiUtilities.Unsubscribe

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Unsubscribe()

static void AkWaapiUtilities.Unsubscribe ( uint id )
inlinestatic

Unsubscribe from an existing subscription. Creates a WaapiCommand object containing a lambda call to UnsubscribeAsync and adds it to the waapiCommandQueue.

参数
id The subscription ID received from the initial subscription.


Wwise Unity Integration Documentation: AkWaapiUtilities.Connected

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Connected

System.Action AkWaapiUtilities.Connected
static

Fired when the connection is established, should be used by external classes to subscribe to topics they are interested in.


Wwise Unity Integration Documentation: AkWaapiUtilities.Disconnecting

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ Disconnecting

System.Action<bool> AkWaapiUtilities.Disconnecting
static

Fired when the connection is closing or closed, the bool parameter represents whether the socket connection is still open (for cleaning up subscriptions).

被这些函数引用 Disconnected().


Wwise Unity Integration Documentation: AkWaapiUtilities.QueueConsumed

  • AkWaapiUtilities
Connected
Delete
Disconnected
Disconnecting
GetChildren< T >
GetProject< T >
GetResultDelegate< T >
GetResultListDelegate< T >
GetStatusString
GetWwiseObject< T >
GetWwiseObjectAndAncestors< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjectAndDescendants< T >
GetWwiseObjects< T >
IsConnected
IsPlayable
OpenSoundBankInExplorer
OpenWorkUnitInExplorer
ParseChildAddedOrRemoved
ParseObjectInfo
ParseRenameObject
ParseSelectedObjects
QueueCommand
QueueCommandWithReturnType< T >
QueueCommandWithReturnWwiseObjects< T >
QueueConsumed
Rename
Search< T >
SelectObjectInAuthoring
StopAllTransports
Subscribe
TogglePlayEvent
Unsubscribe

◆ QueueConsumed

System.Action AkWaapiUtilities.QueueConsumed
static

Fired when all commands in the queue have been executed.


Wwise Unity Integration Documentation: AkWwiseTreeWAAPIDataSource类 参考

Public 成员函数 | 所有成员列表
AkWwiseTreeWAAPIDataSource类 参考

This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions. 更多...

继承自 AkWwiseTreeDataSource .

Public 成员函数

void SubscribeTopics ()
Subscribes to nameChanged, childAdded, childRemoved, and selectionChanged WAAPI events in order to keep the picker in sync with the Wwise project explorer. 更多...

详细描述

This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions.


Wwise Unity Integration Documentation: AkWwiseTreeWAAPIDataSource.SubscribeTopics

  • AkWwiseTreeWAAPIDataSource
SubscribeTopics

◆ SubscribeTopics()

void AkWwiseTreeWAAPIDataSource.SubscribeTopics ( )
inline

Subscribes to nameChanged, childAdded, childRemoved, and selectionChanged WAAPI events in order to keep the picker in sync with the Wwise project explorer.

引用了 AkWaapiUtilities.Subscribe().


Wwise Unity Integration Documentation: Args类 参考

所有成员列表
Args类 参考

Abstract base class for WAAPI command arguments. 更多...

类 Args 继承关系图:
JsonSerializable ArgsCommand ArgsDisplayName ArgsObject ArgsPlay ArgsRename ArgsTransport WaqlArgs

详细描述

Abstract base class for WAAPI command arguments.


Wwise Unity Integration Documentation: ArgsCommand类 参考

所有成员列表
ArgsCommand类 参考

WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync(). 更多...

类 ArgsCommand 继承关系图:
Args JsonSerializable

详细描述

WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync().


Wwise Unity Integration Documentation: ArgsDisplayName类 参考

所有成员列表
ArgsDisplayName类 参考

WAAPI arguments containing an object identfier and name used when deleting an object. 更多...

类 ArgsDisplayName 继承关系图:
Args JsonSerializable

详细描述

WAAPI arguments containing an object identfier and name used when deleting an object.


Wwise Unity Integration Documentation: ArgsObject类 参考

所有成员列表
ArgsObject类 参考

WAAPI arguments containing an object identfier. 更多...

类 ArgsObject 继承关系图:
Args JsonSerializable

详细描述

WAAPI arguments containing an object identfier.


Wwise Unity Integration Documentation: ArgsPlay类 参考

所有成员列表
ArgsPlay类 参考

WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback. 更多...

类 ArgsPlay 继承关系图:
Args JsonSerializable

详细描述

WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback.


Wwise Unity Integration Documentation: ArgsRename类 参考

所有成员列表
ArgsRename类 参考

WAAPI arguments containing an object identfier and new value used when renaming an object. 更多...

类 ArgsRename 继承关系图:
Args JsonSerializable

详细描述

WAAPI arguments containing an object identfier and new value used when renaming an object.


Wwise Unity Integration Documentation: ArgsTransport类 参考

所有成员列表
ArgsTransport类 参考

WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands. 更多...

类 ArgsTransport 继承关系图:
Args JsonSerializable

详细描述

WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands.


Wwise Unity Integration Documentation: ErrorDetails类 参考

所有成员列表
ErrorDetails类 参考

Used to deserialize details in WAAPI error messages. 更多...

类 ErrorDetails 继承关系图:
JsonSerializable

详细描述

Used to deserialize details in WAAPI error messages.


Wwise Unity Integration Documentation: ErrorMessage类 参考

所有成员列表
ErrorMessage类 参考

Used to deserialize WAAPI error messages. 更多...

类 ErrorMessage 继承关系图:
JsonSerializable

详细描述

Used to deserialize WAAPI error messages.


Wwise Unity Integration Documentation: JsonSerializable类 参考

所有成员列表
JsonSerializable类 参考

Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson. 更多...

类 JsonSerializable 继承关系图:
Args ErrorDetails ErrorMessage Options ReturnTransport ReturnWwiseObjects< T > ReturnWwiseObjects< T > SelectedWwiseObjects TransportState WwiseChildModifiedInfo WwiseRenameInfo

详细描述

Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson.


Wwise Unity Integration Documentation: Options类 参考

所有成员列表
Options类 参考

Abstract base class for WAAPI command options. 更多...

类 Options 继承关系图:
JsonSerializable ReturnOptions TransportOptions

详细描述

Abstract base class for WAAPI command options.


Wwise Unity Integration Documentation: ReturnOptions类 参考

所有成员列表
ReturnOptions类 参考

WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects. 更多...

类 ReturnOptions 继承关系图:
Options JsonSerializable

详细描述

WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects.


Wwise Unity Integration Documentation: ReturnTransport类 参考

所有成员列表
ReturnTransport类 参考

Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID. 更多...

类 ReturnTransport 继承关系图:
JsonSerializable

详细描述

Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID.


Wwise Unity Integration Documentation: ReturnWwiseObjects类 参考

ReturnWwiseObjects类 参考

Class used to deserialize a WAAPI response containing Wwise objects. 更多...

详细描述

Class used to deserialize a WAAPI response containing Wwise objects.


Wwise Unity Integration Documentation: SelectedWwiseObjects类 参考

所有成员列表
SelectedWwiseObjects类 参考

Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic. 更多...

类 SelectedWwiseObjects 继承关系图:
JsonSerializable

详细描述

Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic.


Wwise Unity Integration Documentation: TransportOptions类 参考

所有成员列表
TransportOptions类 参考

WAAPI options used to specify the transport ID when subscribing. 更多...

类 TransportOptions 继承关系图:
Options JsonSerializable

详细描述

WAAPI options used to specify the transport ID when subscribing.


Wwise Unity Integration Documentation: TransportState类 参考

所有成员列表
TransportState类 参考

Used to deserialize transport-state information receieved from the transport.stateChanged topic. 更多...

类 TransportState 继承关系图:
JsonSerializable

详细描述

Used to deserialize transport-state information receieved from the transport.stateChanged topic.


Wwise Unity Integration Documentation: WaapiHelper类 参考

所有成员列表
WaapiHelper类 参考

Contains a helper function GetWwiseObjectTypeFromString. 更多...

详细描述

Contains a helper function GetWwiseObjectTypeFromString.


Wwise Unity Integration Documentation: WaapiKeywords类 参考

静态 Public 属性 | 所有成员列表
WaapiKeywords类 参考

Contains fields for specific WAAPI keywords. 更多...

静态 Public 属性

static ReadOnlyDictionary< WwiseObjectType, string > | WwiseObjectTypeStrings
Maps WwiseObjectType to strings. 更多...
static ReadOnlyDictionary< string, string > | FolderDisplaynames
Maps root folder names to displayed strings. 更多...
static ReadOnlyDictionary< string, WwiseObjectType > | typeStringDict
Maps strings to WwiseObjectType. 更多...

详细描述

Contains fields for specific WAAPI keywords.


Wwise Unity Integration Documentation: WaapiKeywords.FolderDisplaynames

  • WaapiKeywords
FolderDisplaynames
typeStringDict
WwiseObjectTypeStrings

◆ FolderDisplaynames

ReadOnlyDictionary<string, string> WaapiKeywords.FolderDisplaynames
static

Maps root folder names to displayed strings.


Wwise Unity Integration Documentation: WaapiKeywords.typeStringDict

  • WaapiKeywords
FolderDisplaynames
typeStringDict
WwiseObjectTypeStrings

◆ typeStringDict

ReadOnlyDictionary<string, WwiseObjectType> WaapiKeywords.typeStringDict
static

Maps strings to WwiseObjectType.


Wwise Unity Integration Documentation: WaapiKeywords.WwiseObjectTypeStrings

  • WaapiKeywords
FolderDisplaynames
typeStringDict
WwiseObjectTypeStrings

◆ WwiseObjectTypeStrings

ReadOnlyDictionary<WwiseObjectType, string> WaapiKeywords.WwiseObjectTypeStrings
static

Maps WwiseObjectType to strings.


Wwise Unity Integration Documentation: Wamp类 参考

类 | Public 成员函数 | 所有成员列表
Wamp类 参考

WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise. 更多...

类

class | ErrorException
Exception thrown during WAMP operations. 更多...
class | TimeoutException
Exception thrown during WAMP operations when the timeout is reached. 更多...

Public 成员函数

delegate void PublishHandler (string json)
Publish events are delegates registered with Subscribe. 更多...

详细描述

WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise.


Wwise Unity Integration Documentation: Wamp.ErrorException类 参考

  • Wamp
  • ErrorException
所有成员列表
Wamp.ErrorException类 参考

Exception thrown during WAMP operations. 更多...

继承自 Exception .

详细描述

Exception thrown during WAMP operations.


Wwise Unity Integration Documentation: Wamp.TimeoutException类 参考

  • Wamp
  • TimeoutException
所有成员列表
Wamp.TimeoutException类 参考

Exception thrown during WAMP operations when the timeout is reached. 更多...

继承自 Exception .

详细描述

Exception thrown during WAMP operations when the timeout is reached.


Wwise Unity Integration Documentation: Wamp.PublishHandler

  • Wamp
PublishHandler

◆ PublishHandler()

delegate void Wamp.PublishHandler ( string json )

Publish events are delegates registered with Subscribe.


Wwise Unity Integration Documentation: WaqlArgs类 参考

所有成员列表
WaqlArgs类 参考

WAAPI arguments containing a WAQL string. 更多...

类 WaqlArgs 继承关系图:
Args JsonSerializable

详细描述

WAAPI arguments containing a WAQL string.


Wwise Unity Integration Documentation: WwiseChildModifiedInfo类 参考

所有成员列表
WwiseChildModifiedInfo类 参考

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics. 更多...

类 WwiseChildModifiedInfo 继承关系图:
JsonSerializable

详细描述

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics.


Wwise Unity Integration Documentation: WwiseObjectInfo结构体 参考

所有成员列表
WwiseObjectInfo结构体 参考

Class containing the information returned by a WAAPI request for an object. 更多...

详细描述

Class containing the information returned by a WAAPI request for an object.


Wwise Unity Integration Documentation: WwiseObjectInfoJsonObject类 参考

所有成员列表
WwiseObjectInfoJsonObject类 参考

Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo. 更多...

详细描述

Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo.


Wwise Unity Integration Documentation: WwiseObjectInfoParent类 参考

所有成员列表
WwiseObjectInfoParent类 参考

Contains the GUID of the returned object's parent. 更多...

详细描述

Contains the GUID of the returned object's parent.


Wwise Unity Integration Documentation: WwiseRenameInfo类 参考

所有成员列表
WwiseRenameInfo类 参考

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic. 更多...

类 WwiseRenameInfo 继承关系图:
JsonSerializable

详细描述

Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic.


Wwise Unity Integration Documentation: 类索引

类索引
a | b | c | e | j | o | r | s | t | w
a
AkMemBankLoader ArgsObject
o
TransportOptions
AkRadialEmitter ArgsPlay TransportState
ak AkRoom ArgsRename Options Wamp.TimeoutException
AcousticTexture (AK.Wwise) AkRoomAwareManager ArgsTransport
r
w
AuxBus (AK.Wwise) AkRoomAwareObject
b
AkAmbient AkRoomManager RTPC (AK.Wwise) AkWaapiUtilities.WaapiCommand
AkAmbientLargeModePositioner AkRoomPortal Bank (AK.Wwise) ReturnOptions WaapiHelper
AkAudioListener AkRoomPortalObstruction BaseGroupType (AK.Wwise) ReturnTransport WaapiKeywords
AkBank AkSpatialAudioDebugDraw BaseType (AK.Wwise) ReturnWwiseObjects Wamp
AkEarlyReflections AkSpatialAudioEmitter
c
ReturnWwiseObjects WaqlArgs
AkEmitterObstructionOcclusion AkSpatialAudioListener
s
WwiseChildModifiedInfo
AkEnvironment AkState CallbackFlags (AK.Wwise) WwiseObjectInfo
AkEnvironment.AkEnvironment_CompareByPriority AkSurfaceReflector
e
State (AK.Wwise) WwiseObjectInfoJsonObject
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm AkSwitch Switch (AK.Wwise) WwiseObjectInfoParent
AkEnvironmentPortal AkTriggerBase Event (AK.Wwise) AkSpatialAudioListener.SpatialAudioListenerList WwiseRenameInfo
AkEvent AkWaapiUtilities AkEnvironmentPortal.EnvListWrapper AkWaapiUtilities.SubscriptionInfo
AkEventCallbackMsg AkWwiseTreeWAAPIDataSource ErrorDetails SelectedWwiseObjects
AkGameObj Args ErrorMessage
t
AkInitializer ArgsCommand Wamp.ErrorException
AkListenerDistanceProbe ArgsDisplayName
j
Trigger (AK.Wwise)
JsonSerializable


Wwise Unity Integration Documentation: 类继承关系

类继承关系
此继承关系列表按字典顺序粗略的排序:
[详情级别 123]
C ak | URI strings to use in WAAPI calls. For a complete description, refer to the official Wwise SDK documentation
▼C AK.Wwise.BaseType | This type represents the base for all Wwise Types that require a GUID
C AK.Wwise.AcousticTexture | This type represents an Acoustic Texture
C AK.Wwise.AuxBus | This type represents an auxiliary send in the Master-Mixer Hierarchy
C AK.Wwise.Bank | This type can be used to load/unload SoundBanks
▼C AK.Wwise.BaseGroupType | This type represents the base for all Wwise Types that also require a group GUID, such as State and Switch
C AK.Wwise.State | This type can be used to set Wwise States
C AK.Wwise.Switch | This type can be used to set Switch values on gameobjects
C AK.Wwise.Event | This type can be used to post Events to the sound engine
C AK.Wwise.RTPC | This type can be used to set game parameter values to the sound engine
C AK.Wwise.Trigger | This type can be used to post triggers to the sound engine
C AK.Wwise.CallbackFlags | This type represents the values of the flags used when posting an Event with a callback
C AkAmbientLargeModePositioner | Use this component to add a Large Mode position to any AkAmbient in a Scene
C AkAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C AkBank | Loads and unloads a SoundBank at a specified moment. Vorbis sounds can be decompressed at a specified moment using the decode compressed data option. In that case, the SoundBank will be prepared
C AkEarlyReflections | Set an early reflections auxiliary bus and send volume for a particular game object
C AkEmitterObstructionOcclusion | Completely obstructs/occludes the emitter of the current game object from its listeners if at least one object is between them
C AkEnvironment | Use this component to define a reverb zone. This needs to be added to a collider object to work properly. See 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone)
▼C AkEnvironment.AkEnvironment_CompareByPriority | Sorts AkEnvironments based on their priorities
C AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm | Sorts AkEnvironments based on the selection algorithm. The selection algorithm is as follows:
C AkEnvironmentPortal | Use this component to define an area that straddles two different AkEnvironment's zones and allow mixing between both zones. 在 Inspector 中使用 AkEnvironment 和 AkEnvironmentPortal (Reverb Zone)
C AkEnvironmentPortal.EnvListWrapper | This enables us to detect intersections between portals and environments in the editor
▼C AkEvent | Helper class that knows a Wwise Event and when to trigger it in Unity. As of 2017.2.0, the AkEvent inspector has buttons for play/stop, play multiple, stop multiple, and stop all. Play/Stop will play or stop the event such that it can be previewed both in edit mode and play mode. When multiple objects are selected, Play Multiple and Stop Multiple will play or stop the associated AkEvent for each object
C AkAmbient | Use this component to attach a Wwise Event to any object in a scene. The sound can be started at various moments, dependent on the selected Unity trigger. This component is more useful for ambient sounds (sounds related to scene-bound objects) but could also be used for other purposes. Since AkAmbient has AkEvent as its base class, it features the play/stop, play multiple, stop multiple and stop all buttons for previewing the associated Wwise event
C AkEventCallbackMsg | Event callback information. Event callback functions can receive this structure as a parameter
C AkGameObj | This component represents a sound object in your scene tracking its position and other game syncs such as Switches, RTPC and environment values. You can add this to any object that will emit sound, and it will be added to any object that an AkAudioListener is attached to. Note that if it is not present, Wwise will add it automatically, with the default values, to any Unity Game Object that is passed to Wwise
C AkInitializer | This script deals with initialization, and frame updates of the Wwise audio engine. It is marked as DontDestroyOnLoad so it stays active for the life of the game, not only one scene. Double-click the Initialization Settings entry, AkWwiseInitializationSettings, to review and edit Wwise initialization settings
C AkListenerDistanceProbe | Add this script on a listener game object to assign another game object as a distance probe. The position of the distance probe will be used for distance calculations for the listener, instead of the position of the listener itself. In third-person perspective applications, the distance probe Game Object may be set to the player character's position, and the listener Game Object's position to that of the camera. In this scenario, attenuation is based on the distance between the character and the sound, whereas panning, spatialization, and spread and focus calculations are based on the camera
C AkMemBankLoader | This class is an example of how to load banks in Wwise, if the bank data was preloaded in memory. This would be useful for situations where you use the WWW class
C AkRadialEmitter | A radial emitter is for sounds that are not point sources, but instead originate from a region of space
C AkRoom | An AkRoom is an enclosed environment that can only communicate to the outside/other rooms with AkRoomPortals
C AkRoomAwareManager | This manager tracks the AkRoomAwareObjects and the AkRooms in which they enter and exit
C AkRoomAwareObject | This component makes a GameObject aware of AkRoom components. When using Spatial Audio rooms, all emitters and the spatial audio listener should have this component
C AkRoomManager | This manager tracks AkRoomPortals and the rooms that they connect (front and back room)
C AkRoomPortal | An AkRoomPortal can connect two AkRoom components together
C AkRoomPortalObstruction | Completely obstructs the spatial audio portal of the current game object from the spatial audio listener if at least one object is between them
C AkSpatialAudioDebugDraw | Add this script on a GameObject to print Spatial Audio paths
C AkSpatialAudioEmitter | (DEPRECATED) This script is deprecated as of 2019.2. Early reflections, Diffraction and Room Reverb can all be enabled per sound in the Sound Property Editor of the Authoring
C AkSpatialAudioListener | Add this script on the game object that represent a listener. This is normally added to the Camera object or the Player object, but can be added to any game object when implementing 3D busses. isDefaultListener determines whether the game object will be considered a default listener - a listener that automatically listens to all game objects that do not have listeners attached to their AkGameObjListenerList's
C AkSpatialAudioListener.SpatialAudioListenerList | This class represents the list of active Unity Game Objects that are designated to be spatial audio listeners. Currently, only one spatial audio listener can be active at a time
C AkState | This will call AkSoundEngine.SetState() whenever the selected Unity event is triggered. For example this component could be set on a Unity collider to trigger when an object enters it
C AkSurfaceReflector | This component converts the provided mesh into Spatial Audio Geometry
C AkSwitch | This will call AkSoundEngine.SetSwitch() whenever the selected Unity event is triggered. For example, this component could be set on a Unity collider to trigger when an object enters it
C AkTriggerBase | Base class for the generic triggering mechanism for Wwise Integration. All Wwise components will use this mechanism to drive their behavior. Derive from this class to add your own triggering condition, as described in 为 Wwise Events 添加新的 Trigger。
C AkWaapiUtilities | This class wraps the client that communicates with the Wwise Authoring application via WAAPI. Given that only one request can be pending on the websocket, a queue is used to consume all calls sequentially. Messages sent to WAAPI use the JSON format and are serialized by Unity Json serialization. Helper classes (WaapiHelper) for serialization, keywords for WAAPI commands (WaapiKeywords), and classes for serializing message arguments and deserializing responses are found in AkWaapiHelper.cs. Uri.cs contains classes with fields containing URI strings for WAAPI calls and error messages
C AkWaapiUtilities.SubscriptionInfo | Class used to store information about a specific subscription
C AkWaapiUtilities.WaapiCommand | A simple structure containing an async payload function that will be executed when it is consumed by the command queue
C AkWwiseTreeWAAPIDataSource | This class communicates with Wwise Authoring via AkWaapiUtilities to keep track of the Wwise object hierarchy in the project. This hierarchy information is stored in a tree structure and is used by the Wwise Picker when it is in WAAPI mode. Changes to the project are received via WAAPI subscriptions
▼C JsonSerializable | Base class for Json serializable objects. Implements implicit cast to string using UnityEngine.JsonUtility.ToJson
▼C Args | Abstract base class for WAAPI command arguments
C ArgsCommand | WAAPI arguments containing an object identfier and command field. Used by AkWaapiUtilities.SelectObjectInAuthoringAsync()
C ArgsDisplayName | WAAPI arguments containing an object identfier and name used when deleting an object
C ArgsObject | WAAPI arguments containing an object identfier
C ArgsPlay | WAAPI arguments containing an Event identfier and transport ID. Used to toggle Event playback
C ArgsRename | WAAPI arguments containing an object identfier and new value used when renaming an object
C ArgsTransport | WAAPI arguments containing a transport ID. Used to specify transports in transport-specific commands
C WaqlArgs | WAAPI arguments containing a WAQL string
C ErrorDetails | Used to deserialize details in WAAPI error messages
C ErrorMessage | Used to deserialize WAAPI error messages
▼C Options | Abstract base class for WAAPI command options
C ReturnOptions | WAAPI options to specify the names of fields to return in a WAAPI request returning WwiseObjects
C TransportOptions | WAAPI options used to specify the transport ID when subscribing
C ReturnTransport | Used to deserialize the response from an ak.wwise.core.transport.create command. Contains the transport ID
C ReturnWwiseObjects< T > | Generic class to deserialize a WAAPI response containing Wwise objects with custom return options
C ReturnWwiseObjects< T > | Generic class to deserialize a WAAPI response containing Wwise objects with custom return options
C SelectedWwiseObjects | Class used to deserialize selected Wwise objects published on the ak.wwise.ui.selectionChanged topic
C TransportState | Used to deserialize transport-state information receieved from the transport.stateChanged topic
C WwiseChildModifiedInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Added and ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.c.nosp@m.hild.nosp@m.Remov.nosp@m.ed topics
C WwiseRenameInfo | Used to deserialize information published on the ak.ww.nosp@m.ise..nosp@m.core..nosp@m.@obj.nosp@m.ect.n.nosp@m.ameC.nosp@m.hange.nosp@m.d topic
C ReturnWwiseObjects | Class used to deserialize a WAAPI response containing Wwise objects
C WaapiHelper | Contains a helper function GetWwiseObjectTypeFromString
C WaapiKeywords | Contains fields for specific WAAPI keywords
C Wamp | WAMP protocol implementation using only strings and regular expressions. This implements only a subset of the WAMP feature set and is only compatible with Wwise
C Wamp.ErrorException | Exception thrown during WAMP operations
C Wamp.TimeoutException | Exception thrown during WAMP operations when the timeout is reached
C WwiseObjectInfo | Class containing the information returned by a WAAPI request for an object
C WwiseObjectInfoJsonObject | Used to deserialize information from a request for a Wwise object. Implements an implicit cast to WwiseObjectInfo
C WwiseObjectInfoParent | Contains the GUID of the returned object's parent


Wwise Unity Integration Documentation: 类成员

这里列出了所有文档化的类成员，并附带类所属的文件:

- a -

  • AcousticTextures : AkSurfaceReflector
  • actionOnEventType : AkEvent
  • Add() : AkSpatialAudioListener.SpatialAudioListenerList
  • AssociatedRoom : AkSurfaceReflector
  • axis : AkEnvironmentPortal

- b -

  • bankName : AkMemBankLoader

- c -

  • ClosePortal() : AkRoomPortal
  • Connected : AkWaapiUtilities
  • curveInterpolation : AkEvent

- d -

  • decodeBank : AkBank
  • Delete() : AkWaapiUtilities
  • diffractionMaxEdges : AkSpatialAudioEmitter
  • diffractionMaxPathLength : AkSpatialAudioEmitter
  • diffractionMaxPaths : AkSpatialAudioEmitter
  • Disconnected() : AkWaapiUtilities
  • Disconnecting : AkWaapiUtilities
  • drawDiffractionPaths : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawFirstOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawHigherOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawSecondOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter

- e -

  • enableActionOnEvent : AkEvent
  • EnableDiffraction : AkSurfaceReflector
  • EnableDiffractionOnBoundaryEdges : AkSurfaceReflector
  • EnteredRoom() : AkRoomAwareObject
  • environments : AkEnvironmentPortal
  • envList : AkEnvironmentPortal
  • ExecuteAction() : AK.Wwise.Event
  • ExitedRoom() : AkRoomAwareObject

- f -

  • FolderDisplaynames : WaapiKeywords

- g -

  • GetChildren< T >() : AkWaapiUtilities
  • GetForward() : AkGameObj
  • GetID() : AkRoom , AkRoomPortal
  • GetPosition() : AkGameObj
  • GetProject< T >() : AkWaapiUtilities
  • GetResultDelegate< T >() : AkWaapiUtilities
  • GetResultListDelegate< T >() : AkWaapiUtilities
  • GetStatusString() : AkWaapiUtilities
  • GetUpward() : AkGameObj
  • GetWwiseObject< T >() : AkWaapiUtilities
  • GetWwiseObjectAndAncestors< T >() : AkWaapiUtilities
  • GetWwiseObjectAndDescendants< T >() : AkWaapiUtilities
  • GetWwiseObjects< T >() : AkWaapiUtilities

- h -

  • HandleEvent() : AkBank , AkRoomPortal

- i -

  • info : AkEventCallbackMsg
  • innerRadius : AkRadialEmitter
  • IsConnected() : AkWaapiUtilities
  • isEnvironmentAware : AkGameObj
  • isLocalizedBank : AkMemBankLoader
  • IsPlayable() : AkWaapiUtilities

- l -

  • loadAsynchronous : AkBank
  • LoadLocalizedBank() : AkMemBankLoader
  • LoadNonLocalizedBank() : AkMemBankLoader

- m -

  • m_positionOffsetData : AkGameObj
  • MAX_ROOMS_PER_PORTAL : AkRoomPortal
  • Mesh : AkSurfaceReflector

- o -

  • OpenSoundBankInExplorer() : AkWaapiUtilities
  • OpenWorkUnitInExplorer() : AkWaapiUtilities
  • outerRadius : AkRadialEmitter

- p -

  • ParseChildAddedOrRemoved() : AkWaapiUtilities
  • ParseObjectInfo() : AkWaapiUtilities
  • ParseRenameObject() : AkWaapiUtilities
  • ParseSelectedObjects() : AkWaapiUtilities
  • Post() : AK.Wwise.Event
  • PostMIDI() : AK.Wwise.Event
  • priority : AkRoom
  • PublishHandler() : Wamp

- q -

  • QueueCommand() : AkWaapiUtilities
  • QueueCommandWithReturnType< T >() : AkWaapiUtilities
  • QueueCommandWithReturnWwiseObjects< T >() : AkWaapiUtilities
  • QueueConsumed : AkWaapiUtilities

- r -

  • reflectAuxBus : AkSpatialAudioEmitter
  • reflectionMaxPathLength : AkSpatialAudioEmitter
  • reflectionsAuxBus : AkEarlyReflections
  • reflectionsAuxBusGain : AkSpatialAudioEmitter
  • reflectionsOrder : AkSpatialAudioEmitter
  • reflectionsVolume : AkEarlyReflections
  • Remove() : AkSpatialAudioListener.SpatialAudioListenerList
  • RemoveGeometry() : AkSurfaceReflector
  • RemoveGeometryInstance() : AkSurfaceReflector
  • Rename() : AkWaapiUtilities
  • reverbAuxBus : AkRoom
  • reverbLevel : AkRoom
  • roomReverbAuxBusGain : AkSpatialAudioEmitter
  • roomToneAuxSend : AkRoom
  • roomToneEvent : AkRoom

- s -

  • saveDecodedBank : AkBank
  • Search< T >() : AkWaapiUtilities
  • SelectObjectInAuthoring() : AkWaapiUtilities
  • sender : AkEventCallbackMsg
  • SetGeometry() : AkSurfaceReflector
  • SetGeometryFromMesh() : AkSurfaceReflector
  • SetGeometryInstance() : AkSurfaceReflector
  • soundEmitterObject : AkEvent
  • SpatialAudioListeners : AkSpatialAudioListener
  • StopAllTransports() : AkWaapiUtilities
  • StopMIDI() : AK.Wwise.Event
  • Subscribe() : AkWaapiUtilities
  • SubscribeTopics() : AkWwiseTreeWAAPIDataSource

- t -

  • TheSpatialAudioListener : AkSpatialAudioListener
  • TogglePlayEvent() : AkWaapiUtilities
  • transitionDuration : AkEvent
  • transmissionLoss : AkRoom
  • TransmissionLossValues : AkSurfaceReflector
  • Trigger() : AkTriggerBase
  • triggerDelegate : AkTriggerBase
  • type : AkEventCallbackMsg
  • typeStringDict : WaapiKeywords

- u -

  • UnloadBank() : AkBank
  • unloadTriggerList : AkBank
  • Unsubscribe() : AkWaapiUtilities
  • UpdateGeometry() : AkSurfaceReflector

- w -

  • WwiseObjectTypeStrings : WaapiKeywords


Wwise Unity Integration Documentation: 类成员 - 函数

- a -

  • Add() : AkSpatialAudioListener.SpatialAudioListenerList

- c -

  • ClosePortal() : AkRoomPortal

- d -

  • Delete() : AkWaapiUtilities
  • Disconnected() : AkWaapiUtilities

- e -

  • EnteredRoom() : AkRoomAwareObject
  • ExecuteAction() : AK.Wwise.Event
  • ExitedRoom() : AkRoomAwareObject

- g -

  • GetChildren< T >() : AkWaapiUtilities
  • GetForward() : AkGameObj
  • GetID() : AkRoom , AkRoomPortal
  • GetPosition() : AkGameObj
  • GetProject< T >() : AkWaapiUtilities
  • GetResultDelegate< T >() : AkWaapiUtilities
  • GetResultListDelegate< T >() : AkWaapiUtilities
  • GetStatusString() : AkWaapiUtilities
  • GetUpward() : AkGameObj
  • GetWwiseObject< T >() : AkWaapiUtilities
  • GetWwiseObjectAndAncestors< T >() : AkWaapiUtilities
  • GetWwiseObjectAndDescendants< T >() : AkWaapiUtilities
  • GetWwiseObjects< T >() : AkWaapiUtilities

- h -

  • HandleEvent() : AkBank , AkRoomPortal

- i -

  • IsConnected() : AkWaapiUtilities
  • IsPlayable() : AkWaapiUtilities

- l -

  • LoadLocalizedBank() : AkMemBankLoader
  • LoadNonLocalizedBank() : AkMemBankLoader

- o -

  • OpenSoundBankInExplorer() : AkWaapiUtilities
  • OpenWorkUnitInExplorer() : AkWaapiUtilities

- p -

  • ParseChildAddedOrRemoved() : AkWaapiUtilities
  • ParseObjectInfo() : AkWaapiUtilities
  • ParseRenameObject() : AkWaapiUtilities
  • ParseSelectedObjects() : AkWaapiUtilities
  • Post() : AK.Wwise.Event
  • PostMIDI() : AK.Wwise.Event
  • PublishHandler() : Wamp

- q -

  • QueueCommand() : AkWaapiUtilities
  • QueueCommandWithReturnType< T >() : AkWaapiUtilities
  • QueueCommandWithReturnWwiseObjects< T >() : AkWaapiUtilities

- r -

  • Remove() : AkSpatialAudioListener.SpatialAudioListenerList
  • RemoveGeometry() : AkSurfaceReflector
  • RemoveGeometryInstance() : AkSurfaceReflector
  • Rename() : AkWaapiUtilities

- s -

  • Search< T >() : AkWaapiUtilities
  • SelectObjectInAuthoring() : AkWaapiUtilities
  • SetGeometry() : AkSurfaceReflector
  • SetGeometryFromMesh() : AkSurfaceReflector
  • SetGeometryInstance() : AkSurfaceReflector
  • StopAllTransports() : AkWaapiUtilities
  • StopMIDI() : AK.Wwise.Event
  • Subscribe() : AkWaapiUtilities
  • SubscribeTopics() : AkWwiseTreeWAAPIDataSource

- t -

  • TogglePlayEvent() : AkWaapiUtilities
  • Trigger() : AkTriggerBase

- u -

  • UnloadBank() : AkBank
  • Unsubscribe() : AkWaapiUtilities
  • UpdateGeometry() : AkSurfaceReflector


Wwise Unity Integration Documentation: 类成员 - 变量

- a -

  • AcousticTextures : AkSurfaceReflector
  • actionOnEventType : AkEvent
  • AssociatedRoom : AkSurfaceReflector
  • axis : AkEnvironmentPortal

- b -

  • bankName : AkMemBankLoader

- c -

  • Connected : AkWaapiUtilities
  • curveInterpolation : AkEvent

- d -

  • decodeBank : AkBank
  • diffractionMaxEdges : AkSpatialAudioEmitter
  • diffractionMaxPathLength : AkSpatialAudioEmitter
  • diffractionMaxPaths : AkSpatialAudioEmitter
  • Disconnecting : AkWaapiUtilities
  • drawDiffractionPaths : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawFirstOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawHigherOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter
  • drawSecondOrderReflections : AkSpatialAudioDebugDraw , AkSpatialAudioEmitter

- e -

  • enableActionOnEvent : AkEvent
  • EnableDiffraction : AkSurfaceReflector
  • EnableDiffractionOnBoundaryEdges : AkSurfaceReflector
  • environments : AkEnvironmentPortal
  • envList : AkEnvironmentPortal

- f -

  • FolderDisplaynames : WaapiKeywords

- i -

  • info : AkEventCallbackMsg
  • innerRadius : AkRadialEmitter
  • isEnvironmentAware : AkGameObj
  • isLocalizedBank : AkMemBankLoader

- l -

  • loadAsynchronous : AkBank

- m -

  • m_positionOffsetData : AkGameObj
  • MAX_ROOMS_PER_PORTAL : AkRoomPortal
  • Mesh : AkSurfaceReflector

- o -

  • outerRadius : AkRadialEmitter

- p -

  • priority : AkRoom

- q -

  • QueueConsumed : AkWaapiUtilities

- r -

  • reflectAuxBus : AkSpatialAudioEmitter
  • reflectionMaxPathLength : AkSpatialAudioEmitter
  • reflectionsAuxBus : AkEarlyReflections
  • reflectionsAuxBusGain : AkSpatialAudioEmitter
  • reflectionsOrder : AkSpatialAudioEmitter
  • reflectionsVolume : AkEarlyReflections
  • reverbAuxBus : AkRoom
  • reverbLevel : AkRoom
  • roomReverbAuxBusGain : AkSpatialAudioEmitter
  • roomToneAuxSend : AkRoom
  • roomToneEvent : AkRoom

- s -

  • saveDecodedBank : AkBank
  • sender : AkEventCallbackMsg
  • soundEmitterObject : AkEvent

- t -

  • transitionDuration : AkEvent
  • transmissionLoss : AkRoom
  • TransmissionLossValues : AkSurfaceReflector
  • triggerDelegate : AkTriggerBase
  • type : AkEventCallbackMsg
  • typeStringDict : WaapiKeywords

- u -

  • unloadTriggerList : AkBank

- w -

  • WwiseObjectTypeStrings : WaapiKeywords


Wwise Unity Integration Documentation: 类成员 - 属性

  • SpatialAudioListeners : AkSpatialAudioListener
  • TheSpatialAudioListener : AkSpatialAudioListener


Wwise Unity Integration Documentation: 成员列表

  • AK
  • Wwise
  • AcousticTexture
AK.Wwise.AcousticTexture 成员列表

成员的完整列表，这些成员属于 AK.Wwise.AcousticTexture,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AK
  • Wwise
  • AuxBus
AK.Wwise.AuxBus 成员列表

成员的完整列表，这些成员属于 AK.Wwise.AuxBus,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AK
  • Wwise
  • Bank
AK.Wwise.Bank 成员列表

成员的完整列表，这些成员属于 AK.Wwise.Bank,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AK
  • Wwise
  • BaseGroupType
AK.Wwise.BaseGroupType 成员列表

成员的完整列表，这些成员属于 AK.Wwise.BaseGroupType,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AK
  • Wwise
  • BaseType
AK.Wwise.BaseType 成员列表

成员的完整列表，这些成员属于 AK.Wwise.BaseType,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AK
  • Wwise
  • CallbackFlags
AK.Wwise.CallbackFlags 成员列表

成员的完整列表，这些成员属于 AK.Wwise.CallbackFlags,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AK
  • Wwise
  • Event
AK.Wwise.Event 成员列表

成员的完整列表，这些成员属于 AK.Wwise.Event,包括所有继承而来的类成员

ExecuteAction(UnityEngine.GameObject gameObject, AkActionOnEventType actionOnEventType, int transitionDuration, AkCurveInterpolation curveInterpolation) | AK.Wwise.Event | inline
Post(UnityEngine.GameObject gameObject) | AK.Wwise.Event | inline
Post(UnityEngine.GameObject gameObject, CallbackFlags flags, AkCallbackManager.EventCallback callback, object cookie=null) | AK.Wwise.Event | inline
Post(UnityEngine.GameObject gameObject, uint flags, AkCallbackManager.EventCallback callback, object cookie=null) | AK.Wwise.Event | inline
Post(ulong gameObjectId) | AK.Wwise.Event | inline
PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array) | AK.Wwise.Event | inline
PostMIDI(UnityEngine.GameObject gameObject, AkMIDIPostArray array, int count) | AK.Wwise.Event | inline
StopMIDI(UnityEngine.GameObject gameObject) | AK.Wwise.Event | inline
StopMIDI() | AK.Wwise.Event | inline


Wwise Unity Integration Documentation: 成员列表

  • AK
  • Wwise
  • RTPC
AK.Wwise.RTPC 成员列表

成员的完整列表，这些成员属于 AK.Wwise.RTPC,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AK
  • Wwise
  • State
AK.Wwise.State 成员列表

成员的完整列表，这些成员属于 AK.Wwise.State,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AK
  • Wwise
  • Switch
AK.Wwise.Switch 成员列表

成员的完整列表，这些成员属于 AK.Wwise.Switch,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AK
  • Wwise
  • Trigger
AK.Wwise.Trigger 成员列表

成员的完整列表，这些成员属于 AK.Wwise.Trigger,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkAmbient 成员列表

成员的完整列表，这些成员属于 AkAmbient,包括所有继承而来的类成员

actionOnEventType | AkEvent
curveInterpolation | AkEvent
enableActionOnEvent | AkEvent
soundEmitterObject | AkEvent
transitionDuration | AkEvent


Wwise Unity Integration Documentation: 成员列表

AkAmbientLargeModePositioner 成员列表

成员的完整列表，这些成员属于 AkAmbientLargeModePositioner,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkAudioListener 成员列表

成员的完整列表，这些成员属于 AkAudioListener,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkBank 成员列表

成员的完整列表，这些成员属于 AkBank,包括所有继承而来的类成员

decodeBank AkBank
HandleEvent(UnityEngine.GameObject in_gameObject) | AkBank | inline
loadAsynchronous AkBank
saveDecodedBank AkBank
UnloadBank(UnityEngine.GameObject in_gameObject) | AkBank | inline


Wwise Unity Integration Documentation: 成员列表

AkEarlyReflections 成员列表

成员的完整列表，这些成员属于 AkEarlyReflections,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkEmitterObstructionOcclusion 成员列表

成员的完整列表，这些成员属于 AkEmitterObstructionOcclusion,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkEnvironment 成员列表

成员的完整列表，这些成员属于 AkEnvironment,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AkEnvironment
  • AkEnvironment_CompareByPriority
AkEnvironment.AkEnvironment_CompareByPriority 成员列表

成员的完整列表，这些成员属于 AkEnvironment.AkEnvironment_CompareByPriority,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AkEnvironment
  • AkEnvironment_CompareBySelectionAlgorithm
AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm 成员列表

成员的完整列表，这些成员属于 AkEnvironment.AkEnvironment_CompareBySelectionAlgorithm,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkEnvironmentPortal 成员列表

成员的完整列表，这些成员属于 AkEnvironmentPortal,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • AkEnvironmentPortal
  • EnvListWrapper
AkEnvironmentPortal.EnvListWrapper 成员列表

成员的完整列表，这些成员属于 AkEnvironmentPortal.EnvListWrapper,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkEvent 成员列表

成员的完整列表，这些成员属于 AkEvent,包括所有继承而来的类成员

actionOnEventType | AkEvent
curveInterpolation | AkEvent
enableActionOnEvent | AkEvent
soundEmitterObject | AkEvent
transitionDuration | AkEvent


Wwise Unity Integration Documentation: 成员列表

AkEventCallbackMsg 成员列表

成员的完整列表，这些成员属于 AkEventCallbackMsg,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkGameObj 成员列表

成员的完整列表，这些成员属于 AkGameObj,包括所有继承而来的类成员

GetForward() | AkGameObj | inlinevirtual
GetPosition() | AkGameObj | inlinevirtual
GetUpward() | AkGameObj | inlinevirtual


Wwise Unity Integration Documentation: 成员列表

AkInitializer 成员列表

成员的完整列表，这些成员属于 AkInitializer,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkListenerDistanceProbe 成员列表

成员的完整列表，这些成员属于 AkListenerDistanceProbe,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkMemBankLoader 成员列表

成员的完整列表，这些成员属于 AkMemBankLoader,包括所有继承而来的类成员

bankName | AkMemBankLoader |
isLocalizedBank | AkMemBankLoader |
LoadLocalizedBank(string in_bankFilename) | AkMemBankLoader | inline
LoadNonLocalizedBank(string in_bankFilename) | AkMemBankLoader | inline


Wwise Unity Integration Documentation: AkObstructionOcclusion.LayerMask

  • AkRoomPortalObstruction

◆ LayerMask

UnityEngine.LayerMask AkObstructionOcclusion.LayerMask = -1
inherited

Indicates which layers act as obstructers/occluders.


Wwise Unity Integration Documentation: AkObstructionOcclusion.maxDistance

  • AkRoomPortalObstruction

◆ maxDistance

float AkObstructionOcclusion.maxDistance = -1.0f
inherited

The maximum distance at which to perform obstruction/occlusion. A negative value will be interpreted as inifinite distance.


Wwise Unity Integration Documentation: AkObstructionOcclusion.refreshInterval

  • AkRoomPortalObstruction

◆ refreshInterval

float AkObstructionOcclusion.refreshInterval = 1
inherited

The number of seconds between obstruction/occlusion checks.


Wwise Unity Integration Documentation: AkObstructionOcclusion.fadeTime

  • AkRoomPortalObstruction

◆ fadeTime

float AkObstructionOcclusion.fadeTime = 0.5f
inherited

The number of seconds for fade ins and fade outs.


Wwise Unity Integration Documentation: 成员列表

AkRadialEmitter 成员列表

成员的完整列表，这些成员属于 AkRadialEmitter,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkRoom 成员列表

成员的完整列表，这些成员属于 AkRoom,包括所有继承而来的类成员

GetID() | AkRoom | inline
priority | AkRoom |
reverbAuxBus | AkRoom |
reverbLevel | AkRoom |
roomToneAuxSend | AkRoom |
roomToneEvent | AkRoom |
transmissionLoss | AkRoom |


Wwise Unity Integration Documentation: 成员列表

AkRoomAwareManager 成员列表

成员的完整列表，这些成员属于 AkRoomAwareManager,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkRoomAwareObject 成员列表

成员的完整列表，这些成员属于 AkRoomAwareObject,包括所有继承而来的类成员

EnteredRoom(AkRoom room) | AkRoomAwareObject | inline
ExitedRoom(AkRoom room) | AkRoomAwareObject | inline


Wwise Unity Integration Documentation: 成员列表

AkRoomManager 成员列表

成员的完整列表，这些成员属于 AkRoomManager,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkRoomPortal 成员列表

成员的完整列表，这些成员属于 AkRoomPortal,包括所有继承而来的类成员

ClosePortal(UnityEngine.GameObject in_gameObject) | AkRoomPortal | inline
GetID() | AkRoomPortal | inline
HandleEvent(UnityEngine.GameObject in_gameObject) | AkRoomPortal | inline
MAX_ROOMS_PER_PORTAL | AkRoomPortal | static


Wwise Unity Integration Documentation: 成员列表

AkRoomPortalObstruction 成员列表

成员的完整列表，这些成员属于 AkRoomPortalObstruction,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkSpatialAudioDebugDraw 成员列表

成员的完整列表，这些成员属于 AkSpatialAudioDebugDraw,包括所有继承而来的类成员

drawDiffractionPaths | AkSpatialAudioDebugDraw
drawFirstOrderReflections | AkSpatialAudioDebugDraw
drawHigherOrderReflections | AkSpatialAudioDebugDraw
drawSecondOrderReflections | AkSpatialAudioDebugDraw


Wwise Unity Integration Documentation: 成员列表

AkSpatialAudioEmitter 成员列表

成员的完整列表，这些成员属于 AkSpatialAudioEmitter,包括所有继承而来的类成员

diffractionMaxEdges | AkSpatialAudioEmitter
diffractionMaxPathLength | AkSpatialAudioEmitter
diffractionMaxPaths | AkSpatialAudioEmitter
drawDiffractionPaths | AkSpatialAudioEmitter
drawFirstOrderReflections | AkSpatialAudioEmitter
drawHigherOrderReflections | AkSpatialAudioEmitter
drawSecondOrderReflections | AkSpatialAudioEmitter
reflectAuxBus | AkSpatialAudioEmitter
reflectionMaxPathLength | AkSpatialAudioEmitter
reflectionsAuxBusGain | AkSpatialAudioEmitter
reflectionsOrder | AkSpatialAudioEmitter
roomReverbAuxBusGain | AkSpatialAudioEmitter


Wwise Unity Integration Documentation: 成员列表

AkSpatialAudioListener 成员列表

成员的完整列表，这些成员属于 AkSpatialAudioListener,包括所有继承而来的类成员

SpatialAudioListeners | AkSpatialAudioListener | static
TheSpatialAudioListener | AkSpatialAudioListener | static


Wwise Unity Integration Documentation: 成员列表

  • AkSpatialAudioListener
  • SpatialAudioListenerList
AkSpatialAudioListener.SpatialAudioListenerList 成员列表

成员的完整列表，这些成员属于 AkSpatialAudioListener.SpatialAudioListenerList,包括所有继承而来的类成员

Add(AkSpatialAudioListener listener) | AkSpatialAudioListener.SpatialAudioListenerList | inline
Remove(AkSpatialAudioListener listener) | AkSpatialAudioListener.SpatialAudioListenerList | inline


Wwise Unity Integration Documentation: 成员列表

AkState 成员列表

成员的完整列表，这些成员属于 AkState,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkSurfaceReflector 成员列表

成员的完整列表，这些成员属于 AkSurfaceReflector,包括所有继承而来的类成员

AcousticTextures | AkSurfaceReflector |
AssociatedRoom | AkSurfaceReflector |
EnableDiffraction | AkSurfaceReflector |
EnableDiffractionOnBoundaryEdges | AkSurfaceReflector |
Mesh | AkSurfaceReflector |
RemoveGeometry() | AkSurfaceReflector | inline
RemoveGeometryInstance() | AkSurfaceReflector | inline
SetGeometry() | AkSurfaceReflector | inline
SetGeometryFromMesh(UnityEngine.Mesh mesh, ulong geometryID, bool enableDiffraction, bool enableDiffractionOnBoundaryEdges, bool enableTriangles, AK.Wwise.AcousticTexture[] acousticTextures=null, float[] transmissionLossValues=null, string name="") | AkSurfaceReflector | inlinestatic
SetGeometryInstance(ulong geometryInstanceID, ulong geometryID, ulong associatedRoomID, UnityEngine.Transform transform) | AkSurfaceReflector | inlinestatic
SetGeometryInstance() | AkSurfaceReflector | inline
TransmissionLossValues | AkSurfaceReflector |
UpdateGeometry() | AkSurfaceReflector | inline


Wwise Unity Integration Documentation: 成员列表

AkSwitch 成员列表

成员的完整列表，这些成员属于 AkSwitch,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkTriggerBase 成员列表

成员的完整列表，这些成员属于 AkTriggerBase,包括所有继承而来的类成员

Trigger(UnityEngine.GameObject in_gameObject) AkTriggerBase


Wwise Unity Integration Documentation: AkTriggerHandler.useOtherObject

  • AkSwitch

◆ useOtherObject

bool AkTriggerHandler.useOtherObject = false
inherited

This property is usefull only when used with colliders. When enabled, the target of the action will be the other colliding object. When disabled, it will be the current object.


Wwise Unity Integration Documentation: AkTriggerHandler.triggerTypes

  • AkSwitch

◆ triggerTypes

System.Collections.Generic.Dictionary<uint, string> AkTriggerHandler.triggerTypes = AkTriggerBase.GetAllDerivedTypes()
staticinherited

Will contain the types of all the triggers derived from AkTriggerBase at runtime


Wwise Unity Integration Documentation: AkTriggerHandler.MAX_NB_TRIGGERS

  • AkSwitch

◆ MAX_NB_TRIGGERS

const int AkTriggerHandler.MAX_NB_TRIGGERS = 32
staticinherited

Since our mask is a 32 bits integer, we can't have more than 32 triggers


Wwise Unity Integration Documentation: AkTriggerHandler.triggerList

  • AkSwitch

◆ triggerList

System.Collections.Generic.List<int> AkTriggerHandler.triggerList = new System.Collections.Generic.List<int> { START_TRIGGER_ID }
inherited

List containing the enabled triggers.


Wwise Unity Integration Documentation: 成员列表

AkWaapiUtilities 成员列表

成员的完整列表，这些成员属于 AkWaapiUtilities,包括所有继承而来的类成员

Connected | AkWaapiUtilities | static
Delete(System.Guid guid) | AkWaapiUtilities | inlinestatic
Disconnected() | AkWaapiUtilities | inlinestatic
Disconnecting | AkWaapiUtilities | static
GetChildren< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetProject< T >(GetResultListDelegate< T > callback, ReturnOptions options) | AkWaapiUtilities | inlinestatic
GetResultDelegate< T >(T result) | AkWaapiUtilities |
GetResultListDelegate< T >(List< T > result) | AkWaapiUtilities |
GetStatusString() | AkWaapiUtilities | inlinestatic
GetWwiseObject< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjectAndAncestors< T >(System.Guid guid, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjectAndDescendants< T >(System.Guid guid, ReturnOptions options, int depth, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjectAndDescendants< T >(string identifier, ReturnOptions options, int depth, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
GetWwiseObjects< T >(List< System.Guid > guids, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
IsConnected() | AkWaapiUtilities | inlinestatic
IsPlayable(WwiseObjectType type) | AkWaapiUtilities | inlinestatic
OpenSoundBankInExplorer(System.Guid guid) | AkWaapiUtilities | inlinestatic
OpenWorkUnitInExplorer(System.Guid guid) | AkWaapiUtilities | inlinestatic
ParseChildAddedOrRemoved(string json) | AkWaapiUtilities | inlinestatic
ParseObjectInfo(List< WwiseObjectInfoJsonObject > returnObjects) | AkWaapiUtilities | inlinestatic
ParseRenameObject(string json) | AkWaapiUtilities | inlinestatic
ParseSelectedObjects(string json) | AkWaapiUtilities | inlinestatic
QueueCommand(string uri, string args, string options) | AkWaapiUtilities | inlinestatic
QueueCommandWithReturnType< T >(string uri, GetResultDelegate< T > callback, string args=null, string options=null) | AkWaapiUtilities | inlinestatic
QueueCommandWithReturnWwiseObjects< T >(WaqlArgs args, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
QueueConsumed | AkWaapiUtilities | static
Rename(System.Guid guid, string newName) | AkWaapiUtilities | inlinestatic
Search< T >(string searchString, WwiseObjectType objectType, ReturnOptions options, GetResultListDelegate< T > callback) | AkWaapiUtilities | inlinestatic
SelectObjectInAuthoring(System.Guid guid) | AkWaapiUtilities | inlinestatic
StopAllTransports() | AkWaapiUtilities | inlinestatic
Subscribe(string topic, Wamp.PublishHandler subscriptionCallback, System.Action< SubscriptionInfo > handshakeCallback) | AkWaapiUtilities | inlinestatic
TogglePlayEvent(WwiseObjectType objectType, System.Guid guid) | AkWaapiUtilities | inlinestatic
Unsubscribe(uint id) | AkWaapiUtilities | inlinestatic


Wwise Unity Integration Documentation: 成员列表

  • AkWaapiUtilities
  • SubscriptionInfo
AkWaapiUtilities.SubscriptionInfo 成员列表

成员的完整列表，这些成员属于 AkWaapiUtilities.SubscriptionInfo,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

AkWwiseTreeWAAPIDataSource 成员列表

成员的完整列表，这些成员属于 AkWwiseTreeWAAPIDataSource,包括所有继承而来的类成员

SubscribeTopics() AkWwiseTreeWAAPIDataSource inline


Wwise Unity Integration Documentation: 成员列表

Args 成员列表

成员的完整列表，这些成员属于 Args,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

ArgsCommand 成员列表

成员的完整列表，这些成员属于 ArgsCommand,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

ArgsDisplayName 成员列表

成员的完整列表，这些成员属于 ArgsDisplayName,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

ArgsObject 成员列表

成员的完整列表，这些成员属于 ArgsObject,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

ArgsPlay 成员列表

成员的完整列表，这些成员属于 ArgsPlay,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

ArgsRename 成员列表

成员的完整列表，这些成员属于 ArgsRename,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

ArgsTransport 成员列表

成员的完整列表，这些成员属于 ArgsTransport,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

ErrorDetails 成员列表

成员的完整列表，这些成员属于 ErrorDetails,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

ErrorMessage 成员列表

成员的完整列表，这些成员属于 ErrorMessage,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

JsonSerializable 成员列表

成员的完整列表，这些成员属于 JsonSerializable,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

Options 成员列表

成员的完整列表，这些成员属于 Options,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

ReturnOptions 成员列表

成员的完整列表，这些成员属于 ReturnOptions,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

ReturnTransport 成员列表

成员的完整列表，这些成员属于 ReturnTransport,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

ReturnWwiseObjects< T > 成员列表

成员的完整列表，这些成员属于 ReturnWwiseObjects< T >,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

SelectedWwiseObjects 成员列表

成员的完整列表，这些成员属于 SelectedWwiseObjects,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

TransportOptions 成员列表

成员的完整列表，这些成员属于 TransportOptions,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

TransportState 成员列表

成员的完整列表，这些成员属于 TransportState,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

WaapiHelper 成员列表

成员的完整列表，这些成员属于 WaapiHelper,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

WaapiKeywords 成员列表

成员的完整列表，这些成员属于 WaapiKeywords,包括所有继承而来的类成员

FolderDisplaynames | WaapiKeywords | static
typeStringDict | WaapiKeywords | static
WwiseObjectTypeStrings | WaapiKeywords | static


Wwise Unity Integration Documentation: 成员列表

Wamp 成员列表

成员的完整列表，这些成员属于 Wamp,包括所有继承而来的类成员

PublishHandler(string json) Wamp


Wwise Unity Integration Documentation: 成员列表

  • Wamp
  • ErrorException
Wamp.ErrorException 成员列表

成员的完整列表，这些成员属于 Wamp.ErrorException,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

  • Wamp
  • TimeoutException
Wamp.TimeoutException 成员列表

成员的完整列表，这些成员属于 Wamp.TimeoutException,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

WaqlArgs 成员列表

成员的完整列表，这些成员属于 WaqlArgs,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

WwiseChildModifiedInfo 成员列表

成员的完整列表，这些成员属于 WwiseChildModifiedInfo,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

WwiseObjectInfoJsonObject 成员列表

成员的完整列表，这些成员属于 WwiseObjectInfoJsonObject,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

WwiseObjectInfoParent 成员列表

成员的完整列表，这些成员属于 WwiseObjectInfoParent,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

WwiseRenameInfo 成员列表

成员的完整列表，这些成员属于 WwiseRenameInfo,包括所有继承而来的类成员


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/Handwritten/WAAPI 目录参考

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • Handwritten
  • WAAPI
WAAPI 目录参考


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime 目录参考

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
Runtime 目录参考


Wwise Unity Integration Documentation: Integration/Assets/Wwise 目录参考

  • Integration
  • Assets
  • Wwise
Wwise 目录参考


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Editor/WwiseWindows 目录参考

  • Integration
  • Assets
  • Wwise
  • API
  • Editor
  • WwiseWindows
WwiseWindows 目录参考


Wwise Unity Integration Documentation: Documentation/private/Doxygen_zh 目录参考

  • Documentation
  • private
  • Doxygen_zh
Doxygen_zh 目录参考


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Editor 目录参考

  • Integration
  • Assets
  • Wwise
  • API
  • Editor
Editor 目录参考

目录


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/WwiseTypes 目录参考

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • WwiseTypes
WwiseTypes 目录参考

目录


Wwise Unity Integration Documentation: Documentation/private/Doxygen_zh/Windows/ReleaseNotes 目录参考

  • Documentation
  • private
  • Doxygen_zh
  • Windows
  • ReleaseNotes
ReleaseNotes 目录参考


Wwise Unity Integration Documentation: Documentation/private 目录参考

  • Documentation
  • private
private 目录参考


Wwise Unity Integration Documentation: Integration/Assets/Wwise/MonoBehaviour/Runtime 目录参考

  • Integration
  • Assets
  • Wwise
  • MonoBehaviour
  • Runtime
Runtime 目录参考


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/WwiseTypes/WwiseTypes 目录参考

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • WwiseTypes
  • WwiseTypes
WwiseTypes 目录参考


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API 目录参考

  • Integration
  • Assets
  • Wwise
  • API
API 目录参考


Wwise Unity Integration Documentation: Documentation/private/Doxygen_zh/Common 目录参考

  • Documentation
  • private
  • Doxygen_zh
  • Common
Common 目录参考


Wwise Unity Integration Documentation: Documentation/private/Doxygen_zh/Windows 目录参考

  • Documentation
  • private
  • Doxygen_zh
  • Windows
Windows 目录参考


Wwise Unity Integration Documentation: Integration/Assets/Wwise/MonoBehaviour 目录参考

  • Integration
  • Assets
  • Wwise
  • MonoBehaviour
MonoBehaviour 目录参考

目录


Wwise Unity Integration Documentation: Documentation/private/Doxygen_zh/Common/ReleaseNotes 目录参考

  • Documentation
  • private
  • Doxygen_zh
  • Common
  • ReleaseNotes
ReleaseNotes 目录参考


Wwise Unity Integration Documentation: Integration/Assets/Wwise/API/Runtime/Handwritten 目录参考

  • Integration
  • Assets
  • Wwise
  • API
  • Runtime
  • Handwritten
Handwritten 目录参考

目录


Wwise Unity Integration Documentation: Integration 目录参考

  • Integration
Integration 目录参考


Wwise Unity Integration Documentation: Documentation 目录参考

  • Documentation
Documentation 目录参考


Wwise Unity Integration Documentation: Integration/Assets 目录参考

  • Integration
  • Assets
Assets 目录参考


Wwise Unity Integration Documentation: 相关页面

相关页面
这里列出了所有相关页面:
WAAPI 实用工具


Wwise Unity Integration Documentation: 成员列表

  • AkWaapiUtilities
  • WaapiCommand
AkWaapiUtilities.WaapiCommand 成员列表

成员的完整列表，这些成员属于 AkWaapiUtilities.WaapiCommand,包括所有继承而来的类成员


Wwise Unity Integration Documentation: 成员列表

WwiseObjectInfo 成员列表

成员的完整列表，这些成员属于 WwiseObjectInfo,包括所有继承而来的类成员